Fedora Linux Support Community & Resources Center
  #1  
Old 21st August 2008, 04:50 AM
misfitspade146 Offline
Registered User
 
Join Date: Aug 2008
Posts: 4
Unhappy Cant activate ethernet device (very new to linux)

fedora 9 redhat
intel quad 9450
asus p5n-mx motherboard
quest dsl

this is only my third day using fedora and this computer, so im pretty lost

eth0 is set to auto obtain ip address settings with:dhcp

but every time i try to activate eth0 it fails:
determining IP information for eth0....Failed

----
the little networked computer logo upper right hand corner
i click eth0 in the drop down and it says avc denial

setroubleshoot gives me 4 errors

SELinux is preventing networkmanager "unlink" to ./dhclient-eth0.pid (var_run_t)
SELinux is preventing networkmanager "read" to ./dhclient-eth0.pid (var_run_t)
SELinux is preventing dhclient "read" to ./dhclient-eth0.pid (var_run_t)
SELinux is preventing dhclient "write" to ./dhclient-eth0.pid (var_run_t)

it says i can attempt to fix with -v'./dhclient-eth0.pid' or ./dhclient-eth0.pid'

i have tried using -v'./dhclient-eth0.pid' in terminal and it said:
bash: -v'./dhclient-eth0.pid' : no such file or directory

./dhclient-eth0.pid' drops me down to a
>
but i dont know any qcommands and i get stuck

so if you read all that its obvious, i dont know what im doing

PLZ!!!!!! HELP ME

Last edited by Demz; 8th October 2008 at 08:41 AM.
Reply With Quote
  #2  
Old 21st August 2008, 05:23 AM
mattcen Offline
Registered User
 
Join Date: Dec 2007
Location: Melbourne, Australia
Posts: 79
SELinux is a security feature in Linux, designed by the NSA. If you're just running a desktop (and not a server), you should be quite save disabling it, or setting it to permissive (It will come up with AVC Denial errors, but not do anything about them). I cannot really tell why this is causing a problem, but I'd set it to permissive and see if it fixes your problem.

To disable SELinux, run 'system-config-selinux' from the command line (there'll be a link on one of the Gnome Administrative menus somewhere I'd guess, but I'm not using Gnome so I couldn't tell you where), and set "Current Enforcing Mode" to Permissive. This should make it permissive only until you restart (if you want permissive to be permanent, set it in "System Default Enforcing Mode").
Try that and see what happens.

Also the '-v ...' command you tried needs to be appended to another command (Sorry to say I can't remember which, but it should mention it somewhere in the selinux-troubleshooter window.

Good Luck,
Mattcen
__________________
My PC Specs:

Desktop: Pentium D 2.8GHz, 3GB DDR2 RAM, NVidia Geforce 7950GT, ~800GB HDD Space, LeadTek DTV2000H TV Card
24" Dell 2408 WFP and 15" LCD, running WinXP and Ubuntu 8.04.

Laptop: Acer 4235 WLMi, Core2 Duo 2.0GHz, 1GB DDR2 RAM, NVidia 7300Go, 160GB HDD Space, 15.4 Inch widescreen LCD
running WinXP and Fedora 9 in dual boot.

Server: Pentium 4 2.8GHz, 2GB DDR RAM, 320GB HDD, Fedora 8 with various Virtual Machines, including Edubuntu Server 8.04 for PXE Booting.
Reply With Quote
  #3  
Old 21st August 2008, 07:57 AM
marcrblevins Offline
Registered User
 
Join Date: Jun 2006
Location: Texas
Age: 43
Posts: 4,168
If you are using a desktop, not a lappy, don't you mind disable NetworkManger and enable network services for now?

You can search this forum for NetworkManager and see the pattern.
Reply With Quote
  #4  
Old 21st August 2008, 10:25 PM
Ragnorok Offline
Registered User
 
Join Date: Aug 2008
Location: Greenfield, NH
Posts: 18
Hmmm. I'm seeing this as well...

- I've been using Linux since Red Hat 5 (not FC, RH, circa 1995), and I have never once seen even SELinux bollix a dhcp session until FC9 went in today. This is more than a little messed up, and non-trivial to resolve. It points to some basic error in FC9's policy, imho, that a simple network address resolution fails so utterly.
- Another serious error is that all "help" for anything relating to SELinux attempts to load a web page on Fedora's site. Naturally that fails when the NIC is offline. Bad Form, Fedora. NO biscuit.
- All I've seen on SELinux is it should be able to generate "avcs" files that may be compiled into policy to allow only the items that fail. Unfortunately FC9 doesn't appear to do that, or if it does the way one gets an avcs file from it doesn't correspond to any forum. They said enter "setenforce 0" before starting the daemon and avcs will be generated automagically. I did a network stop, setenforce 0, then network start, and no file. That would fix this up right quick, and *only* this, if it would but work as advertised.
- So the "fix" is to disable NetworkManager and revert to the old way? Seems a bit of a kludge. I'd be happier addressing the actual policy bug myself. Any clues in that regard? I'm thinking a custom policy file, but having never written one it's going to be slow going. Guess this is a good time to learn!
__________________

(______)
Ragnorok
Reply With Quote
  #5  
Old 24th August 2008, 09:53 PM
misfitspade146 Offline
Registered User
 
Join Date: Aug 2008
Posts: 4
ok

so i put Selinux into premissive mode and tried to activate eth0:

once or twice it said
"100% packet loss, time 3000 ms
pipe 3
failed"

every time after that it said " Determining IP info for eth0... Failed" just like before

and now the little networked computers with the x on the taskbar say "device is unmanaged"

what does this mean
Reply With Quote
  #6  
Old 24th August 2008, 10:24 PM
misfitspade146 Offline
Registered User
 
Join Date: Aug 2008
Posts: 4
Quote:
Originally Posted by marcrblevins
If you are using a desktop, not a lappy, don't you mind disable NetworkManger and enable network services for now?

You can search this forum for NetworkManager and see the pattern.
chkconfig NetworkManager off
chkconfig network on
service NetworkManager stop
system-config-network
service network restart

ok now it trys getting the ip durring startup boot and fails
there is no more networked computers on the taskbar
and when i try and activate it manualy it says

"cannot activate network device eth0!
exiting.
failed."

so i turned networkmanager back on and started it, do i need to to "chkconfig network off"
to get back to where i was
Reply With Quote
  #7  
Old 25th August 2008, 01:23 AM
mattcen Offline
Registered User
 
Join Date: Dec 2007
Location: Melbourne, Australia
Posts: 79
You probably should turn off 'network' if you're using 'NetwrokManager' - you should really only have one network management program running at a time.
I am starting to wonder whether this is a driver issue... or a problem with the network itself. Have you got other computers connected to the network? Could the cable be broken or not properly connected at the other end? I know these seem like trivial questions, but you never know - I for one can't think of any other causes at the moment :S.
__________________
My PC Specs:

Desktop: Pentium D 2.8GHz, 3GB DDR2 RAM, NVidia Geforce 7950GT, ~800GB HDD Space, LeadTek DTV2000H TV Card
24" Dell 2408 WFP and 15" LCD, running WinXP and Ubuntu 8.04.

Laptop: Acer 4235 WLMi, Core2 Duo 2.0GHz, 1GB DDR2 RAM, NVidia 7300Go, 160GB HDD Space, 15.4 Inch widescreen LCD
running WinXP and Fedora 9 in dual boot.

Server: Pentium 4 2.8GHz, 2GB DDR RAM, 320GB HDD, Fedora 8 with various Virtual Machines, including Edubuntu Server 8.04 for PXE Booting.
Reply With Quote
  #8  
Old 26th August 2008, 10:26 PM
misfitspade146 Offline
Registered User
 
Join Date: Aug 2008
Posts: 4
it cant be the network itself because it works fine on the laptop that i am on right now. i will just start with a fresh slate and see what i can do about re-installing the motherboard drivers then fedora.
Reply With Quote
  #9  
Old 15th September 2008, 02:13 PM
Ragnorok Offline
Registered User
 
Join Date: Aug 2008
Location: Greenfield, NH
Posts: 18
Quote:
Originally Posted by mattcen
SELinux is a security feature in Linux, designed by the NSA. If you're just running a desktop (and not a server), you should be quite save disabling it, or setting it to permissive (It will come up with AVC Denial errors, but not do anything about them). I cannot really tell why this is causing a problem, but I'd set it to permissive and see if it fixes your problem.
- I know this is NSA tech and I for one appreciate their effort, but I've installed other distro that use SELinux and not a one of them has prevented the NIC from coming up. I've never gotten any network card to work in Ubuntu on four different machines, but that wasn't SELinux. (sardonic grin) Suse, Debian, and prior FC distro (5? 6?) have at least allowed DHCP out of the box. Samba ... sure, have to configure that. But DHCP? This is a first.
- I also know I can disable it, but don't feel I should have to, and quite frankly don't want to. I believe there is no such thing as too much paranoia when connected to the 'net, and SELinux is a good tool to have in the arsenal. It just shouldn't be configured to be quite so disruptive on an initial install. Imho it really leaves egg on the face of Linux when one of the primary distro won't work immediately after install.
- I sincerely wish I should remember what I did to fix it, because I'd put it here for poor misfitspade146, but alas I've geezed it. I just know I did get it and Samba to work, finally, so it is possible...
__________________

(______)
Ragnorok
Reply With Quote
  #10  
Old 16th September 2008, 01:39 AM
mattcen Offline
Registered User
 
Join Date: Dec 2007
Location: Melbourne, Australia
Posts: 79
Quote:
Originally Posted by Ragnorok
- I know this is NSA tech and I for one appreciate their effort, but I've installed other distro that use SELinux and not a one of them has prevented the NIC from coming up. I've never gotten any network card to work in Ubuntu on four different machines, but that wasn't SELinux.
I can see your point of view on this Ragnorak, and that is all well and good - I'm glad that you have had success using a system with SELinux enabled without being crippled by it (I for example, couldn't get a service working at all with it enabled... I think it was Samba, without rewriting the policies, something I certainly wasn't keen to try).

I suggested disabling SELinux as a step towards diagnosis if nothing else, as if it was SELinux, that would've ruled it out.
As things stand, it appears that SELinux is not the problem, and I'm running out of ideas .
__________________
My PC Specs:

Desktop: Pentium D 2.8GHz, 3GB DDR2 RAM, NVidia Geforce 7950GT, ~800GB HDD Space, LeadTek DTV2000H TV Card
24" Dell 2408 WFP and 15" LCD, running WinXP and Ubuntu 8.04.

Laptop: Acer 4235 WLMi, Core2 Duo 2.0GHz, 1GB DDR2 RAM, NVidia 7300Go, 160GB HDD Space, 15.4 Inch widescreen LCD
running WinXP and Fedora 9 in dual boot.

Server: Pentium 4 2.8GHz, 2GB DDR RAM, 320GB HDD, Fedora 8 with various Virtual Machines, including Edubuntu Server 8.04 for PXE Booting.
Reply With Quote
  #11  
Old 16th September 2008, 02:46 AM
Ragnorok Offline
Registered User
 
Join Date: Aug 2008
Location: Greenfield, NH
Posts: 18
Quote:
Originally Posted by mattcen
(I for example, couldn't get a service working at all with it enabled... I think it was Samba [snip]).
- The big thing was DHCP with FC9. Once that was working the rest fell into place pretty quickly. Samba, for example simply requires "samba_file_t" or some such SELinux tag be applied recursively to shared directories, using chcon, and it works immediately. No futzing with smbpasswd, nothing ... configure smb.conf, run one additional command, and it's golden. That's right in some doc/howto/forum somewhere ... might even be here! (grin)
- DHCP took a solid week of fiddle-futzing before I could ping anything. It was a real mess, and I don't know how any Linux newb could've taken it.
- In all cases, with FC9, I knew right out of the gate that SELinux was the culprit because it kept tossing alerts with that little gold star. I knew I could disable SELinux and it would in fact work perfectly. 'Course you didn't know that because I never bothered to say, so your suggestion made sense in the context it was given. My apologies for not communicating better.

- My real gripe, such as it is, is that DHCP was so utterly messed up on a virgin installation. Regardless of what's causing that to happen, a completely virgin install should never, imho, exhibit that sort of behaviour, because dynamic IP is the norm. (shrug) That's really all I was getting at.

- On a positive note, I really like that gold star alert thing that FC9 does with SELinux. I really like the information it provides, because I know for certain that SELinux is "interfering" with things and what that "interference" entails, and knowing that prevents me from floundering around as much. Ubuntu doesn't say jack; it simply refuses to route off-box come hell or high water, though I can ping myself all day long. FC9 says what's up in plain English. Very nice! It's things like that get me to stick it out with FC9 where I've tossed the Ubuntu disc in the trash.

- So overall a job well done. Just some speed bumps along the way...
__________________

(______)
Ragnorok
Reply With Quote
  #12  
Old 18th September 2008, 07:54 AM
MaxMaxwell Offline
Registered User
 
Join Date: Sep 2008
Posts: 11
Quote:
Originally Posted by misfitspade146
it cant be the network itself because it works fine on the laptop that i am on right now. i will just start with a fresh slate and see what i can do about re-installing the motherboard drivers then fedora.
I am just starting my search for answers to some of the questions that you have. I too am new to Linux and have had similar network problems. In my case the onboard network device seemed to be one of the causes of my system freezing and rebooting (but not the only one). We both have Asus motherboards and are looking for the method for installing the drivers. Can someone please point to a thread that will help a beginner update drivers from the Asus site with a usb stick.
__________________
Linux Newbie
Pc user and sometimes tech since 386 dx 25
Asus M2A-VM
--AMD 690 G chipset
--ATI Radeon X1250 onboard
--AMD Athlon 64 X2 4800+
--2 GB ram
WD5000AAVS HD Sata
Fedora 9
Reply With Quote
  #13  
Old 19th September 2008, 01:57 AM
dainiuzz Offline
Registered User
 
Join Date: Sep 2008
Posts: 1
looking for help

i've got the same problem as misfitspade146 and dont know what to do iam very new on linux, so iam really looking for help from you also have windows xp pro on my laptop, and network works fine on it, and it means that problem isn't with my network connection..
sorry for my english
Reply With Quote
  #14  
Old 2nd October 2008, 05:10 PM
jchgeek Offline
Registered User
 
Join Date: Sep 2008
Posts: 6
I've got the same thing, just downloaded the DVD FC9 install yesterday, no ethernet, so obviously not fixed yet. The weird thing was that the ethernet card worked fine with the live CD.

I've loaded Fedora several times in the past onto servers, never a significant hitch.

Any thoughts on a solution? Might there be a way to fix from the live CD?
Reply With Quote
  #15  
Old 6th October 2008, 09:23 PM
g8trGTO Offline
Registered User
 
Join Date: Apr 2006
Posts: 11
Does anyone have any additional information on this? We are running into the same issues and here's what we've tried so far:

- Turned off SELinux
- Turned off NetworkManager
- Set a static route to the gateway

We still cannot obtain an IP address from the GW. We tried setting a static IP address, but that didn't work either. I can provide any logs/messages necessary, I didn't know what would be relevant here, so please ask.

Our setup is a Toshiba Qosmio G55 laptop running Fedora 9, fresh install. Any tips or suggestions would be greatly appreciated.
Reply With Quote
Reply

Tags
activate, device, ethernet, linux

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't activate Ethernet and PPPoE rine238 Servers & Networking 1 28th January 2008 11:53 AM
dhcp enabled, can't activate ethernet ruggersway Servers & Networking 2 30th January 2006 10:41 PM
ASOUND Ethernet Fails To Activate mrcpuhead Servers & Networking 3 16th September 2005 08:13 PM


Current GMT-time: 18:41 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Yosemite National Park Photos - Oslob, Cebu Travel Photos - Kasama, Zambia Photos on Instagram - Murano Resort Marrakech Instagram Photos