Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #46  
Old 5th October 2008, 01:10 PM
briantan Offline
Registered User
 
Join Date: Jun 2008
Posts: 715
It seems that f10-beta/gnome is having the same problem as f9 when running with vnc-server. Perhaps Fedora developers think that we should run vnc with gdm instead.
Reply With Quote
  #47  
Old 5th October 2008, 11:23 PM
briantan Offline
Registered User
 
Join Date: Jun 2008
Posts: 715
Managed to solve part of F9/gnome problem. Now vnc-server can start but gui still a bit sluggish.

edit /etc/dbus-1/system.d/gdm.conf , insert the 2 lines in red.

Code:
  <policy user="gdm">
    <allow send_interface="org.gnome.DisplayManager.Manager"/>
    <allow send_interface="org.gnome.DisplayManager.Display"/>
    <allow send_interface="org.gnome.DisplayManager.LocalDisplayFactory"/>
    <allow send_interface="org.gnome.DisplayManager.Settings"/>
    <allow send_interface="org.gnome.DisplayManager.Slave"/>
    <allow send_interface="org.gnome.DisplayManager.Session"/>
    <allow send_destination="org.gnome.DisplayManager"
           send_interface="org.gnome.DBus.Properties" />
  </policy>
Restart messagebus service (may kill gnome session), or simply reboot.

Code:
# /sbin/service messagebus restart
Quote:
Originally Posted by tharizdun
[root@revanent ~]# /usr/sbin/gdm --version

** (gdm-binary:5805): WARNING **: Failed to acquire org.gnome.DisplayManager

** (gdm-binary:5805): WARNING **: Could not acquire name; bailing out
[root@revanent ~]#
The above fix will probably fix this problem.
Reply With Quote
  #48  
Old 6th October 2008, 12:34 AM
tharizdun Offline
Registered User
 
Join Date: Oct 2008
Posts: 8
Quote:
Originally Posted by briantan View Post
Managed to solve part of F9/gnome problem. Now vnc-server can start but gui still a bit sluggish.
Hmm - I have no sluggish response with F9/gdm/vnc and did not (yet) make the changes you suggest below. I'm happy to share specs/file contents with you if you think it will help troubleshoot the symptoms you're seeing.


Quote:
Originally Posted by briantan View Post
edit /etc/dbus-1/system.d/gdm.conf , insert the 2 lines in red.

Code:
  <policy user="gdm">
    <allow send_interface="org.gnome.DisplayManager.Manager"/>
    <allow send_interface="org.gnome.DisplayManager.Display"/>
    <allow send_interface="org.gnome.DisplayManager.LocalDisplayFactory"/>
    <allow send_interface="org.gnome.DisplayManager.Settings"/>
    <allow send_interface="org.gnome.DisplayManager.Slave"/>
    <allow send_interface="org.gnome.DisplayManager.Session"/>
    <allow send_destination="org.gnome.DisplayManager"
           send_interface="org.gnome.DBus.Properties" />
  </policy>
Restart messagebus service (may kill gnome session), or simply reboot.

Code:
# /sbin/service messagebus restart

The above fix will probably fix this problem.
I just made this change and rebooted. Unfortunately, no change. I don't mean for anyone to spend any time on this, but for folks who are curious, my entire file now looks like this (saved prior to last reboot):


[root@revanent ~]# cat /etc/dbus-1/system.d/gdm.conf
<!DOCTYPE busconfig PUBLIC
"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

<!-- Only root can own the service -->
<policy user="root">
<allow own="org.gnome.DisplayManager"/>

<allow send_interface="org.gnome.DisplayManager.Manager"/>
<allow send_interface="org.gnome.DisplayManager.Display"/>
<allow send_interface="org.gnome.DisplayManager.LocalDisp layFactory"/>
<allow send_interface="org.gnome.DisplayManager.Settings"/>
<allow send_interface="org.gnome.DisplayManager.Slave"/>
<allow send_interface="org.gnome.DisplayManager.Session"/>
<allow send_destination="org.gnome.DisplayManager"
send_interface="org.gnome.DBus.Properties" />
</policy>

<policy context="default">
<deny send_interface="org.gnome.DisplayManager.Manager"/>
<deny send_interface="org.gnome.DisplayManager.Display"/>
<deny send_interface="org.gnome.DisplayManager.LocalDisp layFactory"/>
<deny send_interface="org.gnome.DisplayManager.Settings"/>
<deny send_interface="org.gnome.DisplayManager.Slave"/>
<deny send_interface="org.gnome.DisplayManager.Session"/>
<deny send_destination="org.gnome.DisplayManager"
send_interface="org.gnome.DBus.Properties" />

<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetId"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetRemoteHostname"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetSeatId"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetX11DisplayName"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetX11DisplayNumber"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="IsLocal"/>

<allow send_interface="org.gnome.DisplayManager.LocalDisp layFactory"
send_member="CreateTransientDisplay"/>

<allow send_interface="org.gnome.DisplayManager.Manager"
send_member="GetDisplays"/>

</policy>

<policy user="gdm">
<allow send_interface="org.gnome.DisplayManager.Manager"/>
<allow send_interface="org.gnome.DisplayManager.Display"/>
<allow send_interface="org.gnome.DisplayManager.LocalDisp layFactory"/>
<allow send_interface="org.gnome.DisplayManager.Settings"/>
<allow send_interface="org.gnome.DisplayManager.Slave"/>
<allow send_interface="org.gnome.DisplayManager.Session"/>
<allow send_destination="org.gnome.DisplayManager"
send_interface="org.gnome.DBus.Properties" />
</policy>

</busconfig>
[root@revanent ~]#




Another curious behavior: I can use "Administration->Update System" locally with no problem, but if I use it via vnc, the "Update System" button is grayed out in the Update System dialogue. Does anyone know if that is a precaution which exists by design?
Reply With Quote
  #49  
Old 6th October 2008, 12:53 AM
briantan Offline
Registered User
 
Join Date: Jun 2008
Posts: 715
Without the changes in dbus gdm.conf, F9/Gnome will not work with VNC-server. You'll get just a gray screen.

I have yet to have success with gdm/xinetd.d/Xvnc.
Reply With Quote
  #50  
Old 6th October 2008, 01:08 AM
tharizdun Offline
Registered User
 
Join Date: Oct 2008
Posts: 8
Quote:
Originally Posted by briantan View Post
Without the changes in dbus gdm.conf, F9/Gnome will not work with VNC-server. You'll get just a gray screen.

I have yet to have success with gdm/xinetd.d/Xvnc.
Hm, that was not the case for me. I was able to get it working with my previously posted binary versions (possibly different than yours?) without adding these lines to the <policy user="gdm"> section:

<allow send_interface="org.gnome.DisplayManager.Slave"/>
<allow send_interface="org.gnome.DisplayManager.Session"/>


I added the lines today to see if it would affect the gdm-binary --version behavior (and it didn't).

As a sanity check, I've just removed them and rebooted and gdm/vnc/F9 seems to be working still with no problems.

Now the lines do exist (and always have existed) within the <policy user="root"> as accept and in the <policy context="default" as deny. Those were defaults.

I have a developer's F9 install with virtually every security/bug/enhancement fix applied and SELinux and Network Manager disabled. It is running on a Compaq 6910p laptop.

Strange that we're seeing different behavior.
Reply With Quote
  #51  
Old 6th October 2008, 01:17 AM
briantan Offline
Registered User
 
Join Date: Jun 2008
Posts: 715
Not sure if we are talking about the same thing. Mine gnome/vnc-server/F9.

You mentioned gdm/vnc/F9, I presumed it is about xinetd/vnc/gdm setup?

Default /etc/dbus-1/system.d/gdm.conf does not have these 2 lines within <policy user="gdm">. I extracted the file from gdm rpm to confirm this.
Code:
     <allow send_interface="org.gnome.DisplayManager.Slave"/>
     <allow send_interface="org.gnome.DisplayManager.Session"/>

Last edited by briantan; 6th October 2008 at 01:21 AM.
Reply With Quote
  #52  
Old 6th October 2008, 01:34 AM
briantan Offline
Registered User
 
Join Date: Jun 2008
Posts: 715
Tharizdun, my list of binary is similar to yours.
Code:
# yum list |grep gdm
bluecurve-gdm-theme.noarch               1.0.0-1.fc8            installed       
fedorabubbles-gdm-theme.noarch           1.0.0-1.fc8            installed       
fedoradna-gdm-theme.noarch               1.0.0-1.fc8            installed       
fedoraflyinghigh-gdm-theme.noarch        1.0.0-1.fc8            installed       
fedorainfinity-gdm-theme.noarch          8.0.1-1.fc8            installed       
gdm.x86_64                               1:2.22.0-10.fc9        installed       
gdm-extra-faces.x86_64                   1:2.20.5-3.fc8         installed       
gdm-user-switch-applet.x86_64            1:2.22.0-10.fc9        installed       
gdmap.x86_64                             0.7.5-6.fc6            fedora
Reply With Quote
  #53  
Old 6th October 2008, 01:44 AM
tharizdun Offline
Registered User
 
Join Date: Oct 2008
Posts: 8
Quote:
Originally Posted by briantan View Post
Not sure if we are talking about the same thing. Mine gnome/vnc-server/F9.

You mentioned gdm/vnc/F9, I presumed it is about xinetd/vnc/gdm setup?

Default /etc/dbus-1/system.d/gdm.conf does not have these 2 lines within <policy user="gdm">. I extracted the file from gdm rpm to confirm this.
Code:
     <allow send_interface="org.gnome.DisplayManager.Slave"/>
     <allow send_interface="org.gnome.DisplayManager.Session"/>

Maybe not (sorry - I'm a noob). I am using gdm/gnome as my desktop manager and installed the vnc-server you reference in your guide and have the Fedora 9 OS installed.

I am using the network service (rather than network manager) - which I thought still launched xinetd on demand but now I see it doesn't (I don't have xinetd anywhere in my file system). I guess that's the difference?

These two lines:

<allow send_interface="org.gnome.DisplayManager.Slave"/>
<allow send_interface="org.gnome.DisplayManager.Session"/>


are in the default file, but not within the gdm portion, only the root portion. They are also in the default portion but listed as deny, not accept. Here is the default file - it works fine for me without adding the two lines:

[root@revanent system.d]# cat gdm.conf
<!DOCTYPE busconfig PUBLIC
"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

<!-- Only root can own the service -->
<policy user="root">
<allow own="org.gnome.DisplayManager"/>

<allow send_interface="org.gnome.DisplayManager.Manager"/>
<allow send_interface="org.gnome.DisplayManager.Display"/>
<allow send_interface="org.gnome.DisplayManager.LocalDisp layFactory"/>
<allow send_interface="org.gnome.DisplayManager.Settings"/>
<allow send_interface="org.gnome.DisplayManager.Slave"/>
<allow send_interface="org.gnome.DisplayManager.Session"/>
<allow send_destination="org.gnome.DisplayManager"
send_interface="org.gnome.DBus.Properties" />
</policy>

<policy context="default">
<deny send_interface="org.gnome.DisplayManager.Manager"/>
<deny send_interface="org.gnome.DisplayManager.Display"/>
<deny send_interface="org.gnome.DisplayManager.LocalDisp layFactory"/>
<deny send_interface="org.gnome.DisplayManager.Settings"/>
<deny send_interface="org.gnome.DisplayManager.Slave"/>
<deny send_interface="org.gnome.DisplayManager.Session"/>
<deny send_destination="org.gnome.DisplayManager"
send_interface="org.gnome.DBus.Properties" />

<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetId"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetRemoteHostname"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetSeatId"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetX11DisplayName"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="GetX11DisplayNumber"/>
<allow send_interface="org.gnome.DisplayManager.Display"
send_member="IsLocal"/>

<allow send_interface="org.gnome.DisplayManager.LocalDisp layFactory"
send_member="CreateTransientDisplay"/>

<allow send_interface="org.gnome.DisplayManager.Manager"
send_member="GetDisplays"/>

</policy>

<policy user="gdm">
<allow send_interface="org.gnome.DisplayManager.Manager"/>
<allow send_interface="org.gnome.DisplayManager.Display"/>
<allow send_interface="org.gnome.DisplayManager.LocalDisp layFactory"/>
<allow send_interface="org.gnome.DisplayManager.Settings"/>
<allow send_destination="org.gnome.DisplayManager"
send_interface="org.gnome.DBus.Properties" />
</policy>

</busconfig>
[root@revanent system.d]#


If xinetd is the difference, then I'm sorry if I missed that earlier.
Reply With Quote
  #54  
Old 6th October 2008, 02:50 AM
briantan Offline
Registered User
 
Join Date: Jun 2008
Posts: 715
OK. So we are talking about the same thing. I'm using network service as well. Still investigating what is causing the sluggishness.

FYI, xinetd services are found in /etc/xinetd.d directory. It is not used by vncserver.

I am trying to setup Xvnc via xinetd service. So far no success.
Reply With Quote
  #55  
Old 17th October 2008, 09:19 PM
apit86 Offline
Registered User
 
Join Date: Jun 2008
Posts: 12
i have configure all that vnc configuration file but cannot start.it's appear:

Starting VNC server: no displays configured [FAILED]
Reply With Quote
  #56  
Old 17th October 2008, 11:44 PM
briantan Offline
Registered User
 
Join Date: Jun 2008
Posts: 715
Check your spelling in /etc/sysconfig/vncservers. Show the output of this command.

Code:
# sed -e '/^#/d' -e '/^$/d' /etc/sysconfig/vncservers
Reply With Quote
  #57  
Old 28th October 2008, 09:30 AM
menace519 Offline
Registered User
 
Join Date: Oct 2008
Posts: 11
Nice Guide.

I was able to get the GUI working with XFCE only b/c it was used in the brian's guide. Here are the contents of my xstartup file.


-----------------------------------------------
#!/bin/sh

vncconfig -iconic &
# Uncomment the following two lines for normal desktop:
#unset SESSION_MANAGER
#exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
#xsetroot -solid grey
#xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm &

startxfce4 &
-----------------------------------------------------

A few questions.

Am I suppose to uncomment? It seems to be working with the GUI just fine. What does this code do?

#unset SESSION_MANAGER
#exec /etc/X11/xinit/xinitrc

whats the code to start KDE or GNOME?
Reply With Quote
  #58  
Old 28th October 2008, 12:36 PM
briantan Offline
Registered User
 
Join Date: Jun 2008
Posts: 715
Quote:
Originally Posted by menace519 View Post
Code:
#!/bin/sh

vncconfig -iconic &
# Uncomment the following two lines for normal desktop:
#unset SESSION_MANAGER
#exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
#xsetroot -solid grey
#xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm &

startxfce4 &
-----------------------------------------------------

A few questions.

Am I suppose to uncomment? It seems to be working with the GUI just fine. What does this code do?

#unset SESSION_MANAGER
#exec /etc/X11/xinit/xinitrc

whats the code to start KDE or GNOME?
To run XFCE, don't uncomment the above 2 lines (unset and exec).

To run GNOME/KDE, uncomment the above 2 lines, and create/edit the file /etc/sysconfig/desktop with this line:
Code:
DESKTOP=GNOME
or
Code:
DESKTOP=KDE
Commands after "exec /etc/X11/xinit/xinitrc" will not be processed.
Reply With Quote
  #59  
Old 23rd November 2008, 12:38 AM
badger_fruit Offline
Registered User
 
Join Date: Nov 2008
Posts: 64
greeting fedora users!
i have just installed F9 and it is very nice; my other computers all run suse (10.3 and 11) and have done for a while now. I thought i would give Fedora a try to see what I think.

Anyway, so far so good, i am browsing the web no problem lol (which apart from mp3/avi playback, is all it will be used for). However, it is installed on a computer in the loft so i need remote access from the rest of my LAN.

I followed this guide and although i can access via http://127.0.0.1:5801 and http://192.168.1.200:5801 ON THE ACTUAL fedora computer, if I try from any other machine (I have a Win XP with VNC Viewer installed), it "can not find the server". which is odd.

I have disabled my firewall on the fedora machine and can RDP *OUT* from there OK to the other computers, but I just can't VNC *IN*.

Any ideas or suggestions would be greatly appreciated.
Regards

badger
Reply With Quote
  #60  
Old 23rd November 2008, 08:46 AM
marcrblevins Offline
Registered User
 
Join Date: Jun 2006
Location: Texas
Age: 43
Posts: 4,168
badger_fruit, can the computers ping each others?
Reply With Quote
Reply

Tags
guide, mini, vino, vncserver

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nexus Personal mini guide nickeh Guides & Solutions (No Questions) 13 17th June 2011 01:22 AM
Wolfenstein: Enemy Territory! (mini-guide for newbies like me) rpl Gamers' Lounge 7 9th January 2008 11:21 AM
vino-server cdlaforc Using Fedora 4 19th March 2007 06:09 AM
Mini-Guide: Installing grub from Fedora Core 5 (FC5) Rescue CD Nemesis02 EOL (End Of Life) Versions 3 5th June 2006 10:35 PM
Vino-Server jolly_green_gia Using Fedora 1 28th December 2004 07:44 PM


Current GMT-time: 03:41 (Tuesday, 23-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...NH Canciller Ayala Travel Photos - Indian Rocks Beach Florida On The Gulf Coast Beach Photos - El Coca - Bailey's Powerhouse Gym Gainesville Photos - National Trust Lanhydrock Countryside Travel Photos on Instagram