Fedora Linux Support Community & Resources Center
  #1  
Old 28th June 2008, 09:03 PM
madmatt2024 Offline
Registered User
 
Join Date: Jun 2008
Posts: 20
Fedora 9, updated now WIFI signal low. newb

Hi, I'm new to Fedora and Linux in general. I wanted to have Linux on my system and when I was given an extra HDD I went for it but now I'm having problems and need help.
I had problems getting a wireless connection using my RT2500 usb adapter. It always said 50% signal and it kept asking for my key after I already inputted it. My friend came over and we easily got it online after installing my old RTL8180 PCI card. After that I installed and removed some stuff using YUM Extender and did some extra updates. Eventually for some reason after a reboot my WIFI signal dropped from 99% to 12%! In trying to fix it I removed some stuff and could not get a connection at all.
I decided to wipe the drive and start over fresh. I installed Fedora 9, Wifi signal was 99%. Installed YUM Extender as root and let it download and install updates. (about 260 of them!) Once the updates were finished I rebooted and logged back in as root. Now my WIFI signal is 4%-12% and I have sometimes have problems getting online. Occasionally the signal will read 99% for a few seconds then drop back down. Removing the antenna from the card also seems to give a better signal for some reason. The Wireless adapter works fine under Win XP so I know it is good. I asked my friend who uses Fedora 8 about it and he doesn't know what went wrong. Can someone please help?
Reply With Quote
  #2  
Old 8th July 2008, 05:55 AM
madmatt2024 Offline
Registered User
 
Join Date: Jun 2008
Posts: 20
Ge thanks guys. Is there any other information I can post to help? I don't exactly know what other info is needed to troubleshoot this.
Reply With Quote
  #3  
Old 8th July 2008, 06:19 AM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
Try pressing a key early in the boot sequence to bring up the grub boot menu, then press the down arrow to select the previous kernel and hit enter to boot. See if the old kernel works better or not for your wireless.
Reply With Quote
  #4  
Old 8th July 2008, 06:27 AM
madmatt2024 Offline
Registered User
 
Join Date: Jun 2008
Posts: 20
I tried that before and still had the same problem. I also have since removed the other kernal entries from the boot menu so its not like I can easily try it again.
Reply With Quote
  #5  
Old 8th July 2008, 06:52 AM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
If you want to recreate the older kernel entry then post the output of

su -
ls /boot
cat /boot/grub/grub.conf
Reply With Quote
  #6  
Old 8th July 2008, 09:43 PM
madmatt2024 Offline
Registered User
 
Join Date: Jun 2008
Posts: 20
Here it is

config-2.6.25.6-55.fc9.i686 lost+found
config-2.6.25.9-76.fc9.i686 System.map-2.6.25.6-55.fc9.i686
efi System.map-2.6.25.9-76.fc9.i686
grub vmlinuz-2.6.25.6-55.fc9.i686
initrd-2.6.25.6-55.fc9.i686.img vmlinuz-2.6.25.9-76.fc9.i686
initrd-2.6.25.9-76.fc9.i686.img


# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00 acpi=off acm=off
# initrd /initrd-version.img
#boot=/dev/sda
default=1
timeout=15
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.25.9-76.fc9.i686)
root (hd0,0)
kernel /vmlinuz-2.6.25.9-76.fc9.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.25.9-76.fc9.i686.img
title Windows XP
map (hd0) (hd1,1)
map (hd1,1) (hd0)
rootnoverify (hd1,1)
chainloader +1
Reply With Quote
  #7  
Old 9th July 2008, 01:03 AM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
"2.6.25.6-55.fc9.i686"
That version is notoriously bad for wireless drivers also, so it probably won't help, as you said. However, you can try it:

Add the following 4 lines right above the line that says "title Windows XP"

title Fedora (2.6.25.6-55.fc9.i686)
root (hd0,0)
kernel /vmlinuz-2.6.25.6-55.fc9.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.25.6-55.fc9.i686.img

Also since you have it defaulting to boot Windows XP, change "default=1" to "default=2" so it will still default to XP.

Last edited by JEO; 9th July 2008 at 01:08 AM.
Reply With Quote
  #8  
Old 9th July 2008, 02:27 AM
madmatt2024 Offline
Registered User
 
Join Date: Jun 2008
Posts: 20
I just tried the other kernel and I still have the same problem. The strange thing is that none of the kernels listed from the ls /boot are the original kernel that FC9 came with.
Reply With Quote
  #9  
Old 9th July 2008, 03:40 AM
LarryBeal Offline
Registered User
 
Join Date: Jul 2008
Posts: 16
What i think is wrong is wireless adaptor card. You might want to check if its compatible with linux in general or its damaged.
Reply With Quote
  #10  
Old 9th July 2008, 03:46 AM
JN4OldSchool Offline
"Sean The Terrible" -- The forum(er) Vista® rep
 
Join Date: Nov 2005
Posts: 8,823
Quote:
Originally Posted by LarryBeal
What i think is wrong is wireless adaptor card. You might want to check if its compatible with linux in general or its damaged.
It is the F9 kernels!

I am having similar issues. Fresh F9 install the Bekin USB wireless device connects fine. Do a yum update to the latest kernel and the device works, sees the network, but it keeps asking for the WPA key. I enter it, it thinks a few minutes and the same window comes back up. Signal strength is also low. I boot into the initial kernel and she connects like now. This sucks...Either go back to F8 or just exclude kernel updates. As it is my son's computer, and he is a dork when it comes to linux and never updates anyway, i am thinking of the later option.
Reply With Quote
  #11  
Old 9th July 2008, 04:19 AM
madmatt2024 Offline
Registered User
 
Join Date: Jun 2008
Posts: 20
Quote:
Originally Posted by LarryBeal
What i think is wrong is wireless adaptor card. You might want to check if its compatible with linux in general or its damaged.
It works under Windows so it isn't damaged and it did work correctly under Fedora until I updated. It still works but now the signal is low.
Reply With Quote
  #12  
Old 9th July 2008, 07:29 AM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
Quote:
Originally Posted by madmatt2024
I just tried the other kernel and I still have the same problem. The strange thing is that none of the kernels listed from the ls /boot are the original kernel that FC9 came with.
Yea, I think it would be a great idea to try the original kernel. You can increase the number of kernels that F9 keeps around after updates by editing the /etc/yum.conf and increase the installonly_limit from the default 2 to a higher number like 5. Then either use the original kernel rpm from the installation media or download it from a mirror like here:
http://mirrors.kernel.org/fedora/rel...4.fc9.i686.rpm
To install it manually use the command:
su -
rpm -ivh --force kernel-2.6.25-14.fc9.i686.rpm
Reply With Quote
  #13  
Old 9th July 2008, 01:31 PM
hyperspace Offline
Registered User
 
Join Date: Oct 2006
Location: Lincoln, NE
Age: 56
Posts: 414
Quote:
Originally Posted by JN4OldSchool
It is the F9 kernels!

I am having similar issues. Fresh F9 install the Belkin USB wireless device connects fine. Do a yum update to the latest kernel and the device works, sees the network, but it keeps asking for the WPA key. I enter it, it thinks a few minutes and the same window comes back up. Signal strength is also low. I boot into the initial kernel and she connects like now. This sucks...Either go back to F8 or just exclude kernel updates. As it is my son's computer, and he is a dork when it comes to linux and never updates anyway, i am thinking of the later option.
I don't know enough about the kernel and how modules are loaded into it but I have done two new fresh installs since the newest kernel was out. After installing and then getting all the new updates, my wireless (3945) works exactly the same as the original kernel. To add to this crazy mix, some individuals using the 3945 wireless, have problems after the updates.

So, it may be something other than the kernel itself.
__________________
lost in hypertime...

Registered Linux User #329061
Reply With Quote
  #14  
Old 9th July 2008, 01:59 PM
JN4OldSchool Offline
"Sean The Terrible" -- The forum(er) Vista® rep
 
Join Date: Nov 2005
Posts: 8,823
Quote:
Originally Posted by hyperspace
I don't know enough about the kernel and how modules are loaded into it but I have done two new fresh installs since the newest kernel was out. After installing and then getting all the new updates, my wireless (3945) works exactly the same as the original kernel. To add to this crazy mix, some individuals using the 3945 wireless, have problems after the updates.

So, it may be something other than the kernel itself.
Yeah, I dont know enough about the kernel myself. The laptop I am typing this on is running a fully updated F9 and the Atheros AR5007 is working flawlessly. But that doesnt mean anything. When I see just one other person with symptoms almost the same as mine, and when I am on a fresh, base default install, with nothing added, and considering the wireless device preforms flawlessly under the first kernel, I am willing to bet it is the new kernel that is making the difference. If it were my computer I suppose I would try to build my own kernel. I have done it before on Gentoo, but it would require a lot of work to figure out what I am doing. A commonality I see is it is USB wireless devices causing problems, and on my computer, also a fresh build and install, I am getting weird USB errors. Everything works except the card reader though.

Oh well, that is Fedora for you. I have been lucky in that I went from FC4 all the way to F9 with nary a problem! I got bit by the i586 kernel thing in FC6 but that was easily fixed. I have dealt with most of the other bugs without losing a beat, but I have never faced an "it just wont work for you, ha ha!" issue with Fedora. I guess my number was up.
Reply With Quote
  #15  
Old 9th July 2008, 05:06 PM
hyperspace Offline
Registered User
 
Join Date: Oct 2006
Location: Lincoln, NE
Age: 56
Posts: 414
I agree with you. I've been fairly lucky, myself. With all the different hardware permutations, BIOS levels, varying installed software, and such; it is very interesting to see how well any Linux distro works in the wild.
__________________
lost in hypertime...

Registered Linux User #329061
Reply With Quote
Reply

Tags
fedora, low, newb, signal, updated, wifi

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Signal: 11 (Unknown Signal) Fatal Error in MAYA 2009 that run on fedora 10 Haber_Nir Using Fedora 1 28th August 2009 03:26 AM
New Newb to Fedora Wifi Help SrgWallopy Servers & Networking 0 19th June 2008 01:14 AM
How to Improve WIFI Signal? dealmaker Servers & Networking 4 26th August 2007 10:49 AM
Unstable Wifi signal wprauchholz Hardware & Laptops 2 20th October 2006 09:22 PM
Signal strenght display / wifi wprauchholz Hardware & Laptops 1 29th December 2004 06:27 PM


Current GMT-time: 06:22 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Paraiba do Sul Instagram Photos - Perth Amboy Travel Photos - Columbus Travel Photos on Instagram