Fedora Linux Support Community & Resources Center
  #1  
Old 24th June 2008, 07:13 AM
Rykkan Offline
Registered User
 
Join Date: Jun 2008
Posts: 21
WoW and Wine 1.0 Problem

I have a Gateway MX7525, FC9 with 6-57 Kernel, and Wine 1.0. I've followed the install instructions but i still don't have truetype font eventho i have the latest freetype. Errors are:

[Rykkan@localhost ~]$ ./launch-wow.sh

X.Org X Server 1.4.99.902 (1.5.0 RC 2)
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-53.1.19.el5 x86_64
Current Operating System: Linux localhost.localdomain 2.6.25.6-57.fc9.x86_64 #1 SMP Thu Jun 12 13:03:54 EDT 2008 x86_64
Build Date: 12 June 2008 01:05:47AM
Build ID: xorg-x11-server 1.4.99.902-3.20080612.fc9
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.3.log", Time: Mon Jun 23 22:58:46 2008
(==) Using config file: "/etc/X11/xorg.conf"
NTSC PAL
finished output detect: 0
finished output detect: 1
finished output detect: 2
finished all detect
before xf86InitialConfiguration
Wine cannot find the FreeType font library. To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
in RADEONProbeOutputModes
after xf86InitialConfiguration
Entering TV Save
Save TV timing tables
saveTimingTables: reading timing tables
TV Save done
(EE) [drm] DRM was busy with another master.
(EE) RADEON(0): [dri] DRIScreenInit failed. Disabling DRI.
init memmap
init common
init crtc1
init pll1
restore memmap
restore common
restore crtc1
restore pll1
restore LVDS
expected keysym, got XF86Info: line 914 of inet
expected keysym, got XF86Info: line 914 of inet
ALSA lib seq_hw.c:457snd_seq_hw_open) open /dev/snd/seq failed: Permission denied
fixme:advapi:SetSecurityInfo stub
archive Data\patch.MPQ opened
archive Data\enUS\patch-enUS.MPQ opened
archive Data\enUS\patch-enUS-2.MPQ opened
archive Data\patch-2.MPQ opened
archive Data\expansion.MPQ opened
archive Data\common.MPQ opened
archive Data\enUS\locale-enUS.MPQ opened
archive Data\enUS\speech-enUS.MPQ opened
archive Data\enUS\expansion-locale-enUS.MPQ opened
archive Data\enUS\expansion-speech-enUS.MPQ opened
fixmeowrprofllMain (0x60c00000, 1, (nil)) not fully implemented
fixme:ntdll:NtPowerInformation Unimplemented NtPowerInformation action: 11
fixmeowrprofllMain (0x60c00000, 0, (nil)) not fully implemented
fixme:win:EnumDisplayDevicesW ((null),0,0x32eda4,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32ec94,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f2c8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f42c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5a8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5a0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f528,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f518,0x00000000), stub!

Backtrace:
0: X(xf86SigHandler+0x65) [0x47a5d5]
1: /lib64/libc.so.6 [0x3520e322a0]
2: /usr/lib64/xorg/modules/extensions//libglx.so(__glXDeassociateContext+0x35) [0x7f5739c9db95]
3: /usr/lib64/xorg/modules/extensions//libglx.so(__glXContextDestroy+0xf) [0x7f5739c9a28f]
4: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f5739c9d018]
5: /usr/lib64/xorg/modules/extensions//libglx.so(__glXFreeContext+0x6c) [0x7f5739c9c41c]
6: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f5739c9c463]
7: X(FreeResourceByType+0x105) [0x42e8c5]
8: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f5739c98d7e]
9: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f5739c9c782]
10: X(Dispatch+0x364) [0x4466d4]
11: X(main+0x45d) [0x42cbbd]
12: /lib64/libc.so.6(__libc_start_main+0xfa) [0x3520e1e32a]
13: X(FontFileCompleteXLFD+0x281) [0x42bf99]

Fatal server error:
Caught signal 11. Server aborting

finished PLL2
finished PLL1
Entering Restore TV
Restore TV PLL
Restore TVHV
Restore TV Restarts
Restore Timing Tables
Restore TV standard
Leaving Restore TV
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":3.0"
after 610 requests (600 known processed) with 0 events remaining.
[Rykkan@localhost ~]$

Please help! i want wow to work on linux so i don't have to boot into windows.
Reply With Quote
  #2  
Old 24th June 2008, 07:25 AM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hello:
I don't use the application however, try

yum install freetype-devel*

and for the MS fonts follow the guide located here Install Microsoft Truetype Fonts

Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #3  
Old 24th June 2008, 03:08 PM
mjmwired Offline
Registered User
 
Join Date: Feb 2005
Posts: 205
Please do try installing the TTF as listed in the previous post.
Also please report your results back on this thread.

I have heard conflicting issues about fonts with Wine and would love to see more information on it.
Reply With Quote
  #4  
Old 25th June 2008, 05:15 PM
Rykkan Offline
Registered User
 
Join Date: Jun 2008
Posts: 21
I tried the devel but doesn't work, i even tried to use freetype 2.3.6 which just came out. Anyone know a freetype version that works and can tell me how to uninstall mine and install the older one.
Reply With Quote
  #5  
Old 26th June 2008, 09:10 PM
willc0de4food Offline
Registered User
 
Join Date: Dec 2007
Posts: 24
why not actually use the TTF as suggested twice?

to remove, just do yum remove freetype*

also take note of the errors you posted:
Quote:
(EE) [drm] DRM was busy with another master.
(EE) RADEON(0): [dri] DRIScreenInit failed. Disabling DRI.
Reply With Quote
  #6  
Old 26th June 2008, 10:50 PM
Rykkan Offline
Registered User
 
Join Date: Jun 2008
Posts: 21
I swore the second poster said do not try. sorry.
Reply With Quote
  #7  
Old 27th June 2008, 06:34 AM
willc0de4food Offline
Registered User
 
Join Date: Dec 2007
Posts: 24
'ts all good ^_^ just let us know how it goes
Reply With Quote
Reply

Tags
problem, wine, wow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i have a problem with wine The Mishanator Using Fedora 4 25th August 2009 08:46 PM
Problem with Wine Esqulax Using Fedora 8 14th April 2009 03:39 PM
wine, wine-core, wine-tools GL1800 Using Fedora 4 7th July 2006 08:36 PM
Wine Problem elementadiobam Using Fedora 1 2nd July 2006 02:06 PM


Current GMT-time: 04:37 (Tuesday, 29-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat