Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #31  
Old 9th September 2008, 04:17 PM
dhlacik Offline
Registered User
 
Join Date: Jul 2008
Posts: 36
Quote:
Originally Posted by brebs
I don't see that bug - how to reproduce it?

Here's pixman gitweb. Is it this bug?
Well, not easy.

I was continuosly upgrading newer versions of your packages to latest and it worked fine.
Then i installed Fedora 9 i386 to new computer, applied your latest packages and bug is there. I've solved it by installing pixman-0.10.8 from your old/ directory.

Anyway, you are doing great work, thanks to you i love using Fedora 9 as desktop OS.

Regards,

D.
Reply With Quote
  #32  
Old 10th September 2008, 02:36 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
I've updated to cairo-1.7.4.20080909-1 and pixman-0.11.10.20080909-1 - try those.

Edit: On second thoughts, watch the reported bug for a fix.

Edit: I've reverted back to pixman-0.11.8 until the bug is fixed.

Edit: It seems to be fixed. I'll update back to pixman's svn soon.

Last edited by brebs; 11th September 2008 at 03:25 PM.
Reply With Quote
  #33  
Old 11th September 2008, 04:53 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
dhlacik, try pixman-0.11.10.20080911-1 and cairo-1.7.4.20080911-2 - your bug is hopefully fixed.

Edit: Also upgrade to freetype-2.3.7-3, which contains Ubuntu Intrepid's freetype-2.3.7-2ubuntu1

Last edited by brebs; 11th September 2008 at 07:37 PM.
Reply With Quote
  #34  
Old 15th September 2008, 09:52 AM
dhlacik Offline
Registered User
 
Join Date: Jul 2008
Posts: 36
Quote:
Originally Posted by brebs
dhlacik, try pixman-0.11.10.20080911-1 and cairo-1.7.4.20080911-2 - your bug is hopefully fixed.

Edit: Also upgrade to freetype-2.3.7-3, which contains Ubuntu Intrepid's freetype-2.3.7-2ubuntu1
Hello brebs, thanks! it's fixed now yes.

D.
Reply With Quote
  #35  
Old 15th September 2008, 10:17 AM
dhlacik Offline
Registered User
 
Join Date: Jul 2008
Posts: 36
Brebs, how often are you updating those packages?

Regards
Reply With Quote
  #36  
Old 15th September 2008, 05:17 PM
ascii79 Offline
Registered User
 
Join Date: Dec 2007
Posts: 17
I have filed the enchantment in livna.
http://bugzilla.livna.org/show_bug.cgi?id=2092

Thanx brebs...
Reply With Quote
  #37  
Old 15th September 2008, 06:22 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
dhlacik, there is no set timeframe, as with all open-source software. I wanted to get your bug fixed, which was the reason for my recent flurry of activity. Things seem groovy now, so this might be the last update for F9. After that, I might distro-hop, I honestly don't know.

If bugs or new releases or new features appear before I'm done with F9, I'm probably do the decent thing. News will be posted in this thread.

Quote:
Originally Posted by ascii79
livna
Interesting. I doubt the request will succeed, because:

* It could certainly be argued that I'm modifying more packages than necessary. I would counter that with the argument that fixing bugs in essentially-related packages is a good thing. But you know how geeks are

* Livna already has freetype-freeworld-2.3.5-6.lvn9.src.rpm - which is out-of-date, but, well, probably mostly shuts up the people like me who find the default font rendering to be sub-par, after seeing what Ubuntu can do.
Reply With Quote
  #38  
Old 17th September 2008, 03:28 PM
Thunder Offline
Registered User
 
Join Date: Sep 2008
Posts: 5
I have just installed the new fonts but it doesn't work on my system (Fedora 9). Only in Firefox and Thunderbird (wich have I downloaded from Mozilla) looks the Fonts much better. Any Ideas?

http://imagehost.ircstuff.de/archiv.php?bild=598
Reply With Quote
  #39  
Old 17th September 2008, 04:11 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
Quote:
Originally Posted by Thunder
Any Ideas?
Yeah. Read this thread, and the large thread on the Gentoo forum, as I've already said. You're not the only one running KDE.

Edit: I'll edit the cairo RPM to add to /etc/X11/Xresources:
Code:
Xft.lcdfilter: lcddefault
For a bit of user-friendliness.

Edit2: OK, use cairo-1.7.4.20080917-1, which contains:
Code:
%post
/sbin/ldconfig

grep lcdfilter /etc/X11/Xresources > /dev/null
if [ $? -eq 1 ] ; then
    # Add defaults
    echo -e "\n\n! Ubuntu LCD sub-pixel font rendering:\n!   http://www.fedoraforum.org/forum/showthread.php?t=186789\n!   http://forums.gentoo.org/viewtopic-t-511382.html\n! Choices: lcdnone, lcddefault, lcdlight, lcdlegacy\nXft.lcdfilter: lcddefault" >> /etc/X11/Xresources && echo "/etc/X11/Xresources has been updated to lcddefault."
fi
Edit3: This is now done in the fontconfig pkg, rather than cairo - makes more sense there.

Last edited by brebs; 3rd October 2008 at 03:42 PM.
Reply With Quote
  #40  
Old 20th September 2008, 06:31 PM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
Hey, are you certain that modifying the lcdfilter option in .fonts.conf doesn't work?

I run a GNOME desktop but I use Amarok, and it looks to me that setting it to "lcddefault" in /etc/fonts/local.conf does effect Amarok's text rendering.

So correct me if I'm wrong, but this is what I've done so far...

1. Install your packages for cairo, fontconfig, pixman, libXft, and freetype. (libXft doesn't seem to have been updated in a few months, but the others I just finished wget-ing.)

2. Set "lcdfilter" options in [wherever they go], and enable the bytecode interpreter in /etc/fonts/local/conf.

3. Enable full hinting and subpixel rendering. Enjoy?

(My main setup is a bit more detailed -- only the Microsoft fonts specifically use BCI, and I turn on BCI only for bold fonts, but that's basically it.)
Reply With Quote
  #41  
Old 22nd September 2008, 06:41 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
Quote:
Originally Posted by twilightomni
Hey, are you certain that modifying the lcdfilter option in .fonts.conf doesn't work?
Who are you asking? Anyway, Xresources definitely works, and ~/.fonts.conf might work just as well these days.

Quote:
libXft doesn't seem to have been updated in a few months
There's no updates to make - see gitweb. Well, apart from a soname change in the lib filename, which could break other apps.

Last edited by brebs; 22nd September 2008 at 06:44 PM.
Reply With Quote
  #42  
Old 22nd September 2008, 08:52 PM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
I was asking you, yes. I figured you were in charge of the thread.

That makes sense. I had falsely assumed maybe a new version of libXft had come out -- all those libraries seem to be updated very frequently. But perhaps not just yet.
Reply With Quote
  #43  
Old 26th September 2008, 12:41 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
In case anyone's wondering, I'll be skipping cairo 1.8.0 - it rips out all the lovely subpixel-rendering code
Reply With Quote
  #44  
Old 29th September 2008, 10:40 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
Apparently KDE has an issue with Qt4 due to hintstyle being ignored in Cairo (or maybe just toggling monospace) - I've implemented this patch in cairo-1.7.6.20080929-1
Code:
-    if (options->base.hint_style == CAIRO_HINT_STYLE_DEFAULT)
+    options->base.hint_style = CAIRO_HINT_STYLE_DEFAULT;
+
+    if (other->base.hint_style != CAIRO_HINT_STYLE_DEFAULT)
See if it helps with Qt apps, 'cos I don't use them

Last edited by brebs; 29th September 2008 at 10:43 PM.
Reply With Quote
  #45  
Old 3rd October 2008, 04:23 PM
fubz Offline
Registered User
 
Join Date: Mar 2006
Posts: 30
Hi Brebs

As per my priv message, please can you provide more details as to which patches you've applied to which source RPMs so I can maintain my own set of RPMs.

Thank you.
Reply With Quote
Reply

Tags
fedora, font, hardy, lcd, rendering, subpixel, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora's utterly pathetic font rendering has sent be running back to Ubuntu. somethingood Fedora Focus 48 2nd September 2008 07:02 PM
weird font rendering in Fedora 7 oayfer Using Fedora 9 23rd October 2007 10:50 PM
Font Rendering - Fedora 7 euler2 Using Fedora 2 20th June 2007 01:54 PM
Font rendering is so bad in Fedora 7 on my LCD cr4ck3r Using Fedora 15 10th June 2007 04:19 AM
Font rendering in Fedora mario.lopes Using Fedora 0 16th February 2005 11:35 PM


Current GMT-time: 02:21 (Thursday, 02-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat