Fedora Linux Support Community & Resources Center
  #1  
Old 29th February 2008, 02:00 AM
voodoodoc Offline
Registered User
 
Join Date: Jun 2007
Location: Philadelphia, PA
Posts: 117
Windows shared folders via Gnome

I used to be able to access shared folders on Winders computers just by opening up a nautilus file browser window and doing a "connect to server --> windows share" then browse the network and all the windows computers just showed up. The same for printers.

Now when I install Fedora 8 this does not work anymore. I know it all uses samba/cifs under the hood, and I'm guessing I could get it to work by doing some more in depth samba config. I'm really wondering what changed between F7 and F8, or is this a Gnome thing.
Reply With Quote
  #2  
Old 1st March 2008, 04:39 AM
bradchaus Offline
Registered User
 
Join Date: May 2006
Posts: 548
is port 139 open to your network?
__________________
* AMD Phenom 9750, 8GB DDR-1066, Gigabyte MA770UD3, ATI X550, F12 64bit
* Dual Athlon MP2800+, Gigabyte GA-7DPXDWP, 1GB, Centos 5.4

Linux Rules
Reply With Quote
  #3  
Old 1st March 2008, 11:20 AM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,377
Hello voodoodoc

One thing in the Fedora implementation of Samba did change somewhere during the lifespan of Fedora 7.

Up until that time, the smb service started both the smb and the nmb daemons.

Now both smb and nmb have to be started (or stopped) individually.

Take a look in:

Code:
system menu - administration - services
and see if both of those are started on your system.

In F8 as well it appears that if you open the samba service in your firewall:

Code:
system menu - administration - firewall
it is not enough to just "apply" and changes you have made, restarting the machine will have that effect of making the firewall use the new rules as it appears will "disabling" and "enabling" the firewall after changes.
Reply With Quote
  #4  
Old 3rd March 2008, 10:22 PM
voodoodoc Offline
Registered User
 
Join Date: Jun 2007
Location: Philadelphia, PA
Posts: 117
Just had to start smb and nmb, that did the trick. Thanks! Firewall wasn't a problem, in my case I turn off iptables (let my routers firewall deal with the outside world).

So for those that are curious simply do:
Code:
service iptables stop (may or may not be needed)
service smb start
service nmb start
Can also make these start up by default with chkconfig.


EDIT:
You do need a hole in the firewall to get this to work. So either disable iptables like I did or follow the advice previous.

Last edited by voodoodoc; 10th March 2008 at 04:13 AM.
Reply With Quote
Reply

Tags
folders, gnome, shared, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba on F8 - Cannot access windows shared folders tx836519 Servers & Networking 1 12th December 2008 07:56 PM
Access to Windows shared folders and printers out-of-the-box? ygramoel Servers & Networking 3 3rd July 2008 10:42 AM
Windows live messenger shared folders PsyGhost Linux Chat 1 7th June 2008 12:56 PM
Windows Shared Folders webdude Installation, Upgrades and Live Media 7 2nd April 2006 04:56 AM
Accessing Windows Shared Folders rinux Servers & Networking 16 23rd May 2004 04:42 AM


Current GMT-time: 03:17 (Friday, 19-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram