Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Servers & Networking
FedoraForum Search

Forgot Password? Join Us!

Servers & Networking Discuss any Fedora server problems and Networking issues such as dhcp, IP numbers, wlan, modems, etc.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 21st February 2008, 09:54 AM
xiaoyaozi Offline
Registered User
 
Join Date: Feb 2008
Posts: 2
Question how to get wireless 3945abg to connect to a wpa password needed router?

my company's wireless rounter is DHCP
my laptop pc can not connect to the router which needs a wpa password.
it open the password input interface again and again when I entered the correct pwd, when I reinstalled the fedora8, then it can connect to the router, but can not get the correct ip. so who can tell me y?
Reply With Quote
  #2  
Old 21st February 2008, 10:32 AM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,377
Hello xiaoyaozi

Firstly, I have a 3945 that connects well to a WPA encrypted access point but some people are not so lucky.

If your access point does not broadcast its ssid you should consider changing that just as an experiment. Some people have reported that once the machine has connected once it will reconnect after the ssid is hidden again

Secondly, there can be more that one process trying to control the card and there are some things to check.

I assume you are running Gnome as your desktop.

From the System Menu - Administration - Services, make sure that NetworkManager is set to start at boot and is running.

From System Menu - Administration - Network, highlight your wireless card and click 'Edit' from the toolbar.

Make sure that the card is NOT set to "Activate Device when Computer Starts". If your system is up to date there will also be an option to choose "Controlled by NetworkManager", make sure that is selected.

See if those suggestions help otherwise we will all think again.
Reply With Quote
  #3  
Old 21st February 2008, 10:40 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,994
Are yo uusing NetworkMAnager.

There is a bug. When it repeatedly asks for the key, DO NOT provide it. Instead click on the NM icon in the panel and select "connect to new network" and fill in the details.

Also see this !
http://fedoraproject.org/wiki/Bugs/F8Common
Reply With Quote
  #4  
Old 22nd February 2008, 02:38 AM
xiaoyaozi Offline
Registered User
 
Join Date: Feb 2008
Posts: 2
hi bbfuller, thanks for your help, but it can't work well when i followed your suggestion.
and now the network access need static ip to connect instead of DHCP
so first I set the correct IP and DNS as what windows do
then start the NetworkManger service, and enter the password when it ask for wpa key.
it connected successfully in a few seconds
but the IP and DNS have been changed by the service, and can not connect to www
so my question is how can I start it without change my static ip and DNS?

also thanks stevea, I just tried what you said but failed unfortunatly.
Reply With Quote
  #5  
Old 22nd February 2008, 11:03 AM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,377
Hello xiaoyaozi

What I suggested should have worked when you were able to use dhcp as a method of obtaining an ip address.

I haven't tried, but from reading on the forum I understand that the NetworkManager software won't work with static ip addresses.

I believe your only choice for that is going to be to disable NetworkManager from the "Services" application mentioned earlier and to make your connection manually. From what I read NetworkManager may have the facility for static ip addresses in Fedora 9.

This howto:

http://home.nyc.rr.com/computertaijutsu/rhwireless.html

at least tells you how to control wpa_supplicant manually.

I assume you will have to configure your card from the "System - Administration - Network" aplication and then add the control for wpa_supplicant as the howto.

Not sure how that will work out as I've never had to do it.
Reply With Quote
Reply

Tags
3945abg, connect, needed, password, router, wireless, wpa

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i have wireless connection, but can't connect to router aceviperking Servers & Networking 4 10th July 2008 05:49 PM
Can't connect to wireless G Router spike_oki Hardware & Laptops 3 11th February 2008 09:22 PM
Can't connect to wireless G Router spike_oki Servers & Networking 1 11th February 2008 09:21 PM
Fedora 8 cannot connect to wireless router when WPE is on kevinmscs Servers & Networking 0 4th December 2007 08:15 PM
wireless router help needed ozzkoz Servers & Networking 14 13th October 2005 03:40 AM


Current GMT-time: 15:09 (Wednesday, 26-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Linyi Travel Photos on Instagram - Lohja Photos on Instagram - Sao Roque Photos