Fedora Linux Support Community & Resources Center
  #1  
Old 20th February 2008, 04:54 AM
BigBadWoofer Offline
Registered User
 
Join Date: Jan 2008
Age: 67
Posts: 13
Trouble installing WUSB54GC in Fedora 8

I'm having trouble installing a Linksys Wireless USB Adapter (WUSB54GC) in my system running Fedora 8. All the searches for WUSB54GC say that it worked right out of the box so I've done something wrong somewhere.

Initially I was trying to install the PCI version but had no success. Finally I found evidence in the Linksys forum that my computer was old enough that my PCI backplane was not compatible with new PCI cards. So I returned the PCI version for the USB version.

However, before that I had tried to use ndiswrapper to use the Windows drivers to find the PCI adapter. Since then I have deleted any driver built and used yum to remove the whole ndiswrapper package. But I'm not sure that something was not left laying around to cause problems.

Current status as follows:

iwconfig shows:

wlan0 Link encap:Ethernet HWaddr 00:1D:7E:9D:31:B3
inet6 addr: fe80::21d:7eff:fe9d:31b3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:8496 (8.2 KiB)

"iwlist wlan0 scanning" show:

wlan0 Scan completed :
Cell 01 - Address: 00:13:10:10:79:21
ESSID:"linksys"
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=52/100 Signal level=-46 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=0000001fb1d1a96b

I used GNOME Network to set wireless parameters (WEP key, etc).

However when I try to activate the device (ifup) I see:

Determining IP information for wlan0... failed.

Changing wireless parameters doesn't seem to help at all. Just produces additional errors in GNOME Network.

I know the device itself works because I tried it on another computer running XP and it worked successfully with my Linksys Broadband Router (WRT54G).

Any suggestions or comments? Where do I go from here?
Reply With Quote
  #2  
Old 20th February 2008, 05:03 AM
kevmif Offline
Registered User
 
Join Date: Dec 2004
Location: Australia
Posts: 484
Looks just like a config issue with the way you were setting up your connection.

How is your router set up? What security is enabled?
Reply With Quote
  #3  
Old 20th February 2008, 05:45 AM
BigBadWoofer Offline
Registered User
 
Join Date: Jan 2008
Age: 67
Posts: 13
Not sure exactly what you mean by router config. It's set for 128 bit encryption with a WEP passpharase. When I used the same USB Wireless Adapter on my XP computer it connected wtih no problem. The fields were similar when I used GNOME network to config wireless parameters.
Reply With Quote
  #4  
Old 20th February 2008, 05:57 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
The results of iwlist show that the card is working.

I believe that for a WEP network, you can use system-config-network to set it up--it should show the card and there's an option to configure, or edit, or something similar. You should then have a place to put in the network name and password--as the screen will say, if you use the hex password, the long one that doesn't seem like a word, be sure to put 0x in front of it--that's the numeral zero, not a capital o.

I'm not in Fedora right now, I'm writing from FreeBSD and don't have Gnome here, so most of this is from memory. If it's not clear, let me know, but hopefully, my somewhat vague description will let you figure it out.
I repeat though, the USB adapter is working, in the sense that Fedora sees it and is recognizing it as a working wireless interface--otherwise the iwlist scan stuff wouldn't have worked.
Reply With Quote
  #5  
Old 21st February 2008, 03:21 PM
BigBadWoofer Offline
Registered User
 
Join Date: Jan 2008
Age: 67
Posts: 13
I have temporarily shelved using GNOME in favor of the command line approach. I'll figure that out later. Plus I'm not seeing anything from the Network Manager anyway,

Below is a collection of commands and logs done before and after trying to activate the wlan0 interface. I agree with scottro that Fedora is seeing the adapter but not quite in sync yet. Of particular interest is that iwconfig shows changes to the encryption key parameter after attempting to activate the adapter. The system messages seem to indicate a WEP key problem.

So my next question is: how do I specify 128bit encryption as opposed to 64bit encryption. That is the only parameter that appears in the Windows installation process but is not obvious in the Fedora installation process. As I said in the beginning, I have successfully used this adapter on another computer running XP by following the installation process supplied by the manufacturer.

Any help or suggestions would be greatly appreciated. I'm getting older and grayer much too quickly by trying to make this work.

After plugin:

[root@localhost ~]# lsusb
Bus 001 Device 003: ID 13b1:0020 Linksys WUSB54GC 802.11g Adapter [ralink rt73]
Bus 001 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 001 Device 001: ID 0000:0000

[root@localhost ~]# iwconfig
wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[root@localhost ~]# iwlist wlan0 scanning
wlan0 Scan completed :
Cell 01 - Address: 00:13:10:10:79:21
ESSID:"linksys"
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=51/100 Signal level=-50 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=0000003bef9d736e

After iwconfig changes:

[root@localhost ~]# iwconfig
wlan0 IEEE 802.11g ESSID:"linksys"
Mode:Managed Frequency:2.437 GHz Access Point: 00:13:10:10:79:21
Bit Rate=2 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX {modified}
Link Quality=71/100 Signal level=-52 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Trying to bring up:

[root@localhost ~]# ifup wlan0 on

Determining IP information for wlan0... failed.

Tail of /var/log/messages:
Feb 21 09:34:02 localhost dhclient: wmaster0: unknown hardware address type 801
Feb 21 09:34:02 localhost dhclient: wmaster0: unknown hardware address type 801
Feb 21 09:34:02 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
Feb 21 09:34:05 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
Feb 21 09:34:11 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
Feb 21 09:34:22 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
Feb 21 09:34:35 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
Feb 21 09:34:44 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
Feb 21 09:34:57 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
Feb 21 09:35:03 localhost dhclient: No DHCPOFFERS received.

dmesg shows:

WEP decrypt failed (ICV) {multiple}

usb 1-2: new full speed USB device using uhci_hcd and address 3
usb 1-2: configuration #1 chosen from 1 choice
phy0: Selected rate control algorithm 'pid'
usbcore: registered new interface driver rt73usb
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:13:10:10:79:21
wlan0: RX authentication from 00:13:10:10:79:21 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:13:10:10:79:21
wlan0: RX AssocResp from 00:13:10:10:79:21 (capab=0x431 status=0 aid=3)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: disassociate(reason=3)
wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
{more of the same}

After:

[root@localhost ~]# iwconfig
wlan0 IEEE 802.11g ESSID:"linksys"
Mode:Managed Frequency:2.437 GHz Access Point: 00:13:10:10:79:21
Bit Rate=2 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off {changed}
Link Quality=71/100 Signal level=-54 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Reply With Quote
  #6  
Old 21st February 2008, 07:14 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
As I said, haven't used WEP in awhile, but looking at the man page I think it's
(if you're using the default name of Linksys--some of the names in my building make me wonder, but my wife won't let me ask around about who is "freakgirl) and a hex key of xxx-xxx
(yes, that's a short hex key, but just for example)

iwconfig wlan0 essid Linksys key xxx-xxx

seems as if it should work. Give it a shot anyway. The man page for iwconfig is pretty good, actually.

(If you're using an ACSII string, that is a password like john instead whatever the "john" is when translated to hex, it would be key s:john--I guess s: is for string. )
Reply With Quote
  #7  
Old 23rd February 2008, 06:48 AM
johannlo Offline
Registered User
 
Join Date: Jul 2005
Location: Melbourne, Australia
Age: 34
Posts: 762
No don't use ifup script.
ifup is actually a script that calls the options in /etc/sysconfig/network-scripts!!!!

go manual, if it works, then edit the parameters in that directory to suit.

ifconfig <int> up
iwconfing <int> mode managed
iwconfing <int> ap <MAC of AP>
iwconfig <int> channel <channel of AP>
iwconfig <int> key <key - note what scottro mentions about different input formats for the key like s: for ASCII strings>

You should see something like

[root@wintermute johannlo]# iwconfig

wlan0 IEEE 802.11g ESSID:"snowcrash"
Mode:Managed Frequency:2.437 GHz Access Point: 00:12:17:BE:28:2A
Bit Rate=5.5 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:xxxxxxxxxxxxxxxxxxxxxxxxxxx
Link Quality=72/100 Signal level=-48 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


NOW HERE IS THE BIT EVERYONE FORGETS - you need to either manually give it an IP address or run dhclient <int> to get your IP address
__________________
the phases of 'nix troubleshooting

For :eek:
:confused: | google > :D
Next
Reply With Quote
  #8  
Old 25th February 2008, 09:31 PM
BigBadWoofer Offline
Registered User
 
Join Date: Jan 2008
Age: 67
Posts: 13
Well, I'm almost ashamed to admit it but the problem all the time was human error. once I understood network-config it took off like a shot. now running WEP 128bit encryptiion. I may lock it down even more by entering specific IP addresses in the wireless router.

Thanks for all the help and suggestion to all who replyed.
Reply With Quote
  #9  
Old 25th February 2008, 10:51 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
You'd be better off, I think, in doing it with specific MAC addresses rather than IP addresses. Probably everyone in the area has a Linksys or Netgear, and they all use 192.168.1.0/24 addresses by default. The Mac addies are quite similar too, I think two of my neighbors and myself have a 1 digit difference in the Mac addies--we probably all bought our routers the same weekend.

It's not difficult to spoof Mac addresses, but usually, there's one or two unsecured routers around, so who ever might try to break into a network uses those.
Reply With Quote
  #10  
Old 25th February 2008, 11:46 PM
BigBadWoofer Offline
Registered User
 
Join Date: Jan 2008
Age: 67
Posts: 13
Sorry, I meant MAC addresses. I know there is no absolute security but I'd figure I'd do what I can. If it looks like too much work then hopefully they will just move on. As it is there is an unsecured wireless network somewhere in the neighborhood anyway. Let them be the honey pot, chuckle.
Reply With Quote
Reply

Tags
fedora, installing, trouble, wusb54gc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Having trouble installing dvdstyler on fedora 11 serversysadm Using Fedora 4 24th July 2009 05:36 PM
Success with Fedora 10 and LINKSYS WUSB54GC! cadenpsu Guides & Solutions (No Questions) 2 2nd January 2009 12:43 AM
Trouble installing Fedora 7 jo_atman Using Fedora 18 23rd September 2007 08:11 AM
Having trouble installing Fedora 7 on a Mac Pro Spanky Deluxe Installation, Upgrades and Live Media 4 7th August 2007 11:13 PM
Trouble installing Fedora Core 4 SpencerYost Installation, Upgrades and Live Media 4 23rd August 2005 04:45 PM


Current GMT-time: 10:13 (Wednesday, 16-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat