Fedora Linux Support Community & Resources Center
  #1  
Old 2nd February 2008, 09:23 AM
alkojorma Offline
Registered User
 
Join Date: Feb 2008
Posts: 1
Problem with Wow through Wine

Hi

Ive installed Fedora 8 in hope of making some games run through wine. Now i can run wow in D3D but as its unplayable i tried Opengl. The thing is its working when i change settings in /etc/X11/xorg.conf sometimes. Wow then detects a hardware change and asks if i want to load default settings, I press no and can then play wow smooth and lagfree with as it seems full 3d support. But 99% of times it says my 3d card isnt supported and something about Dual-TMU support is needed.

Im runing kernel 2.6.23.14-107.fc8 and fglrxinfo says:

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1950 Series
OpenGL version string: 2.1.7170 Release

glxinfo:

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:

And so on...

Has anyone seen this before? I have tried to solve this for days now and I just cant figure it out. Im guessing i have to downgrade something, or upgrade but i have the latest release from livna and the driver from ATIs homepage screwed my rigg. Ive also tried downgrading xorg-x11-server as shown in ATI guide in the forum.

This is frustrating as i know my card can render the game in OpenGL mode but i cant get to a point where i can figure out how and why it sometimes start and run..

Some feedback on this would be great.

Cheers
Reply With Quote
  #2  
Old 2nd February 2008, 09:25 AM
leigh123linux
Guest
 
Posts: n/a
moved to the gamers lounge
Reply With Quote
  #3  
Old 3rd February 2008, 04:08 PM
tophat Offline
Registered User
 
Join Date: Feb 2008
Posts: 6
Problem with WoW and Wine

Hey

Here is a guide I came across when I was installing WoW on my machines. I know the guide says it is for Gentoo but I've used it already twice on Fedora 8 machines and on a Linux Mint machine.

http://gentoo-wiki.com/HOWTO_Install...raft_with_wine

Since you already have it installed try going down to the Performance Tweaking section. It tells you how to configure the game so that it always runs with OpenGL rather then D3D along with a few other performance tweaks.
Reply With Quote
  #4  
Old 26th June 2008, 10:20 PM
willc0de4food Offline
Registered User
 
Join Date: Dec 2007
Posts: 24
are you using the fglrx drivers?
Reply With Quote
  #5  
Old 18th July 2008, 02:00 AM
DivineSoverign Offline
Registered User
 
Join Date: Jul 2008
Posts: 1
I have the exact same problem, running in D3D gives me WoW in a choppy manner (textures are messed all up, and I get a crash when I get so far in) and running with -opengl gives me the message, "Your 3d accelerator card is not supported by World of Warcraft. Please install a 3d accelerator card with dual-TMU support"

I'm running a nVidia G-force 8800 GTS which I know should be able to play WoW, as per the Gentoo howto. I have the latest nVidia drivers and latest version of Wine, and I've tried everything that the Gentoo howto tries to get me to do. 2.6.25.9-40.fc8

An interesting problem is that when running WoW version 2.0 in D3D, textures are fixed even though the fps are slower.
Reply With Quote
  #6  
Old 18th July 2008, 02:35 PM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 37
Posts: 4,423
As much as I like ATi hardware, use of it, especially their fglrx proprietary driver in conjunction with wine can be problematic. Besides, there's a bug in their current (8.6) drivers cause a checkboard effect with many Windows applications run through wine.
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
  #7  
Old 21st July 2008, 08:40 AM
jazz452 Offline
Registered User
 
Join Date: Jul 2008
Posts: 3
Same problem here on arch linux has wine released a recent update.On another partion i have fedora 9
and it works like a dream so i will check if wine is the same version.By the way nvidia 8800gt oc.
Reply With Quote
  #8  
Old 21st July 2008, 08:57 AM
jazz452 Offline
Registered User
 
Join Date: Jul 2008
Posts: 3
[QUOTE=jazz452]Same problem here on arch linux has wine released a recent update.On another partion i have fedora 9
and it works like a dream so i will check if wine is the same version.By the way nvidia 8800gt oc.[/QUOTE

Last edited by jazz452; 21st July 2008 at 08:45 PM.
Reply With Quote
  #9  
Old 21st July 2008, 08:43 PM
jazz452 Offline
Registered User
 
Join Date: Jul 2008
Posts: 3
Quote:
Originally Posted by jazz452
Just checked different wine version.1.0 works fine but 1.1.1 gives graphics card failure.So downgrade wine to 1.0 should work fine
UPDATE
I just installed lib32 utils in arch 64 bit and works fine so make sure you install the 32bit nvidia files im sure this is the problem * yum install xorg-x11-drv-nvidia-libs.i386* and any dependencies
Reply With Quote
Reply

Tags
problem, wine, wow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i have a problem with wine The Mishanator Using Fedora 4 25th August 2009 09:46 PM
Problem with Wine Esqulax Using Fedora 8 14th April 2009 04:39 PM
wine, wine-core, wine-tools GL1800 Using Fedora 4 7th July 2006 09:36 PM
Wine Problem elementadiobam Using Fedora 1 2nd July 2006 03:06 PM


Current GMT-time: 06:29 (Wednesday, 26-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Boudouaou Photos - Mulleriyawa - Macia Photos