Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 27th January 2008, 04:19 PM
k13pt0 Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
Permission denied trying to install .run extension file

Can anyone gimme guide lines to running a file with a .run extension. Im new to linux cant seem to find much on the subject doing searches. I keep getting a permmision denied in the terminal.
Reply With Quote
  #2  
Old 27th January 2008, 04:25 PM
CraigWatson Offline
Registered User
 
Join Date: Jan 2008
Location: Witham, Essex, UK
Age: 27
Posts: 341
To get around the "permission denied" error, you must run the command as the "root" user:

Code:
[user@machine ~]$ su -
Password: Your-root-password
[root@machine ~]# your-command-here
To return out of "root" user mode, just type exit .

Edit

The above command will elevate you to root-user status until you exit. To run a specific command with elevated permissions, just tag "sudo" to the start of your command, so for example:

Code:
[user@machine ~]$ nano /etc/X11/xorg.conf
Will become:

Code:
[user@machine ~]$ sudo nano /etx/X11/xorg.conf
For some commands like fdisk or lspci you need to have the root user's environment as well as the privileges, so use the "su -" command.
__________________
Personal Website | Windows to Linux - Tips from Experience

Desktop - Galileo
Dual-Boot: Fedora 13 x64, Windows 7 x64
Intel Core2Quad Q6600 @3.6GHz, 8GB PC2-8500 DDR2, ATI HD4870, 23" @ 1920x1080 + 20" @ 1600x900 (both DVI-D), 2TB ICH10R RAID0 array, Custom Watercooling

Laptop - MacBook 5.1 ('08 Aluminium)
Dual-Boot: Fedora 13 x64, Apple OS X
Intel Core2Duo, 2GB 1066MHz DDR3, nVidia 9400M, 13" LCD @ 1280x800, 160GB SATA

Last edited by CraigWatson; 27th January 2008 at 04:32 PM.
Reply With Quote
  #3  
Old 27th January 2008, 04:42 PM
jazzfan Offline
Registered User
 
Join Date: Nov 2007
Posts: 153
try to change premissions to that file:
Code:
su -c chmod 777 $path_to_your_file.run
Now, you'll be able to run this file like a normal user
__________________
Robi
Woodworking ideas

"Fedora -- All my bits are free, are yours?" - Jasse Keating
"Because open sorce matters" - Joomla!
"Be free" - KDE

Last edited by jazzfan; 27th January 2008 at 04:57 PM.
Reply With Quote
  #4  
Old 27th January 2008, 04:47 PM
jazzfan Offline
Registered User
 
Join Date: Nov 2007
Posts: 153
but that's not always smart: this above (both my and Watson's solutions) will give the x.run file full permissions to write over your files. So it would be smarter for you to first do:
Code:
su -c chmod a+rx $path_to_your_file.run
which will only give permissions to read and execute file, but not permit writing anything.
If you now run the .run file from terminal , you will see what and where is program trying to copy files.

After you're sure it won't hurt you, do the command from my first post.
__________________
Robi
Woodworking ideas

"Fedora -- All my bits are free, are yours?" - Jasse Keating
"Because open sorce matters" - Joomla!
"Be free" - KDE

Last edited by jazzfan; 27th January 2008 at 04:51 PM.
Reply With Quote
  #5  
Old 27th January 2008, 04:50 PM
k13pt0 Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
[K13pt0@ip68-2-59- ~]$ su -
Password:
[root@ip68-2-59- ~]# /home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
-bash: /home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run: Permission denied
[root@ip68-2-59- ~]#

Am i running doing this right?
Reply With Quote
  #6  
Old 27th January 2008, 04:52 PM
jazzfan Offline
Registered User
 
Join Date: Nov 2007
Posts: 153
Have you made what I said you in my post?
__________________
Robi
Woodworking ideas

"Fedora -- All my bits are free, are yours?" - Jasse Keating
"Because open sorce matters" - Joomla!
"Be free" - KDE
Reply With Quote
  #7  
Old 27th January 2008, 04:56 PM
k13pt0 Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
[K13pt0@ip68-2-59-24 ~]$ sudo -c chmod 777 $/home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
sudo: illegal option `-c'
usage: sudo -h | -K | -k | -L | -l | -V | -v
usage: sudo [-bEHPS] [-p prompt] [-u username|#uid] [VAR=value]
{-i | -s | <command>}
usage: sudo -e [-S] [-p prompt] [-u username|#uid] file ...
[K13pt0@ip68-2-59-24 ~]$ /home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
bash: /home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run: Permission denied
[K13pt0@ip68-2-59-24 ~]$


I gotta be typing something wrong
Reply With Quote
  #8  
Old 27th January 2008, 04:58 PM
jazzfan Offline
Registered User
 
Join Date: Nov 2007
Posts: 153
sorry, my bad
look now, I correct it
__________________
Robi
Woodworking ideas

"Fedora -- All my bits are free, are yours?" - Jasse Keating
"Because open sorce matters" - Joomla!
"Be free" - KDE
Reply With Quote
  #9  
Old 27th January 2008, 05:03 PM
k13pt0 Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
Lol this is nuts I been trying to figure this out for awhile.
Reply With Quote
  #10  
Old 27th January 2008, 05:04 PM
jazzfan Offline
Registered User
 
Join Date: Nov 2007
Posts: 153
so, it works now?
__________________
Robi
Woodworking ideas

"Fedora -- All my bits are free, are yours?" - Jasse Keating
"Because open sorce matters" - Joomla!
"Be free" - KDE
Reply With Quote
  #11  
Old 27th January 2008, 05:05 PM
k13pt0 Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
[K13pt0@ip68-2-59-24 ~]$ su - c chmod 777 $/home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
su: user c does not exist
[K13pt0@ip68-2-59-24 ~]$ su -c chmod 777 $/home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
su: user 777 does not exist
Reply With Quote
  #12  
Old 27th January 2008, 05:06 PM
k13pt0 Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
No not working still get a permission denied
Reply With Quote
  #13  
Old 27th January 2008, 05:08 PM
k13pt0 Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
[K13pt0@ip68-2-59-24 ~]$ su -
Password:
[root@ip68-2-59-24 ~]# c chmod 777 $/home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
-bash: c: command not found
[root@ip68-2-59-24 ~]# chmod 777 $/home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
chmod: cannot access `$/home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run': No such file or directory

Your code worked Minus the "$" in fromt of my directory Thnks for your help

[root@ip68-2-59-24 ~]# chmod 777 /home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
[root@ip68-2-59-24 ~]# /home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
STUBBED: ftell is 32 bit!
at /home/timo/Build/mojosetup/fileio.c:246

Last edited by k13pt0; 27th January 2008 at 05:13 PM.
Reply With Quote
  #14  
Old 27th January 2008, 05:09 PM
CraigWatson Offline
Registered User
 
Join Date: Jan 2008
Location: Witham, Essex, UK
Age: 27
Posts: 341
take the dollar out before the filename
__________________
Personal Website | Windows to Linux - Tips from Experience

Desktop - Galileo
Dual-Boot: Fedora 13 x64, Windows 7 x64
Intel Core2Quad Q6600 @3.6GHz, 8GB PC2-8500 DDR2, ATI HD4870, 23" @ 1920x1080 + 20" @ 1600x900 (both DVI-D), 2TB ICH10R RAID0 array, Custom Watercooling

Laptop - MacBook 5.1 ('08 Aluminium)
Dual-Boot: Fedora 13 x64, Apple OS X
Intel Core2Duo, 2GB 1066MHz DDR3, nVidia 9400M, 13" LCD @ 1280x800, 160GB SATA
Reply With Quote
  #15  
Old 27th January 2008, 05:10 PM
jazzfan Offline
Registered User
 
Join Date: Nov 2007
Posts: 153
without the $ sign:
Code:
su -c "chmod 777 /home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run"
/home/K13pt0/ETQW-demo-client-1.1-full.r5.x86.run
__________________
Robi
Woodworking ideas

"Fedora -- All my bits are free, are yours?" - Jasse Keating
"Because open sorce matters" - Joomla!
"Be free" - KDE

Last edited by jazzfan; 2nd April 2008 at 05:18 PM.
Reply With Quote
Reply

Tags
denied, extension, file, install, permission, run

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
permission denied when file transfer zodehala Using Fedora 3 23rd April 2009 09:13 PM
permission denied to move a file, Fedora 10 baerb8 Using Fedora 7 25th December 2008 02:36 AM
FC5 named zone file permission denied Donsoloway Servers & Networking 2 11th April 2006 08:16 AM
httpd: file permission denied. Jing Using Fedora 4 22nd November 2004 09:52 PM


Current GMT-time: 23:46 (Thursday, 18-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat