Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 7th January 2008, 05:27 PM
hdavy2005 Offline
Registered User
 
Join Date: Feb 2007
Posts: 17
permission denied when mounting ntfs (Note:Fuse, ntfs-3g already installed)

Hi all ,
I get this error in my /var/log/messages

Jan 7 12:12:06 localhost kernel: audit(1199725908.414:4): avc: denied { getattr } for pid=1641 comm="mount.ntfs-3g" path="/sbin/modprobe" dev=dm-0 ino=2278177 scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:insmod_exec_t:s0 tclass=file
Jan 7 12:12:06 localhost kernel: fuse init (API version 7.8)
Jan 7 12:12:06 localhost kernel: fuse distribution version: 2.7.0
Jan 7 12:12:06 localhost kernel: audit(1199725909.705:5): avc: denied { mount } for pid=1641 comm="mount.ntfs-3g" name="/" dev=hda2 ino=1 scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:unlabeled_t:s0 tclass=filesystem


I have already installed fuse and ntfs-3g on my centos box, i am confused about that permission part.
I installed all these as root.
Thnaks
Reply With Quote
  #2  
Old 25th January 2008, 07:21 PM
zerovice Offline
Registered User
 
Join Date: Mar 2006
Posts: 41
This is an selinux policy issue. You can test by running "setenforce 0" and verifying that is in Permissive mode by "getenforce". Once in Permissive mode try to mount the drive again. I suspect you don't have the latest SELinux policy and you should do a yum update.

- James
Reply With Quote
  #3  
Old 25th January 2008, 10:19 PM
LordMorgul Offline
Registered User
 
Join Date: Mar 2004
Location: Sourthern California, USA
Posts: 503
It may be that your filesystem needs a little relabeling as well. After you try to update policy then as root do either 1) or 2):
1) logout, then in console: fixfiles relabel
2) touch /.autorelabel; reboot
__________________
- Andrew <lordmorgul@gmail.com>

No one now has, and no one will ever again get, the big picture. - Daniel Geer
Reply With Quote
  #4  
Old 28th May 2009, 10:06 PM
oldefoxx Offline
Registered User
 
Join Date: May 2009
Posts: 2
Found What I Think Might Be A Fix Or Workaround.

Had the same problem yesterday. Funny thing is, some partitions mounted automatically, and others did not. Try to mount them manually gave me the same error about permissions, o rlack thereof. Coming back around in case this is a help to others.

The key seems to be the manner of entries in /etc/fstab. You probably already know tht to edi this table (actually, just a text file with columns in it separated by one or more tabs or spaces), you have to be root or super user. To become super user, just get into a
Terminal mode and type sudo -s. When asked for a password, just put your user password there. That should do it. The last character in each prompt line will proabably change from a $ (indicating a user) to a # (meaning root or in super user mode).

Now type in nano /etc/fstab, of if you rather just type in gedit /etc/fstab. That brings up another window with the contents of /etc/fstab displayed. You can now make and save changes, begause nano and gedit are text editors.

To have any partition or drive be self-mounting, there has to be a vailid entry for it in here. Usually, all you see at the start is one for root (mount point set to /), swap (no real name, type is sw), and maybe one of two entries for one or two DVD/CD drifes. These should be fine, no real need to mess with them. But you can add more lines at the bottom.

The first question is, how are you going to identify a specific device? Many versions of Linux use a pointer to where the device is already marked, which is in the /dev directory. There are many possible devices there, but only a few that identify drives. If it starts with f, it is a floppy. If it starts with an h, then it is a hard drive. If it starts with an s, then initially it was aSCSI drive, but now they might use that to identify a removable drive as well. If it starts with a c, it could be a CD or combo DVD/CD drive. The information further over gives more detail. In some cases, instead of using /dev and the class of device, you might see something like UUID=, followed by a long string of characters. This must be a formattable device, and the string of characters are a unique volume ID that assures that this line always points to just this one volume -- unless you happen to reformat it for some reason. Then you have to change this to match the new UUID character string. But some think that is better then relying on something like /dev/sda1 as an example. It is a matter of choice. (remember, if it starts with s, then it is removable, and therefore subject to mount and umount commands by the user or whomever has the right permissions).

Alright, having covered most of the basics, what needs to go here for a partition that does not want to mount or umount, and cites problems in the manner of permisisons?

Actually, this might be a typical entry, lets say for an NTFS volume that you want to access from Linux:

/dev/sda5 /mnt/XP ntfs-3g defaults 0 0


But wait, how do we know that it is /dev/sda5? Or what if it is on our second drive, or a USB connected drive? Now USB is a different category if device, but there is an entry that goes into this table to cover that possibility. But you can read about it elsewhere. This is really a discussion about internal drives.

Yes, that is a good question. How do we find out what that device is considered on this system? This is where I recommend using something like apt-get install and having it install a package called gparted. Gparted is a partition editor, and what it really does is show usour drives and how they are currently partitioned, what file system they have on them, and even how much of each partition has been used up. You can make a few changes with gparted, but mostly we want to see what we already have. And one of the things it shows us is the related device name that is found in /dev. So that is real handy at this point. If you don't have it yet, you can open another terminal console window again, use sudo -s to get superuser priveleges, then apt-get install gparted, and away you go. If you want to know more about gparted, look it up online.

Noq id rhia was identified as a ext2, etx3, ext4, or reiserfs parttition, but you still wanted to access it, you just replace the ntfs-3g with the right designator in that line in the fstab file, and the defaults settings will still work. It's that easy. But how are you going to tell each mouted drive apart from the others? I guess in the way you label them, because that is what shows up when you look for them from the GUI. In my case, I usually start with DRIVE_C, and work my way up the alphabet by changing the last letter as I go from one drive to the next.

Now you save /etc/fstab and quit out of the text editor. You can also quit qparted as well.. But are you done? No, not really. There is one more critical step that you as superuser must do. That is, you must create a mount point that matches the entry in etc/fstab, because if the mount point (actuall a subfolder) does not exist, the mount effort will still fail. So how do you do mount points? AQnd where is a good place to put them? Like i said, you could put them under /mnt, but with some versions of Linux, they prefer to put them under /meda (something to do with removable media and what it might represent I suppose). So if we added an entry with the mount point /mnt/XP as shown above for an example, we would now do aq mkdir /mnt/XP. And that would be it for this drive. Next time we reboot, it should automatically mount if we did everything right. If not, we had better recheck our work.

Sounds really hard and involved, I suppose, but you do this a few times, and you realize that it isn't all tht hard. And it makes sense in a way, if you think about it.

I hope that this helps. Oh, and this is likely applicable to other versions of Linux as well. Now if you don't find it exactly the same in whatever version you are using, don't worry. Visit the supporting forums, and someone can probably explain the differences to you.
Reply With Quote
  #5  
Old 28th May 2009, 10:22 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
hdavy2005 passed away while waiting for your reply, but thanks for the effort.
Reply With Quote
Reply

Tags
denied, installed, mounting, notefuse, ntfs, ntfs3g, permission

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fuse: mount failed: Device or resource busy - Mounting NTFS drive K1u Using Fedora 1 25th August 2007 07:50 AM
SELinux blocks automatic mounting of ntfs partitions via ntfs-3g Fedora-hx4700 Using Fedora 0 21st March 2007 09:24 PM
warning when mounting ntfs after ntfs-3g update pobbz Using Fedora 5 22nd January 2007 12:41 PM
fusermount: failed to open /dev/fuse: Permission denied jpipitone Using Fedora 5 12th April 2006 04:35 AM
NTFS Fuse premissions mounting problem Ambiguous-69 Using Fedora 4 14th February 2006 04:09 PM


Current GMT-time: 12:12 (Friday, 28-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Hipodromo Madrid Photos on Instagram - Cabopino Travel Photos on Instagram - L'Irlandais Instagram Photos