Fedora Linux Support Community & Resources Center
  #1  
Old 29th December 2007, 12:37 AM
cdrom600 Offline
Registered User
 
Join Date: Dec 2007
Posts: 30
Problems mounting Ubuntu ext3 partition

I have Ubuntu 7.10 running on my system, triple-booting with Windows XP Pro and FC8. (GRUB also has its own partition). But this all works fine; it's not the problem.

I'm trying to move from using Ubuntu to Fedora for my daily computer use. My home folder is the only partition on one drive in the computer. I'm having problems when mounting it in FC8.
If, in the terminal, I mount the drive, it appears on the desktop, but if I open it, all the folders and files appear with an icon that looks like a blank sheet of paper. Double-clicking a folder gives me an error that IIRC has something to do with not being able to open it for read.
Additionally, if I try to plug a USB hard drive (formatted as ext3 IIRC) in while using FC8, I don't have permission to write to it. Under the "Permissions" tab, the owner is 1000.
(This doesn't happen with my USB flash drive which is formatted as FAT).

I have a few questions:
1) Are either of these related to the fact that the first user in Ubuntu is UID 1000, while in Fedora it's 500?
2) How can I get read/write access to my external drive (preferably in FC8 and Ubuntu)?
3) How can I access my home partition from FC8 (and preferably Ubuntu)?

Thanks.

Last edited by cdrom600; 29th December 2007 at 12:38 AM. Reason: typo
Reply With Quote
  #2  
Old 29th December 2007, 10:05 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,728
Hi cdrom600. How are you mounting that partition? Can you post the output of /sbin/fdisk -l and cat /etc/fstab ?? I see what you are saying. I have Ubuntu installed along side Fedora here and while I can mount the Ubuntu partition with no trouble and browse all the folders there's one file in my Ubuntu home that looks like what you describe as blank paper.

Edit: I created a new Fedora user with UID and GID 1000. Logging in as that user doesn't make a difference. I think that this is a permissions problem. Permissions are something that escapes my comprehension. Can't get a grip on that stuff.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB

Last edited by glennzo; 29th December 2007 at 10:24 AM.
Reply With Quote
  #3  
Old 29th December 2007, 02:22 PM
NoWayBill Offline
Registered User
 
Join Date: Mar 2007
Location: Indiana
Posts: 94
Perhaps.....
run /sbin/fdisk -| as mentioned by glennzo.
Identify the partition you desire to mount.
then add a line to your /etc/fstab similar to......
Quote:
/dev/sdc5 /storage ext3 defaults 1 2
The first part of line is the desired partition, "/dev/sdc5".

The second "/storage" is the local folder for the partition to be located in.
This could be "/home/username/Desktop/Ubuntu Home" for example, to place the partition on your desktop.

The third is the file system format.

Then create said folder in the path as you've described it.

Open a terminal and enter mount /dev/sdc5, the partition should mount to said folder.
With that line in your fstab file, the partition will be mounted every time you boot.

Should you eventually wipe Ubuntu from your system, remove this line from fstab.
As the system will attemp to mount a non-existent partion at boot and slow the process.
__________________
If all I use Widows for is playing games, does that mean it's just a toy?"

You are the sum of every decision you've made through out your life.
Reply With Quote
  #4  
Old 29th December 2007, 05:10 PM
cdrom600 Offline
Registered User
 
Join Date: Dec 2007
Posts: 30
Quote:
Originally Posted by glennzo
How are you mounting that partition? Can you post the output of /sbin/fdisk -l and cat /etc/fstab ?? I see what you are saying. I have Ubuntu installed along side Fedora here and while I can mount the Ubuntu partition with no trouble and browse all the folders there's one file in my Ubuntu home that looks like what you describe as blank paper.

Edit: I created a new Fedora user with UID and GID 1000. Logging in as that user doesn't make a difference. I think that this is a permissions problem. Permissions are something that escapes my comprehension. Can't get a grip on that stuff.
Code:
# /sbin/fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x163b163a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        2350    18876343+   7  HPFS/NTFS
/dev/sda3            4701        9729    40395442+   5  Extended
/dev/sda4            2351        4700    18876375   83  Linux
/dev/sda5            9697        9729      265072+   6  FAT16
/dev/sda6            4701        7050    18876312   83  Linux
/dev/sda7            7051        9400    18876343+  83  Linux
/dev/sda8            9401        9661     2096451   82  Linux swap / Solaris

Partition table entries are not in disk order

Disk /dev/sdb: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000c0386

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       30401   244196001   83  Linux

Disk /dev/sdc: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x34ba34b9

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1       19929   160079661   83  Linux
That probably merits some explaining:
sda1 is Windows
sda3 is an extended partition which contains the others
sda4 is empty; it used to have Ubuntu on it
sda5 is GRUB
sda6 is Ubuntu
sda7 is Fedora
sda8 is swap
sdb1 is my multimedia drive
sdc1 is my Ubuntu home

Code:
# cat /etc/fstab
LABEL=Fedora7           /                       ext3    defaults        1 1
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/sda8               swap                    swap    defaults        0 0
sda7 has the label Fedora7; it is running Fedora 8, I just haven't changed the partition's label.

The exact error message that pops up when I try to access any file or folder on the Ubuntu home partition reads "The attempt to log in failed." I think this does have something to do with permissions, or maybe SELinux?

Oh, and I'm mounting it from the command line:
Code:
# mount /dev/sdc1 /mnt/ub
# mount
/dev/sda7 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/sdc1 on /mnt/ub type ext3 (rw)
Reply With Quote
  #5  
Old 29th December 2007, 05:17 PM
cdrom600 Offline
Registered User
 
Join Date: Dec 2007
Posts: 30
Quote:
Originally Posted by NoWayBill
...add a line to your /etc/fstab...
Adding the partition to my fstab did not solve the problem; it behaves exactly as it did before.
Reply With Quote
  #6  
Old 29th December 2007, 05:17 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,728
Looks good. I agree. Maybe SELinux permissions. Try turning off SELinux and see if the issue goes away. Then turn it on again and figure out how to deal with it.

Edit: Explore extended options for mount commands in fstab.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB

Last edited by glennzo; 29th December 2007 at 05:19 PM.
Reply With Quote
  #7  
Old 29th December 2007, 05:25 PM
cdrom600 Offline
Registered User
 
Join Date: Dec 2007
Posts: 30
Quote:
Originally Posted by glennzo
Try turning off SELinux and see if the issue goes away. Then turn it on again and figure out how to deal with it.
I was trying that already by the time you posted

Setting SELinux to permissive does not help. Problem occurs as before.

Nothing appears out of the ordinary after I mount the partition:
Code:
# dmesg | tail
ata6.01: cmd a0/00:00:00:00:20/00:00:00:00:00/b0 tag 0 cdb 0x25 data 8 in
         res 40/00:03:00:00:20/00:00:00:00:00/b0 Emask 0x4 (timeout)
ata6: soft resetting port
ata6.00: configured for UDMA/25
ata6.01: configured for MWDMA2
ata6: EH complete
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sdc1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
SELinux: initialized (dev sdc1, type ext3), uses xattr
Reply With Quote
  #8  
Old 29th December 2007, 05:28 PM
cdrom600 Offline
Registered User
 
Join Date: Dec 2007
Posts: 30
Might I need to be a member of a specific group? Right now, I'm a member of the groups fuse and disk; I don't know exactly what these do, though.
Reply With Quote
  #9  
Old 29th December 2007, 05:34 PM
cdrom600 Offline
Registered User
 
Join Date: Dec 2007
Posts: 30
Code:
# fsck -f /dev/sdc1
fsck 1.40.2 (12-Jul-2007)
e2fsck 1.40.2 (12-Jul-2007)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 3A: Optimizing directories
Pass 4: Checking reference counts
Pass 5: Checking group summary information

Data: ***** FILE SYSTEM WAS MODIFIED *****
Data: 181507/20021248 files (2.6% non-contiguous), 21106937/40019915 blocks
fsck doesn't help.

BUT, running nautilus as root allows me to access the drive normally. I just can't access it as my normal user. So this is definitely a permissions problem.
Reply With Quote
  #10  
Old 29th December 2007, 05:47 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,728
Try, in fstab, something along the order of /dev/sdc1 /mnt/ub ext3 (and then uid,gid,rw,etc). Before you do though, explore just exactly what the options are and what they do. Think it may not work anyhow as you may still 500/1000 thing going against you.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #11  
Old 29th December 2007, 06:18 PM
cdrom600 Offline
Registered User
 
Join Date: Dec 2007
Posts: 30
Hmmm...
As I said, my Fedora user is UID 500. In the /mnt/ub folder:
Code:
# ls -l
total 2408356
drwxr-xr-x  2 1000 1000       4096 2007-09-25 20:48 4 Corners
drwxr-xr--  2 1000 1000       4096 2007-11-20 20:36 Act 2 - Misc. Theatre
.......
Owner/group 1000. Suddenly this makes sense.

edit: Sure enough, I created a user with UID/GID 1000 and that user can use the partition normally.

What can I do to access it from my normal user, ID 500?

Last edited by cdrom600; 29th December 2007 at 06:30 PM.
Reply With Quote
  #12  
Old 29th December 2007, 07:26 PM
cdrom600 Offline
Registered User
 
Join Date: Dec 2007
Posts: 30
Some potentially-useful info here: http://forums.fedoraforum.org/showthread.php?t=160400
Reply With Quote
  #13  
Old 30th December 2007, 12:37 AM
philip4567 Offline
Registered User
 
Join Date: Mar 2006
Posts: 57
Why not delete your normal user and change the user name and home directory of your ID 1000 user to your old user name and home directory?
Reply With Quote
Reply

Tags
ext3, mounting, partition, problems, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting ext3 partition changes mount point permissions and ownership (with fix) WNorfleet Installation, Upgrades and Live Media 1 3rd August 2010 03:26 AM
Mounting an ext3 or 4 partition with read and write access using fstab jonathonp Using Fedora 1 24th July 2009 04:19 PM
Intermitent mounting problems with ext3 partion using filesystem labels amiga Using Fedora 0 19th November 2008 05:06 AM
mounting another ext3 partition for rw jhetrick62 Using Fedora 2 20th February 2006 03:23 PM
Mounting ext3 partition with rw permissions for non-root user ilyushin Using Fedora 6 27th June 2005 02:15 PM


Current GMT-time: 19:55 (Tuesday, 30-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat