Fedora Linux Support Community & Resources Center
  #1  
Old 22nd December 2007, 08:00 PM
opE Offline
Registered User
 
Join Date: Dec 2007
Location: Northwestern Norway
Age: 26
Posts: 13
Can't connect my computers to the wireless network.

I've just installed Fedora 8 on my laptop and my stationary pc, but I can't get them connected to the password protected wireless network at home. I know the password and SSID, but I'm new to Fedora so I need some (or a lot of) help to get it working

Thanks
--opE
Reply With Quote
  #2  
Old 22nd December 2007, 08:13 PM
s.v.g. Offline
Registered User
 
Join Date: Nov 2007
Location: UK
Posts: 267
what have you tried so far? is your wireless network being detected at all?

open the terminal (applications>system tools>terminal) and type in this command:

/sbin/iwlist wlan0 scan

it should tell you whether the network is detected. don't post up what it says in case it pops up with information you'd rather keep secure we can work from there

Last edited by s.v.g.; 22nd December 2007 at 08:44 PM.
Reply With Quote
  #3  
Old 22nd December 2007, 08:45 PM
opE Offline
Registered User
 
Join Date: Dec 2007
Location: Northwestern Norway
Age: 26
Posts: 13
Quote:
Originally Posted by s.v.g.
what have you tried so far? is your wireless network being detected at all?

open the terminal (applications>system tools>terminal) and type in this command:

/sbin/iwlist wlan0 scan

it should tell you whether the network is detected. don't post up what it says in case it pops up with information you'd rather keep secure we can work from there
The output was:
Code:
wlan0     No scan results
Reply With Quote
  #4  
Old 22nd December 2007, 08:53 PM
opE Offline
Registered User
 
Join Date: Dec 2007
Location: Northwestern Norway
Age: 26
Posts: 13
update

...however, when I ran that command as root just now it detected the network.
Reply With Quote
  #5  
Old 22nd December 2007, 08:54 PM
s.v.g. Offline
Registered User
 
Join Date: Nov 2007
Location: UK
Posts: 267
for the network card on your laptop (assuming you have a wireless card), you can use ndiswrapper.

download and install the livna repository from:

http://rpm.livna.org/livna-release-8.rpm

then install ndiswrapper in add/remove programs.

go to this website:

http://ndiswrapper.sourceforge.net/j...,installation/

and scroll down to the part where the title reads 'Install Windows Driver' and follow the instructions
Reply With Quote
  #6  
Old 22nd December 2007, 08:57 PM
s.v.g. Offline
Registered User
 
Join Date: Nov 2007
Location: UK
Posts: 267
ah ignore that then. sorry forget to mention the root part :o

if the network is detected, however ironic this might be, i don't think i can help you! i got my network working with ndiswrapper as i couldnt even see the network from the laptop. someone else would be better off helping.

what i can suggest for now is going to services, disable 'network' and enable 'networkmanager' and 'networkmanagerdispatcher'. this should give an icon in the panel you can use to find/connect to the network.
Reply With Quote
  #7  
Old 22nd December 2007, 09:40 PM
opE Offline
Registered User
 
Join Date: Dec 2007
Location: Northwestern Norway
Age: 26
Posts: 13
Quote:
Originally Posted by s.v.g.
ah ignore that then. sorry forget to mention the root part :o

if the network is detected, however ironic this might be, i don't think i can help you! i got my network working with ndiswrapper as i couldnt even see the network from the laptop. someone else would be better off helping.

what i can suggest for now is going to services, disable 'network' and enable 'networkmanager' and 'networkmanagerdispatcher'. this should give an icon in the panel you can use to find/connect to the network.
OK, I tried that, enabling network manager an all that. I didn't see the icon so I rebooted and now the icon was there, I found the network, tried to connect and a box pops up asking for the network password. I entered the password bu then a second box pops up asking for another password along with the message "The application 'nm-applet' (/usr/bin/nm-applet) wants access to the default keyring, but is locked" None of my passwords works on this including the network password.
Any advice is well appreciated :P
__________________
--opE

"I found a hole - it went all the way to China"
Reply With Quote
  #8  
Old 22nd December 2007, 09:46 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,831
The NM(NetworkManager) programand a lot of othes want to keep your passwords (like the nwifi net passwords) in a "keyring".

You should have been asked to establish a keyring password at one of the prompts.
I thought the root passwd was the default but theat's probably not the case.

Try System->Preferences-->System->Keyring MAnager and soo if you can get through the keyring passwd.
I'll take a quick took to see if there is way to reset.
Reply With Quote
  #9  
Old 22nd December 2007, 09:54 PM
opE Offline
Registered User
 
Join Date: Dec 2007
Location: Northwestern Norway
Age: 26
Posts: 13
Quote:
Originally Posted by stevea
The NM(NetworkManager) programand a lot of othes want to keep your passwords (like the nwifi net passwords) in a "keyring".

You should have been asked to establish a keyring password at one of the prompts.
I thought the root passwd was the default but theat's probably not the case.

Try System->Preferences-->System->Keyring MAnager and soo if you can get through the keyring passwd.
I'll take a quick took to see if there is way to reset.
All I can find in the System menu is Power Management, I think I'm missing a few options here.
__________________
--opE

"I found a hole - it went all the way to China"
Reply With Quote
  #10  
Old 22nd December 2007, 10:06 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,831
Delete ~/.gnome2/keyrings/default.keyring
This blows away the keyring and it's contents for your user (~), then it will create a new default keyring when you try nm again.
The next time remember the keyring passwd when you are asked to set it.
Reply With Quote
  #11  
Old 22nd December 2007, 10:08 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,831
Quote:
Originally Posted by opE
All I can find in the System menu is Power Management, I think I'm missing a few options here.
Try "/usr/bin/gnome-keyring-manager" from a terminal. If that also fails then install the keyring manager with
Quote:
su -
yum -y install gnome-keyring-manager

There is also the possibility you are using KDE so don't have the gnome stuff installed ?!!!?
What is your rev (F7, F8 ?) ? What is your desktop (Gnome ? KDE ?) ?
Reply With Quote
  #12  
Old 22nd December 2007, 10:15 PM
opE Offline
Registered User
 
Join Date: Dec 2007
Location: Northwestern Norway
Age: 26
Posts: 13
Quote:
Originally Posted by stevea
Delete ~/.gnome2/keyrings/default.keyring
This blows away the keyring and it's contents for your user (~), then it will create a new default keyring when you try nm again.
The next time remember the keyring passwd when you are asked to set it.
There's no file or folder named keyrings in the .gnome2 folder.
__________________
--opE

"I found a hole - it went all the way to China"
Reply With Quote
  #13  
Old 22nd December 2007, 10:29 PM
opE Offline
Registered User
 
Join Date: Dec 2007
Location: Northwestern Norway
Age: 26
Posts: 13
Anyways - that was on my laptop. I just tried connecting on my stationary now, I entered the network password and a box pops up where I can create a keyring password. After I did that the computer tried to connect, but it isn't able to connect and just goes back to the network password box. I know the password is correct, so I just don't understand what the problem is.
__________________
--opE

"I found a hole - it went all the way to China"
Reply With Quote
  #14  
Old 22nd December 2007, 10:55 PM
opE Offline
Registered User
 
Join Date: Dec 2007
Location: Northwestern Norway
Age: 26
Posts: 13
Quote:
Originally Posted by stevea
Try "/usr/bin/gnome-keyring-manager" from a terminal. If that also fails then install the keyring manager with



There is also the possibility you are using KDE so don't have the gnome stuff installed ?!!!?
What is your rev (F7, F8 ?) ? What is your desktop (Gnome ? KDE ?) ?
I'm using gnome. And seeing as there's no problem with the keyring on my stationary and obviously a problem with it on my laptop, I don't think the keyring is causing the problem with the wireless network since the connection problems on both computers are identical.
__________________
--opE

"I found a hole - it went all the way to China"
Reply With Quote
  #15  
Old 23rd December 2007, 10:10 AM
s.v.g. Offline
Registered User
 
Join Date: Nov 2007
Location: UK
Posts: 267
ok this might or might not work, but could be a solution to your problems.

create a text file in gedit in your home directory called:

start_wlan.bat

now paste this inside and save:

-------------------------------

echo 'Setting Specific Wireless Network Access Point...'
/sbin/iwconfig wlan0 essid moozie

echo 'Scanning For Specific Access Point...'
/sbin/iwlist wlan0 scan

#echo 'Setting Wireless LAN To Managed Mode...'
#/sbin/iwconfig wlan0 mode Managed

echo 'Setting WEP Encryption Key...'
/sbin/iwconfig wlan0 key restricted insertkeyhere

echo 'Setting Specific Wireless Network Access Point...'
/sbin/iwconfig wlan0 essid insertssidhere

echo 'Bring Up Wireless LAN Interface...'
#/sbin/ifconfig wlan0 up
/sbin/dhclient wlan0
#/sbin/dhcpcd wlan0

----------------------------------------------------

now open terminal and run this as root (su, password, /home/insertusername/start_wlan.bat)
this might work, although i really am stabbing in the dark. networking is not my area of expertise, nor linux either to be honest i've assumed that your password is in the form of a WEP encryption key (e.g. 21:FJ78FP32)

this is something i found off a random website that i used to get my network working, although i used ndiswrapper aswell (which you don't need to use). run this as root everytime you turn the computer on. if it works then it can be temporary solution.

Last edited by s.v.g.; 23rd December 2007 at 10:12 AM.
Reply With Quote
Reply

Tags
computers, connect, network, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11 Laptop will not see other computers on the wireless network? computerwhiz1 Using Fedora 7 11th October 2009 10:16 PM
Can't Connect to a wireless network with Network Manager cirne Servers & Networking 23 2nd August 2008 10:43 AM
Using Network Manager to connect FC6 to wireless network. DalekClock Servers & Networking 8 24th March 2007 11:56 PM
How to connect to wireless network? jimmy20013 Servers & Networking 1 29th October 2006 04:56 PM
Can't connect to wireless network chocobanana Servers & Networking 2 29th March 2006 03:01 PM


Current GMT-time: 09:40 (Thursday, 18-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat