Fedora Linux Support Community & Resources Center
  #1  
Old 26th November 2007, 10:44 PM
mcgodx Offline
Registered User
 
Join Date: Aug 2007
Posts: 58
Openoffice.org

I recently tried to use Openoffice.org for the first time on this installation for school, and ran in to a problem. Whenever I try to do something in it like make the window full size, scroll past the end of the document, format the pages, or anything more than just typing, and even then it is iffy, I get problems. It'll crash. I ran it from the terminal and here is the error I get when I maximize the screen. I should thing the error is the same when I do other things, but if you need it I can try:
Quote:
[mylan@localhost ~]$ openoffice.org -writer

::At this point I maximize the window::

X-Error: BadAlloc (insufficient resources for operation)
Major opcode: 53 (X_CreatePixmap)
Resource ID: 0x3a00668
Serial No: 10379 (10379)
These errors are reported asynchronously,
set environment variable SAL_SYNCHRONIZE to 1 to help debugging
Does anyone know what the issue is? Since it mentions X, I am assuming it means the GUI. I am running Compiz-Fusion on the computer. I ran it on Ubuntu and never had a problem with Openoffice.org before, so I kinda hope that's not the issue here (I had some unrelated problems in Ubuntu that make me not want to mess with that again). I also did not have a problem with it in Fedora 7.

Another thing I noticed is that the scroll bars don't render properly. If I want to scroll I have to use the scroll wheel on the mouse, or use page up or page down.

Thanks for any help
Reply With Quote
  #2  
Old 26th November 2007, 11:29 PM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hello:
Quote:
X-Error: BadAlloc (insufficient resources for operation)
The only time I have seen a similar error, it was related to a video driver ? [that may not be the case here, I don't kow]

What type of video card do you have and which driver are you using ?

Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #3  
Old 26th November 2007, 11:37 PM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
I'm with Seve on this. If you are running any proprietary driver (fglrx, or nvidia) try (without rebooting, very important!) to substitute the driver from fglrx/nvidia to ati/nv and see if this happens. If doesn't, what version of the drivers are you running? If you are not running any of the above drivers or cards, what type of video card are you running, and what driver?
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
  #4  
Old 27th November 2007, 12:45 AM
mcgodx Offline
Registered User
 
Join Date: Aug 2007
Posts: 58
I have an nVidia GeForce Go 7200, and I am using the nvidia drivers. I think the driver version is 100.14.19, although I am not positive. I got that number from the display settings manager applet, that's the only way I know how to get that version number.

I do not know how to substitute drivers... Sorry for that, if you could tell me how that would be a help. Thanks.
Reply With Quote
  #5  
Old 27th November 2007, 12:58 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
You running the drivers from Livna or nVidia's site?

Edit

To substitute the driver, all you have to do is to type in a terminal system-config-display or through direct configuration file change (recommended method to ensure everything's OK).

The following is for testing purposes only, should not be a permanent change, as you'll lose 3D accel.
  1. Edit /etc/X11/xorg.conf: Open a terminal window in your session, and then write su, enter root's password. Open the file with gedit, by typing this:
    Code:
    gedit /etc/X11/xorg.conf
    Alternatively you may launch gedit from that command line, and then simply use the Open icon or File -> Open menu entry, and navigate to /etc/X11/
  2. Scroll to Section "Device", there change the Driver "nvidia" line for Driver "nv".
  3. Save the file, exit the root session by typing 'exit' (without the quites) and then close the terminal. Log-out to restart X, you may want to ctrl+alt+backspace in the longin screen to force an X restart and ensure the configuration is picked up.
  4. Log back in, and try to run OpenOffice again, do whatever used to crash the program.


NOTE if you are running the desktop effects by default, turn them off prior you exit your session. It may be possible that you will have to remove the nvidia module from the kernel, by this I mean "unload it", so after you log back in, try to run in a terminal, as your user, /sbin/lsmod | grep nvidia, if you see an nvidia module loaded, su to root again and typ e /sbin/rmmod nvidia, nothing should happen, indicating that the module was successfully unloaded, then exit both sessions in the terminal and try to run OOo.
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.

Last edited by Thetargos; 27th November 2007 at 01:09 AM.
Reply With Quote
  #6  
Old 27th November 2007, 12:59 AM
mcgodx Offline
Registered User
 
Join Date: Aug 2007
Posts: 58
Livna. I got them through yum.
Reply With Quote
  #7  
Old 27th November 2007, 01:07 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
See the above edit to see how to change drivers.
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
  #8  
Old 27th November 2007, 01:25 AM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Quote:
Originally Posted by mcgodx
I have an nVidia GeForce Go 7200, and I am using the nvidia drivers. I think the driver version is 100.14.19, although I am not positive. I got that number from the display settings manager applet, that's the only way I know how to get that version number.

I do not know how to substitute drivers... Sorry for that, if you could tell me how that would be a help. Thanks.
Hello:
There was a known problem with some hardware combinations using the 7200/7300 cards using the latest officially released drivers. Version: 100.14.19 See Post No. 8
http://www.nvnews.net/vbulletin/showthread.php?t=102101

You may want to try the 169.04 [Beta] and see if they help ?
http://www.nvnews.net/vbulletin/showthread.php?t=102509

Livna have them in their testing repo
http://livna-dl.reloumirrors.net/fedora/testing/8/i386/

Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #9  
Old 27th November 2007, 01:26 AM
mcgodx Offline
Registered User
 
Join Date: Aug 2007
Posts: 58
To thetargos: I gave it a shot. It didn't work. It actually made it worse I think, when I forced X to restart, it wouldn't load the "greeter" for 5 tries, then it finally worked. After that the colors were down to thousands (I could see the steps) and OOo still crashed when I maximized.

Last edited by mcgodx; 27th November 2007 at 01:30 AM.
Reply With Quote
  #10  
Old 27th November 2007, 01:50 AM
leadgolem Offline
Registered User
 
Join Date: Apr 2005
Location: Littleton, CO
Age: 29
Posts: 2,857
I've got an nvidia 7300 and I use the kmod-nvidia-96xx driver from livna. It's a touch slower then the kmod-nvidia, but it doesn't lock up.
__________________
S.C.O.U.R.G.E. Heroes of lesser renown, contributor.
Reply With Quote
  #11  
Old 27th November 2007, 01:59 AM
mcgodx Offline
Registered User
 
Join Date: Aug 2007
Posts: 58
Quote:
Originally Posted by Seve
Hello:
There was a known problem with some hardware combinations using the 7200/7300 cards using the latest officially released drivers. Version: 100.14.19 See Post No. 8
http://www.nvnews.net/vbulletin/showthread.php?t=102101

You may want to try the 169.04 [Beta] and see if they help ?
http://www.nvnews.net/vbulletin/showthread.php?t=102509

Livna have them in their testing repo
http://livna-dl.reloumirrors.net/fedora/testing/8/i386/

Seve
Thank you for the tip. I think I might go with the nvidia release, I already downloaded it. Plus I wasn't sure which packages I'd have to download. However I am having an issue with getting X killed for the install. I have tried going to just runlevel 3, which obviously didn't really work, I tried the ctrl alt backspace but X just popped right back up. I saw somewhere that "killall gdm" would work, but that didn't do anything.

Thanks.
Reply With Quote
  #12  
Old 27th November 2007, 03:14 AM
mcgodx Offline
Registered User
 
Join Date: Aug 2007
Posts: 58
Alright I got it all taken care of.

The new drivers were installed, however, now desktop effects won't start. OOo still gives me problems.
Reply With Quote
  #13  
Old 27th November 2007, 03:17 AM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Quote:
Originally Posted by mcgodx
Alright I got it all taken care of.

The new drivers were installed, however, now desktop effects won't start. OOo still gives me problems.
Hello:
Can you post the output of
cat /etc/X11/xorg.conf

Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #14  
Old 27th November 2007, 03:21 AM
mcgodx Offline
Registered User
 
Join Date: Aug 2007
Posts: 58
Here it is:
Quote:
Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
EndSection
Reply With Quote
  #15  
Old 27th November 2007, 03:26 AM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hello:
If you have the nVidia drivers installed then you need to amend your /etc/X11/xorg.conf file

Change
Driver "nv"
to
Driver "nvidia"
and add under Section Device
PHP Code:
Section "Device"
        
Identifier  "Videocard0"
        
Driver      "nvidia"
        
Option      "AddARGBGLXVisuals" "True"
EndSection 
and add the following at the end of the file

PHP Code:
Section "Extensions"
        
Option      "Composite" "Enable"
EndSection 

Save, exit and Ctrl ALt Backspace to restart your Xserver and see how it goes.

Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
Reply

Tags
openofficeorg

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install openoffice from openoffice website? sdowney717 Using Fedora 13 20th March 2007 02:25 AM
Openoffice 1.1.5 rpm for fc3 bert Using Fedora 2 17th November 2005 09:46 AM
OpenOffice 2.0 RC2 zaspelp Using Fedora 0 15th October 2005 06:37 PM


Current GMT-time: 19:10 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat