Fedora Linux Support Community & Resources Center
  #1  
Old 9th November 2007, 11:00 PM
slobodan Offline
Registered User
 
Join Date: Nov 2007
Posts: 2
How to disable SELinux?

I've just installed Fedora 8 KDE from live CD. SELinux is blocking one of my applications,
so I ave a segmentation fault and application fails to run. How should disable SELinux ?
This is a first time using Fedora. I have only some experience with (K)Ubuntu .

thanks
Slobodan
Reply With Quote
  #2  
Old 9th November 2007, 11:03 PM
strikeforce Offline
Registered User
 
Join Date: Jun 2004
Location: Perth, Western Australia
Age: 37
Posts: 1,464
Why disable selinux? What you can do is read the report and follow what is says.

If you do want to disable selinux you can do it by editing the following file.

/etc/selinux/config

Or

You can do it through the gui which is system-config-selinux

**Edit my bad fixed the problem.
__________________
- Helping New Users
Fedora Solved

- How to pay forward
Fedora Help Wanted

- Need a quick guide
Fedora Guide
Reply With Quote
  #3  
Old 9th November 2007, 11:23 PM
skellert Offline
Registered User
 
Join Date: Nov 2006
Location: Australia
Posts: 37
You can disable selinux by editing /boot/grub/grub.conf and finding the lines that say something like the following (from my F7 system)

Code:
title Fedora (2.6.22.9-91.fc7)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.22.9-91.fc7 ro root=LABEL=/ rhgb quiet selinux=0
        initrd /boot/initrd-2.6.22.9-91.fc7.img
Notice the 'selinux=0 at the end of the 'kernel' line???
Reply With Quote
  #4  
Old 9th November 2007, 11:54 PM
slobodan Offline
Registered User
 
Join Date: Nov 2007
Posts: 2
Quote:
Originally Posted by skellert
You can disable selinux by editing /boot/grub/grub.conf and finding the lines that say something like the following (from my F7 system)

Code:
title Fedora (2.6.22.9-91.fc7)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.22.9-91.fc7 ro root=LABEL=/ rhgb quiet selinux=0
        initrd /boot/initrd-2.6.22.9-91.fc7.img
Notice the 'selinux=0 at the end of the 'kernel' line???
Thanks strikeforce & skellert . I've disabled SELinux and application works fine
Reply With Quote
  #5  
Old 11th March 2009, 06:04 AM
mostanser Offline
Registered User
 
Join Date: Mar 2009
Posts: 4
HI thanks for this post
MIne is fedora 10, Gnome and I have tried to edit the grub but did not get "selinux" on /boot/grub/grub.conf
Then I typed a command, system-config-selinux, unfortunately it gives me silly error.

Then, finally I went back to edit /etc/selinux/config file
Then restarted the pc, it works fine now.
See this article if you need.
Disable SELInux in FC 10
thanks again
Reply With Quote
Reply

Tags
disable, selinux

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to permanently disable selinux wvn Guides & Solutions (No Questions) 25 13th February 2014 07:53 AM
disable selinux theAdmiral Security and Privacy 23 21st November 2009 04:51 PM
Disable SELinux or not gobes Using Fedora 1 29th April 2007 11:40 PM
after disable selinux fc6 can't boot .... carlainz EOL (End Of Life) Versions 0 19th April 2007 07:14 PM
how to disable selinux jan1024188 Using Fedora 2 5th November 2006 02:11 AM


Current GMT-time: 09:26 (Tuesday, 16-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat