Fedora Linux Support Community & Resources Center
  #1  
Old 7th November 2007, 09:09 PM
high Offline
Registered User
 
Join Date: Aug 2006
Posts: 27
fedora 8 & pulse audio - nonroot users have no sound

im puzzled anyone else have the same issue?
__________________
High! /wave :D
  #2  
Old 7th November 2007, 09:27 PM
cgrim Offline
Registered User
 
Join Date: Jun 2007
Location: Czech republic
Posts: 183
For me the pulse audio doesn't work too.

Pulse audio volume control application crashes during startup, each aplication using ALSA driver crashes when I want to start playing sound, ...

Someone told me to remove alsa-plugins-pulseaudio package and enable ESD - I've done it but nothing changed.
  #3  
Old 7th November 2007, 09:39 PM
high Offline
Registered User
 
Join Date: Aug 2006
Posts: 27
pulse audio works fine as root just not as non-root users
__________________
High! /wave :D
  #4  
Old 8th November 2007, 01:26 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,129
Sigh, sound. I'll just say, remember, Fedora is considered a bleeding edge distro. Yeah, it should Just Work(TM) but when I get ticked, I tell myself, well, it's not one of those distros that aims to try to be an MS replacement.

Personally, I feel that even ALSA was an answer to a question no one asked, but, that's a rant for a different day. OSS worked with less effort.

Anyway, here is my experience. Firstly, sound has been broken for some people as non-root for awhile. The usual solution, leaving pulseaudio out of the equation, is to edit /etc/security/console.perms.d/50-whatever it's called, and add

<sound>=/dev/dsp* /dev/snd/*

Then, at the bottom add

<console> 0666 <sound> 0600 root

This fixes the non-root issue if pulseaudio isn't involved.

My own experience was that if I removed the alsa-plugins-pulseaudio my other problems went away. If I had it in, I could only use mplayer in X, not in console. Also, in X, before using it, I had to run

pulseaudio &
in an xterm.

I didn't google very much for it, I was too aggravated, and it's one of those things that I feel should just work. Most of this was trial and error.
I should add that for someone else, removing the alsa-plugins-pulseaudio didn't help--I found it as a solution with a quick google, tried it, and it worked for me.

YMMV (Your mileage may vary) with both of these solutions.
  #5  
Old 8th November 2007, 01:41 AM
cr4ck3r Offline
Registered User
 
Join Date: Oct 2005
Posts: 219
I can use PulseAudio just fine, as normal user.
Please refer to this http://www.pulseaudio.org/wiki/PerfectSetup
Btw, I'm still using F7
__________________
Linux User number : 451678
Desktop:
AMD X2 3800+, ASUS M2NPV-VM, GeForce 6150 128MB (onboard), 2GB RAM Corsairs 667, ASUS VW192T LCD 19" Widescreen.
Ubuntu 8.04 (Hardy Heron) x86
------------------------
Laptop:
HP Pavilion DV 5000
Fedora 10 (Cambridge) x86
Linux Machine Number: 359564
  #6  
Old 8th November 2007, 02:07 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,129
I see the wiki notes that *distributors* are encouraged to do that.


Hrrm, looks like a heck of a lot more work for me than simply

yum remove alsa-plugins-pulseaudio.

Just doing that enables me to see things on youtube and play my music or movies in mplayer. My needs are simple.
  #7  
Old 8th November 2007, 03:06 PM
cgrim Offline
Registered User
 
Join Date: Jun 2007
Location: Czech republic
Posts: 183
Quote:
Originally Posted by cr4ck3r
I can use PulseAudio just fine, as normal user.
Please refer to this http://www.pulseaudio.org/wiki/PerfectSetup
Btw, I'm still using F7
Really perfect setup description!
Problem was in my out of date /etc/asound.conf file, where I had:
Code:
defaults.pcm.card 0
defaults.pcm.device 2
defaults.ctl.card 0
..., but there should be:
Code:
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
Thanks for your help. Pulse audio is fantastic!
  #8  
Old 8th November 2007, 03:29 PM
Xenofex Offline
Registered User
 
Join Date: May 2006
Location: Shanghai, China
Age: 32
Posts: 13
Quote:
Originally Posted by scottro
I see the wiki notes that *distributors* are encouraged to do that.


Hrrm, looks like a heck of a lot more work for me than simply

yum remove alsa-plugins-pulseaudio.

Just doing that enables me to see things on youtube and play my music or movies in mplayer. My needs are simple.
I removed alsa-plugins-pulseaudio, too. And it worked. But after I restart my system, non-root users become silent again. And that package is indeed removed. What can I do?
  #9  
Old 8th November 2007, 04:02 PM
strikeforce Offline
Registered User
 
Join Date: Jun 2004
Location: Perth, Western Australia
Age: 39
Posts: 1,464
Please keep this bumped and correct me if I'm wrong.

<mwiriadi> root can hear sound
<mwiriadi> non-root can't
<zcat> the pulseaudio hal plugin didn't pick the right default device.
<mwiriadi> How do you fix it then
<mwiriadi> run system-config-soundcard again?
<zcat> only two ways i way able to fix it: 1) specify the default device by editing /etc/pulse/default.pa 2) disabling onboard sound in BIOS so that it COULDNT get the order wrong.
<zcat> went with #2
<zcat> s/way /was /

I also got it to work by system-config-sound.
System-> Preferences -> Hardware -> Sound and selecting ESD
Also make sure all devices say Pulse Audio.
Make sure your Avahi-Daemon is on from default. System-config-services
Applications -> Sound & Video -> Pulse Audio audio changing thingos in there as well.

Some of those and most of those will fix the issue. If you have an .asoundrc move it to test whether it picks it up properly
__________________
- Helping New Users
Fedora Solved

- How to pay forward
Fedora Help Wanted

- Need a quick guide
Fedora Guide
  #10  
Old 9th November 2007, 12:26 AM
Mystinar Offline
Registered User
 
Join Date: Dec 2005
Location: Michiana
Age: 31
Posts: 133
I initially had no sound on my F8 system, until I turned the speaker volume and all the volume sliders in KMix to 100%. But even then, it is really quiet.
__________________
I'm a proud member of the Online Campaign for Real English. If you believe in capital letters, correct spelling and good sentence structure, then copy this into your signature.
  #11  
Old 9th November 2007, 02:25 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,129
Well, I tried making the changes to asound.conf with no joy. On the other hand, as removing the alsa-plugins works for me, I'll probably leave it alone at present. If it is something that affects a lot of people, they'll fix it, if it is something that only affects me, then shucks, I have my workaround. Maybe it's the fact that I'm an old guy, but for me, as long as I have sound, I'm happy, I'm not too concerned about getting that last nth of quality from it.
  #12  
Old 9th November 2007, 06:37 AM
Xenofex Offline
Registered User
 
Join Date: May 2006
Location: Shanghai, China
Age: 32
Posts: 13
I've got some new paces. I added my normal user into root group. And now I'm able to start pulseaudio manually via pulseaudio -D. And I can hear sound in my normal user. But system wide daemon still can't start. pulseaudio --system doesn't work.

The reason why I added the normal user into root group is that /dev/dsp1 belongs to root group. And only the group members and the owner can read and write it, while others are unable to access to it. I can chmod /dev/dsp1, but it change back every login. When typing pulseaudio --system, I see some device, probably my sound card is not accessable. This happens when I use pulseaudio -D before I add the normal user into root group, too. So, user pulse is added to the root group, too. But other errors took place:

[root@localhost ~]# pulseaudio --system
W: main.c: Warning: home directory of user 'pulse' is not '/var/run/pulse', ignoring.
No protocol specified
E: x11wrap.c: XOpenDisplay() failed
E: module.c: Failed to load module "module-x11-publish" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.

Can someone help?
  #13  
Old 9th November 2007, 06:46 AM
strikeforce Offline
Registered User
 
Join Date: Jun 2004
Location: Perth, Western Australia
Age: 39
Posts: 1,464
I still think you are going to far. I have working audio on my system as a user and I can't even do what you have done.

[marc@strikeforce SPECS]$ ls -lh /dev/dsp
crw-rw----+ 1 root root 14, 3 2007-11-07 12:47 /dev/dsp
[marc@strikeforce SPECS]$ pulseaudio --system
E: main.c: Root priviliges required.

So thats a non-issue.

Code:
[marc@strikeforce SPECS]$ rpm -qa | grep pulse
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-zeroconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-lirc-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
pulseaudio-module-zeroconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8
As I put in my previous post all the settings I have done there as well.

[root@strikeforce mock]# chkconfig --list avahi-daemon
avahi-daemon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

Do you have padevchooser, pavucontrol, paprefs and paman?
__________________
- Helping New Users
Fedora Solved

- How to pay forward
Fedora Help Wanted

- Need a quick guide
Fedora Guide
  #14  
Old 9th November 2007, 07:29 AM
Xenofex Offline
Registered User
 
Join Date: May 2006
Location: Shanghai, China
Age: 32
Posts: 13
Quote:
Originally Posted by strikeforce
I still think you are going to far. I have working audio on my system as a user and I can't even do what you have done.

[marc@strikeforce SPECS]$ ls -lh /dev/dsp
crw-rw----+ 1 root root 14, 3 2007-11-07 12:47 /dev/dsp
[marc@strikeforce SPECS]$ pulseaudio --system
E: main.c: Root priviliges required.

So thats a non-issue.

Code:
[marc@strikeforce SPECS]$ rpm -qa | grep pulse
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-zeroconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-lirc-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
pulseaudio-module-zeroconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8
As I put in my previous post all the settings I have done there as well.

[root@strikeforce mock]# chkconfig --list avahi-daemon
avahi-daemon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

Do you have padevchooser, pavucontrol, paprefs and paman?
I do have padevchooser, pavucontrol, paprefs and paman. And these are only setup tools.

I don't want to go such far if don't I have no sound!

I see your /dev/dsp belongs to the root group as well. But you got sound. So, something may happen to my pulseaudio daemon. It can not start.

And besides, Is there any way to drive the sound card by not using pulseaudio? I tried to uninstall pulseaudio and got nothing. Is there anything else I can do? Or just reinstall all the stuff relates to sound card and re-setup them? What packages should I reinstall?
  #15  
Old 9th November 2007, 07:43 AM
strikeforce Offline
Registered User
 
Join Date: Jun 2004
Location: Perth, Western Australia
Age: 39
Posts: 1,464
You would need to install pulse audio all over again. All the packages listeded help. Your issue is a setup it's nothing else.
__________________
- Helping New Users
Fedora Solved

- How to pay forward
Fedora Help Wanted

- Need a quick guide
Fedora Guide
Closed Thread

Tags
audio, fedora, nonroot, pulse, sound, users

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pulse Audio Sound Card per Application NoOneElse Using Fedora 1 20th May 2010 04:16 PM
Multi User Sound Fedora 10 w/Pulse Audio? ottoguy Using Fedora 4 13th November 2009 09:13 AM
F10 Bluetooth Audio + Pulse == pulse crashes. fwelland Hardware & Laptops 2 7th February 2009 01:07 PM
Fedora 8, Pulse Audio, 2 Audio Cards Alex Lang Using Fedora 5 24th January 2008 09:05 PM
Fedora 7 vs 8 and KDE nonroot sound jaa Using Fedora 1 4th January 2008 10:25 AM


Current GMT-time: 23:30 (Wednesday, 26-04-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat