Fedora Linux Support Community & Resources Center
  #1  
Old 15th September 2007, 04:27 AM
schwim Offline
Registered User
 
Join Date: Dec 2005
Location: In your closet
Age: 40
Posts: 2,287
screensavers/powermanagement in Gnome not working

Hi there guys,

In my attempt to get remote desktop, I tried Gnome. I can get RD working while using Gnome, but I can't seem to get my monitors to power down. i can't even get a screensaver to work.

I am willing to change DE's to get remote desktop, but I have to be able to use those two features.

I've searched, but my searches seem to be geared towards older installs, and don't seem applicable to F7. Could someone give me some pointers? All I've done thus far is install everything via yumex that looked like it pertained to gnome display and screensaver. I then tried to activate via the preferences in Gnome.

thanks,
json
__________________
I read the f'ing manual, and it told me to ask you guys...

performing amazing acts of mediocrity since 1974.
-------------------------------------------------------------------
FC 7(32 bit)/Gnome
AMD Athlon 64 3400+
Nvidia 6800 GT
1 Gig ram
Reply With Quote
  #2  
Old 15th September 2007, 10:48 PM
schwim Offline
Registered User
 
Join Date: Dec 2005
Location: In your closet
Age: 40
Posts: 2,287
Ok, maybe working screensavers and power management in Gnome is asking for too much. Let's start off with pretty pictures:

Anyone know how to allow separate backgrounds in Gnome on a dual head application?

thanks,
json
__________________
I read the f'ing manual, and it told me to ask you guys...

performing amazing acts of mediocrity since 1974.
-------------------------------------------------------------------
FC 7(32 bit)/Gnome
AMD Athlon 64 3400+
Nvidia 6800 GT
1 Gig ram
Reply With Quote
  #3  
Old 15th September 2007, 11:58 PM
Dies Offline
Registered User
 
Join Date: Oct 2006
Posts: 4,754
I would just install xscreensaver with all it's extras, and uninstall gnome screensaver and any extras related to it, unless it tries to take half your system with it , in which case you can just add a 'killall gnome-screensaver' to your startup programs under Preferences>Sessions>Startup.

That's what I used to do, but gss seems to be working fine for me lately.

As far as the separate backgrounds, not sure you can do that.
Reply With Quote
  #4  
Old 16th September 2007, 01:39 AM
schwim Offline
Registered User
 
Join Date: Dec 2005
Location: In your closet
Age: 40
Posts: 2,287
KDE allowed separate bg's by default. Thinking of it, Windows did as well. I wouldn't have guessed that a DE would force you to use the same personalization settings between the two.

Thanks very much for the suggestion concerning xscreensaver.

thanks,
json
__________________
I read the f'ing manual, and it told me to ask you guys...

performing amazing acts of mediocrity since 1974.
-------------------------------------------------------------------
FC 7(32 bit)/Gnome
AMD Athlon 64 3400+
Nvidia 6800 GT
1 Gig ram
Reply With Quote
  #5  
Old 18th September 2007, 04:15 PM
schwim Offline
Registered User
 
Join Date: Dec 2005
Location: In your closet
Age: 40
Posts: 2,287
My sweet lord in heaven... I'm coming the the realization that Gnome is developed by that sweet kid I knew in middle school... you know... the one that had to have corks on the end of his eating utensils? Yeah, that one.

Well, playing with the settings, I managed to get it to use the screensaver. "Yay!" I thought. I set it to 20 minutes and went about my business.

Problem is that for the last three days, the screensaver has loaded on me while I'm working. I'll be using the mouse to scroll a page and it will start getting dark, which in turn causes me to think I'm having a stroke. Then my screensaver will start up. Usually hitting the escape key will get me back to my desktop.

Today, I ended up at some netherworld when I hit the escape key. I got my mouse cursor back, but no desktop. Nothing I did worked for me.

I've noticed that I have gnome-screensaver and xscreensaver installed. Which one might I be using, and should I be using the other one? For the life of me, I can't imagine why I might need choices in screensaver engines, but hey, whatever makes the world go round.

thanks,
json
__________________
I read the f'ing manual, and it told me to ask you guys...

performing amazing acts of mediocrity since 1974.
-------------------------------------------------------------------
FC 7(32 bit)/Gnome
AMD Athlon 64 3400+
Nvidia 6800 GT
1 Gig ram
Reply With Quote
  #6  
Old 18th September 2007, 09:38 PM
Orp Offline
Registered User
 
Join Date: Sep 2007
Posts: 10
I am having the same exact problem as schwim on a dual-headed machine. I'll be typing away and both screens begin to black out. I can stop the fade by moving the mouse or hitting escape. It's very disconcerting. It also steals focus while this is happening which is very annoying. I too was unable to get my screen back once when this happened.

I am using the binary Nvidia drivers.

I though maybe in my case the screensaver isn't picking up activity in display 0:1 which is where I usually am typing/mousing. But this never happened to me with this configuration with early versions of Fedora.
Reply With Quote
  #7  
Old 18th September 2007, 11:40 PM
Dies Offline
Registered User
 
Join Date: Oct 2006
Posts: 4,754
Quote:
Originally Posted by schwim
My sweet lord in heaven... I'm coming the the realization that Gnome is developed by that sweet kid I knew in middle school... you know... the one that had to have corks on the end of his eating utensils? Yeah, that one.

thanks,
json
Hey why don't you just go back to Windows !

Oh, I'm sorry, I mean why don't you just uninstall one of them.

Like I said if gnome-screensaver has too many deps then just go to System>Preferences>Sessions>Startup and add two entries

killall gnome-screensaver <-- to make sure it doesn't run

xscreensaver <-- to make sure it does

To configure xscreensaver just type

xscreensaver-demo
Reply With Quote
  #8  
Old 19th September 2007, 12:04 AM
Dan Offline
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 23,279
Or the really complicated way will work too. From Gnome:

Applications>Add/Remove software>Gnome Desktop Environment, Click Optional packages>Scroll to - Gnome Screensaver>uncheck.

While you're there -- scroll further down, and make sure xscreensaver extras gss and xscreensaver GL extras gss are unchecked.

Click Close, click apply.

Gnome screensaver should be uninstalled for you.


Dan

Last edited by TangledWeb; 19th September 2007 at 12:11 AM.
Reply With Quote
  #9  
Old 19th September 2007, 05:28 AM
schwim Offline
Registered User
 
Join Date: Dec 2005
Location: In your closet
Age: 40
Posts: 2,287
Quote:
Originally Posted by Dies
Hey why don't you just go back to Windows !
Go back to it? I don't even have to turn around!

Sir your initial suggestion seems to have worked splendidly. I will have to wait and see if it recognizes movement on the second desktop and resumes a-ok, but it is working, albeit with some of the most horrendous screensavers I've ever witnessed

Quote:
Originally Posted by Dan
Or the really complicated way will work too. From Gnome:
Mock me if you will, but I am considered a linex power user in these parts. Of course, in these parts, the requirement for the title is simply being able to spell linex.

The reason it took me so long to reply was because I was hoping Orp would try it and let me know if it screwed up his system. No such luck though....

Thanks for all your help guys, seriously. It's greatly appreciated.

thanks,
json
__________________
I read the f'ing manual, and it told me to ask you guys...

performing amazing acts of mediocrity since 1974.
-------------------------------------------------------------------
FC 7(32 bit)/Gnome
AMD Athlon 64 3400+
Nvidia 6800 GT
1 Gig ram
Reply With Quote
  #10  
Old 19th September 2007, 02:11 PM
Orp Offline
Registered User
 
Join Date: Sep 2007
Posts: 10
Hey... I poked around and realized that I have gnome-screensaver on the problem machine, while at home I have xscreensaver-base installed (both are running fc7). Next I will try xscreensaver on the problem machine. I will report my results later.
Reply With Quote
  #11  
Old 19th September 2007, 02:28 PM
schwim Offline
Registered User
 
Join Date: Dec 2005
Location: In your closet
Age: 40
Posts: 2,287
well, during testing last night, the monitors went into shutdown(like they should), but when I woke up this morning, they were still powered, so first I'm taking back all my thanks until I'm sure you guys really helped. Then I'm testing some more.

thanks,
json
__________________
I read the f'ing manual, and it told me to ask you guys...

performing amazing acts of mediocrity since 1974.
-------------------------------------------------------------------
FC 7(32 bit)/Gnome
AMD Athlon 64 3400+
Nvidia 6800 GT
1 Gig ram
Reply With Quote
  #12  
Old 19th September 2007, 04:16 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
json-

I'm wondering if you've given consideration to just not using any screensaver at all and going into your computers bios and and telling it to blank the monitor(s) after x amount of time of no keyboard or mouse input? Though I don't use a dual-head setup, the bios solution sure works great for me. And who needs pretty pictures when you're not even looking at the computer monitor?

Paul
Reply With Quote
  #13  
Old 19th September 2007, 04:26 PM
schwim Offline
Registered User
 
Join Date: Dec 2005
Location: In your closet
Age: 40
Posts: 2,287
Hi there Paul,

Thanks very much for that. The next time I restart, I'll see if I can find it in the bios somewhere. I wasn't aware that the option was available to me

thanks,
json
__________________
I read the f'ing manual, and it told me to ask you guys...

performing amazing acts of mediocrity since 1974.
-------------------------------------------------------------------
FC 7(32 bit)/Gnome
AMD Athlon 64 3400+
Nvidia 6800 GT
1 Gig ram
Reply With Quote
  #14  
Old 19th September 2007, 05:02 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
json-

oops! Once again I spoke (wrote) before positively checking my facts. I rebooted to get into my computers bios just to check where those settings were in order to help direct you to them on your system. Well, that function isn't in my bios. I think I was confusing that with the "ACPI Suspend" functions, which will do monitor blanking, but will also "suspend" your computer. That is a function in the bios.

But, for just plain old monitor screen blanking, in FC6 (probably F7 also), go to System>Preferences>More Preferences>Power_Management

The box there, with the "Running on AC" tab selected, lets you put the display to sleep, with a slider to set the amount of time with no activity for it to kick in. A slider below that, lets you put the computer to sleep in the same fashion. Sorry for the mis-guided info. Dole out whatever punishment you feel is reasonable.

Paul
Reply With Quote
  #15  
Old 19th September 2007, 05:09 PM
schwim Offline
Registered User
 
Join Date: Dec 2005
Location: In your closet
Age: 40
Posts: 2,287
I think this time, punishment will involve two golf balls, a pair of vice-grips and 220 grit sandpaper. We'll figure out what to do with them.

I've got my settings to where it shuts down the monitor after 30 minutes(screenies at 20), and last night it worked as intended, but when I woke up this monring, the screens were blank, but powered. I unchecked "lock the screen" just in case it couldn't go back into shutdown from the password box, and I'll see how that works.

Thanks a lot for checking. I would have ended up changing Munich's time zone, had I been allowed to root around in my bios unattended

thanks,
json
__________________
I read the f'ing manual, and it told me to ask you guys...

performing amazing acts of mediocrity since 1974.
-------------------------------------------------------------------
FC 7(32 bit)/Gnome
AMD Athlon 64 3400+
Nvidia 6800 GT
1 Gig ram
Reply With Quote
Reply

Tags
gnome, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
X GL Screensavers Not Working Animortis Using Fedora 0 12th November 2005 08:57 PM
FC3 screensavers not working on KDE numb Using Fedora 5 16th January 2005 11:22 AM


Current GMT-time: 14:21 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Pali - Hoshiarpur - Sochaczew Photos