Fedora Linux Support Community & Resources Center
  #1  
Old 15th August 2007, 10:34 PM
50MissionCrush Offline
Registered User
 
Join Date: Aug 2007
Posts: 6
Terminal (Shell) problems, Root vs regular user

I'm using Fedora 7 running KDE and my normal user shell opens as a root shell.

Can anyone tell me how I can set this regular user Terminal program to open as a regular user shell ?

From the panel menu I click on System. In the System menu there are 2 Terminal programs, one is simply "Terminal" and is for a regular user (this is the problem one). The other is "Terminal Program - Super User Mode".

If I create a new user the "Terminal" opens as a Shell and the new user is the operator on the command line, the "Terminal Program - Super User Mode" opens as a Root Shell and root is the operator on the command line.

In my account both these shell programs open in root user mode.

I understand that I can simply click on the "sessions" tab in the konsole menu and open a regular shell for the normal user (not root). This works of course and I can simply close the root shell session. I'd just like to get it to work as it should and open in normal user shell mode.

This problem is contagious.

When I did the install I set up the following users in addition to root:

myself
tutor
guest

The first thing I wanted to do was to find the "normal user terminal", and set the background to black and the text to white.
Then I wanted to find the "super user terminal" and set the background to black and the text to green. This way if I were to chose the wrong terminal I would have some coloring indication.

Up until yesterday the problem seemed to be isolated to the "myself" user, where both of my terminal programs opened in Root Shell mode(asking for password). "tutor" and "guest" were still running correctly with the "terminal" opening in normal user Shell and the "super user terminal" opening in Root Shell mode(asking for password).

In an effort to find the problem I logged in as "tutor" today, opened the "terminal" program, went to settings, schema, and changed the color scheme to black background with white text. Then, still under settings I clicked on "save as default", and closed the "terminal" window. Then I opened the "super user terminal" and following the same procedure changed the color scheme to green text on black background. Saved as default, exited.

Now both terminals for user "tutor" are Root Shells(asking for password). What's going on ?!

From some reading on the KDE site concerning the Konsole, it appears the Konsole code is being re-written for KDE 4. And these readings also lead me to believe the configuration setting of KDE 3.* are pretty wacky. Should I just wait for KDE 4 ?

Thanks,

Chip
Reply With Quote
  #2  
Old 16th August 2007, 07:48 PM
PatMcLJr Offline
Registered User
 
Join Date: Apr 2005
Location: earth
Posts: 1,183
I think you know more then me about this. Maybe it's a menu problem?

Pat Jr.
__________________
x--x--x
http://www.gnu.org/philosophy/free-sw.html
Freedom is never Free.
Pat Jr.
Reply With Quote
  #3  
Old 18th August 2007, 09:03 PM
shrubs2000 Offline
Registered User
 
Join Date: Nov 2006
Posts: 13
If you find and answer, I'd like to know too. No matter what/how I open a terminal, it's always a root terminal. Also, I can customize the terminal but it defaults back If I log out and open it again.

Thanx
Reply With Quote
  #4  
Old 19th August 2007, 01:13 PM
50MissionCrush Offline
Registered User
 
Join Date: Aug 2007
Posts: 6
Try right clicking on the panel and adding "Terminal Sessions" from the Add Applet menu. This allows you to choose a normal user Shell or a Root Shell "before" the window opens.

I can live with this, as long as it keeps working. Actually this is excellent.

Chip
Reply With Quote
  #5  
Old 19th August 2007, 03:09 PM
shrubs2000 Offline
Registered User
 
Join Date: Nov 2006
Posts: 13
It's a work around but still doesn't correct the problem.
Reply With Quote
  #6  
Old 9th January 2008, 12:27 PM
shkigor Offline
Registered User
 
Join Date: Nov 2006
Posts: 12
see file in home directory
/home/USER/.kde/share/config/konsolerc

#########
two lines:
DefaultSession=shell.desktop
schema=
#########

DefaultSession may be shell.desktop or su.desktop
schema= may be null or
schema=BlackOnLightYellow.schema
or other
Reply With Quote
  #7  
Old 9th January 2008, 01:21 PM
linuxpcmancn Offline
Registered User
 
Join Date: Dec 2007
Location: /China/BeiJing
Age: 27
Posts: 252
it is confusing me now,i never encounterthis situation,using sudo not su
__________________
An alternative way of life is to love or be loved…

#what's to love > /dev/null

#what's be loved > /trash

:D :D
Reply With Quote
Reply

Tags
problems, regular, root, shell, terminal, user

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hotkey problem: how can I run shell script as regular user? David Batson Using Fedora 1 15th August 2009 04:56 PM
Wireless (Broadcom) & NetworkManager : can connect as root but not as regular user Sam Gamgee Servers & Networking 0 2nd June 2007 08:32 PM
transfer root settings to another regular user duni Installation, Upgrades and Live Media 6 21st August 2006 10:14 AM
Cannot switch user to root via terminal JonJ Using Fedora 5 4th January 2006 09:37 PM
Installing cedega in my regular user (not in root) orbknives Using Fedora 6 9th September 2004 05:39 PM


Current GMT-time: 02:12 (Monday, 22-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat