Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 27th July 2007, 05:35 PM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
Using Gnome and F7, all screensaver and pm disabled. still blanks after 10 minutes!!

Even if I disable the screen saver completely, turn off all power management functions, and make sure the power is plugged in, I still can't watch movies. As you may have gathered from my title, the screen blanks and the workstation locks after 10 minutes. It truly makes it impossible to watch a movie, and I always need to reboot into Windoze.

by the way, one other feature I've noticed in Windoze is that I can turn the laptop monitor display off while still leaving the S-Video out on. Not sure how to do this in Fedora, but it isn't as big of a problem as the screen blanking.

Any help is appreciated. Thanks. I am currently running kernel 2.6.21-1.3228.fc7, and I am going to skip 2.6.22.1-27.fc7 completely until the new kernel is released due to several issues (suspend, wireless).
__________________
$ sudo make --makefile=./beer --always-make --keep-going /home/refrigerator

Linux User #447720
Reply With Quote
  #2  
Old 27th July 2007, 05:50 PM
pete_1967 Offline
Clueless in a Cuckooland
 
Join Date: Mar 2006
Location: Here now, elsewhere tomorrow.
Posts: 4,328
Check that the monitor doesn't have its own power-save features enabled (if it has any) and also if power save features are set in your BIOS.
Reply With Quote
  #3  
Old 27th July 2007, 06:27 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
Hello:

IIRC, I've seen several posts very much like this recently, having to do with some setting(s) in xorg.conf. A search here will probably get you the fix.

V

EDIT: http://forum.fedoraforum.org/forum/s...g+screen+blank

Last edited by Hlingler; 27th July 2007 at 06:38 PM.
Reply With Quote
  #4  
Old 27th July 2007, 06:49 PM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
Quote:
Originally Posted by pete_1967
Check that the monitor doesn't have its own power-save features enabled (if it has any) and also if power save features are set in your BIOS.
No power save feature in BIOS
Quote:
Originally Posted by Hlingler
Hello:

IIRC, I've seen several posts very much like this recently, having to do with some setting(s) in xorg.conf. A search here will probably get you the fix.

V

EDIT: http://forum.fedoraforum.org/forum/s...g+screen+blank
that post is for KDE... is that going to be a problem?
__________________
$ sudo make --makefile=./beer --always-make --keep-going /home/refrigerator

Linux User #447720
Reply With Quote
  #5  
Old 27th July 2007, 06:59 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
Hello:

I saw that you are using GNOME, however, see Post #3 in the link above - xorg.conf is independent of the desktop. In this case, the important difference is ATI vs. nvidia, but you could try the changes to your xorg.conf (back-up first!) to see if that works for you.

Regards,
V
Reply With Quote
  #6  
Old 27th July 2007, 08:03 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
Hello:

This link might help, too: http://www.cyberciti.biz/tips/linux-...ing-blank.html

Regards,
Vince
Reply With Quote
  #7  
Old 27th July 2007, 10:22 PM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
Quote:
Originally Posted by Hlingler
Hello:

I saw that you are using GNOME, however, see Post #3 in the link above - xorg.conf is independent of the desktop. In this case, the important difference is ATI vs. nvidia, but you could try the changes to your xorg.conf (back-up first!) to see if that works for you.

Regards,
V
I do have an ATI... and I had to use Leigh123's downgrade Xorg instructions for X to work.

I made a backup copy of Xorg.conf, made the suggested changes in that other thread, and restarted. There don't appear to be any problems with loading X as a result. I'm not sure yet if it fixed the original problem, though. I will let you know.
__________________
$ sudo make --makefile=./beer --always-make --keep-going /home/refrigerator

Linux User #447720
Reply With Quote
  #8  
Old 27th July 2007, 11:16 PM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
hmmm... ok so that worked... however:
now it doesn't blank or suspend (based on the Gnome Power Manager settings) after inactivity at all!
__________________
$ sudo make --makefile=./beer --always-make --keep-going /home/refrigerator

Linux User #447720

Last edited by SideshowMel; 27th July 2007 at 11:19 PM.
Reply With Quote
  #9  
Old 28th July 2007, 12:12 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
Hm...I'm not sure how to get around this.

One other suggestion: It should be possible to edit those xorg.conf options to specify a long time before screen blanks. Example:
Code:
Section "ServerFlags"
Option "blank time" "180"
Option "standby time" "0"
Option "suspend time" "240"
Option "off time" "0"
EndSection
But I don't know what units (i.e., seconds? minutes? hours?) it's using. This example assumes minutes.

Good Luck,
V
Reply With Quote
  #10  
Old 28th July 2007, 01:08 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,062
I've run into this too, sometimes I want to suspend/sleep the monitor RIGHT now.
So what I did was make some shell aliases to call the xset commands to do it
from a terminal window:

alias dpmsoff "xset -dpms"
alias dpmson "xset +dpms"
alias off "xset dpms force off"

alias standby "xset dpms force standby"
alias suspend "xset dpms force suspend"

(see the man page for xset for much more detail on those)

these are "T shell" aliases in my ~/.tcshrc file. I tend to use the last two
more often, they just force the monitor to suspend or standby but
leave the general dpms state alone.

Most Fedora users use bash shell which I don't like, but bash has similar alias support.
But basically xset -dpms is a very quick way to turn off dpms entirely. You can then watch your movie
and know it won't go to sleep. When you're done do ... :

xset +dpms

If you want to be a bit slicker, you can change the KDE command that's passed to
Linux when you launch your movie program via KDE's menu so that it calls the xset -dpms
call, then the movie program, then the xset +dpms. This way as long as you're starting the movie program from the
KDE start menu, you won't have to
remember to go back to dpms ON mode when the movie is done
(or forget to quit dpms when you start)

You'd do this by using the KDE Menu editor, then in the 'command' slot
for the movie program (say "totem") change this (see attached pic):
Code:
totem %U
to this
Code:
xset -dpms; totem %U; xset +dpms
(NOTE the semi colons must be there to separate commands logically)


I've tried this and it works. I confirmed it by starting totem after making that change and , then in a terminal
I ran "xset -q" to query the Xorg settings, those showed dpms was disabled, then immediately on
quiting Totem, the dpms was back enabled again.

Mark

Last edited by marko; 20th August 2009 at 05:38 AM.
Reply With Quote
  #11  
Old 28th July 2007, 04:09 PM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
Quote:
Originally Posted by marko
I've run into this too, sometimes I want to suspend/sleep the monitor RIGHT now.
So what I did was make some shell aliases to call the xset commands to do it
from a terminal window:

alias dpmsoff "xset -dpms"
alias dpmson "xset +dpms"
alias off "xset dpms force off"

alias standby "xset dpms force standby"
alias suspend "xset dpms force suspend"

(see the man page for xset for much more detail on those)

these are "T shell" aliases in my ~/.tcshrc file. I tend to use the last two
more often, they just force the monitor to suspend or standby but
leave the general dpms state alone.

Most Fedora users use bash shell which I don't like, but bash has similar alias support.
But basically xset -dpms is a very quick way to turn off dpms entirely. You can then watch your movie
and know it won't go to sleep. When you're done do ... :

xset +dpms

If you want to be a bit slicker, you can change the KDE command that's passed to
Linux when you launch your movie program via KDE's menu so that it calls the xset -dpms
call, then the movie program, then the xset +dpms. This way as long as you're starting the movie program from the
KDE start menu, you won't have to
remember to go back to dpms ON mode when the movie is done
(or forget to quit dpms when you start)

You'd do this by using the KDE Menu editor, then in the 'command' slot
for the movie program (say "totem") change this (see attached pic):
Code:
totem %U
to this
Code:
xset -dpms; totem %U; xset +dpms
(NOTE the semi colons must be there to separate commands logically)


I've tried this and it works. I confirmed it by starting totem after making that change and , then in a terminal
I ran "xset -q" to query the Xorg settings, those showed dpms was disabled, then immediately on
quiting Totem, the dpms was back enabled again.

Mark
Dude... many thanks, but that's way beyond me! I don't even know the difference between a bash shell and whatever else you prefer. I think for now, I'm going to just work around it based on this thread. Someday I will revisit this and try your suggestions... I have to learn more first.

Not only that, this is a notebook, so when I want to suspend RIGHT NOW I just close the lid. (getting suspend to work at all was a real pain-in-the-butt, and I can't upgrade my kernel right now because the newest kernel doesn't suspend right for me.)
__________________
$ sudo make --makefile=./beer --always-make --keep-going /home/refrigerator

Linux User #447720

Last edited by SideshowMel; 28th July 2007 at 04:16 PM.
Reply With Quote
  #12  
Old 28th July 2007, 05:12 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,062
Yeah, you can forget about the shell stuff. A "shell" is what's running when you have
a terminal window up and you type commands. It's possible for a linux user to
never even use it.
I'm just saying you can get movie playing to not suspend the display by just setting that xset command before and after running the movie program. The easy way was to use the menu editor to put
xset -dpms; movieplayer %U; xset +dpms

in the command slot for the program (the picture I attached before shows it better)
Mark
Reply With Quote
  #13  
Old 31st July 2007, 10:10 PM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
Quote:
Originally Posted by marko
Yeah, you can forget about the shell stuff. A "shell" is what's running when you have
a terminal window up and you type commands. It's possible for a linux user to
never even use it.
I'm just saying you can get movie playing to not suspend the display by just setting that xset command before and after running the movie program. The easy way was to use the menu editor to put
xset -dpms; movieplayer %U; xset +dpms

in the command slot for the program (the picture I attached before shows it better)
Mark
Yeah I know what a shell is, but I don't know there was anything other than bash. Thanks for the help!
__________________
$ sudo make --makefile=./beer --always-make --keep-going /home/refrigerator

Linux User #447720
Reply With Quote
Reply

Tags
blanks, disabled, gnome, minutes, screensaver

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
INIT: ID "x" respawning too fast: disabled for 5 minutes (After removing GNOME) SicKn3sS Using Fedora 2 24th March 2008 06:31 PM
disabled for 5 minutes message angro Installation, Upgrades and Live Media 3 27th November 2007 02:38 PM
Fedora 8 Test 3 << INIT : "x" respawining too fast: disabled for 5 minutes >> mikhael Using Fedora 4 31st October 2007 05:47 PM
Adding the xscreensaver batch & customizing screensaver options in gnome-screensaver Firewing1 Guides & Solutions (No Questions) 27 14th July 2006 11:09 PM
respawning too fast: disabled for 5 minutes phishbreath Using Fedora 14 24th June 2005 01:37 PM


Current GMT-time: 12:44 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletinģ Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Lapu-Lapu City - Bijawar Travel Photos - Kinel-Cherkassy Travel Photos