Fedora Linux Support Community & Resources Center
  #1  
Old 11th July 2007, 05:31 AM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 178
usb devices do not auto mount anymore. Help.

I hope that someone can help me restore this feature. I used to be able to just plug in the usb drive and click on the little drive icon that appears on the desktop to be able to mount the drive. Now, I do not know what I changed to loose this feature. I have to be root or add a line to /etc/fstab to be able to get it to mount even thogh autofs service is running.

Well, there were changes I made, which I think are unrelated. I changed the case. All hardware are the same and transferred to the new house. I also enabled cool n quiet from BIOS. These are about all changes I made. I rebooted several times but still, no auto mount. I logged in as root, and the drive automounted using the kde gui just like it used to be when It was working for me as a regular user.

Any thoughts about the problem? The message I get from Konqueror when it tries to mount the USB drive is:
Permission denied: Not in active session

Last edited by saqer; 11th July 2007 at 05:33 AM.
Reply With Quote
  #2  
Old 11th July 2007, 07:02 AM
GrapeShot Offline
Registered User
 
Join Date: Jul 2007
Location: Virginia
Posts: 252
This error occurs when the ConsoleKit service is not running. Simply start the service and USB drives will automount again.
Reply With Quote
  #3  
Old 11th July 2007, 01:21 PM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 178
Thanks for the reply. I started the service and checked it is running:
$ /etc/init.d/ConsoleKit status
console-kit-daemon (pid 6979) is running...
but still same error message. Actually, usb drives used to mount even though I have this service not starting almost since I installed Fedora 7.
Reply With Quote
  #4  
Old 12th July 2007, 02:08 AM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 178
In fact, I just found that even I can not mount a DVD. The same exact error message I get. It does not seem to be an autofs problem but rather a permission issue.
Reply With Quote
  #5  
Old 12th July 2007, 03:50 AM
GrapeShot Offline
Registered User
 
Join Date: Jul 2007
Location: Virginia
Posts: 252
Did you logout or reboot after starting the service? The ConsoleKit service tracks sessions, so if you don't reset your session by logging out, the error will persist.
Reply With Quote
  #6  
Old 12th July 2007, 09:06 PM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 178
Quote:
Originally Posted by GrapeShot
Did you logout or reboot after starting the service? The ConsoleKit service tracks sessions, so if you don't reset your session by logging out, the error will persist.
thanks. I am not home but tried it with my office machine and I could reproduce the problem by switching ConsoleKit on and off. As you said it only takes effect if I logout.

I will try it when I go home.
Reply With Quote
  #7  
Old 21st July 2007, 05:32 PM
lionel.hry Offline
Registered User
 
Join Date: Jul 2007
Posts: 2
I have the same problem here almost since i've installed F7. Nor DVD nor USB drives will mount.

I tried what you've said (restart ConsoleKit, logout/login, insert CD), Grapeshot, but it didn't work.

Sager, have you resolved the problem ?
Reply With Quote
  #8  
Old 22nd July 2007, 05:30 AM
rweed Offline
Registered User
 
Join Date: Jun 2007
Posts: 224
Someone else suggested this and it worked for me. I went into Preferences/Removable Media and unchecked the first 3 checkboxes and hit okay. Went back in and rechecked them and hit okay. All is well now.

I did just upgrade to the 2.6.22-27 kernel. The USB drives do seem to take an oddly long time to access the first time, but they work fine after that.
Reply With Quote
  #9  
Old 22nd July 2007, 05:03 PM
lionel.hry Offline
Registered User
 
Join Date: Jul 2007
Posts: 2
Thank you for your suggestion rweed. Unfortunately it didn't work for me. I'm waiting for an answer of Sager, I'll eventually post a bug report.
Reply With Quote
  #10  
Old 22nd July 2007, 10:14 PM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 178
Quote:
Originally Posted by lionel.hry
Thank you for your suggestion rweed. Unfortunately it didn't work for me. I'm waiting for an answer of Sager, I'll eventually post a bug report.
Yes. It worked for me. Indeed, it was the ConsoleKit service. Sadly, you have to "reboot" for changes to take effect. This reminds me of M$ .. ekkkk.
Reply With Quote
  #11  
Old 22nd July 2007, 10:32 PM
BNiels707 Offline
Registered User
 
Join Date: Nov 2006
Posts: 102
I've been having similar issues with the new kernel. I've tried starting/restarting ConsoleKit (with restarting and logging out / back on) and it doesn't seem to help. Its kind of strange.

As a side note, I can't even access even open the "Removable Media" program, it says the "hald" deamon is not accessible. I'm sure its all related somehow, I just haven't managed to put it together...

Last edited by BNiels707; 22nd July 2007 at 10:42 PM.
Reply With Quote
  #12  
Old 23rd July 2007, 11:06 PM
tornadof3 Offline
Registered User
 
Join Date: May 2006
Location: UK
Posts: 164
I have this same problem, ConsoleKit and hal both running perfectly... suggestions above say something about the kernel, how do I go back to a different kernel? This has only happened after a fresh install of F7, FC6 was fine as of 2 days ago!
__________________
CPU: AMD Athlon 64 X2 5600+
RAM: 4GB DDR2
HDD: 1x320GB
Fedora 9 x86_64
Reply With Quote
  #13  
Old 23rd July 2007, 11:53 PM
AlexDudko Offline
Registered User
 
Join Date: Mar 2007
Location: Ukraine
Posts: 381
Yes, this problem occurred when I upgraded to the 2.6.22-27 kernel. Nothing happens yet. Still have to mount usb devises in terminal.
Reply With Quote
  #14  
Old 24th July 2007, 06:08 PM
esdi Offline
Registered User
 
Join Date: Nov 2006
Posts: 13
same problem here since I upgraded to the 2.6.22-1-27 kernel.
I tried the suggested fixes and they are not working for me either.
IE: Restart KonsoleKit and autofs services, logout/logon, reboot.

I noticed that If I reboot with the drive connected, an icon is on the desktop when I log on.
As soon as I disconnect the drive, reconnecting it does not mount it anymore.
logging off then back on does not hep either.
__________________
Control, this is N00bie225, can you tell me where I can RTFM. Over.
Reply With Quote
  #15  
Old 24th July 2007, 06:56 PM
linuxyeung Offline
Registered User
 
Join Date: Jun 2005
Posts: 15
I have two USB drives: one from PNY and the other from sandisk. After I update the kernel to 2.6.22-1-27, the sandisk one continues to automount while the PNY fails.
Reply With Quote
Reply

Tags
anymore, auto, devices, mount, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't mount USB thumbdrive anymore 1xused Hardware & Laptops 5 12th March 2007 11:04 PM


Current GMT-time: 19:53 (Tuesday, 21-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Jobabo Travel Photos - Saint-Pol-sur-Mer Travel Photos on Instagram - Chhapar