FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    TKH Guest

    mdadm fails to assemble my RAID device

    My Fedora FC6 system has 3 RAID devices
    md0 RAID1 hosting the /boot filesystem
    md1 RAID5 hosting the / filesystem
    md2 RAID5 hosting the /usr2 filesystem
    md0 recently failed with one bad disk preventing me from booting up. Instead of working around the single failure it gives me "cannot start dirty degraded array for md1". But it doesn't matter, I wanted to re-image anyway. But I would like to get my md2 back (700GB of precious files). When starting the machine with a Knoppix livecd, the disk partitions making up md2 (/dev... hda2 hdc2 hde2 hdg2) appear to be healthy, but mdadm fails to assemble the array.

    Code:
    root@Knoppix:/# mdadm --assemble --scan
    mdadm: error opening /dev/md0: No such file or directory
    mdadm: error opening /dev/md2: No such file or directory
    mdadm: error opening /dev/md1: No such file or directory
    I read in another thread that I should manually create /dev/md2, but that didn't help.
    Code:
    root@Knoppix:/# mknod /dev/md0 b 9 0
    root@Knoppix:/# mknod /dev/md1 b 9 1
    root@Knoppix:/# mknod /dev/md2 b 9 2
    root@Knoppix:/# ls -al /dev/md*
    brw-r--r-- 1 root root 9, 0 Feb 21 21:19 /dev/md0
    brw-r--r-- 1 root root 9, 1 Feb 21 21:19 /dev/md1
    brw-r--r-- 1 root root 9, 2 Feb 21 21:19 /dev/md2
    root@Knoppix:/#
    root@Knoppix:/# mdadm --assemble --scan
    mdadm: error opening /dev/md0: No such device or address
    mdadm: error opening /dev/md2: No such device or address
    mdadm: error opening /dev/md1: No such device or address
    Another suggestion yielded no success:
    Code:
    root@Knoppix:/# mdadm --assemble /dev/md2 /dev/hda2 /dev/hdc2 /dev/hde2 /dev/hdg2
    mdadm: error opening /dev/md2: No such device or address
    And no luck with this suggestion either:
    Code:
    root@Knoppix:/etc/init.d# mdadm --examine --scan /dev/hd*2 >/etc/mdadm/mdadm.conf
    root@Knoppix:/etc/init.d# cat /etc/mdadm/mdadm.conf
    ARRAY /dev/md2 level=raid5 num-devices=4 UUID=e46f59e0:9cdca28f:f98ddb8f:1d0eb62c
    root@Knoppix:/etc/init.d# /etc/init.d/mdadm start
    root@Knoppix:/etc/init.d# /etc/init.d/mdadm-raid start
    Assembling MD arrays...done (disabled in /etc/default/mdadm).
    root@Knoppix:/etc/init.d# cat /proc/mdstat
    cat: /proc/mdstat: No such file or directory
    Why is there no /proc/mdstst at all?
    Is the RAID service not running? Should I start it manually? How?

    Any ideas?

    Thanks.

  2. #2
    Join Date
    Jun 2005
    Posts
    723
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Perhaps knoppix has problems with raid. try the Fedora cd1 (or the dvd) in linux rescue mode, see if it finds something.
    But of course, take the above with a grain of salt...

  3. #3
    TKH Guest
    Problem solved. Forum member Fayez suggested that the md kernel module mught not be loaded when Knoppix starts up. That was it. I loaded the module with
    modprobe md
    and all of a sudden all the md commands worked properly.
    And I got my files back :-)

    Thanks again for everyone's help.

Similar Threads

  1. mdadm fails after reboot Fedora 10
    By VC_boyo in forum Using Fedora
    Replies: 1
    Last Post: 22nd April 2009, 09:06 PM
  2. mdadm RAID creation - Cannot open device
    By analog4 in forum Using Fedora
    Replies: 2
    Last Post: 11th March 2009, 03:10 AM
  3. RAID 5 - mdadm
    By jscheponik in forum Hardware
    Replies: 3
    Last Post: 12th June 2008, 07:14 PM
  4. Replies: 0
    Last Post: 22nd August 2007, 04:22 AM
  5. Mdadm -- Raid-10
    By BillT440 in forum Using Fedora
    Replies: 1
    Last Post: 7th December 2006, 04:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •