Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

View Poll Results: Did it work for you
Yes 456 48.61%
No 341 36.35%
Nearly worked 141 15.03%
Voters: 938. You may not vote on this poll

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 20th May 2007, 12:58 AM
leigh123linux Offline
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,372
Howto for fglrx / catalyst (Ati driver)

EDIT: Added January 5, 2012


Howto for F16 & F19 (there is no catalyst driver from rpmfusion repository for F20 and higher)


Click this link to make sure your card is supported by this driver (All ATI cards below the HD series are unsupported, in F17 all HD4xxx and below are unsupported)





0. Clean: IF you previously installed this driver using the binary package provided by AMD-ATI, you must un-install it, then repair Mesa:
Code:
su
yum reinstall mesa-libGL
1. Update kernel

Code:
su
yum update kernel
reboot to the new kernel


2. Install driver

install the rpmfusion driver

Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.
Code:
su
yum --nogpgcheck install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install akmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs.i686
Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)

Code:
su
yum --nogpgcheck install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs.i686
For PAE kernels


Code:
su
yum --nogpgcheck install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-catalyst-PAE xorg-x11-drv-catalyst-libs.i686 xorg-x11-drv-catalyst
Or (akmod builds the required kmod on bootup)

3. Make sure radeon is removed from initramfs


Code:
su
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-radeon.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)
4. Reboot











Quote:
Originally Posted by deprecated old content
Howto for F16


I haven't bothered to do a F16 guide as the catalyst driver is complete garbage.
Do yourself a favour and use the open source Radeon driver, if this isn't good enough BUY A NVIDIA CARD INSTEAD.

Last edited by leigh123linux; 5th January 2014 at 10:56 AM. Reason: Content added.
Reply With Quote
  #2  
Old 20th May 2007, 10:03 AM
leigh123linux Offline
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,372
Howto for F15 (Please note that gnome-shell doesn't work with fglrx)



Click this link to make sure your card is supported by this driver ( All ATI cards below the HD series are unsupported )





0. Clean: IF you previously installed this driver using the binary package provided by AMD-ATI, you must un-install it, then repair Mesa:
Code:
su
yum reinstall mesa-libGL




1. Update kernel


Code:
su
yum update kernel
reboot to the new kernel


2. Install driver

install the F15 rpmfusion driver

Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install akmod-catalyst xorg-x11-drv-catalyst  xorg-x11-drv-catalyst-libs.i686
Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)

Code:
su -
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs.i686
For PAE kernels


Code:
su -
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-catalyst-PAE xorg-x11-drv-catalyst-libs.i686  xorg-x11-drv-catalyst
Or (akmod builds the required kmod on bootup )


3. Reboot






.

Last edited by leigh123linux; 3rd November 2010 at 09:32 AM. Reason: .
Reply With Quote
  #3  
Old 21st May 2007, 09:25 PM
leigh123linux Offline
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,372
Howto for F14


Click this link to make sure your card is supported by this driver ( All ATI cards below the HD series are unsupported )





0. Clean: IF you previously installed this driver using the binary package provided by AMD-ATI, you must un-install it, then repair Mesa:
Code:
su
yum reinstall mesa-libGL




1. Update kernel


Code:
su
yum update kernel
reboot to the new kernel


2. Install driver

install the F14 rpmfusion driver

Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.

Code:
su
rpm -Uvh    http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm       http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum  install   akmod-catalyst xorg-x11-drv-catalyst    xorg-x11-drv-catalyst-libs.i686
Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)

Code:
su -
rpm -Uvh   http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm     http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
yum install kmod-catalyst  xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs.i686
For PAE kernels


Code:
su -
rpm -Uvh   http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm     http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
yum install  kmod-catalyst-PAE xorg-x11-drv-catalyst-libs.i686   xorg-x11-drv-catalyst
Or (akmod builds the required kmod on bootup )


3. Reboot





.

Last edited by leigh123linux; 3rd November 2010 at 09:31 AM. Reason: .
Reply With Quote
  #4  
Old 21st May 2007, 10:28 PM
distr0 Offline
Registered User
 
Join Date: Apr 2007
Location: Ontario, Canada
Age: 30
Posts: 67
yeaaah. its pretty

games seem to run horribly now though, is there a solution for this?
Reply With Quote
  #5  
Old 21st May 2007, 10:38 PM
leigh123linux Offline
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,372
Quote:
Originally Posted by distr0
yeaaah. its pretty

games seem to run horribly now though, is there a solution for this?
When I play games I normally disable the effects.

try

gnome-xgl-switch --disable-xgl
__________________
https://admin.fedoraproject.org/pkgdb/users/packages/leigh123linux

https://badges.fedoraproject.org/user/leigh123linux
Reply With Quote
  #6  
Old 22nd May 2007, 02:36 AM
distr0 Offline
Registered User
 
Join Date: Apr 2007
Location: Ontario, Canada
Age: 30
Posts: 67
yep, games run alot smoother with xgl disabled

im glad i swiched to i686, i was having major issues with fglrx in x64, everything just WORKS now running 32 bit
Reply With Quote
  #7  
Old 22nd May 2007, 07:08 PM
nicofo Offline
Registered User
 
Join Date: Nov 2005
Posts: 132
To play a game, run it with "noXgl <myGame>".

Rem: the command "gnome-xgl-switch" is not supported with my script: don't use it !
Reply With Quote
  #8  
Old 22nd May 2007, 08:28 PM
leigh123linux Offline
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,372
Thanks

Quote:
Originally Posted by nicofo
To play a game, run it with "noXgl <myGame>".

Rem: the command "gnome-xgl-switch" is not supported with my script: don't use it !
Hi nicofo,

Great script ( I hope you don't mind me using it in my howto ) , I was aware that the switches were different .
Being a Nvidia user I have been unable to test so I was unable to include any switches.
Could you please post any more usefull switches.

Many thanks Leigh
__________________
https://admin.fedoraproject.org/pkgdb/users/packages/leigh123linux

https://badges.fedoraproject.org/user/leigh123linux
Reply With Quote
  #9  
Old 23rd May 2007, 02:28 PM
joao82 Offline
Registered User
 
Join Date: Nov 2006
Posts: 33
when I do "fglrxinfo" on the terminal I get this:

Quote:
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
nothing shows ATI, is this good or bad? apart from that, everything went ok, it automatically changed "radeon" to "fglrx" on xorg.conf.

and when I type glxinfo i get the following:

Quote:
name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
__________________
Acer 5101 - AMD Turion64 MK36 2.0GHz - ATI Radeon Xpress 1100 128MB (set to 64MB) - 512MB DDR2 - 60 GB HDD - Atheros AR5BMB5 802.11b/g wireless LAN
Fedora Core 6 - kernel 2.6.20-1.2948.fc6 - KDE 3.5.6 - Firefox 2.0.0

Last edited by joao82; 23rd May 2007 at 02:56 PM.
Reply With Quote
  #10  
Old 23rd May 2007, 02:39 PM
leigh123linux Offline
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,372
Quote:
Originally Posted by joao82
when I do "fglrxinfo" on the terminal I get this:



nothing shows ATI, is this good or bad? apart from that, everything went ok, it automatically changed "radeon" to "fglrx" on xorg.conf.

and when I type glxinfo i get the following:
1. Did you edit your xorg.conf as described in section 3 ?
2. Did you restart X or reboot as this is needed . ?

if the above steps fail post the output from

cat /var/log/Xorg.0.log | grep EE


and


cat /var/log/Xorg.0.log | grep WW
__________________
https://admin.fedoraproject.org/pkgdb/users/packages/leigh123linux

https://badges.fedoraproject.org/user/leigh123linux
Reply With Quote
  #11  
Old 23rd May 2007, 02:53 PM
Zero-Override Offline
Registered User
 
Join Date: May 2005
Posts: 741
i am definitly going to like this i think, as soon as i get all my other hardware (mainly my wireless linksys system) then i will try this out!!
__________________
LINUX NUMBER 389596
machine number 290131
Reply With Quote
  #12  
Old 23rd May 2007, 02:54 PM
joao82 Offline
Registered User
 
Join Date: Nov 2006
Posts: 33
sorry, i forgot to do "fglrx-config-display enable"
everything is exactly how you described now. I can now vote on the poll =)
__________________
Acer 5101 - AMD Turion64 MK36 2.0GHz - ATI Radeon Xpress 1100 128MB (set to 64MB) - 512MB DDR2 - 60 GB HDD - Atheros AR5BMB5 802.11b/g wireless LAN
Fedora Core 6 - kernel 2.6.20-1.2948.fc6 - KDE 3.5.6 - Firefox 2.0.0
Reply With Quote
  #13  
Old 24th May 2007, 07:29 PM
nicofo Offline
Registered User
 
Join Date: Nov 2005
Posts: 132
Quote:
Originally Posted by leigh123@linux
Hi nicofo,

Great script ( I hope you don't mind me using it in my howto ) , I was aware that the switches were different .
Being a Nvidia user I have been unable to test so I was unable to include any switches.
Could you please post any more usefull switches.

Many thanks Leigh
Hi,

there is no other command to know except chooseCompositeWM. To summarize the useful commands:
  • noXgl to play a game or use a 3D application. The "-a" option is useful for windowed applications (ex: noXgl ppracer / noXgl -a googleearth)
  • chooseCompositeWM to choose between beryl or compiz (==> you don't need to run them manually). This command is also located in System -> Preferences -> XGL Window Manager [gnome] or K Menu -> Settings -> XGL Window Manager [KDE]
They are all described http://nicofo.tuxfamily.org/dotclear...eryl-on-fedora as well.

And finally, to start / stop using XGL, there is no command for that: you have just to log in and choose or not the XGL session at the login screen.

Enjoy your 3D desktop with ATI
__________________
Install XGL on Fedora, easily: Automatic Installation of XGL
NEW - propose to install compiz-fusion as well !

Last edited by nicofo; 24th June 2007 at 11:08 AM.
Reply With Quote
  #14  
Old 24th May 2007, 07:31 PM
leigh123linux Offline
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,372
Quote:
Originally Posted by nicofo
Hi,

there is no other command to know except chooseCompositeWM. To summarize the useful commands:
  • noXgl to play a game or use a 3D application. The "-a" option is useful for windowed applications (ex: noXgl ppracer / noXgl -a googleearth)
  • chooseCompositeWM to choose between beryl or compiz (==> you don't need to run them manually). This command is also located in System -> Preferences -> XGL Window Manager [gnome] or K Menu -> Settings -> XGL Window Manager [KDE]
They are all described http://nicofo.tuxfamily.org/dotclear...eryl-on-fedora as well.

And finally, to start / stop using XGL, there is no command for that: you have just to log in and choose or not the XGL session at the login screen.

Enjoy your 3D desktop with ATI
Thanks Leigh
__________________
https://admin.fedoraproject.org/pkgdb/users/packages/leigh123linux

https://badges.fedoraproject.org/user/leigh123linux
Reply With Quote
  #15  
Old 25th May 2007, 12:43 AM
Zero-Override Offline
Registered User
 
Join Date: May 2005
Posts: 741
i must have fudged up somewhere

okay here is what i did and have:

i have a fully operational and fresh install of fc7test4
i have the i686 kernel
i have yum and downloaded the packages,

what i don have
i don't have the the namechange from mesa to ati in the xorg.conf
when i tell it to do "service fglrx restart" it says
Code:
 bash: service: command not found
when i reboot it tells me that itś enabling the fglrx and that it may take a while, that works out okay and passes, then whenit should load my xserver it fails and says i fudged something up and that it will repair it =/

what would you suggest i do next?


oh btw, i have my xorg.conf exactly like described
__________________
LINUX NUMBER 389596
machine number 290131
Reply With Quote
Reply

Tags
ati, fglrx, howto

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Catalyst fglrx driver manual install on Fedora 12 Jeff72 Guides & Solutions (No Questions) 15 13th August 2010 09:17 PM
ATI Catalyst™ Display Driver v9.12 rich52 Hardware & Laptops 1 31st December 2009 04:59 AM
HOWTO - make less noise from video card while using fglrx driver multescugeorge@ Guides & Solutions (No Questions) 2 3rd October 2009 08:02 AM
ATI Catalyst 9.x fglrx driver manual install on Fedora 11 Jeff72 Guides & Solutions (No Questions) 25 30th August 2009 08:29 PM


Current GMT-time: 07:57 (Friday, 25-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat