Fedora Linux Support Community & Resources Center
  #1  
Old 15th February 2007, 05:32 PM
dhlstrlm Offline
Registered User
 
Join Date: Jul 2006
Location: helsinki, finland
Age: 33
Posts: 51
Thinkpad on powersaving mode

Hello,

I've been wondering why my computer seems so slow every now and then, and when I checked, I noticed that the cpu is running at only 40% of it's speed (800Mhz instead of 2GHz)

Code:
[walla@Blueprint ~]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 2.00GHz
stepping        : 8
cpu MHz         : 798.072
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx up est tm2
bogomips        : 1597.55
How do I get the full cpu usage to use? The system in question is an IBM Thinkpad T43 running FC6 (2.6.19-1.2895.fc6)
Reply With Quote
  #2  
Old 15th February 2007, 05:51 PM
baschti Offline
Registered User
 
Join Date: Nov 2005
Location: Old Europe
Posts: 377
hi,
the "magic" is provided by this module:
Code:
lsmod | grep cpufreq
this module is loaded via /etc/init.d/cpuspeed
edit: you can disable it with chkconfig
__________________
my JID: baschti@jabber.ccc.de
Reply With Quote
  #3  
Old 15th February 2007, 06:06 PM
dhlstrlm Offline
Registered User
 
Join Date: Jul 2006
Location: helsinki, finland
Age: 33
Posts: 51
Code:
[root@Blueprint ~]# lsmod | grep cpufreq
[root@Blueprint ~]#
Code:
[root@Blueprint init.d]# chkconfig --list
...
cpuspeed        0:off   1:on    2:on    3:on    4:on    5:on    6:off
...
Am I missing something?

Last edited by dhlstrlm; 15th February 2007 at 06:12 PM. Reason: more info
Reply With Quote
  #4  
Old 16th February 2007, 12:34 AM
baschti Offline
Registered User
 
Join Date: Nov 2005
Location: Old Europe
Posts: 377
strange.... seems like the init script failed to load the module, regardless somehow the cpu frequence is scaled down
can you please post the output of
cat /proc/acpi/processor/CPU0/throttling
and
/etc/init.d/cpuspeed status
edit: you should also have a look at /var/log/messages
__________________
my JID: baschti@jabber.ccc.de

Last edited by baschti; 16th February 2007 at 12:36 AM.
Reply With Quote
  #5  
Old 16th February 2007, 05:46 AM
dhlstrlm Offline
Registered User
 
Join Date: Jul 2006
Location: helsinki, finland
Age: 33
Posts: 51
Quote:
Originally Posted by baschti
can you please post the output of
cat /proc/acpi/processor/CPU0/throttling
Code:
[root@Blueprint CPU]# cat throttling
state count:             8
active state:            T0
states:
   *T0:                  00%
    T1:                  12%
    T2:                  25%
    T3:                  37%
    T4:                  50%
    T5:                  62%
    T6:                  75%
    T7:                  87%
[root@Blueprint CPU]#
Quote:
Originally Posted by baschti
and /etc/init.d/cpuspeed status
Code:
[root@Blueprint init.d]# cpuspeed status
cpuspeed v1.2.1

This program monitors the system's idle percentage and reduces or raises the
CPUs' clock speeds and voltages accordingly to minimize power consumption
when idle and maximize performance when needed.  This is the default.

The program may also optionally be configured to reduce the CPUs' clock
speeds if the temperature gets too high, NOT minimize their speeds if the
computer's AC adapter is disconnected or maximize their speeds when the AC
adapter is connected.

By default this program will manage every CPU found in the system.

Usage: cpuspeed [Options]

    Options:
        -d
            Tells the process to daemonize itself (run in background).

        -i <interval>
            Sets the interval between idle percentage tests and possible speed
            changes in tenths of a second (default is 20).

        -n
            Includes nice time as cpu time (off by default)

        -p <fast up> <threshold>
            Sets the CPU idle percentage thresholds.  <fast up> is the idle
            percentage below which a CPU will be set to the highest possible
            speed.  <threshold> is the idle percentage above which a CPU's
            speed will be decreased and below which a CPU's speed will be
            increased (defaults are 10 and 25).

        -m <minimum speed>
            Sets the minimum speed in KHz below which a CPU will not be set.

        -M <maximum speed>
            Sets the maximum speed in KHz above which a CPU will not be set.

        -t <temp file> <maxtemp>
            Sets the ACPI temperature file and the temperature at which CPUs
            will be set to minimum speed.

        -T <interval>
            Sets the interval at which the temperature will be polled in
            tenths  of a second (default is 10).
            (Requires the '-t' option above.)

        -a <AC file>
            Sets the ACPI AC adapter state file and tells the program to set
            the CPUs to minimum speed when the AC adapter is disconnected.
            (This is the default but is changeable by the '-D' option below).

        -A <interval>
            Sets the interval at which the AC adapter state will be polled in
            tenths  of a second (default is 50).
            (Requires the '-a' option above.)

        -C
            Run at maximum speed when AC adapter is connected.
            (Requires the '-a' option above.)

        -D
            Do NOT force minimum speed when AC adapter is disconnected.
            (Requires the '-a' option above.)

        -r
            Restores previous speed on program exit.

        -s <CPU>
            Manage only a single CPU.  <CPU> specifies the number of the CPU
            to manage and is in the range 0 to (n-1) where 'n' is the number
            of CPUs in the system.  Without this option the program creates
            copies of itself to manage every CPU in the system.

    To have a CPU stay at the highest clock speed to maximize performance send
    the process controlling that CPU the SIGUSR1 signal.

    To have a CPU stay at the lowest clock speed to maximize battery life send
    the process controlling that CPU the SIGUSR2 signal.

    To resume having a CPU's clock speed dynamically scaled send the process
    controlling that CPU the SIGHUP signal.

Author:
    Carl Thompson - cet [at] carlthompson.net  (copyright 2002 - 2005)

[root@Blueprint init.d]#
Now I wouldn't mind the cpuspeed to drop down when on battery, but when plugged in, I could use the extra kick...
Reply With Quote
  #6  
Old 16th February 2007, 08:24 AM
dhlstrlm Offline
Registered User
 
Join Date: Jul 2006
Location: helsinki, finland
Age: 33
Posts: 51
Quote:
Originally Posted by baschti
edit: you should also have a look at /var/log/messages
Here's (in my opinion) relevant info from /var/log/messages when the system started up:

Code:
Feb 15 12:16:45 Blueprint kernel: Detected 798.072 MHz processor.
...
Feb 15 12:16:45 Blueprint kernel: Checking if this processor honours the WP bit even in supervisor mode... Ok.
Feb 15 12:16:45 Blueprint kernel: Calibrating delay using timer specific routine.. 1597.55 BogoMIPS (lpj=798777)
Feb 15 12:16:45 Blueprint kernel: Security Framework v1.0.0 initialized
Feb 15 12:16:45 Blueprint kernel: SELinux:  Initializing.
Feb 15 12:16:45 Blueprint kernel: SELinux:  Starting in permissive mode
Feb 15 12:16:45 Blueprint kernel: selinux_register_security:  Registering secondary module capability
Feb 15 12:16:45 Blueprint kernel: Capability LSM initialized as secondary
Feb 15 12:16:45 Blueprint kernel: Mount-cache hash table entries: 512
Feb 15 12:16:45 Blueprint kernel: CPU: L1 I cache: 32K, L1 D cache: 32K
Feb 15 12:16:45 Blueprint kernel: CPU: L2 cache: 2048K
Feb 15 12:16:45 Blueprint kernel: Intel machine check architecture supported.
Feb 15 12:16:45 Blueprint kernel: Intel machine check reporting enabled on CPU#0.
Feb 15 12:16:45 Blueprint kernel: Checking 'hlt' instruction... OK.
Feb 15 12:16:45 Blueprint kernel: SMP alternatives: switching to UP code
Feb 15 12:16:45 Blueprint kernel: Freeing SMP alternatives: 12k freed
Feb 15 12:16:45 Blueprint mcstransd: mcstransd starting
Feb 15 12:16:45 Blueprint kernel: ACPI: Core revision 20060707
Feb 15 12:16:45 Blueprint kernel: CPU0: Intel(R) Pentium(R) M processor 2.00GHz stepping 08
Feb 15 12:16:45 Blueprint kernel: Total of 1 processors activated (1597.55 BogoMIPS).
Feb 15 12:16:45 Blueprint kernel: ENABLING IO-APIC IRQs
Feb 15 12:16:45 Blueprint kernel: ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
Feb 15 12:16:45 Blueprint kernel: Brought up 1 CPUs
...
Feb 15 12:16:45 Blueprint kernel: ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3] C4[C3])
Feb 15 12:16:45 Blueprint kernel: ACPI: Processor [CPU] (supports 8 throttling states)
Feb 15 12:16:45 Blueprint kernel: ACPI: Thermal Zone [THM0] (50 C)
...
Feb 15 12:16:46 Blueprint kernel: ACPI: AC Adapter [AC] (off-line)
Feb 15 12:16:46 Blueprint kernel: ACPI: Battery Slot [BAT0] (battery present)
...
Reply With Quote
  #7  
Old 16th February 2007, 10:06 AM
dhlstrlm Offline
Registered User
 
Join Date: Jul 2006
Location: helsinki, finland
Age: 33
Posts: 51
Ok, I think I found something that works...

I added these lines to /etc/rc.local:

Code:
modprobe cpufreq_ondemand
echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
(Code excerpt from here)


my /proc/cpuinfo now shows:

Code:
model name       : Intel (R) Pentium(R) M processor 2.00GHz
stepping         : 8
cpu MHz          : 1995.299
...the only problem now is that it doesn't "rev-down" when unplugging it from AC

Last edited by dhlstrlm; 16th February 2007 at 11:30 AM. Reason: typo in stepping number
Reply With Quote
  #8  
Old 17th February 2007, 03:06 AM
marko Online
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,068
dhlstrlm:

could you try something for me, run this and confirm you have the proper
kernel and so I can see what particular one you have
Code:
yum list installed kernel
You want the first word on the line(s) to be :

kernel.i686

and not:

kernel.i586

Some Fedora 6's got installed with the 586 kernel and not
the 686 and although the former will work on your pentium-m
some features like power control might be interfered with.

Also go in directory
/sys/devices/system/cpu/cpu0/cpufreq
and do:

cat *

so all the files in there list out and post the results.

Mark

Last edited by marko; 18th February 2007 at 06:38 AM.
Reply With Quote
  #9  
Old 17th February 2007, 07:07 AM
dhlstrlm Offline
Registered User
 
Join Date: Jul 2006
Location: helsinki, finland
Age: 33
Posts: 51
[root@Blueprint cpu0]# yum list installed kernel
Loading "installonlyn" plugin
Installed Packages
kernel.i586 2.6.18-1.2798.fc6 installed
kernel.i586 2.6.19-1.2895.fc6 installed
You have new mail in /var/spool/mail/root
[root@Blueprint cpu0]#

So, kernel appears to be i586.

And there is no cpufreq/ directory under /sys/devices/system/cpu/cpu0

Is this because of the kernel version?

What to do next?
Reply With Quote
  #10  
Old 17th February 2007, 05:24 PM
dhlstrlm Offline
Registered User
 
Join Date: Jul 2006
Location: helsinki, finland
Age: 33
Posts: 51
ok. I updated the kernel to the newest i686 version, and it now works just like designed. Thanks for the help everyone.
Reply With Quote
Reply

Tags
mode, powersaving, thinkpad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PPC and powersaving nightfrost Mac Chat 1 31st January 2008 03:49 PM
Powersaving Mode? Hlingler Using Fedora 2 27th February 2007 10:32 PM
IBM Thinkpad in sleep mode => LCD is still on Stone Dragon Hardware & Laptops 0 25th April 2006 10:08 AM
Text Mode problem on Thinkpad T23 Fedora 4 c.a.hein Hardware & Laptops 0 19th October 2005 03:15 PM


Current GMT-time: 20:07 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Kertosono - Olenegorsk Photos - Minuf Photos