Fedora Linux Support Community & Resources Center
  #1  
Old 24th January 2007, 06:18 AM
linux_fed2 Offline
Registered User
 
Join Date: Sep 2004
Posts: 45
warning: master_wakeup_timer_event: service public/pickup:

hi,

I upgraded our postfix server to postfix 2.2.2-3. After trying the new system, outgoing email could not be send it gives me an error:

Jan 24 14:15:59 dmz postfix/qmgr[10214]: 270E0235D0E: to=<user@mydomain.com>, relay=none, delay=0, status=deferred (delivery temporarily suspended: deferred transport)
Jan 24 14:16:42 dmz postfix/master[4722]: warning: master_wakeup_timer_event: service public/pickup: No such file or directory

Any idea?

I'm using MailScanner, SpamAssassin and clamAV.

Thanks!
Reply With Quote
  #2  
Old 24th January 2007, 01:54 PM
bananasfk Offline
Registered User
 
Join Date: Dec 2006
Posts: 61
1. are you chrooting ?
2. does your mail store thing exist/run in your upgraded config ?
Reply With Quote
  #3  
Old 24th January 2007, 11:59 PM
linux_fed2 Offline
Registered User
 
Join Date: Sep 2004
Posts: 45
i figured it out, the old main.cf was causing the problem. thanks for the reply.

another problem that i'm encountering now is that, after the upgrade postfix was not sending the emails automatically. I have postfix and postfix.in since i'm using MailScanner for spam and virus scanning. i tried to isolate the problem by stoping MailScanner and using only one postfix and it work fine. is this a compatibility issue or a bug?

I add the defer_transports = smtp local virtual relay in /etc/postfix.in/main/cf and i disabled smtp service in /etc/postfix/master.cf.
Reply With Quote
  #4  
Old 25th January 2007, 10:59 AM
bananasfk Offline
Registered User
 
Join Date: Dec 2006
Posts: 61
Quote:
Originally Posted by linux_fed2
i figured it out, the old main.cf was causing the problem. thanks for the reply.
one down!

Quote:
Originally Posted by linux_fed2
another problem that i'm encountering now is that, after the upgrade postfix was not sending the emails automatically. I have postfix and postfix.in since i'm using MailScanner for spam and virus scanning. i tried to isolate the problem by stoping MailScanner and using only one postfix and it work fine. is this a compatibility issue or a bug?

I add the defer_transports = smtp local virtual relay in /etc/postfix.in/main/cf and i disabled smtp service in /etc/postfix/master.cf.
if your using multiple instances of postfix - (master.cf/main.cf x many) then check the mynetworks = line in all instances. To get amavisd to work i can send all inbound mail to port 10024 but I have to redefine 10025 as 10026 in the second instance fwiw.

It seems to work though
Reply With Quote
Reply

Tags
masterwakeuptimerevent, public or pickup, service, warning

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Public service announcement FriedChips Wibble 19 4th October 2008 06:01 AM
Gtk-WARNING and libgnomevfs-WARNING when loading programs from the terminal someuser77 Using Fedora 1 13th May 2006 09:54 AM
service TOMCAT5 start -maxdepth warning jpietari Using Fedora 0 23rd October 2005 03:35 AM
how to connect my roadrunner service or aol service to my fedora core 1 on my compter john nelson jr Using Fedora 1 14th March 2005 12:22 AM


Current GMT-time: 19:41 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Nimbahera Travel Photos - Christiana - Pennadam Travel Photos on Instagram