Fedora Linux Support Community & Resources Center
  #1  
Old 17th April 2004, 08:36 PM
Linuxxx Offline
Registered User
 
Join Date: Feb 2004
Posts: 34
Need to make sure I have the right driver installed for Video Card

Hello

I have a Nvidia GEForce 5200 FX video card that I would like to configure properly in Fedora Core 1.

I am also a Linux newbie, so my understanding of installing drivers is somewhat lacking.

I downloaded a driver the other day from Nvidia's site for the Linux IA32.

From there I logged out of X and installed the Driver. All seemed to go well. No errors whatsoever. I was then able to go back into x.

Now I'm unsure if what I did was successful. I went in to check my Hardware on my Gnome desktop and found that the video card has generic drivers installed.

Can someone please tell me what the proper procedure to install the drivers is if I have indeed botched this process.

Also I would like to get this card operating to expected preformance levels.

Thank you
Scott
Reply With Quote
  #2  
Old 18th April 2004, 03:52 AM
Jman Offline
Registered User
 
Join Date: Mar 2004
Location: Minnesota, USA
Age: 28
Posts: 7,909
There are nvidia rpm packages at the livna.org repository. Unfortunately it's down at the moment, but there is a mirror.

See the FAQ about nvidia.

If you want a spiffy test afterwards, run
Code:
glxgears -info
You should get some crazy number of FPS.

Last edited by Jman; 18th April 2004 at 04:24 PM.
Reply With Quote
  #3  
Old 18th April 2004, 05:04 AM
crackers Offline
Retired Community Manager
 
Join Date: Feb 2004
Location: Seattle, WA, USA
Age: 57
Posts: 3,423
You installed the drivers, but you didn't modify the XF86Config file to use them. Download and read the README.txt file from the NVidia site - you're not quite done yet...
Reply With Quote
  #4  
Old 27th April 2004, 02:56 PM
gonzalo76 Offline
Registered User
 
Join Date: Feb 2004
Location: Buenos Aires, ARG
Age: 37
Posts: 320
After installing the driver you must edit your XF86Config file before
the newly installed driver will be used.

EDITING YOUR XF86CONFIG FILE
If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist.

Once you have configured your XF86Config file, you are ready to restart
X and begin using the accelerated OpenGL libraries. After you restart X,
you should be able to run any OpenGL application and it will automatically
use the new NVIDIA libraries.

ftp://download.nvidia.com/XFree86/Li....0-5336/README
__________________
Greetings :)
gonzalo
Reply With Quote
  #5  
Old 27th April 2004, 03:02 PM
gonzalo76 Offline
Registered User
 
Join Date: Feb 2004
Location: Buenos Aires, ARG
Age: 37
Posts: 320
rpm.livna.org

See why you should use our nvidia video driver rpm packages instead of the nvidia installer. If you want to give it a try, you probably want to install the kernel-module-nvidia-$(uname -r) package. Be careful, only latest kernel is supported.

http://rpm.livna.org/livna-switcher.html
__________________
Greetings :)
gonzalo
Reply With Quote
  #6  
Old 27th April 2004, 08:24 PM
sailor Offline
Administrator
 
Join Date: Mar 2004
Location: San Antonio, Texas - Home of the Alamo, the "Cradle of Texas Liberty"
Age: 56
Posts: 4,100
Now you tell me...I have been fighting with the Nvidia script install for a couple days.....
I took a look at the url you posted and that looks much easier...
thanks again!

will I need to have the kernel source inorder to run the rpm?
that was the last problem that I ran into when trying to install the Nvidia script..

__________________
**********************************************
sailor
San Antonio, Texas

Fedora 20 - Lenovo IdeaPad V570
**********************************************

Last edited by sailor; 27th April 2004 at 10:24 PM.
Reply With Quote
  #7  
Old 28th April 2004, 12:10 AM
imdeemvp Offline
Registered User
 
Join Date: Feb 2004
Age: 45
Posts: 8,256
I preffer to use ATI vidoe cards for all my systems Nvidia they're just a pain....in the butt to configure!
__________________
HELP with JAVA, MP3's, Wireless, Repo's, YUM, Partitions, System Monitors, Nvidia, ATI drivers, LIMEWIRE PRO & MORE!.

Easiest and most friendly desktop ever is PCLinuxOS! Includes all this apps. Just try it.

"The greater the struggle THE greater the achievment."

Do you know HIM?

If you are an idiot click here. NThis will test you linux skills :D
Reply With Quote
  #8  
Old 28th April 2004, 01:08 AM
gonzalo76 Offline
Registered User
 
Join Date: Feb 2004
Location: Buenos Aires, ARG
Age: 37
Posts: 320
Quote:
Originally posted by sailorsgh
Now you tell me...I have been fighting with the Nvidia script install for a couple days.....
I took a look at the url you posted and that looks much easier...
thanks again!

will I need to have the kernel source inorder to run the rpm?
that was the last problem that I ran into when trying to install the Nvidia script..
My current kernel version is 2.4.22-1.2188.nptl i686, it's the last one of the 2.4 series.

So, in my case, I had to download:

1. kernel-module-nvidia-2.4.22-1.2188.nptl-1.0.5336-0.lvn.3.1.i686.rpm
2. nvidia-glx-1.0.5336-0.lvn.3.1.i386.rpm

Then, I installed them with : rpm -ivh *.rpm

Also, you do not need to drop out of X to perform the installation.

The Livna Nvidia driver RPM comes with a small python script, which works as an extension to redhat-config-xfree86, and does all the editing of the XFree86 configuration file for you.

The only thing is that there are only 2 kernel versions available, 2.4...2174 and 2.4...2188 and they are only for Fedora Core 1.

Download link:
http://rpm.livna.org/fedora/1/i386/RPMS.stable/
__________________
Greetings :)
gonzalo
Reply With Quote
  #9  
Old 28th April 2004, 01:21 AM
gonzalo76 Offline
Registered User
 
Join Date: Feb 2004
Location: Buenos Aires, ARG
Age: 37
Posts: 320
Quote:
Originally posted by imdeemvp
I preffer to use ATI vidoe cards for all my systems Nvidia they're just a pain....in the butt to configure!
I don't think so... they are so easy to install.

From nvidia.com:

Type "sh NVIDIA-Linux-x86-1.0-5336-pkg1.run" to install the driver, then edit your X86Config file as appropriate. See the text README for more detailed instructions.

From livna.org:

There's a binary RPM packages only contain the files necessary for your computer's architechture, therefore the file sizes are much smaller compared to generic source packages.
The Livna Nvidia driver RPM comes with a small python script, which works as an extension to redhat-config-xfree86, and does all the editing of the XFree86 configuration file for you.
Also, you do not need to drop out of X to perform the installation. And if you boot a kernel without Nvidia support, a boot script will automagically detect that the Nvidia kernel module is missing and revert to XFree86 configuration.

So, I think it's not too hard to install the nvidia drivers and configured them and I really don't understand why you installed the ATI drivers if you have an NVIDIA chip.

Configure the driver ?
Well, if you choose to download from nvidia.com you'll only have to change a word:

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist.

I don't think that's too hard to do, don't you ?
__________________
Greetings :)
gonzalo
Reply With Quote
  #10  
Old 28th April 2004, 02:21 AM
sailor Offline
Administrator
 
Join Date: Mar 2004
Location: San Antonio, Texas - Home of the Alamo, the "Cradle of Texas Liberty"
Age: 56
Posts: 4,100
Thumbs up

Perfect...worked great..I had same kernel...
got 459.8 fps with glxgears -info...
that tip is going in my archive...thank you so much...sailor
__________________
**********************************************
sailor
San Antonio, Texas

Fedora 20 - Lenovo IdeaPad V570
**********************************************
Reply With Quote
  #11  
Old 28th April 2004, 02:38 AM
gonzalo76 Offline
Registered User
 
Join Date: Feb 2004
Location: Buenos Aires, ARG
Age: 37
Posts: 320
Quote:
Originally posted by sailorsgh
Perfect...worked great..I had same kernel...
got 459.8 fps with glxgears -info...
that tip is going in my archive...thank you so much...sailor
Great !!!

greetings
gonzalo
__________________
Greetings :)
gonzalo
Reply With Quote
  #12  
Old 28th April 2004, 02:48 AM
imdeemvp Offline
Registered User
 
Join Date: Feb 2004
Age: 45
Posts: 8,256
gozalo76 said:
" I don't think so... they are so easy to install. "

i had problems when i used to have rh8.....sorry i did not mention that....at the time no drivers so i returned it and purchased an ATI....

greetings...gonzalo76!
__________________
HELP with JAVA, MP3's, Wireless, Repo's, YUM, Partitions, System Monitors, Nvidia, ATI drivers, LIMEWIRE PRO & MORE!.

Easiest and most friendly desktop ever is PCLinuxOS! Includes all this apps. Just try it.

"The greater the struggle THE greater the achievment."

Do you know HIM?

If you are an idiot click here. NThis will test you linux skills :D
Reply With Quote
  #13  
Old 14th May 2004, 02:09 AM
the_1ne Offline
Registered User
 
Join Date: May 2004
Location: Romania
Age: 29
Posts: 1
Nice .... but I have some problems here ...

So, let me say what is wrong at me:
I have a GeForce 2 Mx 400 form Inno3D... and I installed the NVIDIA driver, also I configured the XF86Config (etc) but it has some problems

First: I used the default kernel form the distribution of FC1, default KDE, default XFree86, etc ... and after a few seconds it crashes ... i have to say that the muse cursor doesn't work like without nvidia driver ... Also I have to say that after any reboot the driver will not load any moore ... (

Second: I used the latest KDE (3.2.2) and the same problem appears ... The same problem at rebooting !

Third: I made an up-date to the entire sistem (I used "apt-get -f upgrade). In GUI appears the same problem with mouse and crashes (the windos are opening after a few seconds, also with the menus, popups, etc). But here at reboot the system does not start X anymore... when FC tries to start any graphical interface, appers some image on the screen (probably is the "buffer" of the video card...(?) ... on the screen exists just random chars from the entire ascii code and not any graphical things and is not doing anything! It seems that it does not enter the runlevel 5 (maybe that runlevel 2 is't entered too)...

What should I do ??? I'm desperate !

P.S. Exscuse my English !!! :!:
P.S. I have AMD Barton 2500+, 2 x 256 DDR 400 Dual Channel and MB Epox 8RDA+ ... (etc). Is possible that all of this crashes to be caused because the kernel is'nt compatible with Barton, or with Epox mainboards ??? Please help me, I don't know what to do anymoore!!! :!:
__________________
Mess with the BEST
Die like the REST

Last edited by the_1ne; 14th May 2004 at 02:18 AM.
Reply With Quote
Reply

Tags
card, driver, installed, make, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO - make less noise from video card while using fglrx driver multescugeorge@ Guides & Solutions (No Questions) 2 3rd October 2009 08:02 AM
No video card detected when wide flat screen installed OralDeckard Hardware & Laptops 2 17th July 2008 02:46 AM
installed Fed 5 fine, but no sound and cant find drivers for video card gtrgy Installation, Upgrades and Live Media 3 21st November 2006 04:26 AM
Bad Video Card or Bad Driver? jafar Hardware & Laptops 2 25th November 2005 10:10 AM
Want to make sure this video card is Linux/FC3 compatible before I order Bob D. Hardware & Laptops 0 20th March 2005 03:32 PM


Current GMT-time: 10:11 (Wednesday, 16-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat