Fedora Linux Support Community & Resources Center
  #31  
Old 18th December 2006, 02:54 PM
SysProbe Offline
Registered User
 
Join Date: Dec 2006
Location: Albany, New York
Posts: 6
Did anyone try using the below resolution, and was able to solve the shutdown problem.

If you were able to solve the problem, please just post a message so we can get an idea if there may need to be other resolutions aside from the one quoated below.

Thanks

Dwight
a.k.a......SysProbe

www.ShoppersChoiceMall.com


Quote:
Originally Posted by SysProbe
Shut down PROBLEM SOLVED FOR ME

**Thanks so much Anniedog and ZWfed

I am completely new to Linux & have never done anything with it, except install the OS

I recently ordered the Fedora Core6 disk and did my install within the last few days & had the exact problem everyone here was having.

I took a chance and did what ZWfed said, and my problem was solved.

Please note that I have a old 486-machine with an Award Bios

I went into the Bios and made sure that my power-management settings were ENABLED

I then was able to navigate to the grub.conf file by using the below path. The path may be different on your computer I do not know, because I am completely new to Linux.

My Computer>File System>boot>grub>grub.conf

I added the below comment at the end of the file on a seperate line.

apm=realmode-power-off

I then shutdown my computer, but had to hard-power off by pushing the power-button in , but once she re-booted & I logged into the machine & then shut her down ALL WAS WELL

Thanks a bunch guys.

SysProbe
.......aka Dwight
Reply With Quote
  #32  
Old 18th December 2006, 10:02 PM
DealerMan Offline
Registered User
 
Join Date: Aug 2005
Posts: 25
Shutdown works properly now

I'm a very happy guy. Many thanks to ZW and Annie for providing the solution.

ZW, as far as your 'Preferences' are concerned, are you booting into KDE? If so, boot into Gnome, because the menu system works just a little different when you compare the 2 (sometimes it doesn't get mentioned in a 'how-to' fix).

Good luck, let us know what happens.

For those who may be watching, here's exactly what I did to fix my shutdown problem (in FC6):

Open a terminal in super user mode.
at the prompt, type in: gedit /etc/grub.conf
you may have to hit enter for a new line, then type: apm=realmode-power-off
hit save, then close
exit from terminal, then power down one more time using the power button
power up, then test it to make sure it works

Good luck, may the force be with you.
Reply With Quote
  #33  
Old 20th December 2006, 10:54 PM
Divit11 Offline
Registered User
 
Join Date: Jun 2006
Location: Elmhurst, IL, USA
Posts: 84
Wink Changing my BIOS worked for me

Hi All,
Just a brief history. I have a PIII setup to dual boot in MS XP Home and FC6. When I had FC5 installed my machine would shut down when I left FC5 but would not shut down without the 3-4 second button thing when I left XP. After upgrading to FC6 (fresh install) it was back to holding down the power button to shut down.

I tried adding " apm=realmode-power-off " to the grub.conf file but that did not change anything for me.

I saw a comment in another thread (that Anniedog may have also been trying to communicate) about power management. So I did the following:

1- Commented out the line " apm=realmode-power-off in grub.conf
2- Did a cold boot and held the DEL key down to access my Award Software Bios
3- Used the down arrow to highlight the menu item: Power Management Setup hit Enter
4- I noticed that the ACPI Function was Disabled
5- Changed the option to Enabled then did ESC; F10; Y
6- When the machine rebooted into FC6 I was able to power down without holding the power button down.

For those Dual Booters out there still reading this thread:
During a further google search I found a soluton to the XP side of my problem.

1- When in XP click on Start / Settings / Control Panel / Power Options
2- Select the APM Tab
3- In the section Advanced Power Management check the box by "Enabled Advanced Power Management support"
4- Click OK
5- When I shut down my machine, it turned off without the power button thing.

I hope this helps one or two of you.

Divit11

Last edited by Divit11; 21st December 2006 at 06:10 AM.
Reply With Quote
  #34  
Old 22nd December 2006, 10:04 AM
Anniedog Offline
Registered User
 
Join Date: Aug 2006
Location: UK
Posts: 653
zwfed You should be able to place your mouse over Applications and right click then you should see Edit Menus option from there you should have various choices etc. The fix for power down hasnt worked for me yet either. I am going to try placing the line apm = realmode etc in various positions in grub.conf as I have three kernels saved now I am not certain if this line is being reached. It is a little frustrating that we cant seem to get it. I am wondering if there may be several different causes for this as adding this line has had no effect at all for me. It may be that for some it may be an incorrect bios setting only and once this is corrected the kernel just does what it should properly, but for others it may be more complcated. I will post back if I get it working.
Reply With Quote
  #35  
Old 30th December 2006, 01:29 PM
Jack Malmostoso Offline
Registered User
 
Join Date: Dec 2003
Posts: 9
Hi guys,
I have been having this same problem on my old PIII 550 on a BX440 motherboard with a 1999 BIOS.
First, a comment on the APM=realmodeblahblah: Fedora's kernel is compiled without the support for that, so it's pretty useless to use that as kernel argument on boot.

That said, the kernel argument that does the trick is "acpi=force". You have to edit /boot/grub/menu.lst so that your "kernel" lines read something like this:

Code:
kernel /boot/vmlinuz-2.6.XX-XXXX acpi=force ro root=LABEL=/ rhgb quiet
If you put the argument at the end of the file, it won't do anything, cause it won't be parsed correctly.
I have tested this solution and it works just perfectly.

Btw, I found out thanks to a Debian error message on a similar machine

Hope this helps, I will now comment on the reported bug to ask for a patch that configures grub to use this behaviour for older BIOSes.
Happy new year everyone
__________________
Best Regards, Jack
Linux User #264449
Powered by Fedora Core 6 (x86)
Powered by Debian Sid (PPC & AMD64)
Reply With Quote
  #36  
Old 30th December 2006, 03:48 PM
ryptyde Offline
Registered User
 
Join Date: May 2005
Location: Tragic City, Michigan USA
Posts: 1,647
Thumbs up

Quote:
Originally Posted by Jack Malmostoso
Hi guys,
I have been having this same problem on my old PIII 550 on a BX440 motherboard with a 1999 BIOS.

That said, the kernel argument that does the trick is "acpi=force". You have to edit /boot/grub/menu.lst so that your "kernel" lines read something like this:

Code:
kernel /boot/vmlinuz-2.6.XX-XXXX acpi=force ro root=LABEL=/ rhgb quiet
If you put the argument at the end of the file, it won't do anything, cause it won't be parsed correctly.
I have tested this solution and it works just perfectly.
I have an older PIII 550 MHz also from 1999 and it is running FC6 and the "halt but no shutdown" has been an inconvenience up until now.

I followed the aforementioned fix from Jack Malmostoso and it worked perfectly.

!
Reply With Quote
  #37  
Old 31st December 2006, 05:09 PM
jcwinnie Offline
Registered User
 
Join Date: Nov 2003
Location: SouthernTierNY, USA
Posts: 129
Thumbs up

Thanks, Jack! Your suggestion worked.
__________________
Stay Clear of Netgear
Reply With Quote
  #38  
Old 31st December 2006, 09:12 PM
zwfed Offline
Registered User
 
Join Date: Nov 2006
Posts: 32
Thanks Jack and it works for me.
Reply With Quote
  #39  
Old 31st December 2006, 11:58 PM
lxuser Offline
Registered User
 
Join Date: Dec 2006
Location: I live in Cirencester
Age: 41
Posts: 1
Hello, I am new, especially to linux. I have tried all the suggesstions in this forum and I am still having problems shutting down the computer.
Reply With Quote
  #40  
Old 1st January 2007, 02:31 PM
Jack Malmostoso Offline
Registered User
 
Join Date: Dec 2003
Posts: 9
Quote:
Originally Posted by lxuser
Hello, I am new, especially to linux. I have tried all the suggesstions in this forum and I am still having problems shutting down the computer.
Hi,

a few guidelines for when you post to a forum, in order to give you the best help possible:

1) Specify your distribution and the kernel you're running (the output of the uname -a command is the best thing you can give us). Don't forget to include a summary of your hardware (CPU, Motherboard, Video Card, Sound Card at least). Don't say things like "My PC configuration is in my signature", cause I (as well as other users) have my preferences set not to show them.

2) Specify clearly your problem. Don't be afraid to bore us, give as many details as you can. As long as you write in plain english, it's ok.

3) Specify what you have done until now to try to solve your problem.

We have all been newbies, and believe me, if you follow these guidelines you'll make our job easier.

Try again now
__________________
Best Regards, Jack
Linux User #264449
Powered by Fedora Core 6 (x86)
Powered by Debian Sid (PPC & AMD64)
Reply With Quote
  #41  
Old 23rd January 2007, 10:49 PM
moogii Offline
Registered User
 
Join Date: Nov 2006
Posts: 31
I'm having similar problem as well ..

Dell optiplex 500

3ple boot..
1 suse
2 fc6
3 ubuntu.

the problem is i dont have the grub.conf file. cos i didnt install grub on fedora.

only grub installed was from SuSE....However when I shut down SuSE,it just shuts down...

FC6 and Ubuntu don.t

I always HAVE TO PUSH THE DAMN BUTTON........

PLSE...SUGGESSTION?
Reply With Quote
  #42  
Old 24th January 2007, 12:18 AM
beissemj Offline
Registered User
 
Join Date: Jan 2007
Posts: 43
Quote:
Originally Posted by moogii
I'm having similar problem as well, the problem is i dont have the grub.conf file.
I believe Suse calls it menu.lst.
Reply With Quote
  #43  
Old 24th January 2007, 09:41 AM
moogii Offline
Registered User
 
Join Date: Nov 2006
Posts: 31
so u suggesting me to add this " apm=realmode-power-off" to my menu.lst ???????????

I'm really not sure .Because My SUSE is fine ..Dont have to push power button .

Only Problem is Fedora Core 6..I would add that line to "grub.conf" if I had installed GRUB on my FC6.

but I didn't....So.....

If I do it as you said my SuSE would be screwed...don' t you think??

or am I wrong?
Reply With Quote
  #44  
Old 25th January 2007, 10:16 PM
moogii Offline
Registered User
 
Join Date: Nov 2006
Posts: 31
no problems now.I enabled ACPI option in BIOS.
Then no problem at all....i didnt add any line or a word in anywhere.

Ubuntu ok.
FC6 ok.
SuSE ok.

So i'm happy.
Reply With Quote
  #45  
Old 26th January 2007, 09:29 PM
robertos Offline
Registered User
 
Join Date: Jan 2007
Posts: 38
gdm problem

I have upgraded from FC4 to FC6 and now when i boot it doesn't start X correctly
i think it's a problem with gdm...i cannot login in X. i get this in /var/log/messages

gdm_config_parse: Standard X server not found.
no suitable security token driver could be found

Any ideas?
Thanks

PS:i've personally had it with Fedora...seriously.i hope you can help me or i think i'll drop it.
This is not a menace or something like that,it's my personal opinion.
Reply With Quote
Reply

Tags
fc4, fc6, shutdown, upgraded

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgraded kernel, upgraded nVidia driver via livna = Wine problems plutus Using Fedora 12 16th June 2008 11:21 PM
Why do shutdown -h and shutdown -r behave so differently? jlixfeld Using Fedora 1 18th March 2008 06:00 PM
F8 : No Shutdown in menu, Login Screen is weird, Can't Shutdown only reboot megat Using Fedora 5 19th November 2007 11:00 AM
Shutdown doesn't shutdown completely, not ACPI related... MasterC Using Fedora 2 12th February 2007 06:07 PM
How to hide FC6 shutdown messages or use shutdown spash renjoyhenry Using Fedora 0 5th November 2006 05:09 AM


Current GMT-time: 09:34 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Meizhou - West Hartford - Wolcott Instagram Photos