Fedora Linux Support Community & Resources Center
  #1  
Old 9th November 2006, 07:41 PM
mikesat Offline
Registered User
 
Join Date: Nov 2006
Location: Poland
Posts: 2
Can't boot windows after hibernating FC6 - PLEASE HELP !

Hello everybody,

I give up ... I'm fighting with FC6 suspend-to-disk problem for several days - but with no success. I think it is some problem with bios .... but let's start from the beginning:

I've seen several messages on the web complaining about no option to boot anything else (like windows) after hibernating fedora core 5/6. This is because booting any other version of linux can corrupt file system. Therefere people can't suspend linux, start windows, and then later resume linux. This problem is particularly related to SWSUSP which is used on fedora core 5/6. But i'm fine with this - my problem is little different. Of course I know that SWSUSP2 solves all the problems, but as i said - my case is different.

Since first hibernation of FC6 i can't boot windows no more, even after several reboots. From the moment every time i turn on my laptop grub is automatically loading linux without giving me ability to boot windows. It looks like my machine was hibernated before, but it happens after several reboots. /etc/grub.conf file looks ok, the timeout is set to 300s:

default=0
timeout=300
splashimage=(hd0,1)/grub/splash.xpm.gz
#hiddenmenu
password --md5 $1$jpNih1$lfq3AYeZL4EmA/1uFOSuM0
title Linux (2.6.18-1.2798)
root (hd0,1)
kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00
initrd /initrd-2.6.18-1.2798.fc6.img
title Windows
rootnoverify (hd0,0)
chainloader +1



I've seen some posts saying SWSUSP suspend process change grub.conf so that you get no option to boot anything else. But after applying chattr +i attribute it wouldn't help so i think it's not the case. Currently i think it is some problem with bios. I suppose after first hibernation some bios flag was set and at present every reboot is treated as suspend resume. But how to reset this flag ? There is no option related to hibernation in my laptop CMOS settings. Do you have some idea how to solve this problem? This time google wasn't my friend Anyhow in a minute i try to reset the CMOS battery, maybe it would help - but it would be only temporary solution.

Last edited by mikesat; 9th November 2006 at 07:51 PM.
Reply With Quote
  #2  
Old 9th November 2006, 08:05 PM
leigh123linux
Guest
 
Posts: n/a
change default to 1 to get windows

default=1

#hiddenmenu
password --md5 $1$jpNih1$lfq3AYeZL4EmA/1uFOSuM0

did you set grub password

Last edited by leigh123linux; 9th November 2006 at 08:10 PM.
Reply With Quote
  #3  
Old 10th November 2006, 12:52 AM
mikesat Offline
Registered User
 
Join Date: Nov 2006
Location: Poland
Posts: 2
Quote:
Originally Posted by leigh123
change default to 1 to get windows

default=1
I know that, but it is very unconvenient have to change grub configuration every time i want to boot windows and after that change the grub configuration again (using rescue cd) to boot linux.

Quote:
Originally Posted by leigh123
#hiddenmenu
password --md5 $1$jpNih1$lfq3AYeZL4EmA/1uFOSuM0

did you set grub password
Yes, i set the password Sorry for my inattention for placing md5 password here - of course password has been changed
Reply With Quote
  #4  
Old 21st October 2007, 03:18 AM
danbui Offline
Registered User
 
Join Date: Oct 2007
Posts: 1
For Fedora Core 6 and 7, you should be able to comment out the pm-utils "01grub" file so that the power management utility script will not change grub to resume Fedora automatically upon reboot.
Search for the 01grub file with "locate 01grub".
The 01grub file should be located in /etc/pm/hooks/01grub, or /usr/lib/pm-utils/sleep.d/01grub.

You should be able to add the line "exit 0" near the top of this file to disable changing of grub by pm-utils.

After this change I can choose to boot Windows or Fedora from the grub startup screen. I don't ever share file systems between Windows and Fedora so I don't have problems with corrupted filesystems when resuming both OS'es from hibernation.
Reply With Quote
Reply

Tags
boot, fc6, hibernating, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
can you dual boot an OS while hibernating the other? DeadPark121 Using Fedora 22 30th April 2009 10:46 PM
Avoid restarting network service after hibernating yersin Servers & Networking 1 24th March 2008 10:38 AM
No information output while hibernating/waking up aleph Using Fedora 1 19th November 2007 12:43 PM
Hibernating windows & Running Fedora kbalona Using Fedora 0 24th September 2006 09:46 PM


Current GMT-time: 06:52 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
San Juan de los Lagos Travel Photos - Dillingen an der Donau Travel Photos on Instagram - Ludinghausen Travel Photos