Fedora Linux Support Community & Resources Center
  #1  
Old 7th November 2006, 05:26 PM
Whip-lash Offline
Registered User
 
Join Date: Jun 2004
Age: 32
Posts: 18
Unable to automount USB Storage after FC6 Upgrade

After upgrading from FC5 to FC6 (using yum) on my Dell Optiplex GX270, external USB storage will no longer automatically mount. So far I have tried 3 flash sticks of different makes and sizes, and 2 hard drives (1 standard 3.5" drive in an ext. enclosure, and 1 Cowon iAudio M3).

At first, I thought the issue was with FC6 itself, noting that other people were having similar issues. Then I upgraded another machine (Sony PCG-GRV550 Laptop) from FC5 to FC6, and had no problems with USB storage. It even correctly marked the iAudio as a DAP. At this point, I'm thinking it's something with HAL, since the device is being detected and listed in hal-device-manager.

Does anyone have any recommendations?
Reply With Quote
  #2  
Old 8th November 2006, 10:09 PM
Whip-lash Offline
Registered User
 
Join Date: Jun 2004
Age: 32
Posts: 18
Hmm, no takers? I'd rather not reinstall everything just to see if this fixes this problem...
Reply With Quote
  #3  
Old 8th November 2006, 10:21 PM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hello:
I believe it is a current bug?
Have you scanned through bugzilla?
http://bugzilla.redhat.com/bugzilla/

Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #4  
Old 9th November 2006, 01:56 PM
Whip-lash Offline
Registered User
 
Join Date: Jun 2004
Age: 32
Posts: 18
I have. The following Bugzilla entries appear to be related:

http://bugzilla.redhat.com/bugzilla/....cgi?id=201744
http://bugzilla.redhat.com/bugzilla/....cgi?id=214040

The first one is a user with fc6-test2, so that one is less likely to be related, though I'm watching it just in case. The second one is closer, though doesn't provide much detail.
Reply With Quote
  #5  
Old 15th November 2006, 01:54 PM
Whip-lash Offline
Registered User
 
Join Date: Jun 2004
Age: 32
Posts: 18
Red face

... Well, I think I managed to piss off someone in the #fedora channel. It wasn't my intention to badger him, or to seem uncooperative, but the thought of rebuilding the entire machine from scratch seemed to be overkill for this problem.

Oddly enough, I think the problem is resolved now. While running an rdiff-backup, I noticed a suspicious file had changed:

Code:
Processing changed file usr/share/hal/fdi/policy/gparted-disable-automount.fdi
The file had apparently been deleted after I opened gparted to verify the current disk layout. Below are the contents of the file before it was deleted (pulled from the rdiff-backup increments):

Code:
<deviceinfo version='0.2'><device><match key='@block.storage_device:storage.hotpluggable' bool='true'><merge key='volume.ignore' type='bool'>true</merge></match></device></deviceinfo>
Once the file was gone, automounting immediately started working again. I tested it on all the types I had available to me that were having the problem before, and it seems to have fixed the problem.

I had installed gparted before the upgrade to FC6. This was a fedora supplied rpm, installed via yum. My bet is something in the previous version (I'd have to rip through old logs to see which one it was) installed this policy file, for some reason unapparent to me, and running gparted with the current version (gparted-0.3.1-1.fc6) cleaned out the file.

I'm not sure if I would classify this as a bug, but I can say that I had no idea to check the /usr/share/hal/fdi/policy directory for anything. Documentation regarding hal and gnome-mount, at least via the sources I knew of (fedoraproject.org, etc.), were either sparse or non-existant.

I was literally inches away from rebuilding the entire machine for something as trivial (IMO) as this.


Now to see if I can apologize to the user on #fedora. -.-;;
Reply With Quote
  #6  
Old 16th November 2006, 12:42 PM
blobby Offline
Registered User
 
Join Date: Nov 2006
Location: Copenhagen, Denmark
Age: 33
Posts: 32
Quote:
Originally Posted by Whip-lash
... Well, I think I managed to piss off someone in the #fedora channel. It wasn't my intention to badger him, or to seem uncooperative, but the thought of rebuilding the entire machine from scratch seemed to be overkill for this problem.

Oddly enough, I think the problem is resolved now. While running an rdiff-backup, I noticed a suspicious file had changed:

Code:
Processing changed file usr/share/hal/fdi/policy/gparted-disable-automount.fdi
The file had apparently been deleted after I opened gparted to verify the current disk layout. Below are the contents of the file before it was deleted (pulled from the rdiff-backup increments):

Code:
<deviceinfo version='0.2'><device><match key='@block.storage_device:storage.hotpluggable' bool='true'><merge key='volume.ignore' type='bool'>true</merge></match></device></deviceinfo>
Once the file was gone, automounting immediately started working again. I tested it on all the types I had available to me that were having the problem before, and it seems to have fixed the problem.

I had installed gparted before the upgrade to FC6. This was a fedora supplied rpm, installed via yum. My bet is something in the previous version (I'd have to rip through old logs to see which one it was) installed this policy file, for some reason unapparent to me, and running gparted with the current version (gparted-0.3.1-1.fc6) cleaned out the file.

I'm not sure if I would classify this as a bug, but I can say that I had no idea to check the /usr/share/hal/fdi/policy directory for anything. Documentation regarding hal and gnome-mount, at least via the sources I knew of (fedoraproject.org, etc.), were either sparse or non-existant.

I was literally inches away from rebuilding the entire machine for something as trivial (IMO) as this.


Now to see if I can apologize to the user on #fedora. -.-;;
Thanks this really solved my problem.
I've been *****ing about this for about a week.
__________________
Smolt
___________________________________________

I also love KeithAndTheGirl.com
Reply With Quote
  #7  
Old 19th November 2006, 06:52 PM
JN4OldSchool Offline
"Sean The Terrible" -- The forum(er) Vista® rep
 
Join Date: Nov 2005
Posts: 8,823
Just encountered the same thing! Never used Gparted, but I like QTParted. Yesterday I installed both. GParted would never start, it kept serching for drives for 5 minutes till i shut it down. Today I go to take pics out of my camera through my card reader. No love! WTF? OK, hook up the USB. No mount but it sees the camera. Try my flash drive. Same. OK, I know I have used the pen drive recently on FC6...So a quick forum search revealed this. I pulled the file out of /usr/share/hal/fdi/policy and I'm good to go. Bumping this so all the oldtimers can take note, we will encounter this again.

Last edited by JN4OldSchool; 19th November 2006 at 06:54 PM.
Reply With Quote
  #8  
Old 26th November 2006, 06:22 PM
stuuu Offline
Registered User
 
Join Date: May 2006
Location: UK
Posts: 12
I've been putting off trying to figure this out since installing FC6 and first thing I search brings up this!
I thought it was related to my samba problem, but that seemed to be solved by just removing and then re- install samba-client.

Thanks.
Reply With Quote
  #9  
Old 23rd February 2007, 11:34 AM
gr8dude Offline
Registered User
 
Join Date: Jul 2005
Location: Moldova, Chişinău
Posts: 30
I have a similar problem, except there is no such file in that directory. Where should I dig?
__________________
he, who found a perfect woman, is a perfect man.
Reply With Quote
  #10  
Old 27th February 2007, 11:00 PM
kpearsonxyz Offline
Registered User
 
Join Date: Jul 2006
Location: Lehi, UTAH
Age: 59
Posts: 71
The mount never happens because the device isn't accepted when inserted. This started happening after I updated my PC from FC6 default respin from FedoraUnity.org 20070111. In other words, it worked fine after upgradeing from FC5 to FC6, but after a few days, quit working. Because of this, I can't sync my handheld, or use it as a memory stick, or use any memory sticks/flash drives, or an external USB hard disk.

Here's what I get in /var/log/messages when I plug in any USB device, other than my mouse, which works fine. Hmmm.. It's a 'low speed device':

Feb 27 15:43:19 lehi kernel: usb 4-6: new high speed USB device using ehci_hcd and address 39
Feb 27 15:43:19 lehi kernel: usb 4-6: device descriptor read/64, error -32
Feb 27 15:43:20 lehi kernel: usb 4-6: device descriptor read/64, error -32
Feb 27 15:43:20 lehi kernel: usb 4-6: new high speed USB device using ehci_hcd and address 40
Feb 27 15:43:20 lehi kernel: usb 4-6: device descriptor read/64, error -32
Feb 27 15:43:21 lehi kernel: hub 4-0:1.0: Cannot enable port 6. Maybe the USB cable is bad?
Feb 27 15:43:21 lehi kernel: usb 4-6: new high speed USB device using ehci_hcd and address 41
Feb 27 15:43:21 lehi kernel: usb 4-6: device not accepting address 41, error -32
Feb 27 15:43:21 lehi kernel: usb 4-6: new high speed USB device using ehci_hcd and address 42
Feb 27 15:43:22 lehi kernel: usb 4-6: device not accepting address 42, error -32

I'm not sure where to look as the fdi issues above don't apply. I've never put gpartd, or any other partition manipulation software on this desktop PC.

TIA,
__________________
KpearsonXYZ
Registered Linux User 424918
(15 years on Linux before registering
No registered machines; too lazy to count)
Reply With Quote
  #11  
Old 9th March 2007, 06:24 PM
mnisay Offline
Registered User
 
Join Date: May 2005
Location: PH
Posts: 696
this does not solve mine
Reply With Quote
  #12  
Old 14th March 2007, 04:04 PM
feniks Offline
Registered User
 
Join Date: Feb 2007
Location: NJ-NY, USA
Age: 35
Posts: 16
Question

Hi,

I think that usb disks automount doesn't work in my FC6 (using Unity respin 20070111).
I cannot find the device letter for my external USB hdd, however it seems to be accepted by the kernel, found this in log:
Mar 14 10:48:20 intel-03 kernel: usb 4-1: new full speed USB device using uhci_hcd and address 3
Mar 14 10:48:20 intel-03 kernel: usb 4-1: configuration #1 chosen from 1 choice

what is conf #1?

but after that nothing happens, tried using dpmesg but only disk listed are my 2 SATA hard drives, no sign of usb disk. at this point I cannot mount that disk manually since I do not know the id of it (sda and sdb are my internal SATA drives). any ideas how to fix it?

Just please keep in mind that I am still a newbie to linux systems. This is the first time I play with Linux longer than a few days had some exp with linux distros in the past but didn't like them. FC6 seems to be the first one I really like

EDIT:
Looking in /dev/disk/by-id/ does not show any usb disk. I see only 2 internal sata drives. can someone tell me what's wrong with automounting USB disks?
I use FC6 with all updates as of mid February. Unfortunately since I started using KDE instead of gnome the System Updates no longer pops up. Let me install all latest updates and post here, perhaps updates solve the problem.

sorry for the mess.

Last edited by feniks; 14th March 2007 at 04:27 PM. Reason: my bad, needed to re-edit message
Reply With Quote
  #13  
Old 15th March 2007, 07:53 AM
mnisay Offline
Registered User
 
Join Date: May 2005
Location: PH
Posts: 696
what does

#lsusb

says?

usually, /dev/usb1 needs to be mounted. i still cant figure out how to automount it under FC6 though i am still searching google for more. others said i have to delete a file from /usr/share/... but it doesnt work. i remember this was working before with FC2 and FC4, as well as the latest CentOS with my farms. dont know any reason why it should not be working as an automatic mounting feature either from nautilus.

waiting for more.
Reply With Quote
  #14  
Old 15th March 2007, 03:45 PM
feniks Offline
Registered User
 
Join Date: Feb 2007
Location: NJ-NY, USA
Age: 35
Posts: 16
I updated my FC6 box to the latest kernel and updates as of yesterday. USB flash disk now automounts with no problems (an icon appears on KDE desktop). however 500GB USB external HDD from Western Digital still cannot mount properly. the command:
tail -f /var/log/messages
show proper recognition of the device and than there is an error with device descriptor and device is being assigned with different usb address and then there's another error, etc.
result is that the USB HDD cannot be mounted at all neither automatically nor manually.
didn't have time yet to test it with different external HDD or the same HDD on different FC6 box. will let know soon.

Last edited by feniks; 15th March 2007 at 03:46 PM. Reason: typos
Reply With Quote
  #15  
Old 17th March 2007, 06:21 AM
werewolf6851 Offline
Registered User
 
Join Date: Mar 2007
Posts: 5
I found the following steps a pain, makes so I can mount the USB devices
su -c "/sbin/service messagebus restart;/sbin/service haldaemon restart"
gnome-mount -d /dev/sda1
note, if login runtime 2, do the above, then startx, will get an icon on the desktop for the usb device

also had problems mounting the cdrom, but adding my user name on the line as the group disk in /etc/group was able to mount it via gnome-mount -d /dev/hdc (my cdrom is and ide in laptop)
but I get the following info when i do
libhal-storage.c 1401 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was not set.
but still reads just fine

I did something that made auto mount work one time but not figured out what it was, and can't get smtp port open yet so I can use fetchmail

Mark Keith
Reply With Quote
Reply

Tags
automount, fc6, storage, unable, upgrade, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boots into TTY1 and won't automount Mass storage Device barf Using Fedora 2 29th June 2009 10:08 PM
Unable to automount USB Storage after Fedora 10 Upgrade tsangcn Hardware & Laptops 17 5th April 2009 02:55 PM
FC8 automount crashes after upgrade from fc7 spribyl Using Fedora 0 2nd July 2008 04:11 PM
Ipod will not automount after upgrade to Fedora 7 nitroblast Hardware & Laptops 7 24th July 2007 10:20 PM


Current GMT-time: 18:11 (Sunday, 21-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat