Fedora Linux Support Community & Resources Center
  #1  
Old 30th October 2006, 05:02 PM
pressesctoquit Offline
Registered User
 
Join Date: Oct 2006
Posts: 27
enabling desktop effects

Hi all, having a problem enabling destop effects on Fedora Core 6, when I try to, "desktop efects could not be enabled" pops up. Anything I can do, commands that need to be entered in terminal or something, noob to linux so realy lost
Reply With Quote
  #2  
Old 30th October 2006, 05:11 PM
Vapour Offline
Registered User
 
Join Date: Oct 2006
Posts: 9
Update your video driver. Make sure it supports 3d

Run the following:
# glxinfo | grep -i direct
__________________
------
Vapour RHCE, VCP
1. HP nc6400, Fedora Core 6, 99.4% MS tax free
2. AMD Athlon 64, Fedora Core 6, 100% MS tax free

Linux User #424690
Reply With Quote
  #3  
Old 30th October 2006, 05:16 PM
pressesctoquit Offline
Registered User
 
Join Date: Oct 2006
Posts: 27
what do you mean run? long time windows user so spell it out....
Reply With Quote
  #4  
Old 30th October 2006, 05:20 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
what I did was install freshrpms-release from....

http://ftp.freshrpms.net/pub/freshrp....fc.noarch.rpm


then did....

yum install nvidia-x11-drv

then rebooted

then I added to my xorg.conf.....

Section "Module"
Load "glx"
Load "dri"
Load "extmod" <------- this
EndSection

and

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "UseEDID" "FALSE"
Option "AddARGBGLXVisuals" "TRUE" <---- this
EndSection

then restart X, and type desktop-effects at the prompt, hey presto

but I am using an nvidia card, and you must have a 3d graphics card
Reply With Quote
  #5  
Old 30th October 2006, 05:30 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
Oh and just to add, before doing this I had some random desktop crashes were all my window decorations would disapere and a crash handler thing would pop up, but now it seems more stable with desktop effects on
Reply With Quote
  #6  
Old 30th October 2006, 05:30 PM
pressesctoquit Offline
Registered User
 
Join Date: Oct 2006
Posts: 27
ok, well im still a little confused, I did click an install you link, but I have an ATi card so how do I yum install something? Alos cannot make out all the text and stuff you have down at the bottom there,
i.e
Quote:
then I added to my xorg.conf
how do you do that?
Reply With Quote
  #7  
Old 30th October 2006, 05:35 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
oh sorry, I dont know about ATi cards, but I'm sure theres something on this forum about it

to edit your xorg.conf you can do it a number of ways really, first you need to be root to edit this file

then me personaly in a root console I use...

bash# vi /etc/X11/xorg.conf

but some people dont like vi, so you could goto a root console and type....

bash# gedit /etc/X11/xorg.conf
or
bash# kedit /etc/X11/xorg.conf

whichever desktop you use

once looking at the xorg.conf file you should recognise the stuff I put up there, and the relevant information
Reply With Quote
  #8  
Old 30th October 2006, 05:48 PM
r1348 Offline
Registered User
 
Join Date: Jun 2005
Location: Milan, Italy
Age: 30
Posts: 337
Which ATI card do you own?
Desktop effectsare available only on cards up to Radeon 9250, using the open source driver.
Higher cards doesn't have DRI support out of the box and should use the proprietary ATI driver for hardware acceleration, that currently doesn't support AIGLX.
__________________
Laptop (Compal JFL92)
Reply With Quote
  #9  
Old 30th October 2006, 05:52 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
and I'v just noticed if you do use the frshrpms repos then they do have ati drivers there

just....

yum install ati-x11-drv

instead of nvidia-x11-drv
Reply With Quote
  #10  
Old 30th October 2006, 05:54 PM
pressesctoquit Offline
Registered User
 
Join Date: Oct 2006
Posts: 27
Radeon X1600PRO
Reply With Quote
  #11  
Old 30th October 2006, 06:14 PM
pressesctoquit Offline
Registered User
 
Join Date: Oct 2006
Posts: 27
ok did add those lines you gave me before and ran yum install ati-x11-drv, how do I restart x now?
Reply With Quote
  #12  
Old 30th October 2006, 06:17 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
to restart X you just have to log out, and it will restart X before going back to the login screen

BUT....

I'm not sure if the instruction above are relevant for ATi cards, did you search for ATi stuff on this forum???

I'm not sure if Option "AddARGBGLXVisuals" "TRUE" works on ATi driver, you'll have to search about
Reply With Quote
  #13  
Old 30th October 2006, 06:22 PM
pressesctoquit Offline
Registered User
 
Join Date: Oct 2006
Posts: 27
ok, havent restarted yet, havent got the slightest idea on what to search for since I have no idea what that line means
Reply With Quote
  #14  
Old 30th October 2006, 06:24 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
you wanna search for instructions on getting desktop-effects working with ATi cards, as the instructions I put up there are for nvidia cards

sorry I probably shouldn't have jumped in and give those instructions without first finding out what card you had

infact ignor everything I put up there and maybe someone else can give instructions for your case

sorry
Reply With Quote
  #15  
Old 30th October 2006, 09:19 PM
garymayor Offline
Registered User
 
Join Date: Nov 2004
Posts: 52
Follow the tutorial here worked a treat for me
http://lunapark6.com/?p=2454
Reply With Quote
Reply

Tags
desktop, effects, enabling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kde not working after enabling desktop effects phoebetor Using Fedora 1 10th September 2008 07:52 PM
Help with enabling Desktop effects on fedora 6 ryb37 Installation, Upgrades and Live Media 1 23rd January 2008 02:39 AM
Desktop Effects not enabling, wrongopinions Hardware & Laptops 2 4th June 2007 11:06 PM
Enabling Desktop Effects jamillikan Using Fedora 1 2nd January 2007 09:15 PM
Problems enabling desktop effects OOOOO Using Fedora 1 1st December 2006 01:46 PM


Current GMT-time: 07:06 (Wednesday, 03-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat