Fedora Linux Support Community & Resources Center
  #1  
Old 25th October 2006, 11:40 PM
earthwormgaz Offline
Registered User
 
Join Date: Sep 2006
Posts: 51
Nvidia + Aiglx + Fc6

Okay, I got this working, nobody else needs to suffer!

Right, bag the nvidia beta drivers from here:

http://rpm.livna.org/fedora/testing/6/i386/

Now, I am told that Xorg 7.1 autoloads Modules, so you don't need an Xorg Module section anymore. So, comment it out (the RPMs will put it in for you annoyingly).

vim /etc/X11/xorg.conf

Make it read as follows to comment it out:

#Section "Module"
# Load "glx"
#EndSection

And, add the following line to the section marked "Device":

Option "AddARGBGLXVisuals" "True"

Now, every time you bloody reboot, the livna RPM has installed a tool that will put the damn Module section back in. So, do the following:

vim /usr/sbin/nvidia-config-display

And I added "#" at the start of these lines to comment them out, it seems to work:

# Create an empty modules section
#if xconfig.modules == None:
#xconfig.modules = xf86config.XF86ConfModule()

And these lines as well:

#removeModule(xconfig.modules, "dri")
#removeModule(xconfig.modules, "GLcore")
#addModule(xconfig.modules, "glx")

Now, reboot and choose "System > Preferences > Desktop Effects" and turn the wobbley ****e on! W00t!

Last edited by earthwormgaz; 26th October 2006 at 03:13 PM.
Reply With Quote
  #2  
Old 25th October 2006, 11:47 PM
earthwormgaz Offline
Registered User
 
Join Date: Sep 2006
Posts: 51
ARGH! You also need to add the following to xorg.conf in the Device section!!!!

Option "AddARGBGLXVisuals" "True"
Reply With Quote
  #3  
Old 26th October 2006, 03:19 AM
iamroot Offline
Registered User
 
Join Date: Jun 2005
Location: Singapore
Posts: 1,039
Thanks for the instructions. I'll be trying them out later.
Reply With Quote
  #4  
Old 26th October 2006, 02:54 PM
germanomichel Offline
Registered User
 
Join Date: Oct 2006
Posts: 1
Quote:
Originally Posted by earthwormgaz
Okay, I got this working, nobody else needs to suffer!

Right, bag the nvidia beta drivers from here:

http://rpm.livna.org/fedora/testing/6/i386/

Now, I am told that Xorg 7.1 autoloads Modules, so you don't need an Xorg Module section anymore. So, comment it out (the RPMs will put it in for you annoyingly).

vim /etc/X11/xorg.conf

Make it read as follows to comment it out:

#Section "Module"
# Load "glx"
#EndSection

Now, every time yoy bloody reboot, the livna RPM has installed a tool that will put the damn Module section back in. So, do the following:

vim /usr/sbin/nvidia-config-display

And I added "#" at the start of these lines to comment them out, it seems to work:

# Create an empty modules section
#if xconfig.modules == None:
#xconfig.modules = xf86config.XF86ConfModule()

And these lines as well:

#removeModule(xconfig.modules, "dri")
#removeModule(xconfig.modules, "GLcore")
#addModule(xconfig.modules, "glx")

Now, reboot and choose "System > Preferences > Desktop Effects" and turn the wobbley ****e on! W00t!

Thank you!!!!

I have just installed the 9626 X86_64 Drivers from livna.org. Followed your instructions and... DONE!!! Working!!! Nothing else required. Pretty cool.

Thx
Reply With Quote
  #5  
Old 26th October 2006, 03:16 PM
freeker Offline
Registered User
 
Join Date: Oct 2006
Posts: 1
Thumbs up

your guide works fine. Big THX

itś also possible to install these drivers with
yum --enablerepo=livna-testing update kmod-nvidia
or
yum --enablerepo=livna-testing install kmod-nvidia
Reply With Quote
  #6  
Old 27th October 2006, 10:39 PM
Peanut-Butter Offline
Registered User
 
Join Date: Oct 2004
Posts: 3
Thank you! Your guide worked for me
Reply With Quote
  #7  
Old 1st November 2006, 01:32 AM
sparks40 Offline
Registered User
 
Join Date: Aug 2006
Posts: 59
"your guide works fine. Big THX

itś also possible to install these drivers with
yum --enablerepo=livna-testing update kmod-nvidia
or
yum --enablerepo=livna-testing install kmod-nvidia"

Does this mean that all of the steps mentioned prior to this one are not really necessary, (i.e. commenting and editing the xorg file)?
Reply With Quote
  #8  
Old 1st November 2006, 03:40 AM
j_baer Offline
Registered User
 
Join Date: Nov 2004
Location: Lansing, MI
Age: 61
Posts: 104
I must be missing something

On a fresh install of FC6 I can not get the nvidia drivers to install.

All I get is a dependcy error ....

Reply With Quote
  #9  
Old 1st November 2006, 03:48 AM
scotta3234 Offline
Registered User
 
Join Date: Sep 2005
Location: Fairfax, VA
Posts: 1,280
It's due to a bug in Anaconda. Try specifying the .i586 and it should work.
Code:
yum --enablerepo=livna-testing install kmod-nvidia.i586
Reply With Quote
  #10  
Old 1st November 2006, 03:58 AM
sparks40 Offline
Registered User
 
Join Date: Aug 2006
Posts: 59
Hi scotta3234.

Is this the only line of code necessary to install the nvidia drivers in FC6?

# yum --enablerepo=livna-testing install kmod-nvidia.i586


I'm using an Asus M2N-MX MB with an onboard nVidia Geforce 6100 GPU.

TNX
Reply With Quote
  #11  
Old 1st November 2006, 04:03 AM
scotta3234 Offline
Registered User
 
Join Date: Sep 2005
Location: Fairfax, VA
Posts: 1,280
Yes, that code should get you the proper beta livna nvidia drivers needed to run AIGLX. You will also have to edit your xorg.conf.
Reply With Quote
  #12  
Old 7th November 2006, 04:32 PM
Serdar Offline
Registered User
 
Join Date: Aug 2005
Posts: 23
How can I find out if .i586 or .i686 installed on my system. When i run uname -m it gives me .i686 but since I can't install the nvidia drivers now I am not sure If it is the right way to check it.

-s
__________________
sa
Reply With Quote
Reply

Tags
aiglx, fc6, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AIGLX, nVidia and KDE Jongi Using Fedora 3 23rd October 2006 10:06 AM


Current GMT-time: 08:15 (Monday, 24-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Ilawa Photos on Instagram - Jamay - Matola Travel Photos on Instagram