Fedora Linux Support Community & Resources Center
  #1  
Old 12th October 2006, 09:03 AM
zl2k Offline
Registered User
 
Join Date: May 2005
Posts: 41
help! nvidia geforce 6200 on fc3 glx missing

hi, there
I just replace the nvidia geforce 4 with a nvidia geforce 6200 on my fc3 box. I installed the NVIDIA-Linux-x86-1.0-8774-pkg1.run and updated all the packages.
I also did
Code:
yum install nvidia-glx kernel-module-nvidia-`(uname -r)`
Here is what I got:
Code:
glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 16 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 16 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
The xorg.conf is like
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Tue Aug  1 21:11:12 PDT 2006
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	ModulePath   "/usr/X11R6/lib/modules/extensions/nvidia"
	ModulePath   "/usr/X11R6/lib/modules"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "DELL 1704FPT"
	DisplaySize  340	270
	HorizSync    30.0 - 81.0
	VertRefresh  56.0 - 76.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection
How can I solve the problem so that I can use direct rendering in fc3? Does the geforce 6200 support dri in fc3? Thanks for help.

zl2k

Last edited by zl2k; 12th October 2006 at 09:06 AM.
Reply With Quote
  #2  
Old 12th October 2006, 10:18 AM
wwagner Offline
Registered User
 
Join Date: Oct 2006
Location: sw Germany
Posts: 95
Your xorg.conf file is incomplete. I think in modules part should be the "nvidia" driver included.

Something went wrong...

Try configure your graphic card using system-config tool and see if you can select "nvidia" driver.
Reply With Quote
  #3  
Old 12th October 2006, 02:36 PM
zl2k Offline
Registered User
 
Join Date: May 2005
Posts: 41
I think the xorg.conf is complete.

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce"
EndSection
Reply With Quote
  #4  
Old 12th October 2006, 07:17 PM
wwagner Offline
Registered User
 
Join Date: Oct 2006
Location: sw Germany
Posts: 95
Sorry, I had no reference system. You are right.

I have almost the same xorg.conf file. (almost same monitor, nvidia GeForce 6800) Differences are in the Files section:

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
FontPath "unix/:7100"
EndSection

I think you have checked the path already?!

Please compare. I have

yum list installed | grep nvidia
mod-nvidia.i686 1.0.8774-1.2.6.17_1.21
xorg-x11-drv-nvidia.i386 1.0.8774-1.lvn5

installed.
Before I have tried to use the other packages and had also some problems. As longer as I think about eveything, that must be your problem...

Try this first!

Hope you succeed!
Reply With Quote
Reply

Tags
6200, fc3, geforce, glx, missing, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i load Nvidia drivers for a Geforce 6200 vid card? tigerhead Using Fedora 6 7th July 2009 08:01 AM
Geforce 6200 TC + Nvidia Driver = Multi Coloured Lined Console Jygar Hardware & Laptops 0 28th January 2007 02:43 PM
Problem with NVidia Geforce 6200 TC resolution nigel_c Installation, Upgrades and Live Media 3 6th January 2007 06:43 AM
FC 4 and geforce 6200 vivek_nz76 Installation, Upgrades and Live Media 0 14th January 2006 10:28 PM
can not test openGL support for nvidia geforce 6200 lnthai2002 Hardware & Laptops 2 15th August 2005 03:09 PM


Current GMT-time: 14:35 (Wednesday, 20-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat