Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (Not For Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (Not For Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 8th October 2006, 07:52 AM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Post Atheros Chipset Based Cards + MadWifi Installation & Usage (T60 and Z60 MUST read)

A little intro behind this HOW TO, and the extra info I talk about below is very useful especially to Thinkpad owners, so if you don't feel like reading it just jump to the Instructions part below.

Intro

The reason why I am writing this HOW TO is that my laptop which is an IBM Thinkpad (OK a Lenovo but that doesn't sound as cool ) T60 (1953-D7U) came with an Intel 3945ABG card, which I thought was OK, however the awful performance and support of this card under Linux (even though it has a crappy unofficial support from Intel) made me sick I just couldn't take it anymore.
Well someone would say "Mini-PCI cards are plenty and cheap what would be the big deal, just switch to something fully supported under Linux, like Atheros, RALINK or a CISCO Aironet ?"
Well those are nice options, TBH I would jump on a CISCO Aironet purchase had that been an option since those cards are supported under Linux straight out of the box, HOWEVER one main problem exists here, my laptop is T60 Thinkpad, what does that mean ?
Well, 2 problems :

1- New Thinkpads don't utilize mini-PCI slots, they use the newer technology mini-PCI Express. Since this is the most recent technology, in the world of laptops this means that it would take a bit of time before third party parts vendors will lay their hands on it. So I researched my options in online stores and all I found were highly priced Intel cards that would do me nothing. Then suddenly I looked up Atheros website and found out that they have this product, the AR5006EX.
Well I started jumping around from happiness, until I remembered one sad fact! read -2

2- Lenovo Laptops have something called "Electronic Handshake". What does that mean, you say, well in simple terms, if I buy the Atheros AR5006EX mini-PCI Express card which is a non Lenovo certified card, the T60 would switch from cool mode to b!tchy-girlfriend mode and basically bug the hell out of me with error messages about the card until I remove it. A sad fact about my Thinkpad laptops, but I was so sick of the Intel card that I was willing to look up a way to bypass that issue. Actually there is a solution, however it was something that would void my warranty that I have paid for and it would require tinkering with the BIOS and that isn't my favorite area to make mistakes in .

So I was back at square one . I decided not to give up, I researched some more, then on ThinkWiki.org I read the following page
Yay I was saved I have seen that same card so many times on the Lenovo website but it never occurred to me that Lenovo actually offers an Atheros based mini-PCI Express card.
The site mentions absolutely nothing about Atheros, I don't know why but they just call it

ThinkPad 11a/b/g Wireless LAN Mini-PCI Express Adapter
. I took my credit card out of my wallet and ordered it form Lenovo's website faster than you can say Atheros!!

Well I later received an email from Lenovo telling me that it will take 20 days for me to receive my card, ARRRGGHH!!! I calmed down and looked up the IBM Model Name 40Y7026 on Google and for my surprise they have it
Now as much as I hate Best Buy but come on they have what I wanted for the same price as Lenovo and they will ship immediately so I went for it and canceled my Lenovo order.
I chose Ground shipping, still it arrived in 2 days yesterday, I was thrilled as I opened up my beloved Thinkpad's guts and took that crappy Intel 3945 ABG along with Intel's Centrino marketing BS and installed a real wi-fi card in

This was my first experience with an Atheros card so it took me a little bit to understand how the madwifi drivers function and what's HAL and OpenHAL and all that good stuff
Now enough talk and let's move on to the Instructions

Last edited by Tuxic; 28th November 2006 at 11:05 AM.
Reply With Quote
  #2  
Old 8th October 2006, 07:53 AM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Post Instructions

Fedora 8:
From this point forward if a command starts with a $ this means you can execute it without being root, and if a command starts with a # then you will need to become root before you execute it.


After upgrading to Fedora 8, I was facing issues that I didn't in Fedora 7 or prior Fedora releases.
After investigating it properly it turned out that the culprit is in fact has to do with Atheros card's auto detect speed functionality amongst something else.

- Make sure your system is up to date! As root do the following :
Code:
# yum update
We will need kernel source RPMS installed so do the following:
Code:
# yum install kernel-devel

All that is required to take care of this issue in Fedora 8 is adding as root the following line to /etc/modprobe.conf:

Code:
# gedit /etc/modprobe.conf
Add what's below:
Code:
 
install ath_pci /sbin/modprobe --ignore-install ath_pci; /sbin/iwpriv ath0 mode 3
options ath_pci autocreate=sta
alias ath0 ath_pci
However the built in module for atheros , ath5k conflicts with the to be installed modules, so make sure to add the following line to /etc/modprobe.conf too:

Code:
blacklist ath5k
Eventually, the section of /etc/modprobe.conf relating to the Atheros stuff will end up looking as follows:

Code:
#Atheros wireless configurations
blacklist ath5k
install ath_pci /sbin/modprobe --ignore-install ath_pci; /sbin/iwpriv ath0 mode 3
options ath_pci autocreate=sta
alias ath0 ath_pci
Make sure to save and exit.

Now from here almost all approaches ought to work, you can either compile madwifi / madwifi-ng drivers and install them OR you can get madwifi rpms from Livna (or maybe elsewhere) and install those too, these options ought to work. However, even though both approaches have worked for me I compile and use the madwifi-ng drivers myself, but I suggest you give madwifi RPMS from Livna a shot first, those should work, otherwise go for the compilation and installation.

To Obtain and Install Livna madwifi RPMS:

1- Go Here for 64-bit systems or Here for 32-bit systems

2- Download the following:
kmod-madwifi
madwifi

What I tested on my 64-bit systemI was using the following package versions:

kmod-madwifi-2.6.23.1-42.fc8-0.9.3.3-9.lvn8.x86_64
madwifi-0.9.3.3-1.lvn8.x86_64

on a 32-bit system those would be:


kmod-madwifi-2.6.23.1-42.fc8-0.9.3.3-9.lvn8.i386
madwifi-0.9.3.3-1.lvn8.i386

Just go for the latest versions of the madwifi / kmod-madwifi packages you can get from Livna at the time you are doing this.

After downloading to the directory where the RPMS from Livna have been downloaded, navigate to the directory where you have downloaded the packages then install by either clicking them or via terminal:

As root:
Code:
#yum localinstall kmod-madwifi-0.9.3.3-10.lvn8.x86_64.rpm madwifi-0.9.3.3-1.lvn8.x86_64.rpm
That should be it for Fedora 8!

For best results do a reboot and things should be fine, however if you are having no luck with getting the RPMS to work from Livna and or other places, follow the "Fedora 7 or below" procedures however KEEP the /etc/modprobe.conf file as it is in the Fedora 8 section!

Fedora 7 or below:

Obtaining the files : We all know madwifi RPMS are available from Livna.org and ATRPMS, however I didn't personally obtain any positive results from them under Fedora 7 so I removed all the madwifi RPMS and went for the real stuff, the tar balls.

1 - Make sure your system is up to date as root do the following :
Code:
yum update
We will need kernel source RPMS installed so do the following:
Code:
yum install kernel-devel
This command is not applicable to Fedora Core 6 or later, as there is no seperate SMP Kernel that is installable from the repo
In case you like me have an SMP kernel installed then do the following:
Code:
yum install kernel-smp-devel
Not required for Fedora 7 according to my tests
Also we need to use yum in order to install another package we will be needing :
Code:
yum install sharutils
Then we head over to MadWiFi's sourceforge.net page and download the latest tar ball and save it in your home directory.

2 -
Note that I recommend using the madwifi-ng drivers which I mention at the bottom in case you apply all the steps correctly and still can't get your card to work right.

In this guide I am using the following version of madwifi : madwifi-0.9.2.tar.gz
So if you are trying to apply these instructions with a newer tar-ball just replace the newer version's name instead of what I have here. From this point forward if a command starts with a $ this means you can execute it without being root, and if a command starts with a # then you will need to become root before you execute it.

* 3
- Navigate to your home directory :
Code:
cd /home/YOUR-USERNAME
- Extract the content of the tar ball :
Code:
$ tar -xzvf madwifi-0.9.2.tar.gz
Some output will scroll down your terminal.
Code:
$ cd madwifi-0.9.2
Code:
$ cd scripts/
now we need to do some prep before starting things up execute the following scripts in order using these 2 commands (this will help you out a lot in case you were messing around with madwifi drivers before):
Code:
# ./madwifi-unload.bash
Code:
# ./find-madwifi-modules.sh /
Make sure to select the "remove" option once prompted, by simply typing r then Enter.

*4
After preparing the surgery room for the operation we now need to build the madwifi drivers from source.
Lets go up a directory :
Code:
cd ..
build the drivers :
Code:
$ make
OR

If you have a dual core system you can use the following command instead to speed things up a bit for geeknes sake!
Code:
make -j2
Now install the drivers (remember # means root)
Code:
# make install
OR
Again for dual core machines
Code:
make -j2 install
---------------------------------
TIP:
If you are one of them lucky boys to have more than 2 cores on your system, then you just make the number of cores as part of the argument for make!
So since I am geek enough to have two quad-cores on my desktop, I can for example do this:

Code:
make -j8
Followed by a :

Code:
make -j8 install
This is such a small compilation that you might NOT notice a big difference, however when you are compiling an app as big as Firefox or what not, cutting the time by 8 is a BIG advantage. SO just thought you guys might find this useful

---------------------------------


*5 If you reached this step without errors, then getting your card to work might not be too far away
Now we need to create an entry in /etc/modprobe.conf for our new device, so lets as root add the following lines to /etc/modprobe.conf using your favorite text editor as root :

Code:
# gedit /etc/modprobe.conf
Then add the following contents in:

Code:
alias ath0 ath_pci
options ath_pci autocreate=sta
alias wifi0 ath_pci
Now save the changes to the file and close it then restart your system.

Happy Browsing
Tuxic

Last edited by Tuxic; 18th February 2008 at 04:19 AM.
Reply With Quote
  #3  
Old 9th October 2006, 09:08 AM
freshmeat Offline
Registered User
 
Join Date: May 2005
Age: 35
Posts: 137
my laptop i s built in wireless device, Atheros AR5600X. Does it ur guide help too?
__________________
Catch me if u can... ;)
Reply With Quote
  #4  
Old 9th October 2006, 02:33 PM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Quote:
Originally Posted by freshmeat
my laptop i s built in wireless device, Atheros AR5600X. Does it ur guide help too?
So is my Atheros in my laptop, yes it should work for your AR5006EX too as your laptop has almost the same chipset as mine.


Tuxic
Reply With Quote
  #5  
Old 10th October 2006, 03:59 AM
freshmeat Offline
Registered User
 
Join Date: May 2005
Age: 35
Posts: 137
Mine one is not AR5006EX, but is AR5006X.

I have a question about this script:

alias ath0 ath_pci
options ath_pci autocreate=sta
alias wifi0 ath_pci

how can i configure this??
my ath0 is a LAN, then how about my wireless adapter? what should i put?
__________________
Catch me if u can... ;)
Reply With Quote
  #6  
Old 10th October 2006, 04:07 AM
scotta3234 Offline
Registered User
 
Join Date: Sep 2005
Location: Fairfax, VA
Posts: 1,280
Excellent how-to. Although, I'd be very sad if I had to do all of what you mentioned above. I have an Atheros based pci card in my desktop and I just installed the rpm via yum(yes i see you mentioned that) and changed my modprobe.conf. I'm sure that with all the configurations out there the rpms wont always work. I can't tell you how many Madwifi posts I've responded to. Now people can use the tarballs and follow your how-to and it should definitely work.
Reply With Quote
  #7  
Old 10th October 2006, 04:13 AM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Quote:
Originally Posted by freshmeat
Mine one is not AR5006EX, but is AR5006X.

I have a question about this script:

alias ath0 ath_pci
options ath_pci autocreate=sta
alias wifi0 ath_pci

how can i configure this??
my ath0 is a LAN, then how about my wireless adapter? what should i put?
That's an easy one.
Go to system-config-network and delete any thing other than your ethernet in there like (ath0 and so on).

Then as mentioned in the how to, open the /etc/modprobe.conf with your favorite text editor and then add the following lines to the end of the file :

Code:
alias ath0 ath_pci
options ath_pci autocreate=sta
alias wifi0 ath_pci
Save the file then reboot your system, then start system-config-network again, then add a new wireless device from there you should be able to see the atheros card in the wireless list.
Finally use the atheros card with your favorite wifi manager (such as wlassistant) and you should be set.

Tuxic
Reply With Quote
  #8  
Old 10th October 2006, 04:15 AM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Quote:
Originally Posted by scotta3234
Excellent how-to. Although, I'd be very sad if I had to do all of what you mentioned above. I have an Atheros based pci card in my desktop and I just installed the rpm via yum(yes i see you mentioned that) and changed my modprobe.conf. I'm sure that with all the configurations out there the rpms wont always work. I can't tell you how many Madwifi posts I've responded to. Now people can use the tarballs and follow your how-to and it should definitely work.
Thanks for the feedback, I hope this how-to isn't too hard for the newcomers and all.

Tuxic
Reply With Quote
  #9  
Old 10th October 2006, 01:43 PM
freshmeat Offline
Registered User
 
Join Date: May 2005
Age: 35
Posts: 137
it seems i found a driver for my wireless adapter. i try to connect to wireless netowork, but it disappointed me again. i can't activate the device from the network administration. i tried to yum install wlassistant, it could search the wireless netowork but it couldn't connect. what should i do next?
__________________
Catch me if u can... ;)
Reply With Quote
  #10  
Old 10th October 2006, 05:34 PM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Quote:
Originally Posted by freshmeat
it seems i found a driver for my wireless adapter. i try to connect to wireless netowork, but it disappointed me again. i can't activate the device from the network administration. i tried to yum install wlassistant, it could search the wireless netowork but it couldn't connect. what should i do next?
Check the following first :

Is your network using WEP (64 or 128 bit) encryption ?
Are you putting the right info in wlassistant (WEP Key, SSID, ...etc)
Are you broadcasting your SSID from the router ?
Are you trying to use more IP Addresses than what your router is setup to handle ?
Is the DHCP service enabled on your router ?
If all fails, can you at least connect with a static IP (as I did in the script I wrote in the how-to) ?
Can you test your router with a different card or system or OS ?

Try the above stuff and get back to me with what you get.
Tuxic
Reply With Quote
  #11  
Old 14th October 2006, 12:00 AM
Round11 Offline
Registered User
 
Join Date: Oct 2006
Posts: 2
I'm having a slight issue with the HOWTO. Not sure what to do in order to fix it either, since I'm a Fedora newb....

Code:
build the drivers :

Code:
$ make
On the above step, I get:
Code:
/bin/sh: cc: command not found
Checking requirements... ok.
Checking kernel configuration... FAILED
Only kernel versions 2.4.x and above are supported.
You have .
make: *** [configcheck] Error 1
Here's my kernel:
Code:
Linux localhost.localdomain 2.6.17-1.2187_FC5 #1 Mon Sep 11 01:17:06 EDT 2006 i686 i686 i386 GNU/Linux
Any ideas?

Last edited by Round11; 14th October 2006 at 12:03 AM. Reason: Added uname -a
Reply With Quote
  #12  
Old 14th October 2006, 11:37 AM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Quote:
Originally Posted by Round11
I'm having a slight issue with the HOWTO. Not sure what to do in order to fix it either, since I'm a Fedora newb....

Code:
build the drivers :

Code:
$ make
On the above step, I get:
Code:
/bin/sh: cc: command not found
Checking requirements... ok.
Checking kernel configuration... FAILED
Only kernel versions 2.4.x and above are supported.
You have .
make: *** [configcheck] Error 1
Here's my kernel:
Code:
Linux localhost.localdomain 2.6.17-1.2187_FC5 #1 Mon Sep 11 01:17:06 EDT 2006 i686 i686 i386 GNU/Linux
Any ideas?
OK, looks like an easy fix, just to make sure what to tell you to do next, do the following and get back to me with output :

Code:
rpm -qa| grep gcc
then
Code:
rpm -qa| grep kernel
Tuxic

Last edited by Tuxic; 14th October 2006 at 11:40 AM.
Reply With Quote
  #13  
Old 27th October 2006, 11:25 PM
barnys Offline
Registered User
 
Join Date: Sep 2006
Posts: 8
Hello,

I have a Thinkpad T42 with an atheros running FC 6 (general release from 10/24) and I just can't get "IT" to install.
I installed the *rpm from http://zod.freshrpms.net/rpm.html?id=299 but I don't know what to do next and my card is unrecognized thought the rpm was installed.
Then I tried going to /usr/src//madwifi-0.9.2-2.fc6/ and did make and got the following:

[root@FC6 madwifi-0.9.2-2.fc6]# make
/bin/sh: line 0: cd: /lib/modules/2.6.18-1.2798.fc6/build: No such file or directory
Makefile.inc:89: *** /lib/modules/2.6.18-1.2798.fc6/build is missing, please set KERNELPATH. Stop.
[root@FC6 madwifi-0.9.2-2.fc6]#

Then I tried following your instructions and when I got to the make the same happen. PLEASE HELP! this is the only thing that it is not working for me, I am a newbie and don't know what to do next.
Reply With Quote
  #14  
Old 28th October 2006, 02:07 AM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Post

Quote:
Originally Posted by barnys
Hello,

I have a Thinkpad T42 with an atheros running FC 6 (general release from 10/24) and I just can't get "IT" to install.
I installed the *rpm from http://zod.freshrpms.net/rpm.html?id=299 but I don't know what to do next and my card is unrecognized thought the rpm was installed.
Then I tried going to /usr/src//madwifi-0.9.2-2.fc6/ and did make and got the following:

[root@FC6 madwifi-0.9.2-2.fc6]# make
/bin/sh: line 0: cd: /lib/modules/2.6.18-1.2798.fc6/build: No such file or directory
Makefile.inc:89: *** /lib/modules/2.6.18-1.2798.fc6/build is missing, please set KERNELPATH. Stop.
[root@FC6 madwifi-0.9.2-2.fc6]#

Then I tried following your instructions and when I got to the make the same happen. PLEASE HELP! this is the only thing that it is not working for me, I am a newbie and don't know what to do next.
Hi, to answer your questions, I think for your case you don't have a good chance of getting things to work through installing RPMS, as is this the case for many of us.
You are saying that you follwed the steps in the how to and can't get things to work, I understand your frustration, however the following error :
Code:
/lib/modules/2.6.18-1.2798.fc6/build: No such file or directory
tells me that you didn't install the kernel sources for your kernel, which is the following step :
Code:
yum install kernel-devel
Obviously you are using the non-smp kernel so you can skip the following line

Code:
yum install kernel-smp-devel
Please go through the HOW TO step by step, skipping one step as small as it looks could make the difference between working and not working.

So again follow all the steps line by line and tell me if it works out for you or not.

Tuxic
Reply With Quote
  #15  
Old 29th October 2006, 11:44 PM
Tuxic Offline
Registered User
 
Join Date: Feb 2006
Posts: 166
Quote:
Originally Posted by barnys
Hello,

I have a Thinkpad T42 with an atheros running FC 6 (general release from 10/24) and I just can't get "IT" to install.
I installed the *rpm from http://zod.freshrpms.net/rpm.html?id=299 but I don't know what to do next and my card is unrecognized thought the rpm was installed.
Then I tried going to /usr/src//madwifi-0.9.2-2.fc6/ and did make and got the following:

[root@FC6 madwifi-0.9.2-2.fc6]# make
/bin/sh: line 0: cd: /lib/modules/2.6.18-1.2798.fc6/build: No such file or directory
Makefile.inc:89: *** /lib/modules/2.6.18-1.2798.fc6/build is missing, please set KERNELPATH. Stop.
[root@FC6 madwifi-0.9.2-2.fc6]#

Then I tried following your instructions and when I got to the make the same happen. PLEASE HELP! this is the only thing that it is not working for me, I am a newbie and don't know what to do next.
I appologize for the info I provided you with in the previous post, after you notified me of the issue, I decided to invistegate it closer, so I took the plunge and installed FC6 on my laptop, I got the same error as you did even with all the steps applied, so I looked up madwifi's developers mailing list and I was informed that there is an issue with the way Fedora Core 6 refers to it's kernel. To make a long story short there are 2 options and one of them works for me, here we go :

Option 1 : after you do a
Code:
$ tar xzvf madwifi-0.9.2.tar.gz
open net80211/ieee80211_linux.c and change the line that says

Code:
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18)
into
Code:
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,17)
and then go back to the madwifi folder and do a make and go on with the rest of the steps of the process in the HOW-TO.

The above however didn't work for me, so I present you with option :2

Option 2:

Instead of downloading the latest madwifi package, download the latest madwifi-ng package (madwifi next generation).

Using this instead of the madwifi-0.9.2 in the HOW-TO and then follow all the steps over again.

However I would advise you to go back to using the usual madwifi packages as soon as the madwifi developers fix the issue

So hope that helps many people out there stop pulling their hair apart


Tuxic

Last edited by Tuxic; 6th December 2006 at 06:46 AM.
Reply With Quote
Reply

Tags
atheros, based, cards, chipset, installation, madwifi, read, t60, usage, z60t

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Atheros Cards -madwifi- On.Tilt.MC Hardware & Laptops 0 30th January 2007 05:10 AM
Atheros Chipset Based Cards and Madwifi helpful read Tuxic Servers & Networking 0 8th October 2006 06:38 PM
Network Manager and Atheros Based Madwifi binaryblade Servers & Networking 1 26th May 2005 06:50 PM


Current GMT-time: 06:42 (Tuesday, 25-07-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin Copyright 2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat