Fedora Linux Support Community & Resources Center
  #31  
Old 10th November 2007, 11:52 PM
rxmccaf Offline
Registered User
 
Join Date: Nov 2007
Posts: 6
ATI Radeon Linux Fedora 8

OK. Here is how I got my ATI Radeon X1950 to work under Fedora 8 on an AMD x86_64 system.
It's not trivial, but not super difficult either. This worked with kernel 2.6.23.1-42.fc8
There are really two problems - This should fix both of them.

1. Download the driver from http://ati.amd.com/support/drivers/l...64-radeon.html

2. It will most likely put this in your /home/username/Desktop directory. (where username is the name you used to login). So cd /home/username/Desktop

3. chmod 744 ati-driver-installer-8.42.3-x86.x86_64.run

4. Go ahead and try to install it. ./ati-driver-installer-8.42.3-x86.x86_64.run
If you are running Gnome or KDE it will look like it worked, you won't see any errors. But it really didn't work.
It will fail and you will get all kinds of errors. But thats OK - it made a directory for us that we will need later.
If you really want to see the errors - try this.. ./ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Fedora/F8

6. ./ati-driver-installer-8.42.3-x86.x86_64.run --extract fglrx_8_42
This will create a directory called fglrx_8_42

7. download this as a text file and name it ati-fix-tmp. http://docs.google.com/View?docid=ddbph2tz_16hfmq4q

8. mv fglrx_8_42/packages/Fedora/ati-packager.sh fglrx_8_42/packages/Fedora/ati-packager.sh.orig
This backs up the original file to a new name.

9. cp ati-fix-tmp fglrx_8_42/packages/Fedora/ati-packager.sh
This replaces the original file, with the file you just made.

10. chmod 755 fglrx_8_42/packages/Fedora/ati-packager.sh
This makes the file executable so the script will run.

11. cd fglrx_8_42

12. ./ati-installer.sh 8.42.3 --buildpkg Fedora/F8
# NOTE: you must put in the "8.42.3" above.

13. This will still fail, but we fixed the first problem, which was creating the /tmp directory with the wrong name.
For the second problem - this is from http://wiki.cchtml.com/index.php/Fed...allation_Guide

14. cd /lib/modules/fglrx/build_mod/

15, cp firegl_public.c firegl_public.c.orig

16. with your favorite text editor create this file. Name it firegl.patch (I know it says 2.6.22, but it
works with 2.6.23 also)
## ========= Copy and paste =============
8.43.3 for 2.6.23 compatibility

--- firegl_public.c.orig 2007-10-23 19:31:26.000000000 +0200
+++ firegl_public.c 2007-10-23 19:32:07.000000000 +0200
@@ -217,6 +217,56 @@
#define preempt_enable()
#endif

+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,22)
+#if defined(__i386__)
+#define ptep_test_and_clear_dirty(vma, addr, ptep) ({ \
+ int __ret = 0; \
+ if (pte_dirty(*(ptep))) \
+ __ret = test_and_clear_bit(_PAGE_BIT_DIRTY, \
+ &(ptep)->pte_low); \
+ if (__ret) \
+ pte_update((vma)->vm_mm, addr, ptep); \
+ __ret; \
+})
+
+static inline int pte_read(pte_t pte) { return (pte).pte_low & _PAGE_USER; }
+static inline int pte_user(pte_t pte) { return (pte).pte_low & _PAGE_USER; }
+#ifdef CONFIG_X86_PAE
+/*
+ * Is the pte executable?
+ */
+static inline int pte_x(pte_t pte)
+{
+ return !(pte_val(pte) & _PAGE_NX);
+}
+
+/*
+ * All present user-pages with !NX bit are user-executable:
+ */
+static inline int pte_exec(pte_t pte)
+{
+ return pte_user(pte) && pte_x(pte);
+}
+#else
+static inline int pte_exec(pte_t pte)
+{
+ return pte_user(pte);
+}
+#endif /* PAE */
+
+#elif defined(__x86_64__)
+static inline int ptep_test_and_clear_dirty(struct vm_area_struct *vma,
+ unsigned long addr, pte_t *ptep)
+{
+ if (!pte_dirty(*ptep))
+ return 0;
+ return test_and_clear_bit(_PAGE_BIT_DIRTY, &ptep->pte);
+}
+static inline int pte_read(pte_t pte) { return pte_val(pte) & _PAGE_USER; }
+static inline int pte_exec(pte_t pte) { return !(pte_val(pte) & _PAGE_NX); }
+#endif
+#endif
+
// ================================================== ==========
/* globals */

@@ -2489,7 +2539,7 @@ void ATI_API_CALL __ke_put_vm_page_table
#ifndef ptep_clear_flush_dirty
#define ptep_clear_flush_dirty(__vma, __address, __ptep) \
({ \
- int __dirty = ptep_test_and_clear_dirty(__ptep); \
+ int __dirty = ptep_test_and_clear_dirty(__vma, __address, __ptep); \
if (__dirty) \
flush_tlb_page(__vma, __address); \
__dirty; \
@@ -2936,7 +2986,7 @@ int ATI_API_CALL __ke_request_irq(unsign
{
return request_irq(irq,
(void(*)(int, void *, struct pt_regs *))handler,
- SA_SHIRQ, dev_name, dev_id);
+ IRQF_SHARED, dev_name, dev_id);
}

void ATI_API_CALL __ke_free_irq(unsigned int irq, void *dev_id)
@@ -2959,7 +3009,7 @@ int ATI_API_CALL __ke_request_irq(unsign
irq_handler_func = handler;
return request_irq(irq,
ke_irq_handler_wrap,
- SA_SHIRQ, dev_name, dev_id);
+ IRQF_SHARED, dev_name, dev_id);
}

void ATI_API_CALL __ke_free_irq(unsigned int irq, void *dev_id)
@@ -5436,7 +5486,7 @@ unsigned int ATI_API_CALL KAS_Spinlock_R
/** \brief Type definition of the structure describing Slab Cache object */
typedef struct tag_kasSlabCache_t
{
- kmem_cache_t* cache; /* OS slab cache object */
+ struct kmem_cache *cache; /* OS slab cache object */
spinlock_t lock; /* OS spinlock object protecting the cache */
unsigned int routine_type; /* Type of routine the cache might be accessed from */
char name[14]; /* Cache object name (kernel 2.4 restricts its length to 19 chars) */
@@ -5482,7 +5532,7 @@ unsigned int ATI_API_CALL KAS_SlabCache_
DBG_TRACE("creating slab object '%s'", slabcache_obj->name);

if ((slabcache_obj->cache =
- kmem_cache_create(slabcache_obj->name, iEntrySize, 0, 0, NULL, NULL)))
+ kmem_cache_create(slabcache_obj->name, iEntrySize, 0, 0, NULL)))
{
ret = 1;
}
## =========== End - copy and paste ============


17. patch -p0 < firegl.patch

18. ./make.sh
You may see some warnings - but it will compile.

19 . cd ..

20. ./make_install.sh
You may see some warnings - but it will compile.

21. aticonfig --initial -f

22. modprobe fglrx

23. ldconfig

24. Use cntrl-alt-backspace (hold down all 3 at the same time) to restart your Xwindows server.

25. Log back in. Open a command line terminal.

26. su - (it will ask for the root password)

27. glxinfo | grep direct
you should see... direct rendering: Yes

* This is optional - but perhaps helpful.

28. cd /etc/X11

29. Use your favorite text editor to edit xorg.conf
at the very bottom add this...

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

30. You may also want to edit the "device" section like this.

Section "Device"
Identifier "aticonfig-Device[0]" # this line is already there
Driver "fglrx" # this line is already there
Option "UseFastTLS" "0" #add this line
Option "BlockSignalsOnLock" "on" #add this line
Option "ForceGenericCPU" "off" #add this line
Option "KernelModuleParm" "locked-userpages=0" #add this line
BusID "PCI:7:0:0" # This line is useful for PCIe (PCI Express) cards ONLY!!
EndSection

31. from the command line as root try the following commands.
glxgears - after a few minutes you can close the window
fgl_glxgears - after a few minutes you can close the window

32. At this point if everything works, I would reboot the computer. Congradulations!!!
  #32  
Old 11th November 2007, 01:25 PM
mdb Offline
Registered User
 
Join Date: May 2004
Posts: 17
This worked perfectly for me last night in installing this for my ATI Radeon X1300 Pro card (AGP bus). There is one small glitch--if you copy/paste the long patch as shown here, it will complain about a problem around line 7 when you run the patch -p0 in the next step. I found it was better to follow the link just before the patch and do the wget to download the patch listing into the file, firegl.patch. Otherwise, if you follow every step just as outlined here, it worked perfectly, and I've got the driver running under Fedora Core 8 now.
  #33  
Old 11th November 2007, 05:40 PM
screwballl Offline
Registered User
 
Join Date: Jul 2007
Location: /loc/florida
Posts: 15
I got all the way to step 17 and got this error:

Code:
[root@localhost build_mod]# patch -p0 < firegl.patch
patching file firegl_public.c
patch: **** malformed patch at line 6: #define preempt_enable()
and it will not let me go any further.

I tried it 2 ways, in step 16 i saved it to the last folder being used which was /lib/modules/fglrx/build_mod/ and this is when I get this error.
If I save it to the Desktop then I get it asking "File to patch:"

Code:
[root@localhost Desktop]# patch -p0 < firegl.patch
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|8.43.3 for 2.6.23 compatibility
|
|--- firegl_public.c.orig 2007-10-23 19:31:26.000000000 +0200
|+++ firegl_public.c 2007-10-23 19:32:07.000000000 +0200
--------------------------
File to patch: ^C
[root@localhost Desktop]#

At this point nothing beyond it works


edit: I will follow what mdb stated here and report back as to my success
__________________
E6600 on GA-EP35-DS3P with 2GB DDR2-1066
320MB evga 8800GTS PCIe
Corsair HX620W PSU
X-Fi Xtreme Music
Antec 300 case
Dual boot drives:
320GB 7200.10 SATA3 - XP & Vista x64
80GB WD SATA3 - Ubuntu

Fedora system:
iMac G3 Aqua cube - attempting FC10 PPC on it but too many problems

Last edited by screwballl; 11th November 2007 at 05:55 PM.
  #34  
Old 11th November 2007, 06:12 PM
rxmccaf Offline
Registered User
 
Join Date: Nov 2007
Posts: 6
Make sure the patch file is in the same directory as firegl_public.c
which should be /lib/modules/fglrx/build_mod/

if you do an ls you should see both firegl.patch and firegl_public.c

Last edited by rxmccaf; 11th November 2007 at 07:08 PM. Reason: left out the word "see"
  #35  
Old 11th November 2007, 07:12 PM
screwballl Offline
Registered User
 
Join Date: Jul 2007
Location: /loc/florida
Posts: 15
already tried that
did not work for me

but something else did work for me, on the other website you mentioned in step 13 gave an alternative method which did work for me
http://wiki.cchtml.com/index.php/Fed...allation_Guide


Installation from Livna repository
Code:
rpm -ivh http://rpm.livna.org/livna-release-8.rpm
yum install -y kmod-fglrx
and restart X

At this point I typed in "glxinfo | grep direct" and it said "direct rendering: Yes"

wow that would have saved a whole lot of time.. plus when I restarted X it went straight to my 1440x900 on the primary monitor... now need to get the dual head working as the secondary monitor is also showing a mirrored 1440x900 but as it is a 17" CRT, it "scrolls" to the different areas. Any changes to the xorg.conf just completely mess up X so I will need somxe further digging to get that working properly. Primary is 19" widescreen LCD at 1440x900 and secondary is 17" CRT native at 1280x1024.
__________________
E6600 on GA-EP35-DS3P with 2GB DDR2-1066
320MB evga 8800GTS PCIe
Corsair HX620W PSU
X-Fi Xtreme Music
Antec 300 case
Dual boot drives:
320GB 7200.10 SATA3 - XP & Vista x64
80GB WD SATA3 - Ubuntu

Fedora system:
iMac G3 Aqua cube - attempting FC10 PPC on it but too many problems
  #36  
Old 15th November 2007, 09:39 PM
dibl Offline
Registered User
 
Join Date: Nov 2007
Location: Ohio, USA
Posts: 17
OpenGL/GLX broken Nvidia driver, F8 ??

Brand new to Fedora, not so new to Linux -- searched and didn't find anything helpful on this. Forgive me if I missed the obvious answer, please.

I installed/enabled the Livna repo and followed the drill to install the newest available Nvidia driver on my F8 (64-bit) system. It appeared to install correctly. Ran "nvidia-settings" in root mode and set my default resolution, detected my display, and saved to the /etc/X11/xorg.conf file. Verified my xorg.conf file against (a) the one that works great in Ubuntu and (b) the many examples around this forum, and on firewing1's site. Added the "Coolbits" option for fun. Ran "nvidia-settings" as a user and it looks right.

Opened the terminal and entered "glxgears". The X server restarted. Hmmmmmmmm! Logged back in, opened "nvidia-settings" and clicked the "OpenGL/GLX Information" item. The X server restarted.

Logged back in, searched for anything, came up empty.

I noticed this error in the terminal window after running "nvidia-settings" again:
Code:
Xlib:  extension "XVideo" missing on display ":0.0".
Anyone got a clue?

Here's my xorg.conf file:

Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Wed Sep 12 14:29:17 PDT 2007

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 130.0
VertRefresh 50.0 - 160.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7900 GS"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "Coolbits" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1600x1200 +0+0"

SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
__________________
Intel Core 2 Extreme @3.3GHz on Intel D975XBX
Nvidia GF 7900GS, SyncMaster 1100MB

Last edited by dibl; 15th November 2007 at 09:51 PM.
  #37  
Old 24th November 2007, 05:55 PM
rogster Offline
Registered User
 
Join Date: Nov 2007
Posts: 1
I too had a similar issue

The guide worked VERY well at the end I saw the gears and the gears in the cube, and the direct rendering was a big YES, but upon reboot X couldn't load with the new config and reverted to the old where my redering is a big NO now.

I'm still new to fedora so help is appreciated

What steps can I take now to get the old config back now (in addition to fixing the X problem)
  #38  
Old 20th December 2007, 08:29 AM
RossClement Offline
Registered User
 
Join Date: Dec 2007
Posts: 23
Quote:
Originally Posted by rogster
The guide worked VERY well at the end I saw the gears and the gears in the cube, and the direct rendering was a big YES, but upon reboot X couldn't load with the new config and reverted to the old where my redering is a big NO now.

I'm still new to fedora so help is appreciated

What steps can I take now to get the old config back now (in addition to fixing the X problem)
I'm having a similar problem. I installed the nvidia modules from livna, and rebooted. But on reboot I got the famous "can't start X server", and it goes through the whole process, ending up with the old non-3d drivers installed and working. This now happens every time I reboot.

I didn't run "nvidia-settings" (or whatever it's called), could this be the problem.

I include the output of glxinfo (showing that the mesa driver is running) and also a .png of my nvidia rpms installed.

My card is an old GeForce 2 card.

Any hints as to what might be wrong?
Attached Thumbnails
Click image for larger version

Name:	nvidia.png
Views:	494
Size:	57.9 KB
ID:	14407  
Attached Files
File Type: txt glxinfo.txt (3.5 KB, 373 views)
  #39  
Old 20th December 2007, 02:12 PM
zx5000 Offline
Registered User
 
Join Date: Jan 2005
Posts: 37
nvidia-settings doesn't really do much.

try this first /usr/bin/nvidia-xconfig this will create a nvidia specific xorg.conf file.
backup your xorg.conf to a safe name you'll remember.
try to start your x server
if it fails don't go through the config process
save the Xorg.0.log
to get x working again you should be able to just replace the nvida with nv in the device section and restart X.
examine your saved Xorg.0.log and it should give you some hints.
  #40  
Old 23rd December 2007, 09:26 AM
RossClement Offline
Registered User
 
Join Date: Dec 2007
Posts: 23
I finally got to try this. The Xorg.0.log file said that my card isn't supported by the nvidia drivers and that I should use nvidia-legacy. I uninstalled the nvidia driver and kernel module,and installed the corresponding nvidia-legacy ones. Note that all installation and uninstallation I've done has been through yum (specifically yumex) using livna packages.

This time the computer goes boot, and X comes up. But when I try to use opengl (e.g. when I run glxgears, 3D doesn't work. Also, when it boots it only gives me the option of 800x600 and 640x480 (I think, in any case, no 1024x768) screens.

nvidia settings does work, and I can adjust things such as gamma. But when I try to adjust openGl/GLX settings, I get:

Code:
The OpenGL extension 'GLX' is not supported by
the X server or there was a problem retrieving
GLX information from the X server.
I attach here my Xorg.0.log file, and also my /etc/X11/xorg.conf file, and also the output of glxinfo.
Attached Files
File Type: txt glxinfo.txt (2.6 KB, 388 views)
File Type: conf xorg.conf (915 Bytes, 448 views)
File Type: txt Xorg_0_log.txt (31.1 KB, 383 views)

Last edited by RossClement; 23rd December 2007 at 09:32 AM.
  #41  
Old 25th December 2007, 05:07 PM
karlpiuemeno Offline
Registered User
 
Join Date: Jul 2007
Location: Kernel
Age: 28
Posts: 108
Installing the fglrx drivers from livna repo, black screen at reboot.... or better: displays shuts down on gnome loading / login....

mine is an x1050 AGP
  #42  
Old 26th December 2007, 06:27 AM
TriBooter Offline
Registered User
 
Join Date: Apr 2007
Posts: 29
I have much respect for the Fedora Project and I am very thankful for the learning I was able to do in the environment...... and for this reason I am likely to try to "keep up" with what's going on and what is new.....................................

But sadly, frustration got the best of me back in 6.
I jumped ship to Ubuntu and I'm not having near the difficulty anymore.
I am however still stuck with 1680x1050 (native resolution for my monitor).
But it looks very good in Ubuntu.... I'd just rather have a 1280x800 option.



Anyways, my contribution to this is that ATI released a new Catalyst Control Center version.
It's much better than previous versions and I'm using it with no problem in Ubuntu.

I don't like the idea of this really, all things considered.
But I thought I'd share the info to see what you guys have to say about it....
__________________
Dell XPS
2 GB Ram
Intel Core 2 Duo E6400
Dual Seagate SATA Drives
Booting Vista, XP Pro 64 & Ubuntu 7.10 64-bit
:eek:
  #43  
Old 26th December 2007, 11:38 AM
RossClement Offline
Registered User
 
Join Date: Dec 2007
Posts: 23
Quote:
Originally Posted by RossClement
I finally got to try this. The Xorg.0.log file said that my card isn't supported by the nvidia drivers and that I should use nvidia-legacy. I uninstalled the nvidia driver and kernel module,and installed the corresponding nvidia-legacy ones. Note that all installation and uninstallation I've done has been through yum (specifically yumex) using livna packages.
I finally solved my problems. Partially at least.

Even though the error message in the xorg log file said to use the legacy drivers, my card wouldn't work property with the kmod-legacy drivers. It's the 96xx drivers I needed, not the straight legacy ones.

And, when I installed the modules, it didn't modify my xorg.conf file. So I had to go through that and add bits, changing the driver to "nvidia" and loading various glx and extmod (?) extensions to get it to work. It does now work, including the aiglx (?) extensions rather than xgl, allowing me wobbly windows and the like. The number I get out of glxgears does seem suspiciously low, bug glxinfo reports that nvidia is running. There may be some more refinement to go.

Last edited by RossClement; 26th December 2007 at 11:50 AM.
  #44  
Old 26th December 2007, 11:51 PM
jmuirhead Offline
Registered User
 
Join Date: Nov 2006
Location: Placerville, CA
Age: 57
Posts: 18
Problem is: how do you know which rpm package to install? kmod-nvidia, the 96xx one, or the legacy one? Which nVidia card goes with which package?
  #45  
Old 27th December 2007, 12:16 AM
Reindeer Offline
Registered User
 
Join Date: Feb 2005
Posts: 116
nVidia driver yum update conflict

Quote:
Originally Posted by jmuirhead
Problem is: how do you know which rpm package to install? kmod-nvidia, the 96xx one, or the legacy one? Which nVidia card goes with which package?
I have the very same question.
Yum is giving me an error when I try to install the latest round of nVidia drivers:


--> Running transaction check
---> Package kmod-nvidia-96xx.x86_64 0:96.43.01-1.2.6.23.8_34.fc7 set to be updated
--> Processing Conflict: xorg-x11-drv-nvidia-96xx conflicts xorg-x11-drv-nvidia
--> Processing Conflict: xorg-x11-drv-nvidia conflicts xorg-x11-drv-nvidia-96xx
--> Restarting Dependency Resolution with new changes.
---> Loop Number: 2
--> Running transaction check
--> Finished Dependency Resolution
Error: xorg-x11-drv-nvidia-96xx conflicts with xorg-x11-drv-nvidia


Looking at some of the troubles that others are having installing the latest nVidia drivers,
I am loathe to upset my working system.
Does anyone know which drivers are the right ones for 64bit Fedora 7 ?

I'm currently using 100.14.19 on Xorg version 1.3.0 with a GeForce 7600 GT
__________________
Registered Linux User #456652
Smolt Profile
Closed Thread

Tags
ati, binary, drivers, nvidia, problem, warning

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3D acceleration not working with Nvidia binary drivers bjrosen Fedora 13 Development Branch 10 20th May 2010 04:57 PM
F12, two graphics cards and nVidia binary drivers eoghan Using Fedora 0 14th April 2010 06:24 PM
Nvidia binary drivers and Fedora 10, do they work? bjrosen Hardware & Laptops 2 25th November 2008 09:41 PM


Current GMT-time: 09:35 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Carballo Travel Photos on Instagram - Mlalo Photos on Instagram - Aberystwyth Photos