Fedora Linux Support Community & Resources Center
  #1  
Old 10th September 2006, 11:03 PM
Stefan21 Offline
Registered User
 
Join Date: Sep 2006
Posts: 27
Yum?

Hello.. I recently tried to configure the wireless coneection but I seemed to messed up something in the network settings.. Although I have no problem accesing web pages and ping works with no problem when I try to Update the Software I get the Following Error:
Unable to retrieve update information
Unable to retrieve software information. This could be caused by not having a network connection available.

Also when I'm trying to Add/Remove Software I get the same error.. Please if you have some advice or information I'd be glad..

Thanx..
Stefanos

P.S.(P). I tried to uninstall yum and install it again back when I get the following
rpm -e yum
error: Failed dependencies:
yum >= 2.5.3 is needed by (installed) pirut-1.0.3-0.fc5.noarch
Please help??
Reply With Quote
  #2  
Old 10th September 2006, 11:13 PM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
The failed dependency is pirut (the add/remove software program). They both use yum. . Without yum available you will probably need to download the yum and pirut rpms directly from the fedora project download site.

If you are in the directory where you downloaded the yum rpm, some command like

rpm -Uvh --force yum*

should update it.
Reply With Quote
  #3  
Old 11th September 2006, 12:02 AM
Stefan21 Offline
Registered User
 
Join Date: Sep 2006
Posts: 27
Still the same error... I used the command (--force) with the yum-2.6.1-0.fc5.noarch.rpm and worked.. Do I have to install also pirut? Thanx for the reply JEO..
Reply With Quote
  #4  
Old 11th September 2006, 12:10 AM
Stefan21 Offline
Registered User
 
Join Date: Sep 2006
Posts: 27
I installed both and now I get the "Unable to retrieve software information" error...

Any suggestions?
Reply With Quote
  #5  
Old 11th September 2006, 03:15 PM
Stefan21 Offline
Registered User
 
Join Date: Sep 2006
Posts: 27
Solved..

I solved my problem.. There was a file atrpms.repo and I removed it from the direcotry and everything is up and running..
Reply With Quote
  #6  
Old 12th September 2006, 04:21 AM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
Good job on fixing it. It's hard to track down the source of some of these errors when the error message is so general.
Reply With Quote
Reply

Tags
yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Current GMT-time: 07:18 (Thursday, 18-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
La bahia de la Entrega, Huatulco Travel Photos - Vojanovy sady Travel Photos on Instagram - Fairview Winery Travel Photos on Instagram