Fedora Linux Support Community & Resources Center
  #1  
Old 15th May 2006, 12:19 PM
woppa30 Offline
Registered User
 
Join Date: May 2005
Location: England
Posts: 107
vncviewer only shows black screen.

I have changed something but I'm not quite sure what.
Fedora Core 5 machine. fully updated with yum which may have caused this problem...
For a while now I have been using vnc to look at and interact with the :0 display by having a
load "vnc" in the modules section in the /etc/X11/xorg.conf file as described here.
http://www.realvnc.com/products/free/4.1/x0.html

My /home/david.vnc.xstartup looks like this.
#!/bin/sh

# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &

Until recently this allowed me to control the :0 display of my FC5 box at home either through my home LAN or via the internet with tunnelling through ssh from a Windows XP machine with PuTTy.

Has anybody any idea why my vncviewer only shows a black screen with nothing of the :0 display shown ?? even if I create anothe desktop with vncserver and try and connect to that I still get nohing but a black creen with no desktop.
Any ideas anybody ???
Thanks in advance,
woppa
Reply With Quote
  #2  
Old 12th June 2006, 07:27 PM
havenoclu Offline
Registered User
 
Join Date: Jan 2005
Posts: 200
did you ever figure this out?? i'm having the same problems. vnc works fine if i run vncserver from ssh, but i'd like to have screen 0 working. i know it used to work....so i dunno if an update screwed it up or what.

edit: maybe i should clarify. vnc sessions run with xinetd do not work. starting one manually (via ssh) works fine.

Last edited by havenoclu; 12th June 2006 at 07:29 PM.
Reply With Quote
  #3  
Old 12th June 2006, 08:38 PM
havenoclu Offline
Registered User
 
Join Date: Jan 2005
Posts: 200
i figured i should answer my own question...in case anyone else runs into a similar problem. i just added localhost to xhost, and viola! took me a lot of hunting around to find this solution, so maybe this'll help a couple of you.

Code:
xhost +localhost
I believe you should change "localhost" to whatever you have set after the "-query" option in your xinetd vnc file...but that could be wrong. localhost should be right for most people.
Reply With Quote
Reply

Tags
black, screen, shows, vncviewer

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Youtube player just shows black screen Waggoneer Using Fedora 9 16th February 2009 07:03 AM
black screen after loading befor login screen DemonGodKid Using Fedora 3 31st May 2007 09:42 PM
Nvidia GEForce FX 5200 Black screen with X or Blue Screen and nothin frusconi Installation, Upgrades and Live Media 15 17th January 2007 02:05 AM
Black screen when screen locked - server still operational JMitchell Using Fedora 7 22nd September 2006 12:09 AM


Current GMT-time: 16:25 (Friday, 21-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Caluire-et-Cuire - Midlothian Photos on Instagram - Bor Instagram Photos