Fedora Linux Support Community & Resources Center
  #1  
Old 29th March 2004, 03:09 AM
jbarby Offline
Registered User
 
Join Date: Mar 2004
Posts: 13
pppd is driving me nuts

Hello everyone

Here is the story.

I am building a linux box for my grandma . Thing is I had a simple system setup before in windows but she kept getting virii. (sigh) I put on norton and she couldn't figure out how to use it when norton caught a virus in her email. So basically I have been trying to set up a linux box for her since it would have a nice firewall and virii are practically nonexistent. I am attempting to dummy proof fedora I set auto login put a shutdown icon on her desktop setup her hoyle casino 2003 with wine as a simple shortcut you know basic stuff I figure i can make it as easy as windows as she wont be installing stuff or anything like that just email and a couple games I install. I plan to put up a vnc server in case anything goes wrong.

The Problem:

I have a Syntax 8601 motherboard most everything is integrated. I have the winmodem working the virtual driver works on boot and there is a symlink to /dev/modem .

I want in an effort to make things simple for her to get dial on demand working. KPPP works just fine I can dial out etc so I know the modem works.

I haved decided to try and start from scratch again with pppd. I have been to several howto sites to no avail. I understand that now that pppd supports dial on demand. and that I need a dialing script to make the modem dial etc.

It is my understanding that none of the gui packages can setup dial on demand. I dont mind console stuff but there are so many howto's and a lot of them that no longer work its driving me nuts. (making the winmodem work was easier)

The Info

The initilization string is ATZ

My provider is earthlink

Its a 56k winmodem running on the smartlink 2.9.6 driver I have a symlink to /dev/ttySL0 -> /dev/modem

The provider uses PAP authentication

Using a touchtone phone

dial on demand needed

or a modem howto that actually works with fedora would be helpful.

any tips on making a solution that will be active on boot would be cool else i'll probably just shove it into rc.local

Thanks Guys
Reply With Quote
  #2  
Old 29th March 2004, 02:16 PM
kbradl1 Offline
Registered User
 
Join Date: Mar 2004
Posts: 96
A command line dial-up utility that is already in Fedora is wvdial. The website is http://open.nit.ca/wiki/?page=WvDial

There are plenty of FAQS and tutorials, just search google.
Or type "man wvdialconf" and "man wvdial" at the terminal.

It is not a demand-dial application but you could add it to rc.local, as you suggested, or add it to the mozilla run script.

I have also heard of Diald : http://www.tldp.org/HOWTO/Diald-HOWTO.html but have never used it.
Reply With Quote
  #3  
Old 30th March 2004, 08:08 PM
jbarby Offline
Registered User
 
Join Date: Mar 2004
Posts: 13
(sigh) tried a script template not ppd just segfaults

my /etc/ppp/chatscript file

REPORT CONNECT
TIMEOUT 3
ABORT NO\sDIALTONE
ABORT BUSY
ABORT NO\sANSWER
'' \rAT
'OK-+++\c-OK' ATH0
TIMEOUT 30
OK ATZ
OK ATDT660-3500
CONNECT ''

my /etc/ppp/pap-secrets file

# Filename: /etc/ppp/pap-secrets
# Copy this text into a text editor and save it to /etc/ppp/pap-secrets, then
# type "chmod 600 /etc/ppp/pap-secrets"
#
# This Script was generated by the PPP Configurator
# see http://www.linux.net.nz/pppconfig/ for details.
#
# Secrets for authentication using PAP
# client server secret IP addresses
login * password *
# End of file.

my /etc/ppp/options file

# Filename: /etc/ppp/options
# Copy this text into a text editor and save it to /etc/ppp/options
#
# This Script was generated by the PPP Configurator
# see http://www.linux.net.nz/pppconfig/ for details.
#
crtscts
asyncmap
modem
defaultroute
#
# If your chat is not in /usr/sbin, you will have change the next line to
# its location before using this script.
#
connect "/usr/sbin/chat -v -f /etc/ppp/chatscript"
/dev/ttySL0
0.0.0.0:0.0.0.0
noipdefault
ipcp-accept-remote
ipcp-accept-local
# End of file.


used script generator at : http://www.linux.net.nz/pppconfig/
Reply With Quote
  #4  
Old 2nd April 2004, 01:09 AM
dishawjp Offline
Registered User
 
Join Date: Mar 2004
Location: Central NY
Age: 62
Posts: 477
Hi jbarby,

Maybe another approach will work. When I used dialup, I always connected with:

/sbin/ifup ppp0

Playing around with this, I found that Fedora does something a bit differently, and when you run the network configuration utility and set up your ISP, it creates a file in your /etc/sysconfig/network-scripts file named: ifcfg-<name_of_your_ISP>

I copied ifcfg-<name_of_ISP> to ifcfg-ppp0 and then was able to dial up as before.

Since I no longer have a dialup connection, I can't test this, but could you create two tiny shell scripts, one named connect and the other named disconnect, and put them in the ~/Desktop directory so that they'd appear on her desktop? The file named connect would be /sbin/ifup-ppp0 and disconnect would be /sbin/ifdown ppp0?

Then she could just click on those icons to connect and disconnect.

Just a thought.

Jim Dishaw

<edit>

At first I wasn't going to include this since you may know full well how to write a simple script, but the form for the connect script would be something like:

# ! /bin/bash
# a script to dial into my ISP
/sbin/ifup ppp0

Then give it a chmod +x and it should work.

Jim

Last edited by dishawjp; 2nd April 2004 at 01:13 AM.
Reply With Quote
  #5  
Old 28th March 2005, 04:47 PM
aemarchant Offline
Registered User
 
Join Date: Mar 2005
Posts: 1
Dialup as normal user

Here's what I've done to start a dialup connection without logging on as root. (Running Fedora Core 3 on an old laptop with a PCMCIA modem).

Open Applications>System Settings>Network
Setup a new connection, named "madasafish" after the dialup ISP.
Check the option for "Allow all users to enable and disable the device.

Looking at the /etc/sysconfig/network-scripts directory, there is now a file called ifcfg-madasafish and also links to shell scripts, called ifup and ifdown. If you use "sh ifup madasafish" from the terminal in this directory, the connection starts.

The connection script can be modified to:

# !/bin/bash
# dialup script to open Madasafish connection
/etc/sysconfig/network-scripts/ifup madasafish

I saved it to ~/Desktop and used the Properties dialog to make it executable. The disconnect script using ifdown is similar. Seems to work OK.

If you want it to launch without asking you to confirm, go to Applications>File Browser>Preferences>Behaviour and alter the setting for executable text files.

Hope this is useful

AM
Reply With Quote
  #6  
Old 1st December 2005, 03:28 AM
sully Offline
Registered User
 
Join Date: May 2005
Posts: 1
You could also try

I am a newby but have been in a similar situation. For some reason FC3 seems to create more than 1 pppd and have been running into problems whith multiple users on the same computer enabling and disabling the dialup connection to use the phone or whatever. When there are 2 or more pppd processes running it seems impossible to browse the internet.

If grandma clicks to enable the internet connection twice she will either have to reboot or su to root and killall pppd.

This link has a solution http://www.theory.physics.ubc.ca/ppp-kill-wrapper.html

So now i have 2 links on each users desktop

enable dialup = /sbin/ifup <myisp>
disable dialup = pppoff

I put pppoff in ~/bin/pppoff for each user
Reply With Quote
Reply

Tags
driving, nuts, pppd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum updates driving me nuts! JN4OldSchool Wibble 58 16th February 2007 06:31 PM
Why Fedora is Driving me nuts. USACOMPUTERTEC Using Fedora 92 10th November 2006 09:12 PM
FC5 - iptables driving me nuts...> Psy_Ops Servers & Networking 8 13th April 2006 05:48 AM
ProFTPD HELP! Driving me nuts! taigon Servers & Networking 0 2nd March 2006 09:22 PM
ati drivers are driving me nuts archvile Hardware & Laptops 2 8th February 2005 01:28 AM


Current GMT-time: 09:08 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Chiautla Travel Photos - Dandeli - Bilgram Instagram Photos