Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old 24th March 2006, 04:01 AM
smfinley Offline
Retired Community Manager
 
Join Date: Jul 2004
Posts: 1,334
How to install ndiswrapper for Broadcom BCM4318 [AirForce One 54g] (bcmwl5) in FC5

Go to ftp://ftp.support.acer-euro.com/note...0_5020/driver/ and get ftp://ftp.support.acer-euro.com/note...ver/80211g.zip.

If you have not already done so open a terminal and do a "yum install kernel-devel gcc compat-libstdc++-33" as root to provide a build environment.

Do a "mkdir bcmwl" in your home directory. Unzip 80211g.zip. (Use the command "unzip 80211g.zip".) Go to the 80211g folder that it makes when you unzip it (cd 80211g) and do a "cp bcmwl5.inf bcmwl5.sys ~/bcmwl".

Go to http://sourceforge.net/projects/ndiswrapper/ and download ndiswrapper-1.16.tar.gz. This should save the file to your home folder. If it saves the file to your desktop instead go to your desktop and drag the file into your "Home" folder. (Left mouse click on the file and drag it on top of your "Home" folder while holding the left mouse button down. Then release the mouse button.)

Do a "tar xzvf ndiswrapper-1.16.tar.gz" in your home directory.

Type "su -". Hit enter. Type your root password. Hit enter. Type "cd /home/your_user_name/ndiswrapper-1.16". Hit enter. Type "make". Hit enter. Wait for the build process to complete. Type "make install". Hit enter. Wait for the install to complete.

As root do a "/usr/sbin/ndiswrapper -i /home/your_user_name/bcmwl/bcmwl5.inf". This creates /etc/ndiswrapper/bcmwl5/bcmwl5.inf.

As root do a "/usr/sbin/ndiswrapper -l" You should see:
Quote:
Installed ndis drivers:
bcmwl5 driver present, hardware present
As root do "gedit /etc/modprobe.conf" (or use you favorite text editor). In gedit add the line "alias wlan0 ndiswrapper" to /etc/modprobe.conf. (Be sure there is a blank line at the end of the file.) Click the "save" button in gedit and close it.

Go to "System" > "Administration" > "Network", type your root password, click on "New" and in the "Select Device Type" dialog select "Wireless connection". Click "Forward". In the "Select Wireless Device" dialog select "ndiswrapper (wlan0)". Click "Forward". In the "Configure Wireless Connection" dialog fill in your wireless LAN information. Put a "0x" before the hex key for your WEP encryption. Click "Forward". In the "Configure Network Settings" dialog select "Automatically obtain IP address settings with DHCP or put your info in the appropriate boxes if you have a fixed IP address. Click "Forward". Click "Apply". In the "Network Configuration" dialog double click on "wlan0" and fine tune the settings. Be sure to tick the checkbox for "Activate device when computer starts", then click the "Wireless Settings" tab, select "Auto" in the "Mode" box, select "Specified" under "Network name (SSID)" and type in your SSID, channel and encryption hex key (if you have not already done so) and be sure to preface the hex key with "0x", select "Auto" in the "Transmit rate:" box. Finally click "ok". Then in the "Network Configuration" dialog click on the "Activate" button while "wlan0" is selected to activate it. You may want to de-activate your normal Ethernet connection (eth0) at this point by highlighting it, selecting "edit", unticking the "Activate device when computer starts" checkbox, clicking "ok", and then disabling it by clicking on the "Deactivate" button while it is still highlighted. Reboot your machine. (Note that you will have to re-build the driver each time you install a new kernel.)

Note: For more recent kernels add the line "blacklist bcm43xx" in in "/etc/modprobe.d/blacklist" to disable the native bcm43xx driver (that interferes with ndiswrapper when you have a Broadcom card) or use these alternate instructions.
__________________
Stanton Finley
stanton-finley.net

Last edited by smfinley; 10th July 2006 at 02:06 AM.
  #2  
Old 25th March 2006, 02:14 AM
keithmcd Offline
Registered User
 
Join Date: Jun 2005
Location: /home/keith
Age: 30
Posts: 49
I have a slightly different card, but I followed your instructions (I have a BCM4406 - Dell Truemobile 1300).

Anyway, it does finally show up in system-config-network which is good, but when trying to bring it up, i get the error "Determining IP information for wlan0... failed; no link present. Check cable?"

I know it's not the connection because I'm about five feet from my wireless and my PDA can connect to the internet wirelessly just fine. Just to be sure - I disabled MAC address filtering on my router and it still wont connect. It sees the access point in "iwlist scan" which just makes me even more frustrated. Any ideas?
  #3  
Old 27th March 2006, 12:05 PM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
[root@localhost bcmwl5]# ndiswrapper -l
Installed drivers:
bcmwl5 driver installed, hardware present
[root@localhost bcmwl5]# modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.15-1.2054_FC5smp/misc/ndiswrapper.ko): Invalid module format
[root@localhost bcmwl5]# uname -r
2.6.15-1.2054_FC5smp

If you get an error message as the one in bold, this is what I did to solve the problem
Code:
/sbin/depmod -a
before
Code:
/sbin/modprobe ndiswrapper
  #4  
Old 27th March 2006, 04:11 PM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
Another way of getting ndiswrapper instead of building it is, add Livna repository to /etc/yum.repo.d with
Code:
rpm -ivh http://ftp.freshrpms.net/pub/freshrpms/fedora/linux/5/freshrpms-release/freshrpms-release-1.1-1.fc.noarch.rpm
edit /etc/yum.repo.d/livna.repo and change enabled=1 to enabled=0
then
Code:
yum --enablerepo=livna install ndiswrapper kmod-ndiswrapper
  #5  
Old 28th March 2006, 01:14 AM
TFrog Offline
Registered User
 
Join Date: Aug 2004
Posts: 41
Quote:
Originally Posted by smfinley
Go to ftp://ftp.support.acer-euro.com/note...0_5020/driver/ and get ftp://ftp.support.acer-euro.com/note...ver/80211g.zip.

If you have not already done so open a terminal and do a "yum install kernel-devel gcc compat-libstdc++-33" as root to provide a build environment.

Do a "mkdir bcmwl" in your home directory. Unzip 80211g.zip. (Use the command "unzip 80211g.zip".) Go to the 80211g folder that it makes when you unzip it (cd 80211g) and do a "cp bcmwl5.inf bcmwl5.sys ~/bcmwl".

Go to http://sourceforge.net/projects/ndiswrapper/ and download ndiswrapper-1.10.tar.gz. This should save the file to your home folder. If it saves the file to your desktop instead go to your desktop and drag the file into your "Home" folder. (Left mouse click on the file and drag it on top of your "Home" folder while holding the left mouse button down. Then release the mouse button.)

Do a "tar xzvf ndiswrapper-1.10.tar.gz" in your home directory.

Type "su -". Hit enter. Type your root password. Hit enter. Type "cd /home/your_user_name/ndiswrapper-1.10". Hit enter. Type "make". Hit enter. Wait for the build process to complete. Type "make install". Hit enter. Wait for the install to complete.

As root do a "/usr/sbin/ndiswrapper -i /home/your_user_name/bcmwl/bcmwl5.inf". This creates /etc/ndiswrapper/bcmwl5/bcmwl5.inf.

As root do a "/usr/sbin/ndiswrapper -l" You should see:As root do "gedit /etc/modprobe.conf" (or use you favorite text editor). In gedit add the line "alias wlan0 ndiswrapper" to /etc/modprobe.conf. (Be sure there is a blank line at the end of the file.) Click the "save" button in gedit and close it.

Go to "System" > "Administration" > "Network", type your root password, click on "New" and in the "Select Device Type" dialog select "Wireless connection". Click "Forward". In the "Select Wireless Device" dialog select "ndiswrapper (wlan0)". Click "Forward". In the "Configure Wireless Connection" dialog fill in your wireless LAN information. Put a "0x" before the hex key for your WEP encryption. Click "Forward". In the "Configure Network Settings" dialog select "Automatically obtain IP address settings with DHCP or put your info in the appropriate boxes if you have a fixed IP address. Click "Forward". Click "Apply". In the "Network Configuration" dialog double click on "wlan0" and fine tune the settings. Be sure to tick the checkbox for "Activate device when computer starts", then click the "Wireless Settings" tab, select "Auto" in the "Mode" box, select "Specified" under "Network name (SSID)" and type in your SSID, channel and encryption hex key (if you have not already done so) and be sure to preface the hex key with "0x", select "Auto" in the "Transmit rate:" box. Finally click "ok". Then in the "Network Configuration" dialog click on the "Activate" button while "wlan0" is selected to activate it. You may want to de-activate your normal Ethernet connection (eth0) at this point by highlighting it, selecting "edit", unticking the "Activate device when computer starts" checkbox, clicking "ok", and then disabling it by clicking on the "Deactivate" button while it is still highlighted. Reboot your machine. (Note that you will have to re-build the driver each time you install a new kernel.)
I tried this process of yours step by step exactly as you wrote. On the final compile for the driver it gave me fits about something to do with a 4k limit in the kernel and one of the commands failed to work. Could you update this How To for FC 5 with step by step instructions. The beginning of your how to is a bit cryptic for new users? I've used your How To's before with great success and would like to take this time to thank you for them as well as all the help you've been to many of us.
  #6  
Old 28th March 2006, 06:13 AM
TFrog Offline
Registered User
 
Join Date: Aug 2004
Posts: 41
wpa_supplicant up and running but no wireless yet.

I followed a very good How To on wpa_supplicant and was able to get that to function. Also loaded the Livna rpms for NDISwrapper. lspci sees the wireless adapter but network doesn't see it when i open it up. Any ideas? Would an edit of modprob.config help at this point? Atheros chipset NIC's were easy compared to this!!!!!!!!! Wish I'd have done more research before my laptop purchase but am very happy with this laptop since purchasing it.
  #7  
Old 29th March 2006, 12:05 AM
9c1 Offline
Registered User
 
Join Date: Mar 2006
Posts: 9
Tut worked perfect at first (with wpa disabled), then I enabled on my router and put the key in-now it doesn't connect. I took off the key reinstall the drivers, and reset the router to factory settings and it still won't connect. any help?

**edit** now I get this after reboot

Determining IP information for wlan0...dhclient(2762) is already running - exiting.
exiting.
failed.

**edit 2**
My wireless card works online with that error up top.IF anyone can give me some advice, that'll be greatly appreciated

Last edited by 9c1; 29th March 2006 at 12:22 AM.
  #8  
Old 29th March 2006, 09:15 AM
quad3d@work Offline
Registered User
 
Join Date: Mar 2006
Location: Austin, TX
Posts: 8
I never really got the GUI part to work. wlan0 isn't loaded on startup (Wifi light is off). I had to su to root everytime and iwconfig it to work at work (WEP).

iwconfig wlan0 key restricted XXXXXXXXXX (If no WEP I guess you can leave this part out)
iwconfig wlan0 essid 'XXXXX' (if your SSID doesn't change each time you don't have to run this everytime)
dhclient wlan0 (by this point my Wifi light turns on by itself)

Hope this helps some.
  #9  
Old 29th March 2006, 11:26 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
Quote:
Originally Posted by 9c1
Tut worked perfect at first (with wpa disabled), then I enabled on my router and put the key in-now it doesn't connect. I took off the key reinstall the drivers, and reset the router to factory settings and it still won't connect. any help?

**edit** now I get this after reboot

Determining IP information for wlan0...dhclient(2762) is already running - exiting.
exiting.
failed.

**edit 2**
My wireless card works online with that error up top.IF anyone can give me some advice, that'll be greatly appreciated
I don't know why you are getting that error message and post the output of
Code:
chkconfig --list dhclient
  #10  
Old 29th March 2006, 11:44 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
Quote:
Originally Posted by quad3d@work
I never really got the GUI part to work. wlan0 isn't loaded on startup (Wifi light is off). I had to su to root everytime and iwconfig it to work at work (WEP).

iwconfig wlan0 key restricted XXXXXXXXXX (If no WEP I guess you can leave this part out)
iwconfig wlan0 essid 'XXXXX' (if your SSID doesn't change each time you don't have to run this everytime)
dhclient wlan0 (by this point my Wifi light turns on by itself)

Hope this helps some.
Here is a visual how to, posted by imdeemvp for FC4, see if this helps to get the gui part workingHow to ndiswrapper
  #11  
Old 30th March 2006, 01:08 PM
Gallan Offline
Registered User
 
Join Date: Jan 2005
Location: Finland
Posts: 253
hi,

I have little broblem with ndiswrapper, it finds ip fine when I go to system-network and press activate but when computer starts it is waiting and waiting and then ip...fail!?! after boot I go again to network and start wlan0 and it goes on in 1 or 2 seconds. any ideas?
__________________
asus A3500 laptop
intel celeron m360
1 GB memory
Fedora Core 9
registered LINUX user 395221
  #12  
Old 31st March 2006, 11:12 AM
FouCrazy Offline
Registered User
 
Join Date: Mar 2006
Posts: 4
Hello,
I have followed your steps and I obtain a problem at the moment for activating the device :
The device to ndiswrapper wlan0 does not seem to be present, delaying the boot.
I have proven with two drivers and it always says the same .

Thanks for the posts.
  #13  
Old 1st April 2006, 08:59 AM
jeswin Offline
Registered User
 
Join Date: Jun 2005
Posts: 3
Works!!!

Thank you!

It really worked! You saved my day!

Clear and short instructions, good job!

/Jeswin


-----------------------------------------
My laptop: Hewlett Packard Pavillion zv6000

Last edited by jeswin; 2nd April 2006 at 08:14 AM.
  #14  
Old 1st April 2006, 09:23 PM
LaChild Offline
Registered User
 
Join Date: Feb 2006
Posts: 24
Quote:
Originally Posted by FouCrazy
Hello,
I have followed your steps and I obtain a problem at the moment for activating the device :
The device to ndiswrapper wlan0 does not seem to be present, delaying the boot.
I have proven with two drivers and it always says the same .

Thanks for the posts.
I too had the problem of my ndiswrapper not showing up. Heres a post by hilbert70 that got this up and running for me.

Hope that helps
  #15  
Old 2nd April 2006, 11:55 AM
FouCrazy Offline
Registered User
 
Join Date: Mar 2006
Posts: 4
...my problem solved alone? this appears....
all ok and running but without explication...
Thanks
__________________
Compaq nx6125
Fedora Core 5
Closed Thread

Tags
54g, airforce, bcm4318, bcmwl5, broadcom, fc5, install, ndiswrapper

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Rayskee80 Servers & Networking 2 19th September 2009 11:08 AM
Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Rykkan Hardware & Laptops 19 23rd June 2008 03:17 PM
WIFI for Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Control babbutycoon Servers & Networking 24 20th April 2008 05:24 PM
How to ndiswrapper 1.47 [FC7] BCM4318 [AirForce One 54g] linux_gentoo Servers & Networking 64 29th January 2008 04:20 AM
How to use native bcm43xx support for Broadcom BCM4318 [AirForce One 54g] in FC5 smfinley Guides & Solutions (No Questions) 131 15th October 2007 01:51 PM


Current GMT-time: 12:24 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Xiannu - Suisan Instagram Photos - Waren Photos