Fedora Linux Support Community & Resources Center
  #1  
Old 11th November 2012, 12:44 AM
Trouhel Offline
Registered User
 
Join Date: Nov 2012
Location: France
Posts: 17
linuxchrome
F17 kernel 3.6.6 and kmod-nvidia seems broken on G210

Since upgrading to 3.6.6 kernel, installing kmod-nvidia (304-60) on a machine with a G210 graphic card, X doesn't work properly anymore : no login/logout screen and task bar when using gdm/gnome, no task bar with cinnamon, i.e. loks like everything that uses some sort of "transparency" doesn't work anymore (as far as I remember, I ran into similar problems with either lxde or kde). I've no way to look at the logs as I run Fedora from Live USB only.

Did anyone else ran into the same issue/ has any clue ?

P.S.: It worked like a charm with earlier kernels.
Reply With Quote
  #2  
Old 11th November 2012, 09:29 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,078
linuxfirefox
Re: F17 kernel 3.6.6 and kmod-nvidia seems broken on G210

You can mount your HDD partition after you boot your computer with a LiveCD and look at /var/log/messages or switch to a different terminal by pressing Ctrl+Alt+F2 where you can login as root.

Does it still work if you chose an older kernel version in grub?
Reply With Quote
  #3  
Old 11th November 2012, 01:16 PM
Trouhel Offline
Registered User
 
Join Date: Nov 2012
Location: France
Posts: 17
linuxchrome
Re: F17 kernel 3.6.6 and kmod-nvidia seems broken on G210

Thanks for the tip.

I do not have any older kernels available. I tried reinstalling F17 release with 3.3.7 kernel + kmod-nvidia but was unable to get it to boot.

I saw nothing alerting in /var/log/messages except than nouveau drm seems to be called while lsmod doesn't report nouveau loaded. /var/log/Xorg.0.log seems OK too.

But, he autologin user .xsession-errors has the following :

CurrentTime used to choose focus window; focus window may not be correct.
Got a request to focus the no_focus_window with a timestamp of 0. This shouldn't happen!

At worst, guess I'll stick with nouveau until either a newer kernel/kmod-nvidia is available.

PS: I am wrong assuming a Live USB booted with syslinux doesn't use grub ?

Last edited by Trouhel; 13th November 2012 at 09:44 PM.
Reply With Quote
  #4  
Old 13th November 2012, 09:43 PM
Trouhel Offline
Registered User
 
Join Date: Nov 2012
Location: France
Posts: 17
linuxchrome
Re: F17 kernel 3.6.6 and kmod-nvidia seems broken on G210

reinstalled using kernel 3.3.4 + nvidia drivers 295.53 : these work fine.
Reply With Quote
  #5  
Old 22nd November 2012, 12:48 PM
Trouhel Offline
Registered User
 
Join Date: Nov 2012
Location: France
Posts: 17
linuxchrome
Re: F17 kernel 3.6.6 and kmod-nvidia seems broken on G210

Tried installing 3.6.7 + nvidia 304.64 today : still broken.
Did anyone gave a try to either that one or 3.6.6 + 204.60 on other nvidia cards?
Reply With Quote
  #6  
Old 24th November 2012, 11:15 PM
chrisjr Offline
Registered User
 
Join Date: Mar 2006
Posts: 10
linuxfirefox
Re: F17 kernel 3.6.6 and kmod-nvidia seems broken on G210

The new NVIDIA 304.64 driver doesn't seem to be reading the contents of the 00-nvidia.conf (?) file in the /etc/X11/xorg.conf.d/ directory. But if you add the two "ModulePath" lines in this file to the "Files" section of /etc/X11/xorg.conf then the driver will work correctly.

At least, it did for me .
Reply With Quote
  #7  
Old 24th November 2012, 11:58 PM
Divit11 Offline
Registered User
 
Join Date: Jun 2006
Location: Elmhurst, IL, USA
Posts: 84
linuxfirefox
Re: F17 kernel 3.6.6 and kmod-nvidia seems broken on G210

Thanks chrisjr, your solution worked for me!
Divit11
__________________
Asus P7P55D-E LX MB w Intel Core i5-760 2.8GHz; C M Hyper 212 Plus CPU Cooler; Corsair XMS3 8GB DDR3 1333 RAM; EVGA GeForce 9500 GT Card; WD Caviar Blk WD1002FAEX 1TB HD; LITE-ON 24X iHAS424-98 DVD/CD Writer; OCZ Pro OCZ600W PS; 2x Asus VS238H-P LED Monitors; OS: MS 7 Hm Prem 64 bit & Fedora-20-x86_64
Reply With Quote
  #8  
Old 25th November 2012, 11:03 AM
Trouhel Offline
Registered User
 
Join Date: Nov 2012
Location: France
Posts: 17
linuxchrome
Re: F17 kernel 3.6.6 and kmod-nvidia seems broken on G210

Thanks a lot. Works fine for me as well.
Reply With Quote
Reply

Tags
broken, f17, g210, kernel, kmodnvidia, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fc16 kmod-nvidia 3D accelaration broken? deathkill Hardware & Laptops 1 30th January 2012 11:49 PM
Broken by attempting to install kmod-nvidia kazakore Installation, Upgrades and Live Media 11 14th April 2011 03:17 PM
Kmod-Nvidia Broken after a kernel update newmanium2001 Using Fedora 52 15th November 2008 03:55 PM
Kmod-nvidia and PAE kernel ahess Using Fedora 6 15th June 2008 07:11 AM
Kernel 2.6.17-1 No Kmod-Nvidia flebber Using Fedora 54 17th August 2006 10:31 PM


Current GMT-time: 14:25 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Mozhga Travel Photos on Instagram - Miri Photos - Salzburg Photos