Fedora Linux Support Community & Resources Center
  #1  
Old 28th September 2012, 12:55 AM
cOdef0x Offline
Registered User
 
Join Date: Sep 2012
Location: /home/
Posts: 14
linuxfirefox
Question How to install mplayer or vlc Fedora 16

Hello,

I'm new here.

I've installed Fedora16 in my PC. I need to know how to install mplayer or, vlc in it?


Thanks.
Reply With Quote
  #2  
Old 28th September 2012, 01:11 AM
GoinEasy9 Offline
Registered User
 
Join Date: May 2009
Location: Manorville, New York, USA
Posts: 1,674
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Make sure you have rpmfusion repos installed. If you don't, you can get them here:
http://rpmfusion.org/Configuration

then, in a terminal:

su -
<password>
yum install mplayer vlc
__________________
Registered Linux User #348347
Have you been seduced by siduction? http://siduction.org/index.php
Running Fedora 19/20, siduction and openSUSE 13.1 with KDE
Reply With Quote
  #3  
Old 28th September 2012, 01:12 AM
BBQdave Online
The Ubu-Grillmaster
 
Join Date: Aug 2011
Location: North Carolina
Age: 46
Posts: 1,973
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Quote:
Originally Posted by cOdef0x View Post
I need to know how to install... vlc...

http://rpmfusion.org/

Add this repo and install away

VLC is in RPM Fusion FREE, but if you want to add more software to choose from, you can also add RPM Fusion nonFREE.
__________________
On quest for blue smoke and red rings...
Reply With Quote
  #4  
Old 28th September 2012, 02:09 AM
cOdef0x Offline
Registered User
 
Join Date: Sep 2012
Location: /home/
Posts: 14
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Thanks for your replies.

Shows errors during mplayer installation:
Code:
sudo yum install mplayer
Loaded plugins: langpacks, presto, refresh-packagekit
rpmfusion-free                                                  | 2.7 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mplayer.i686 0:1.0-0.126.20110816svn.fc16 will be installed
--> Processing Dependency: mplayer-common = 1.0-0.126.20110816svn.fc16 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: faad2-libs >= 1:2.6.1 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libfribidi.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53) for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51) for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libdca.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: librtmp.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libvdpau.so.1 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libavcodec.so.53 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libfaad.so.2 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libxvidcore.so.4 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libgroupsock.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libavutil.so.51 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libmp3lame.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libx264.so.116 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libliveMedia.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libpostproc.so.51 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libBasicUsageEnvironment.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libUsageEnvironment.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libavformat.so.53 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libcaca.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: liba52.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2) for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libmpeg2.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: liblirc_client.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53) for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libpostproc.so.51(LIBPOSTPROC_51) for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libswscale.so.2 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libmpg123.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Running transaction check
---> Package a52dec.i586 0:0.7.4-15.fc11 will be installed
---> Package faad2-libs.i586 1:2.7-1.fc11 will be installed
---> Package ffmpeg-libs.i686 0:0.8.5-2.fc16 will be installed
--> Processing Dependency: libva.so.1 for package: ffmpeg-libs-0.8.5-2.fc16.i686
---> Package lame-libs.i686 0:3.98.4-1.fc14 will be installed
---> Package libdca.i686 0:0.0.5-5.fc12 will be installed
---> Package libmpeg2.i686 0:0.5.1-8.fc12 will be installed
---> Package libmpg123.i686 0:1.12.3-1.fc14 will be installed
---> Package librtmp.i686 0:2.4-0.1.20110811gitc58cfb3e.fc16 will be installed
---> Package live555.i686 0:0-0.32.2011.09.02.fc16 will be installed
---> Package mplayer.i686 0:1.0-0.126.20110816svn.fc16 will be installed
--> Processing Dependency: libfribidi.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libvdpau.so.1 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: libcaca.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
--> Processing Dependency: liblirc_client.so.0 for package: mplayer-1.0-0.126.20110816svn.fc16.i686
---> Package mplayer-common.i686 0:1.0-0.126.20110816svn.fc16 will be installed
---> Package x264-libs.i686 0:0.0.0-0.31.20110811.fc16 will be installed
---> Package xvidcore.i686 0:1.3.2-2.fc15 will be installed
--> Finished Dependency Resolution
Error: Package: mplayer-1.0-0.126.20110816svn.fc16.i686 (rpmfusion-free)
           Requires: libfribidi.so.0
Error: Package: mplayer-1.0-0.126.20110816svn.fc16.i686 (rpmfusion-free)
           Requires: liblirc_client.so.0
Error: Package: mplayer-1.0-0.126.20110816svn.fc16.i686 (rpmfusion-free)
           Requires: libvdpau.so.1
Error: Package: mplayer-1.0-0.126.20110816svn.fc16.i686 (rpmfusion-free)
           Requires: libcaca.so.0
Error: Package: ffmpeg-libs-0.8.5-2.fc16.i686 (rpmfusion-free)
           Requires: libva.so.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
vlc shows more

What to do now?
Reply With Quote
  #5  
Old 28th September 2012, 02:20 AM
GoinEasy9 Offline
Registered User
 
Join Date: May 2009
Location: Manorville, New York, USA
Posts: 1,674
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Do you have both the rpmfusion-free and rpmfusion-nonfree repos enabled? If you have only -free repositories enabled, it might be looking for codecs from the -nonfree repo. Or there's a problem with the package at the moment. But I don't have a problem with them at the moment, on 16 or 17.
__________________
Registered Linux User #348347
Have you been seduced by siduction? http://siduction.org/index.php
Running Fedora 19/20, siduction and openSUSE 13.1 with KDE
Reply With Quote
  #6  
Old 28th September 2012, 02:29 AM
cOdef0x Offline
Registered User
 
Join Date: Sep 2012
Location: /home/
Posts: 14
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Only rpm-fusion free is enabled:
Quote:
rpmfusion-free RPM Fusion for Fedora 16 - Free 355
I've also checked the "/etc/yum.repos.d/rpmfusion-free.repo" file.

Any free alternate of mplayer/vlc to play video files,dvd etc ?
Reply With Quote
  #7  
Old 28th September 2012, 03:30 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

well, all those dependencies were for mplayer, so you should still be able to install vlc with no problems.

But those dependencies are in the Fedora repos.. I wonder if it's either trying to use a newer version or an older one.

You can try enabling the updates-testing and the rpmfusion free/nonfree updates-testing repos and see if it picks up the dependencies then.

You can also try installing the dependencies before installing mplayer

yum install libcaca fribidi lirc-libs libva libvdpau

Edit:

corrected typo in package names above

Last edited by DBelton; 28th September 2012 at 04:44 AM.
Reply With Quote
  #8  
Old 28th September 2012, 04:31 AM
cOdef0x Offline
Registered User
 
Join Date: Sep 2012
Location: /home/
Posts: 14
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Quote:
[root@localhost ~]# yum install libcaca fribidi litc-libs libva libvdpau
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
No package libcaca available.
No package fribidi available.
No package litc-libs available.
No package libva available.
No package libvdpau available.
Error: Nothing to do
What's wrong with this?
Can I manually download these files?

---------- Post added at 09:31 AM ---------- Previous post was at 09:12 AM ----------

I've installed some by manually downloading from rpm.pbone.net ; it now shows 1 dependency error:

Quote:
--> Finished Dependency Resolution
Error: Package: mplayer-1.0-0.126.20110816svn.fc16.i686 (rpmfusion-free)
Requires: liblirc_client.so.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
I can't find it there.
& vls shows much more errors
Reply With Quote
  #9  
Old 28th September 2012, 04:43 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Do you have your Fedora, updates, and updates testing repos disabled by chance? That is kinda what it looks like.

Also, I had a typo above. I put litc-libs, and it should be lirc-libs.
Reply With Quote
  #10  
Old 28th September 2012, 04:48 AM
cOdef0x Offline
Registered User
 
Join Date: Sep 2012
Location: /home/
Posts: 14
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Found it by searching as liblirc_client.so.0

This time yum downloaded & installed 'mplayer' with some other dependencies:
Quote:
Installed:
mplayer.i686 0:1.0-0.126.20110816svn.fc16

Dependency Installed:
a52dec.i586 0:0.7.4-15.fc11
faad2-libs.i586 1:2.7-1.fc11
ffmpeg-libs.i686 0:0.8.5-2.fc16
lame-libs.i686 0:3.98.4-1.fc14
libdca.i686 0:0.0.5-5.fc12
libmpeg2.i686 0:0.5.1-8.fc12
libmpg123.i686 0:1.12.3-1.fc14
librtmp.i686 0:2.4-0.1.20110811gitc58cfb3e.fc16
live555.i686 0:0-0.32.2011.09.02.fc16
mplayer-common.i686 0:1.0-0.126.20110816svn.fc16
x264-libs.i686 0:0.0.0-0.31.20110811.fc16
xvidcore.i686 0:1.3.2-2.fc15

Complete!
I've tested with some video files, it's working.

Thanks for all help

---------- Post added at 09:48 AM ---------- Previous post was at 09:45 AM ----------

Quote:
Originally Posted by DBelton View Post
Do you have your Fedora, updates, and updates testing repos disabled by chance? That is kinda what it looks like....
Yes :O
I'm enabling those.
Reply With Quote
  #11  
Old 28th September 2012, 05:01 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

You should always have your Fedora and updates repo enabled. That's where it pulls the majority of the libs from, and also where you get your updates. Updates-testing is optional. You get newer packages, but some could have problems. (Most are fine, but occasionally one slips through that could cause some problems)
Reply With Quote
  #12  
Old 28th September 2012, 05:06 AM
cOdef0x Offline
Registered User
 
Join Date: Sep 2012
Location: /home/
Posts: 14
linuxfirefox
Re: How to install mplayer or vlc Fedora 16

Okay
Reply With Quote
Reply

Tags
fedora, install, mplayer, vlc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help me ,how to install mplayer in fedora 12 cqzhugege Using Fedora 7 19th May 2010 12:15 AM
How to install mplayer in the fedora 11 ? luoluo Using Fedora 1 1st October 2009 02:06 AM
cannot install mplayer on fedora 9 zakhmi Using Fedora 9 27th July 2008 11:36 PM
Fedora 5 core - mplayer install prob jeepfreak Using Fedora 7 11th July 2006 10:25 PM
install mplayer on a Fedora Core 5 lothario Using Fedora 10 5th July 2006 09:18 PM


Current GMT-time: 02:20 (Tuesday, 23-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat