Fedora Linux Support Community & Resources Center
  #1  
Old 26th January 2010, 06:19 AM
KirkD Offline
Registered User
 
Join Date: Oct 2007
Posts: 386
linuxfedorafirefox
Audio stopped working?

Yesterday all was good and fine with no issues whatsoever. Today, when I start up I have audio at the login screen - the characteristic "clunk" when I choose my user account. Once KDE starts up I see that my audio is muted. Hovering over it says "Volume at 100% (muted)" - no problem, I'll just unmute it. But I get no audio on YouTube or RhythmBox or any other method I've tried audio.

This happened once before with FC9 or FC10 - a kernel update killed the audio. I did a full update last night but didn't notice any issues until this morning after reboot. Booting into the old kernel didn't seem to fix the problem though.

Any tips on getting my audio back?

-Kirk

BTW - I'm running FC12 2.6.31.12-174.2.3.fc12.i686.PAE with KDE 4.3.4
Reply With Quote
  #2  
Old 26th January 2010, 09:09 AM
BugRocks1 Offline
Registered User
 
Join Date: Jan 2010
Posts: 894
windows_xp_2003firefox
To see if the audio is enabled.
lspci | grep -i audio


To see the codecs, pci paths and error messages for the audio
dmesg | grep -iE 'hda|sound'

ltrace and strace to track what the program is doing very good to see where the audio actually is failing.

http://linuxhelp.blogspot.com/2006/0...eshooting.html

If it is because of a missing link or if the file didn't exist in some directory it will show up on the trace.
If you can't undertand the output of the tracing you can always post it here maybe someone can see the problem.
Reply With Quote
  #3  
Old 27th January 2010, 02:35 AM
KirkD Offline
Registered User
 
Join Date: Oct 2007
Posts: 386
linuxfedorafirefox
Thank you for the tips. Following is what I get as output for the commands you suggested.

Code:
lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)



dmesg | grep -iE 'hda|sound'
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
HDA Intel 0000:00:1b.0: setting latency timer to 64
ALSA sound/pci/hda/hda_codec.c:3862: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3866:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3870:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3871:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3874:    dig-out=0x21/0x0
ALSA sound/pci/hda/hda_codec.c:3882:    inputs: mic=0xb, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
ALSA sound/pci/hda/patch_sigmatel.c:3188: stac92xx: dac_nids=1 (0x10/0x0/0x0/0x0/0x0)
input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input12
ALSA sound/pci/hda/hda_intel.c:691: azx_get_response timeout, switching to polling mode: last cmd=0x01df000e
input: HDA Intel Mic at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
input: HDA Intel HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
I don't quite know how to interpret the output. Seems odd that the hda_codec.c containing lines all refer to 0x0 for the various output options. But then again, I don't exactly know what it is should be.

strace and ltrace seem useful as well, but I'm not sure which program to trace. Any additional help is appreciated.

BTW - Another update from last night contained a number of pulseaudio updates. I also tried uninstalling pulseaudio and then reinstalling it - same results. I have sound on the login screen and then nothing once I'm in KDE. (Haven't tried Gnome.)


Edit:

I just logged out of KDE and back into Gnome. The sound was still muted upon startup, but I was able to turn up the volume and have sound. Must be a KDE issue. All the output for the two commands above is the same between KDE and Gnome, too.

Last edited by KirkD; 27th January 2010 at 02:41 AM.
Reply With Quote
  #4  
Old 27th January 2010, 03:12 AM
jbone Offline
Registered User
 
Join Date: Nov 2009
Posts: 13
linuxfedorafirefox
I got similar problem after yum update.

Code:
[xxxx@Acorn ~]$ lspci | grep -i audio
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)

[xxxx@Acorn ~]$ dmesg | grep -iE 'hda|sound'
ALSA sound/pci/ac97/ac97_codec.c:2163: MC'97 1 converters and GPIO not ready (0xff00)
Although sound worked before, sometimes I did get an annoying error message "ich 6 does not work with stac 9XXX, fall back to pulseaudio" (something like that). My computer is dell inspiron 6000.

Help is highly appreciated.

Update: I can get sound on the youtube site, but not on amarok.

Last edited by jbone; 27th January 2010 at 04:02 AM.
Reply With Quote
  #5  
Old 27th January 2010, 03:35 AM
KirkD Offline
Registered User
 
Join Date: Oct 2007
Posts: 386
linuxfedorafirefox
OK, so I log out of KDE, go into Gnome and sound works. It started up muted just like in KDE, but I could actually adjust the sound and, more importantly, hear it once I turned it up. I assume the issue is KDE. I log out, go back to KDE, and it no longer starts up muted _AND_ I get my audio back.

Somewhere along the way there was a configuration issue that KDE couldn't fix. Any ideas? It works now, but I would love to know why.

-Kirk

---------- Post added at 07:35 PM CST ---------- Previous post was at 07:34 PM CST ----------

jbone - Try the logout, switch window managers, logout, and switch back. Are you using KDE or Gnome?
Reply With Quote
  #6  
Old 27th January 2010, 04:04 AM
jbone Offline
Registered User
 
Join Date: Nov 2009
Posts: 13
linuxfedorafirefox
Quote:
Originally Posted by KirkD View Post
OK, so I log out of KDE, go into Gnome and sound works. It started up muted just like in KDE, but I could actually adjust the sound and, more importantly, hear it once I turned it up. I assume the issue is KDE. I log out, go back to KDE, and it no longer starts up muted _AND_ I get my audio back.

Somewhere along the way there was a configuration issue that KDE couldn't fix. Any ideas? It works now, but I would love to know why.

-Kirk

---------- Post added at 07:35 PM CST ---------- Previous post was at 07:34 PM CST ----------

jbone - Try the logout, switch window managers, logout, and switch back. Are you using KDE or Gnome?
Thanks, Kirk. I use KDE. I will try the trick you suggested.
Reply With Quote
  #7  
Old 27th January 2010, 04:28 AM
KirkD Offline
Registered User
 
Join Date: Oct 2007
Posts: 386
linuxfedorafirefox
Let us know if it works.
Reply With Quote
  #8  
Old 27th January 2010, 08:02 AM
BugRocks1 Offline
Registered User
 
Join Date: Jan 2010
Posts: 894
windows_xp_2003firefox
@jbone:

I think but am not sure you have some driver problem there it should have shown a lot more on the dmesg and what it is showing says it is not ready for use(I think).

@KirkD:

Glad you got your sound back, from what you posted there was no problems that I could see but I'm not and expert on audio just a curious guy.

About what to trace, when I do have those problems I start at the top going to trace the program that is having trouble and in your case that would be anything that have sound involved, so I would try tracing vlc or amarok and putting the trace on a txt, so I could search for the words sound, audio, stream, streams and etc and see what is being called and then trace that is like following bread crumbs
Reply With Quote
  #9  
Old 27th January 2010, 05:04 PM
KirkD Offline
Registered User
 
Join Date: Oct 2007
Posts: 386
windows_xp_2003firefox
BugRocks - thank you for the info! I will definitely keep tracing around for future reference.

I'm still unsure what the problem with my audio was, but I'm not complaining. The fix was easy. 8^)
Reply With Quote
  #10  
Old 28th January 2010, 01:45 AM
jbone Offline
Registered User
 
Join Date: Nov 2009
Posts: 13
linuxfedorafirefox
I found the solution here: http://forums.fedoraforum.org/showthread.php?t=239013. Changing the backend from xine to gstream solved my problem too. I did not logout and switch window manager since I installed only KDE from the livecd. I think Gnome defaults the backend to gstream, so switching to Gnome can make the sound work. Thank you very much!

Quote:
Originally Posted by KirkD View Post
Let us know if it works.


---------- Post added at 04:42 PM CST ---------- Previous post was at 04:27 PM CST ----------



---------- Post added at 04:45 PM CST ---------- Previous post was at 04:42 PM CST ----------

Thanks, BugRocks! The sound is back by changing the backend from xine to gsream. But I still get the same results when issuing the two commands you recommended. Definitely something is not right. The sound card in the dell inspiron 6000 is sigma tel stac 975x, previously I can see two audio devices (sigma tel stac and pulseaudio) in "system setting"->"multimedia" (KDE), but I can see only one (internal audio analog stereo) right now.

Quote:
Originally Posted by BugRocks1 View Post
@jbone:

I think but am not sure you have some driver problem there it should have shown a lot more on the dmesg and what it is showing says it is not ready for use(I think).

Last edited by jbone; 28th January 2010 at 01:44 AM.
Reply With Quote
  #11  
Old 28th January 2010, 10:22 PM
rdieter Offline
Community Manager
 
Join Date: Feb 2004
Location: Omaha, NE USA
Age: 43
Posts: 452
linuxfedorakonqueror
A recent phonon update should cure all ills:
https://admin.fedoraproject.org/upda...DORA-2010-1030
https://admin.fedoraproject.org/upda...DORA-2010-1024

making both xine/gstreamer backends much better and usable (esp when used with pulseaudio).
Reply With Quote
  #12  
Old 29th January 2010, 02:32 AM
jbone Offline
Registered User
 
Join Date: Nov 2009
Posts: 13
linuxfedorafirefox
Quote:
Originally Posted by rdieter View Post
A recent phonon update should cure all ills:
https://admin.fedoraproject.org/upda...DORA-2010-1030
https://admin.fedoraproject.org/upda...DORA-2010-1024

making both xine/gstreamer backends much better and usable (esp when used with pulseaudio).
I did 'yum update', now both gstream and xine work. Thanks for your great work on KDE.
Reply With Quote
  #13  
Old 31st January 2010, 05:08 PM
rgaelzer Offline
Registered User
 
Join Date: Oct 2005
Location: Rio Grande do Sul, Brazil
Posts: 136
linuxfedorafirefox
gstreamer backend solved the problem (I think).

Ok. I also have sound back on my Dell Vostro 1500 laptop.
My laptop has the same audio device as KirkD's and the
lspci | grep -i audio
dmesg | grep -iE 'hda|sound'
listings returned pretty much the same results.

What happened with me was that I didn't have the gstreamer backend and simply installing it with yum brought the sound back.
I don't know if it was a kernel update that caused the problem, because at the same time I was trying to make the sound work for skype and kopete (msn).

Although the problem seems to be fixed, I still have some questions:
1. Using KDE, when I open the System Settings app -> Sound and Video Configuration, the only device listed is "Internal Audio Analog Stereo". I'm pretty sure that there were additional audio devices listed. Shouldn't the Intel 82801H audio controller be listed there?

2. On the Backend tab, should I promote GStreamer as the preferred backend then, instead of Xine?

3. Since we are on a multimedia topic, could someone point me to instructions on how to use webcam/audio/microphone with kopete (msn protocol) and skype?

Thank you.
__________________
Rudi Gaelzer
Registered Linux user # 153741
Reply With Quote
Reply

Tags
audio, stopped, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Working in Audio Card but not in audio port !!! gowrishankar Using Fedora 0 6th February 2009 11:43 AM
FC10: Audio suddenly stopped working ajrandall Using Fedora 4 25th January 2009 11:24 PM
M-Audio MobilePre USB Audio Box Stopped Working Since Being Reconnected ConfusedNewb Hardware & Laptops 2 16th December 2007 05:26 AM


Current GMT-time: 21:26 (Saturday, 22-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Calarca Travel Photos on Instagram - Mlowo Travel Photos - Bremerton Photos on Instagram