Fedora Linux Support Community & Resources Center
  #1  
Old 22nd June 2007, 02:25 PM
Chum Offline
Registered User
 
Join Date: Jun 2007
Posts: 2
Problems Installing dsniff, requires libdb.so.3 -- Fedora 7

I've been trying to install dsniff on a lab machine running Fedora 7 but can't get the supplied RPM to install correctly. Output is below when using the rpm linked from dsniff's page (ftp://ftp.falsehope.com/home/gomez/dsniff/):

Code:
[localhost ~]# rpm -i dsniff-2.3-2.i386.rpm

error: Failed dependencies:
        libdb.so.3 is needed by dsniff-2.3-2.i386
        libdb.so.3(GLIBC_2.0) is needed by dsniff-2.3-2.i386
I've also attempted to download the source and compile, but fails during make:

Code:
[localhost dsniff-2.3]# make
gcc -g -O2 -D_BSD_SOURCE -D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD -DHAVE_NET_ETHERNET_H -DDSNIFF_LIBDIR=\"/usr/local/lib/\" -I. -I/usr/local/include      -I./missing -c ./arpspoof.c
./arpspoof.c: In function ‘arp_send’:
./arpspoof.c:49: warning: passing argument 1 of ‘libnet_get_hwaddr’ from incompatible pointer type
./arpspoof.c:49: error: too many arguments to function ‘libnet_get_hwaddr’
./arpspoof.c:60: warning: passing argument 6 of ‘libnet_build_ethernet’ from incompatible pointer type
./arpspoof.c:60: error: too few arguments to function ‘libnet_build_ethernet’
./arpspoof.c:64: error: ‘ETH_H’ undeclared (first use in this function)
./arpspoof.c:64: error: (Each undeclared identifier is reported only once
./arpspoof.c:64: error: for each function it appears in.)
./arpspoof.c:64: error: too few arguments to function ‘libnet_build_arp’
./arpspoof.c: In function ‘main’:
./arpspoof.c:181: warning: assignment makes pointer from integer without a cast
make: *** [arpspoof.o] Error 1
Any suggestions?
Reply With Quote
  #2  
Old 22nd June 2007, 02:53 PM
leadgolem Offline
Registered User
 
Join Date: Apr 2005
Location: Littleton, CO
Age: 32
Posts: 2,857
Not a solution, but this should get you a bit further in compiling. Before you actually run a "make" usually you would want to run a "./configure" from the directory of the source files. Doing that in the dsniff-2.3 folder gave me a few errors about missing stuff. I was able to resolve the first two by using yum to install the devel packages for the missing items.
Code:
yum install db4-devel libpcap-devel
Where I got stuck was with libnids, yum can't find any package mentioning that.

I hope that was helpful.
__________________
S.C.O.U.R.G.E. Heroes of lesser renown, contributor.
Reply With Quote
  #3  
Old 22nd June 2007, 03:25 PM
Chum Offline
Registered User
 
Join Date: Jun 2007
Posts: 2
Thanks for the reply. Should have mentioned that I ran ./configure, but it seemed to finish without issue. I wasn't able to find libnids in yum, but was able to download and compile the sourced version (1.21) -- that seemed to finish properly.

Looking through the ./configure output, I see the following:

Code:
checking for libnids... yes
checking whether libnids version is good... yes
Reply With Quote
  #4  
Old 22nd June 2007, 03:27 PM
leadgolem Offline
Registered User
 
Join Date: Apr 2005
Location: Littleton, CO
Age: 32
Posts: 2,857
That is very odd. I'm using the Fedora 64bit and got a libnids missing error. Oh well, not a utility I really wanted anyway.
__________________
S.C.O.U.R.G.E. Heroes of lesser renown, contributor.
Reply With Quote
Reply

Tags
dsniff, fedora, installing, libdbso3, problems, requires

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing software the requires kernel source FC8 daviddoria Using Fedora 7 8th December 2007 05:28 PM
Installing gcc in FC7 - requires older dependencies maccas17 Installation, Upgrades and Live Media 5 25th September 2007 08:36 PM
Problem installing dsniff ahsan Security and Privacy 8 11th September 2007 10:59 PM
Installed Fedora 3 from harddrive/internet and installing package requires CD disk 1? zeriod Using Fedora 0 22nd February 2005 02:45 AM


Current GMT-time: 06:45 (Tuesday, 25-07-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat