Fedora Linux Support Community & Resources Center
  #16  
Old 4th July 2012, 08:16 AM
gastonv Offline
Registered User
 
Join Date: Nov 2006
Posts: 155
linuxfirefox
Re: Problem google-chrome in FC17

Hello and thanks for your reply.
from that site, I have downloaded, unzipped and "tarred" and copied
libflashplayer.so in /usr/lib/mozilla/plugins

Code:
[gastonv@gastonv 10.3.183.20]$ ls ~/Downloads/fp*
/home/gastonv/Downloads/fp_10.3.183.20_archive.zip
[gastonv@gastonv 10.3.183.20]$ history | grep unzip
  458  unzip fp_10.3.183.20_archive.zip
[gastonv@gastonv 10.3.183.20]$ ls ~/Downloads/
10.3.183.20
10.3.183.20_debug
[root@gastonv 10.3.183.20]# ls
flashplayer_10_3r183_20_linux_sa.tar.gz
flashplayer_10_3r183_20_linux.tar.gz
flashplayer10_3r183_20_mac_intel.dmg
flashplayer10_3r183_20_mac_sa.app.zip
flashplayer10_3r183_20_winax.exe
flashplayer10_3r183_20_win.exe
flashplayer10_3r183_20_win_sa.exe
flashplayer_10_sa.tar.gz
libflashplayer.so
uninstall_flashplayer10_3r183_20_mac_intel.dmg
uninstall_flash_player_win.exe
usr
[root@gastonv 10.3.183.20]# cp libflashplayer.so /usr/lib/mozilla/plugins
[root@gastonv 10.3.183.20]# echo $PATH
/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/opt/real/RealPlayer:/home/gastonv/.local/bin:/home/gastonv/bin:/opt/real/RealPlayer:/opt/real/RealPlayer
[root@gastonv 10.3.183.20]# ls usr
bin  lib  share
[root@gastonv 10.3.183.20]# ls usr/lib
kde4
[root@gastonv 10.3.183.20]# ls usr/bin
flash-player-properties
Starting Google-Chrome for a test of a swf-stream from e.g.
http://www.swr.de/landesschau-rp/hie...nlh/index.html
I see a grey window and I recieve a message (free translated to english):
Code:
Flash is to old
In chrome://plugins I have enabled:
Code:
Flash - Versie: 10.3 r183 Kritieke beveiligingsupdate downloaden
Shockwave Flash 10.3 r183
and disabled:
Code:
VLC Multimedia Plugin (compatible Totem 3.4.2) (Uitgeschakeld)
The Totem 3.4.2 plugin handles video and audio streams.
Shockwave Flash - Versie: 10.1 r999.<br>Gnash 0.8.10, the GNU SWF Player. Copyright (C) 2006, 2007, 2008, 2009, 2010, 2011 <a href="http://www.fsf.org">Free Software Foundation</a>, Inc. <br> Gnash comes with NO WARRANTY, to the extent permitted by law. You may redistribute copies of Gnash under the terms of the <a href="http://www.gnu.org/licenses/gpl.html">GNU General Public License</a>. For more information about Gnash, see <a href="http://www.gnu.org/software/gnash/"> http://www.gnu.org/software/gnash</a>. <br> Compatible Shockwave Flash 10.1 r999. 
VLC Web Plugin (Uitgeschakeld)
Version 2.0.1 Twoflower, copyright 1996-2011 VideoLAN and Authors
http://www.videolan.org/vlc/
In the shell, I see the following:
Code:
[gastonv@gastonv ~]$ google-chrome --disable-bundled-ppapi-flash
Gtk-Message: Failed to load module "pk-gtk-module"
(google-chrome:2281): Pango-CRITICAL **: pango_font_description_set_size: assertion `size >= 0' failed
(google-chrome:2281): Pango-WARNING **: failed to create cairo scaled font, expect ugly output. the offending font is 'Cantarell'
(google-chrome:2281): Pango-WARNING **: font_face status is: no error has occurred
(google-chrome:2281): Pango-WARNING **: scaled_font status is: invalid matrix (not invertible)
(google-chrome:2281): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='Cantarell', text='Nieuw tabblad'
[2281:2281:2245457086:ERROR:CONSOLE(1)] "Uncaught ReferenceError: ntp is not defined", source:  (1)
nvfx_screen_get_param:95 -  Warning: unknown PIPE_CAP 30
nvfx_screen_get_param:95 -  Warning: unknown PIPE_CAP 30
nvfx_screen_get_param:95 -  Warning: unknown PIPE_CAP 55
nvfx_screen_get_param:95 -  Warning: unknown PIPE_CAP 56
nvfx_screen_get_param:95 -  Warning: unknown PIPE_CAP 59
nvfx_screen_get_param:95 -  Warning: unknown PIPE_CAP 58
nvfx_screen_get_param:95 -  Warning: unknown PIPE_CAP 30
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
[2281:2281:2667536298:ERROR:x11_util.cc(1221)] X Error detected: serial 56698, error_code 10 (BadAccess (attempt to access private resource denied)), request_code 140, minor_code 1 (X_ShmAttach)
[2281:2281:2667541523:ERROR:x11_util.cc(1221)] X Error detected: serial 56699, error_code 148 (BadShmSeg (invalid shared segment parameter)), request_code 140, minor_code 3 (X_ShmPutImage)
[2281:2281:2667686454:ERROR:x11_util.cc(1221)] X Error detected: serial 56709, error_code 148 (BadShmSeg (invalid shared segment parameter)), request_code 140, minor_code 2 (X_ShmDetach)

Last edited by gastonv; 4th July 2012 at 08:41 AM.
Reply With Quote
  #17  
Old 4th July 2012, 11:42 AM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: Problem google-chrome in FC17

It works properly here, both in Firefox and Chrome.
I didn't have libflashplayer.so in that zip file so extract flashplayer_10_3r183_20_linux.tar.gz and use the one from there.
vlc (npapi) doesn't interfere with it but the totem plugin does, so remove or disable it.

Chrome just pops-up a bar asking to run the plugin or not, then simply accept that (click to run, NOT to update).
Screenshots:
Firefox http://ompldr.org/vZW4yNg
Chrome http://ompldr.org/vZW4yZA and http://ompldr.org/vZW4yZQ
Reply With Quote
  #18  
Old 4th July 2012, 01:08 PM
gastonv Offline
Registered User
 
Join Date: Nov 2006
Posts: 155
linuxfirefox
Re: Problem google-chrome in FC17

Hello,
In Google Chrome I have done what you have recommended and it runs! Splendid!
Many thanks für the beautiful tip!
Now as one more test, I can run in Google Chrome
http://tvthek.orf.at/live/4270431
but in the shell I see many lines like e.g.
Code:
Failed to open VDPAU backend libvdpau_nouveau.so: can not open divided object file: File or directory did not exist.
Gtk-Message: Failed to load module "pk-gtk-module"
Again many thanks!
Now I can try it in Firefox too.
Reply With Quote
  #19  
Old 4th July 2012, 02:27 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: Problem google-chrome in FC17

If it works, then I think there's no problem.
I don't have those errors because:
- I use the nvidia driver, not nouveau.
- I don't have packagekit installed and I use Xfce, not GNOME.

But you could maybe report a bug for xorg-x11-drv-nouveau if it's not reported yet.
Reply With Quote
  #20  
Old 4th July 2012, 04:36 PM
gastonv Offline
Registered User
 
Join Date: Nov 2006
Posts: 155
linuxfirefox
Re: Problem google-chrome in FC17

I have:
Code:
[gastonv@gastonv ~]$ lspci | grep nVidia
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)
[gastonv@gastonv ~]$ yum list installed | grep nouveau
xorg-x11-drv-nouveau.i686           1:0.0.16-37.20120306gitf5d1cd2.fc17
In FC16 I had installed and worked with Xfce
For installing it, I made:
Code:
[root@gastonv gastonv]# yum groupinstall xfce
Now it will install 29 Packages (+37 Dependent packages)
Should it make a difference for running flash streams in firefox and google-chrome?
I consider to install it again ...
On this moment, in Gnome (not Gnome 3), with Firefox and Google-Chrome I can do all the things I like.
Reply With Quote
  #21  
Old 4th July 2012, 04:41 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: Problem google-chrome in FC17

No it won't make no difference (the packagekit related errors are for installing rpm's, it doesn't affect videos).
Using the nvidia driver (xorg-x11-drv-nvidia-173xx), though, might make some difference.
But if you're satisfied already then just leave it like that and ignore those error messages.
Reply With Quote
  #22  
Old 11th July 2012, 11:26 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxchrome
Re: Problem google-chrome in FC17

The latest update 'solved' the Flash issue.
It automatically disables ppapi Flash for older CPU's.
So we don't need to launch it with --disable-bundled-ppapi-flash anymore.
Reply With Quote
  #23  
Old 13th July 2012, 08:09 AM
gastonv Offline
Registered User
 
Join Date: Nov 2006
Posts: 155
linuxfirefox
Re: Problem google-chrome in FC17

Hello,
Many thanks for the tip.
Yesterday, I have upgraded to:
Code:
 [gastonv@gastonv ~]$ yum list installed | grep google-chrome
google-chrome-stable.i386           20.0.1132.57-145807          @google-chrome
Yesterday, I could successfully start in the shell with:
Code:
 [gastonv@gastonv ~]$ google-chrome
In the shell, I received many messages as before, but Google Chrome runned without any error.
Now today, as a second test, I started from the button and it also runs with the same good result.
In the property of the button, I see:
Code:
 /opt/google/chrome/google-chrome
So, I can also can confirm that the problem is solved.
With all of the plugins on this moment, I am very happy, because I can do some applications in Firefox, other in Google-Crome and still other in Opera.
Code:
 [gastonv@gastonv ~]$ ls /usr/lib/mozilla/plugins
libflashplayer.so                      libtotem-gmp-plugin.so
libgnashplugin.so                      libtotem-mully-plugin.so
libgnome-shell-browser-plugin.so       libtotem-narrowspace-plugin.so
libjavaplugin.so                       libvlcplugin.so
librhythmbox-itms-detection-plugin.so  nphelix.so
libtotem-cone-plugin.so                nphelix.xpt
So, many thanks for the nice communication.
I have stillanother problem with Google Earth, but that is another Thread.
Greetings,
Gaston Verhulst.
Reply With Quote
Reply

Tags
fc17, googlechrome, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with installation of Google chrome chansanle Using Fedora 6 2nd January 2012 07:25 AM
Problem in Google Chrome after uograding to Fedora 15 sumanish Using Fedora 3 3rd June 2011 05:17 PM
Problem on Google chrome chandru1 Using Fedora 7 21st June 2010 10:04 AM
Google Chrome Access Problem nlhma Using Fedora 2 23rd April 2010 11:28 PM
Problem In Installing google chrome in fedora 12 kodinbk Using Fedora 2 1st February 2010 06:53 PM


Current GMT-time: 18:55 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat