Fedora Linux Support Community & Resources Center
  #1  
Old 12th October 2009, 08:23 PM
john_erlandsson Offline
Registered User
 
Join Date: Oct 2009
Location: Sweden
Posts: 37
windows_xp_2003firefox
[SOLVED]nvidia and kernel questions

Hi!

I am new to linux, and ave been running fedora 11 for a while...
After installing google earth i realized that i did not have any drivers installed for my Geeforce 8800GT graphic card.

After a bit of googeling i found that i needed to install the kmod-nvidia package. But when installing the package with yum and rebooting the computer it fails to start kde and gets stuck with a black screen.

I can still boot from an old kernel but the latest one wont work even after removing the kmod-nvidia package.

since i had a couple of old kernels left, i tried installing the driver again on one of them. This time i choosed the kmod-nvidia which had the same version number as my kernel (the one i tried first was simply called "kmod-nvidia"). But the result was the same as before.

So my questions are:

what went wrong?

Can i simply yum remove the broken kernel and install it again without any problems?

Is it better to download the driver from nvidia.com rather than getting it from the repository?


Appreciate any help...


//John

Last edited by john_erlandsson; 18th October 2009 at 08:12 PM.
Reply With Quote
  #2  
Old 12th October 2009, 08:31 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
linuxfedorafirefox
one mistake i made once was not installing kmod-nvidia-PAE

if you just try to install kmod-nvidia, it wont work

just make sure you are using a PAE kernel first

this might help
__________________
Processor: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
Memory: 16GB
OpenGL Renderer: GeForce GTX 550 Ti/PCIe/SSE2
Operating System: Fedora release 20 (Heisenbug)
Desktop Environment: KDE 4.1.12
Reply With Quote
  #3  
Old 12th October 2009, 08:40 PM
john_erlandsson Offline
Registered User
 
Join Date: Oct 2009
Location: Sweden
Posts: 37
windows_xp_2003firefox
just found this tutorial... The akmod seems like a good idea. Will try this once i get the latest kernel working again....

I am running the standard kernel

Last edited by john_erlandsson; 12th October 2009 at 08:46 PM.
Reply With Quote
  #4  
Old 12th October 2009, 10:27 PM
twohot Offline
Registered User
 
Join Date: Jun 2009
Location: 9ja://coalcity
Posts: 254
linuxfedorafirefox
Sorry john_erlandsson, from my experience, removing and reinstalling the kernel gets you nowhere. It seems some configuration files that were created during the installation remain unchanged after the kernel has been renewed. Essentially, dependent packages still think you have the old kernel and behave accordingly.

I suspect the kmod-nvidia driver is created from driver codes supplied by nVidia developers -- the installation scripts on their sites repeat the same failure pattern and will report alteration on a reinstalled kernel (it doesn't know its a clean install). One advice though: If you do get your Card working with the kmod or nvidia scripts, don't perform any installs that will relocate or adjust your xorg.conf significantly. Its fatal.

Right now, I'm anxious to see 3D acceleration implemented by the Nouveau driver from fedora developers. That looks, to me, like the solution that will set most people at ease.

Last edited by twohot; 12th October 2009 at 10:31 PM.
Reply With Quote
  #5  
Old 13th October 2009, 01:22 AM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 47
Posts: 3,936
linuxfedorafirefox
you might want to search for my posts on the kernel and nvidia issue ( there are 3 with 5 pointing )
change "nvidia"in xorg.conf to "nv " and then install the kmod then rename the driver back to nvidia .
__________________
OpenSUSE 13.1-64bit & Scientific Linux 6.5-64bit ( fedora 4 to 11) and 19/20 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #6  
Old 13th October 2009, 09:28 PM
john_erlandsson Offline
Registered User
 
Join Date: Oct 2009
Location: Sweden
Posts: 37
windows_xp_2003firefox
Thank you for replying. I am out on field work for the rest of this week. But now i have some ideas to work with when i get home.

I have not installed the kernel-devel & kernel-headers. Will try that. Is there any way of booting up without starting X? Would be nice to keep working with the broken kernel instead of destroying the last working one i have...

//John
Reply With Quote
  #7  
Old 18th October 2009, 08:11 PM
john_erlandsson Offline
Registered User
 
Join Date: Oct 2009
Location: Sweden
Posts: 37
linuxfedorafirefox
Installed the PAE kernel and followed the tutorial... Worked like a charm. GoogleEarth and SweetHome3D is smooth as silk.


Thank you.


//John
Reply With Quote
Reply

Tags
kernel, nvidia, questions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver version / nvidia kernel conflict Wangberg Using Fedora 16 13th June 2007 09:57 AM
FC6, nVidia and SLI (a few questions) BassBlu Using Fedora 23 17th November 2006 10:48 PM
Questions regarding Nvidia and ltmodem bigboss2200 Using Fedora 0 1st September 2006 01:14 PM
yum install nvidia-glx kernel-module-nvidia-`(uname -r)` DIDN'T WORK :( jmachine Using Fedora 16 14th July 2005 08:57 PM
Questions about KDE 3.2 & K3b + Nvidia svarreby Fedora Core 2 Test Releases 4 28th February 2004 02:04 AM


Current GMT-time: 04:03 (Monday, 15-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat