Fedora Linux Support Community & Resources Center
  #1  
Old 8th June 2011, 10:29 AM
Greken Offline
Registered User
 
Join Date: May 2011
Posts: 4
linuxfedorafirefox
libGL issue with Maya and Fedora 14

Hi everyone!

I'm very new to Linux and have just made my very first install-from-scratch of a Linux distro. Fedora 14 in this case. I would almost get impressed by myself if it wasn't for this troublesome issue that I have right now:

If I open Maya 2009 or Maya 2012 (the only installs that I have of that app) and press "New scene" (or open any scene)Maya will just close itself down. No warnings. No drama.

I have already done the basics by removing all prefs and it did not work. So, in order to get further information, I ran it through gdb:

Code:
Program received signal SIGSEGV, Segmentation fault.
0x00000038b58775ea in ?? () from /usr/lib64/nvidia/libGL.so.1
Missing separate debuginfos, use: debuginfo-install Maya2009_0_64-2009.0-452.x86_64
This gave me two leads: libGL and debuginfo-install.

Lead #1: debuginfo-install
When executing the line below, it results in the error "Could not find debuginfo for main pkg: Maya2009_0_64-2009.0-452.x86_64. No debuginfo packages available to install":

Code:
debuginfo-install Maya2009_0_64-2009.0-452.x86_64
Since Maya is a commercial product I don't think Fedora could store any info in their own repositories. Maya was installed using a rpm-file. Does rpm have such a feature so it can look inside the rpm package for "debuginfo"?

Lead #2: libGL
I should mention what I have configured in Fedora 14 so far:

The Nouveau drivers are disabled, since they do not work very well with Maya and similar commercial applications.
The Nvidia drivers were installed in two steps (with a reboot between each line):

Code:
yum update kernel*
yum install akmod-nvidia.x86_64 xorg-x11-drv-nvidia-libs.x86_64
Additional infos
This is the hardware I have been using:
CPU: Intel Core i7 990X (3,4 GHz)
Graphics: Nvidia Quadro FX 3800

It might be worth mention that I did an "update" once by clicking the bug icon that appeared in Fedora which installed 300+ updates to different packages/libraries. It DID mess up my host file so I couldn't resolve this machine's IP address so it wouldn't suprise me if it has done something else.

Does anyone have any suggestions on what more I could try?

Update 1#: mesa-OpenGL
I totally forgot to read through the install documentation before posting here. I found this in the manual:

"Some distributions include the system OpenGL driver mesa-GL, which is not ideal for running Maya. Maya is a 64-bit application and requires a 64-bit OpenGL 3D-accelerated driver for best performance."

The manual suggested that I could try read the upper part of the glxinfo in order to see what I was using. And of what I could find, this looks right:

Code:
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro FX 3800/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 260.19.36
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
Since I also kept a log of all modifications that I have made in Fedora 14, I double-checked with it as well. Nothing that would say that I have installed mesa-GL. But to be triple sure, I ran this command:

Code:
yum info mesa-libGL.x86_64
And that command told me that it's installed. So does that mean that it's used then? Or is there a safer way of checking which OpenGL is used?

Last edited by Greken; 8th June 2011 at 10:51 AM. Reason: Added research updates
Reply With Quote
  #2  
Old 10th June 2011, 09:28 AM
Greken Offline
Registered User
 
Join Date: May 2011
Posts: 4
linuxfedorafirefox
Re: libGL issue with Maya and Fedora 14

Okay, I have figured out why I even had mesa-libGL.x86_64 installed. It's because wxPython has it as dependency when I installed it using yum.

As soon as I removed mesa-libGL.x86_64 Maya worked again. But by removing mesa-libGL.x86_64 it removed several dependencies that I still need (among them two mesa-devel packages)..

Will report back to this thread once I have solved this mess.

---------- Post added at 10:28 AM ---------- Previous post was at 10:14 AM ----------

As I understand it, yum does not remove a single package without taking the dependencies into the account. So I had to solve it using rpm:

Code:
rpm -e --nodeps mesa-libGL-7.9-5.fc14.x86_64
I don't know if this might break something else in the system, but at least currently I do not use OpenGL with wxPython so I'm fine with this =)

This solves my problem and I hope it will help someone else in the future!!
Reply With Quote
  #3  
Old 25th February 2013, 07:34 AM
quaam Offline
Registered User
 
Join Date: Feb 2013
Location: California
Posts: 1
linuxchrome
Re: libGL issue with Maya and Fedora 14

Thank you! This has helped me with the very same problem on Fedora 15
Reply With Quote
  #4  
Old 22nd May 2013, 08:43 AM
focusgfx Offline
Registered User
 
Join Date: May 2013
Location: Egypt
Posts: 2
linuxchrome
Re: libGL issue with Maya and Fedora 14

thank you, your post solved my problem too, thanks again
maya 2014 and fedora 18
Reply With Quote
  #5  
Old 12th September 2013, 09:42 PM
focusgfx Offline
Registered User
 
Join Date: May 2013
Location: Egypt
Posts: 2
linuxchrome
Re: libGL issue with Maya and Fedora 14

I've found another solution without disabling the mesa-libGL
what I did is, I copied the all the files inside blender/lib folder to maya/lib folder and maya worked perfectly!
I know that it's weird but it worked )
[blender 2.68a]
maya 2014 and fedora 19-x86_64
Reply With Quote
Reply

Tags
64 bit, fedora 14, libgl, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Maya 2011 on Fedora 14 chk2033 Using Fedora 3 13th December 2010 01:12 AM
Maya 8.5 on Fedora? Thetargos Fedora Focus 14 27th September 2007 08:24 AM
mesa-libGL SELinux-related issue? robatino Using Fedora 8 3rd August 2007 05:50 AM
Maya 7 crashes on Fedora 6 Negatratoron Using Fedora 2 28th November 2006 12:34 AM


Current GMT-time: 12:40 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Pemalang Photos - Balch Springs - Ariquemes Instagram Photos