Fedora Linux Support Community & Resources Center
  #31  
Old 29th February 2012, 12:53 PM
gustavokrm Offline
Registered User
 
Join Date: Sep 2011
Posts: 16
linuxfirefox
Re: F16 - Bumblebee

So, I was finally successful in installing Bumblebee on Fedora 16. At last!
The only problem is that I have to disable the card manually each time. I still hasn't been able to automate the process. I guess I will have to run through the process again later today. I will let you know if it works. Maybe I am missing something..
Reply With Quote
  #32  
Old 1st March 2012, 01:43 AM
sbjaved Offline
Registered User
 
Join Date: Oct 2007
Location: Gujranwala, Pakistan
Posts: 46
linuxchrome
Re: F16 - Bumblebee

I followed the instructions on fedora wiki.

Here are some commandline outputs:

Quote:
[saad@saad-dell-xps-15 ~]$ dmesg | grep bbswitch
[ 6933.907951] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[ 6933.907961] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[ 6933.908139] bbswitch: detected an Optimus _DSM function
[ 6933.908144] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[ 7031.147048] bbswitch: disabling discrete graphics
[ 7031.147213] bbswitch: Result of Optimus _DSM call: 11000059


[saad@saad-dell-xps-15 Bumblebee]$ sudo cat /proc/acpi/bbswitch
0000:01:00.0 OFF

[ 8772.261362] bbswitch: disabling discrete graphics
[ 8772.261744] bbswitch: Result of Optimus _DSM call: 11000059
[ 8772.272925] pci 0000:01:00.0: Refused to change power state, currently in D0
[ 8772.307069] pci 0000:01:00.0: power state changed by ACPI to D3

[saad@saad-dell-xps-15 Bumblebee]$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
299 frames in 5.0 seconds = 59.796 FPS

[saad@saad-dell-xps-15 Bumblebee]$ optirun glxgears
1144 frames in 5.0 seconds = 228.656 FPS
Thank you Bumblebee Devs! (im running f16 on dell xps 15)

Now whats the proper way to get it to load at startup? I only followed the wiki instructions...didn't create any bbswitch.conf or run dkms. There is a bumblebee.service file in the bumblebee folder under scripts/systemmd...

Ok i followed ragib's instructions. Built bbswitch module into kernel with dkms and created a bbswitch.conf file under modules.d. Added bumblebeed.service to systemmd dir. It works at boot

But i think the module was built for one specific kernel only (3.2.7-1.fc16.x86_64). When i update the kernel, I'll have to build and install bbswitch again...right?

Last edited by sbjaved; 1st March 2012 at 02:18 AM.
Reply With Quote
  #33  
Old 1st March 2012, 08:04 PM
ragib Offline
Registered User
 
Join Date: Jan 2012
Location: Malaysia
Posts: 12
linuxfirefox
Re: F16 - Bumblebee

Quote:
But i think the module was built for one specific kernel only (3.2.7-1.fc16.x86_64). When i update the kernel, I'll have to build and install bbswitch again...right?
I could be wrong but, if you installed bbswitch using DKMS, it will be rebuilt automatically after each kernel update. I installed once on my laptop, and had several kernel updates after that. Still working.
http://en.wikipedia.org/wiki/Dynamic...Module_Support
Do google some more to find out more about this.
Reply With Quote
  #34  
Old 6th March 2012, 12:40 AM
twchambers Online
Registered User
 
Join Date: Jan 2012
Location: Watford
Posts: 17
linuxchrome
Re: F16 - Bumblebee

Thanks ragib. As a result of your clear instructions I now have bumblebee and the optirun command working effectively on my laptop.

Unfortunately, the glxgears frame rate results are a little less than satisfactory.

Code:
[thomas@optimus ~]$ optirun glxgears
1211 frames in 5.0 seconds = 242.171 FPS
1209 frames in 5.0 seconds = 241.732 FPS
1219 frames in 5.0 seconds = 243.662 FPS
1202 frames in 5.0 seconds = 240.370 FPS
1206 frames in 5.0 seconds = 241.182 FPS
1204 frames in 5.0 seconds = 240.618 FPS
1205 frames in 5.0 seconds = 240.937 FPS
1198 frames in 5.0 seconds = 239.575 FPS
(GT555M 2GB)

I assume that this is due to the nouveau drivers, but could it be a result of a mistake in my installation?

Finally, has anyone got this to work with the propitiatory drivers yet? I would really love to be able to get the >1000 fps in glxgears that I think I should.
Reply With Quote
  #35  
Old 6th March 2012, 03:23 AM
ragib Offline
Registered User
 
Join Date: Jan 2012
Location: Malaysia
Posts: 12
linuxfirefox
Re: F16 - Bumblebee

Quote:
Unfortunately, the glxgears frame rate results are a little less than satisfactory.
The next thing that you could try is to test optirun with different image transport mode. Have you tried the following commands yet?

Quote:
Have u tried these yet? Which one gives highest FPS?

optirun -c proxy glxgears
optirun -c rgb glxgears
optirun -c yuv glxgears
optirun -c xv glxgears
optirun -c jpeg glxgears

optirun -c proxy glxgears -fullscreen
optirun -c rgb glxgears -fullscreen
optirun -c yuv glxgears -fullscreen
optirun -c xv glxgears -fullscreen
optirun -c jpeg glxgears -fullscreen

my laptop gives highest FPS on rgb. had to set it to default by editing bumblebee.conf
Reply With Quote
  #36  
Old 6th March 2012, 03:51 PM
twchambers Online
Registered User
 
Join Date: Jan 2012
Location: Watford
Posts: 17
windows_xp_2003ie
Re: F16 - Bumblebee

Thank you again. Tried those commands and as with yours works best using rgb. Comes in at around 500 fps compared to the 230-ish of all the other modes.
Have you tried the bumblebee-ui package at all yet? Will try downloading and using that later tonight, and maybe the optidesk utility too.
Only issue I have at the moment is that for some reason the laptop boots with the nVidia GPU running. Using optirun and then terminating the application causes it to then switch back to just Intel. I'm sure it's my error in setting up somewhere.
Would still love to be able to use the nVidia drivers with this as opposed to the open ones but it's good for now and gives me longer battery life and stops the laptop burning up!
Reply With Quote
  #37  
Old 7th March 2012, 07:09 AM
ragib Offline
Registered User
 
Join Date: Jan 2012
Location: Malaysia
Posts: 12
linuxfirefox
Re: F16 - Bumblebee

Quote:
Only issue I have at the moment is that for some reason the laptop boots with the nVidia GPU running. Using optirun and then terminating the application causes it to then switch back to just Intel. I'm sure it's my error in setting up somewhere.
About that,
Quote:
for bbswitch :

sudo echo bbswitch load_state=0 unload_state=1 > /etc/modules-load.d/bbswitch.conf
If this part is configured properly, each time the module bbswitch is loaded at boot, it should turn off your Nvidia card. So, check out that file's content.
Code:
sudo cat /etc/modules-load.d/bbswitch.conf
After booting, what is the output of the following?
Code:
sudo cat /proc/acpi/bbswitch 
[sudo] password for user: 
0000:01:00.0 OFF
Reply With Quote
  #38  
Old 7th March 2012, 12:46 PM
twchambers Online
Registered User
 
Join Date: Jan 2012
Location: Watford
Posts: 17
windows_xp_2003ie
Re: F16 - Bumblebee

Made sure that I did the step for bbswitch and
Code:
sudo cat /etc/modules-load.d/bbswitch.conf
does indeed produce bbswitch load_state=0 unload_state=1

After boot I get
Code:
sudo cat /proc/acpi/bbswitch 
[sudo] password for user: 
0000:01:00.0 ON
Reply With Quote
Reply

Tags
bumblebee, f16

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Current GMT-time: 22:24 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Bagua Grande - Huilong - Bloomingdale