Fedora Linux Support Community & Resources Center
Old 18th December 2013, 12:01 AM
1namu Offline
Registered User
Join Date: Oct 2012
Location: Earth
Posts: 8
Unable to ssh or ping workstation remotely

After I installed a new motherboard, I am unable to ssh or ping my workstation from my laptop. I was able to do so with the old motherboard.

Trying to ssh from my laptop to my workstation:

  ssh -v namu@mahavira.mech.northwestern.edu 
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to mahavira.mech.northwestern.edu [] port 22.
    debug1: connect to address port 22: Connection timed out
    ssh: connect to host mahavira.mech.northwestern.edu port 22: Connection timed out
Trying to ping workstation (mahavira) from my laptop:

ping mahavira.mech.northwestern.edu
    PING mahavira.mech.northwestern.edu ( 56(84) bytes of data.
    --- mahavira.mech.northwestern.edu ping statistics ---
    182 packets transmitted, 0 received, 100% packet loss, time 181365ms
I can ping and ssh fine from my workstation (mahavira). The issue is not with my laptop, for I tried accessing my workstation from other computers also and experienced the same problem.

I don't know how to resolve this issue, but here is some more information about my workstation:

Output of lsmod | grep iptable:

  lsmod | grep iptable
    iptable_nat            13011  1 
    nf_nat_ipv4            13199  1 iptable_nat
    nf_nat                 25642  3 ipt_MASQUERADE,nf_nat_ipv4,iptable_nat
    iptable_mangle         12695  1 
    nf_conntrack           86438  9 nf_conntrack_netbios_ns,ipt_MASQUERADE,nf_nat,nf_nat_ipv4,xt_conntrack,nf_conntrack_broadcast,iptable_nat,nf_conntrack_ipv4,nf_conntrack_ipv6
Output of ps -ef | grep ssh:

ps -ef | grep ssh
    root     26809     1  0 16:20 ?        00:00:00 /usr/sbin/sshd -D
    namu     27251 27186  0 16:31 pts/5    00:00:00 ssh nkp053@quest.it.northwestern.edu
    root     27541 27077  0 16:44 pts/3    00:00:00 grep --color=auto ssh
Output of cat /etc/ssh/sshd_config:
 cat /etc/ssh/sshd_config
    #	$OpenBSD: sshd_config,v 1.87 2012/07/10 02:19:15 djm Exp $
    # This is the sshd server system-wide configuration file.  See
    # sshd_config(5) for more information.
    # This sshd was compiled with PATH=/usr/local/bin:/usr/bin
    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented.  Uncommented options override the
    # default value.
    # If you want to change the port on a SELinux system, you have to tell
    # SELinux about this change.
    # semanage port -a -t ssh_port_t -p tcp #PORTNUMBER
    #Port 22
    #AddressFamily any
    #ListenAddress ::
    # The default requires explicit activation of protocol 1
    #Protocol 2
    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key
    #HostKey /etc/ssh/ssh_host_ecdsa_key
    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 1024
    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    SyslogFacility AUTHPRIV
    #LogLevel INFO
    # Authentication:
    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6
    #MaxSessions 10
    #RSAAuthentication yes
    #PubkeyAuthentication yes
    # The default is to check both .ssh/authorized_keys and .ssh/authorized_keys2
    # but this is overridden so installations will only check .ssh/authorized_keys
    AuthorizedKeysFile	.ssh/authorized_keys
    #AuthorizedKeysCommand none
    #AuthorizedKeysCommandUser nobody
    #AuthorizedPrincipalsFile none
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes
    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no
    PasswordAuthentication yes
    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes
    ChallengeResponseAuthentication no
    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no
    #KerberosUseKuserok yes
    # GSSAPI options
    #GSSAPIAuthentication no
    GSSAPIAuthentication yes
    #GSSAPICleanupCredentials yes
    GSSAPICleanupCredentials yes
    #GSSAPIStrictAcceptorCheck yes
    #GSSAPIKeyExchange no
    # Set this to 'yes' to enable PAM authentication, account processing, 
    # and session processing. If this is enabled, PAM authentication will 
    # be allowed through the ChallengeResponseAuthentication and
    # PasswordAuthentication.  Depending on your PAM configuration,
    # PAM authentication via ChallengeResponseAuthentication may bypass
    # the setting of "PermitRootLogin without-password".
    # If you just want the PAM account and session checks to run without
    # PAM authentication, then enable this but set PasswordAuthentication
    # and ChallengeResponseAuthentication to 'no'.
    # WARNING: 'UsePAM no' is not supported in Fedora and may cause several
    # problems.
    #UsePAM no
    UsePAM yes
    #AllowAgentForwarding yes
    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    UsePrivilegeSeparation sandbox		# Default for new installations.
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #ShowPatchLevel no
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10:30:100
    #PermitTunnel no
    #ChrootDirectory none
    #VersionAddendum none
    # no default banner path
    #Banner none
    # Accept locale-related environment variables
    AcceptEnv XMODIFIERS
    # override default of no subsystems
    Subsystem	sftp	/usr/libexec/openssh/sftp-server
    # Uncomment this if you want to use .local domain
    #Host *.local
    #	CheckHostIP no
    # Example of overriding settings on a per-user basis
    #Match User anoncvs
    #	X11Forwarding no
    #	AllowTcpForwarding no
    #	ForceCommand cvs server

I have a flight tomorrow and need to access my workstation remotely. Please do help me resolve this problem tonight.
Reply With Quote
Old 18th December 2013, 12:12 AM
ocratato Offline
Registered User
Join Date: Oct 2010
Location: Canberra
Posts: 1,960
Re: Unable to ssh or ping workstation remotely

Can we assume that your new motherboard includes a new NIC ?

If so, then your workstation has a new MAC address, so you will need to ensure the network routers have been updated to reflect this.
Don't tell me "The sky is the limit" when there are footprints on the moon.
Reply With Quote
Old 18th December 2013, 03:30 AM
1namu Offline
Registered User
Join Date: Oct 2012
Location: Earth
Posts: 8
Re: Unable to ssh or ping workstation remotely

Originally Posted by ocratato View Post
Can we assume that your new motherboard includes a new NIC ?

If so, then your workstation has a new MAC address, so you will need to ensure the network routers have been updated to reflect this.
My motherboard was replaced by the same type & make so the NIC is not an issue. I did update the ifconfig-eth1 file with the new MAC address. Without this step, I was unable to connect to the internet. Now I am able to connect to the internet. From my workstation, I can ssh into other machines just fine. I cannot ssh into the workstation from other computers.
Reply With Quote
Old 18th December 2013, 10:19 AM
GarethTheRed Offline
Registered User
Join Date: May 2011
Location: Yorkshire, UK
Posts: 106
Re: Unable to ssh or ping workstation remotely

Have you tried temporarily stopping the firewall on your workstation?
sudo service iptables stop
If that allows ssh, then it's a firewall issue. Why you'd have a firewall issue after changing the motherboard is a different question altogether!
Computing is just a fad - it'll never catch on.
Reply With Quote

ping, remotely, ssh, unable, workstation

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
running Programs Remotely via ssh (slightly different) Cassanova Using Fedora 4 21st March 2009 01:40 AM
Executing applications remotely with SSH? ravellian Servers & Networking 4 3rd November 2006 01:44 PM
SSH Remotely kingjoshy Using Fedora 16 22nd December 2005 09:17 AM
PING - unable to ping from outside of my network defragmented Servers & Networking 1 6th February 2005 06:29 PM
Installing KDE remotely via SSH Ideal Disaster Using Fedora 5 5th November 2004 07:43 PM

Current GMT-time: 15:45 (Wednesday, 07-10-2015)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat