Fedora Linux Support Community & Resources Center
  #1  
Old 17th April 2017, 09:00 PM
fallenstar Offline
Registered User
 
Join Date: Mar 2012
Location: Leicester, UK
Posts: 11
linuxfedorachrome
Openvpn 2.4 won't start

I run the usual command to start openvpn but since the upgrade to 2.4 it throws up an error message:

Code:
sudo openvpn /etc/openvpn/my_expressvpn_uk_-_london_udp1.ovpn 
[sudo] password for phoenix: 
Options error: Unrecognized option or missing or extra parameter(s) in /etc/openvpn/my_expressvpn_uk_-_london_udp1.ovpn:16: tls-remote (2.4.1)
Use --help for more information.
I have fixed it by downgrading to 2.3 but it is not a permanent fix.

Any ideas?
Reply With Quote
  #2  
Old 17th April 2017, 09:40 PM
wolfred Offline
Registered User
 
Join Date: Apr 2014
Location: Brooklyn
Posts: 46
linuxfedorafirefox
Re: Openvpn 2.4 won't start

Look in line 16 of my_expressvpn_uk_-_london_udp1.ovpn the ouput you posted says something is missing on that line.
you need to put your tls auth in pem format between these.
Code:
<tls-auth>
</tls-auth>
Reply With Quote
  #3  
Old 18th April 2017, 09:58 AM
fallenstar Offline
Registered User
 
Join Date: Mar 2012
Location: Leicester, UK
Posts: 11
linuxfedorachrome
Re: Openvpn 2.4 won't start

these are lines 15 - 17

tls-client
tls-remote server
ns-cert-type server

what should I do with it?

thanks
Reply With Quote
  #4  
Old 18th April 2017, 04:45 PM
wolfred Offline
Registered User
 
Join Date: Apr 2014
Location: Brooklyn
Posts: 46
linuxfedorafirefox
Re: Openvpn 2.4 won't start

I don't see tls-remote server in the openvpn man page, can you post where you saw that, I might have old documents :-(

I see tls-server but that goes in the server configs. Instead of tls-remote ip/hostname try remote ip/hostname

I got this from the openvpn man page and https://community.openvpn.net/openvp...tartedwithOVPN

Last edited by wolfred; 18th April 2017 at 05:05 PM.
Reply With Quote
  #5  
Old 18th April 2017, 05:56 PM
fallenstar Offline
Registered User
 
Join Date: Mar 2012
Location: Leicester, UK
Posts: 11
linuxfedorachrome
Re: Openvpn 2.4 won't start

this is from the script my_expressvpn.....etc

the first few lines are:

dev tun
fast-io
persist-key
persist-tun
replay-persist cur-replay-protection.cache
nobind
remote europe-cluster.expressnetwork.net 1194
remote uk-cluster.expressnetwork.net 1194
remote uk-cluster2.expressnetwork.net 1194
remote uk-cluster3.expressnetwork.net 1194
remote uk-cluster4.expressnetwork.net 1194
remote-random
pull
comp-lzo
tls-client
tls-remote server
ns-cert-type server
verb 3
key-direction 1
route-method exe
route-delay 2
tun-mtu 1500
fragment 1300
mssfix 1450
Reply With Quote
  #6  
Old 18th April 2017, 06:06 PM
fallenstar Offline
Registered User
 
Join Date: Mar 2012
Location: Leicester, UK
Posts: 11
linuxfedorachrome
Re: Openvpn 2.4 won't start

Ok, apparently ExpressVPN now have a Terminal based linux app so I don't need to run openvpn now. It works.

Thanks though
Reply With Quote
  #7  
Old 18th April 2017, 06:49 PM
wolfred Offline
Registered User
 
Join Date: Apr 2014
Location: Brooklyn
Posts: 46
linuxfedorafirefox
Re: Openvpn 2.4 won't start

Comment some lines out as a test. I left tls-client on assuming that tls-server is on the server side and it is properly configured.

dev tun
#fast-io
persist-key
persist-tun
replay-persist cur-replay-protection.cache
nobind
remote europe-cluster.expressnetwork.net 1194
remote uk-cluster.expressnetwork.net 1194
remote uk-cluster2.expressnetwork.net 1194
remote uk-cluster3.expressnetwork.net 1194
remote uk-cluster4.expressnetwork.net 1194
remote-random
pull
comp-lzo
tls-client
#tls-remote server
ns-cert-type server
verb 3
key-direction 1
route-method exe
route-delay 2
tun-mtu 1500
fragment 1300
#mssfix 1450
Reply With Quote
Reply

Tags
openvpn, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenVPN server won't start automatically computersavvy Servers & Networking 3 31st December 2016 09:57 PM
NM-Manager wont start OpenVPN majestyx Servers & Networking 0 9th January 2012 03:45 PM
[OpenVPN] client start without entering username GerritG5 Servers & Networking 0 26th May 2010 02:45 PM
f-12 openvpn server does not start at boot perazim Servers & Networking 6 28th November 2009 03:19 PM
Why my OpenVPN service can't start up ? yu xintian Using Fedora 1 24th November 2009 10:16 AM


Current GMT-time: 05:29 (Tuesday, 30-05-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat