Fedora Linux Support Community & Resources Center
  #1  
Old 16th April 2017, 04:14 PM
inga1 Offline
Registered User
 
Join Date: Feb 2011
Posts: 7
linuxfedorafirefox
norwegian keyboard not recognised

I have recently installed fedora 25. I am not entirely sure that I chose the right keyboard during installation, but I used the system-config-keyboard command to change into Norwegian and the localectl command produces the following
System Locale: LANG=en_US.UTF-8
VC Keymap: no
X11 Layout: no
X11 Model: pc105
(I tried to change the LANG as well but was told that Norwegian varieties were unknown.)
Any advice on how to get the right keyboard setting is most welcome
Reply With Quote
  #2  
Old 16th April 2017, 05:11 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,560
linuxchrome
Re: norwegian keyboard not recognised

Somewhat dated, but some of the information in this posting may help you out.
Reply With Quote
  #3  
Old 16th April 2017, 05:25 PM
lsatenstein Online
Registered User
 
Join Date: Jun 2005
Location: Montreal, Que, Canada
Posts: 4,024
linuxfedorafirefox
Re: norwegian keyboard not recognised

If using Gnome it is a two step opeation,

1) systemtray=>Regional Settings and Language => add your keyboard and set the language.
2) systemtray=>keyboard=>settings (you need to scroll down and choose the rule for keyboard switching.
I use two rules (menu and win+space ). I use two layouts ca (for French Canada) and en for USA/Canada English

Try that, it should do the job.
__________________
Leslie in Montreal

Interesting web sites list
http://forums.fedoraforum.org/showth...40#post1697840
Reply With Quote
  #4  
Old 16th April 2017, 06:39 PM
inga1 Offline
Registered User
 
Join Date: Feb 2011
Posts: 7
linuxfedorafirefox
Re: norwegian keyboard not recognised

Thank you, but I have already tried those options. It seems like the computer thinks it is using the Norwegian keyboard while it is not.
Reply With Quote
  #5  
Old 17th April 2017, 02:17 AM
gordon64
Guest
 
Posts: n/a
linuxfirefox
Re: norwegian keyboard not recognised

simple things first as I am simple heh heh
Quote:
System Locale: LANG=en_US.UTF-8
are you wanting American English?

Code:
localectl list-locales | grep NO
nb_NO
nb_NO.iso88591
nb_NO.utf8
nn_NO
nn_NO.iso88591
nn_NO.utf8
no_NO
no_NO.ISO-8859-1
se_NO
se_NO.utf8
try changing to your native lang as per
https://docs.fedoraproject.org/en-US...iguration.html

so try

Code:
su
localectl set-locale LANG=nb_NO.utf8
reboot
on reboot report output for
Code:
locale
cat /etc/vconsole.conf
I don't speak Nor* but there is
Code:
localectl list-keymaps
that suggests

Code:
su
localectl set-keymap no
localectl set-x11-keymap no
reboot

Last edited by gordon64; 17th April 2017 at 02:29 AM.
Reply With Quote
  #6  
Old 17th April 2017, 11:10 AM
inga1 Offline
Registered User
 
Join Date: Feb 2011
Posts: 7
linuxfedorafirefox
Re: norwegian keyboard not recognised

Thank you.
Here are the outputs>
[inga@localhost ~]$ locale
LANG=nb_NO.UTF-8
LC_CTYPE="nb_NO.UTF-8"
LC_NUMERIC=nn_NO.UTF-8
LC_TIME=nn_NO.UTF-8
LC_COLLATE="nb_NO.UTF-8"
LC_MONETARY=nn_NO.UTF-8
LC_MESSAGES="nb_NO.UTF-8"
LC_PAPER=nn_NO.UTF-8
LC_NAME="nb_NO.UTF-8"
LC_ADDRESS="nb_NO.UTF-8"
LC_TELEPHONE="nb_NO.UTF-8"
LC_MEASUREMENT=nn_NO.UTF-8
LC_IDENTIFICATION="nb_NO.UTF-8"
LC_ALL=
[inga@localhost ~]$ cat /etc/vconsole.conf
KEYMAP=no
FONT=eurlatgr

...all I want is for the computer to recognise the characters on my keyboard
Reply With Quote
  #7  
Old 18th April 2017, 02:12 AM
gordon64
Guest
 
Posts: n/a
linuxfirefox
Re: norwegian keyboard not recognised

that is tricky.

what does
Code:
localectl status
setxkbmap -query | grep layout
now show please?

the bottom command looks for the main layout and its variant.
The bottom one is likely to show us,us but not sure what your top command is going to show.

2) I found an old bug and work a round
https://bugs.launchpad.net/ubuntu/+s...s/+bug/1284635

delete your .config/ibus dir
log out and log back in to test

3) if that fails then try
Code:
sudo setxkbmap -layout no
this is a session only type fix but I could find nothing useful in "journalctl -b"

FYI
doing it for me with an US international kb....I set it to gb and the # changed to
Reply With Quote
  #8  
Old 18th April 2017, 06:43 PM
inga1 Offline
Registered User
 
Join Date: Feb 2011
Posts: 7
linuxfedorafirefox
Re: norwegian keyboard not recognised

Thank you, Gordon. The first command produced the same output as the localectl command shown above. Both the setxkbmap commands gave:
No protocol specified Cannot open display ":0"
Removing the .config/ibus directory didn't work, either.
Reply With Quote
  #9  
Old 19th April 2017, 01:03 AM
gordon64
Guest
 
Posts: n/a
linuxfirefox
Re: norwegian keyboard not recognised

OOPS

I was on xorg during those x kb commands see below for probable solution

Last edited by gordon64; 19th April 2017 at 05:15 AM.
Reply With Quote
  #10  
Old 19th April 2017, 01:28 AM
gordon64
Guest
 
Posts: n/a
linuxfirefox
Re: norwegian keyboard not recognised

I think I have solved it...here is how I did it.

originally I did both location and kb but I now know it works with just the kb layout

Settings -> Region and language

-> input sources (for me US only)

click the + button and add gb kb......................................or no
click the gb keyboard and press the up arrow to make it the new default...........................or no

logout and login

top RH corner you will see and new pulldown for both input kb layouts with gb on top......................or no

2) Also with a text editor / terminal but not my web browser open you can swap instantly between layouts so

$
works

GUI actually works

Last edited by gordon64; 19th April 2017 at 01:37 AM.
Reply With Quote
  #11  
Old 20th April 2017, 02:49 AM
lsatenstein Online
Registered User
 
Join Date: Jun 2005
Location: Montreal, Que, Canada
Posts: 4,024
linuxfedorafirefox
Re: norwegian keyboard not recognised

Try left-window button and space bar to toggle between US and Norwegian keyboard layouts.
__________________
Leslie in Montreal

Interesting web sites list
http://forums.fedoraforum.org/showth...40#post1697840
Reply With Quote
  #12  
Old 20th April 2017, 03:50 PM
inga1 Offline
Registered User
 
Join Date: Feb 2011
Posts: 7
linuxfedorafirefox
Re: norwegian keyboard not recognised

I think the problem was that I had chosen the wrong type of Norwegian keyboard (something called "typing booster"). I removed that one and found another version (hidden among "other input sources"), and now everything works.

Thanks a lot for your help and patience. I m s lcky.

Inga
Reply With Quote
Reply

Tags
keyboard, norwegian, recognised

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dvd rw not recognised megaloman Using Fedora 4 14th June 2010 04:42 PM
Can't make accents etc (Norwegian keyboard) Torswin Using Fedora 0 19th January 2009 04:03 PM
HD- CD not recognised indi Hardware & Laptops 13 26th December 2004 04:35 AM
Evolution in Norwegian RaZieL Using Fedora 1 13th December 2004 06:03 AM
OpenOffice.org in FC2 and Norwegian letters /, / and / Singularity Using Fedora 4 27th May 2004 12:24 PM


Current GMT-time: 03:52 (Thursday, 29-06-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin Copyright 2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat