Fedora Linux Support Community & Resources Center
  #16  
Old 6th April 2017, 01:30 PM
Vareg Offline
Registered User
 
Join Date: Aug 2013
Location: renaissance-dating.com
Posts: 136
linuxfedorafirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

alright, I'm back on my feet and here's what efibootmgr gives me now:

Code:
vareg@localhost ~]$ efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0002,3000,3001,2001,2002,2003
Boot0000* EFI HDD Device (WDC WD7500BPVT-60HXZT3)
Boot0001* Fedora
Boot0002* Fedora
Boot0004* Notebook Hard Drive
Boot0011* USB Hard Drive - SanDisk
Boot0012* USB Hard Drive (UEFI) - SanDisk
Boot0013* Internal CD/DVD ROM Drive (UEFI)
Boot2001* USB Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk
Boot3004* Internal Hard Disk or Solid State Disk
[vareg@localhost ~]$
Thanks to you, it looks a lot healthier now. Boot time is okay, around 1m45 and boot selection's now extremely quick. It's comforting to know I don't have 450 entries in my efiboot folder anymore, so thanks a lot for all your help!
__________________
http://renaissance-dating.com
http://rolandc.net
https://www.linkedin.com/in/rclemenceau
https://google.com/+RolandCLEMENCEAU
Reply With Quote
  #17  
Old 6th April 2017, 02:07 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,467
linuxchrome
Re: Long, long Fedora boot (stopwatch Fedorathon)

Yes, that looks more like it is supposed to, but....

BootCurrent: 0000

That would indicate to me that your last boot was from:

Boot0000* EFI HDD Device (WDC WD7500BPVT-60HXZT3)

which is the BOOTX64.EFI shim that generates a new "Fedora" entry everytime it is used. Which might explain the now two Fedora entries? Or maybe you just left two.

Perhaps it's just showing you booted from 0000 entry then changed the boot order to make 0002 the first in the boot order. Anyway, good job at cleaning up the mess. Keep an eye on that after the next few boots. If any more "Fedora"'s show up, then set the first to boot as "3001".
Reply With Quote
  #18  
Old 6th April 2017, 09:04 PM
Vareg Offline
Registered User
 
Join Date: Aug 2013
Location: renaissance-dating.com
Posts: 136
linuxfedorafirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

well, here's what efibootngr shows now:

Code:
vareg@localhost ~]$ efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0003,3000,3001,3002,2001,2002,2003
Boot0000* EFI HDD Device (WDC WD7500BPVT-60HXZT3)
Boot0001* Fedora
Boot0002* Fedora
Boot0003* Fedora
Boot0004* Notebook Hard Drive
Boot0011* USB Hard Drive - SanDisk
Boot0012* USB Hard Drive (UEFI) - SanDisk
Boot0013* Internal CD/DVD ROM Drive (UEFI)
Boot2001* USB Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk
Boot3002* Internal Hard Disk or Solid State Disk
Boot3004* Internal Hard Disk or Solid State Disk
[vareg@localhost ~]$
looks like you're right, well, it's no that big a deal though, I can always do some cleaning once in a while...
__________________
http://renaissance-dating.com
http://rolandc.net
https://www.linkedin.com/in/rclemenceau
https://google.com/+RolandCLEMENCEAU
Reply With Quote
  #19  
Old 6th April 2017, 11:51 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,467
linuxchrome
Re: Long, long Fedora boot (stopwatch Fedorathon)

As I said, if you specify "3001" as first in the boot order, rather than "0003", the "Fedora" spawning from "0000" should stop. At least I would think so. The other thing to do is to move the BOOTX64.EFI file out of the /boot/efi/EFI/fedora/ directory to somewhere else for safe keeping and that should eliminate the Boot0000* EFI HDD Device (WDC WD7500BPVT-60HXZT3) entry which is causing the problem.

Is your HP UEFI firmware messing with your first boot option that you have been setting on a reboot?

You can also restore the efi file to its proper place by doing:
Code:
# dnf reinstall shim
Code:
$ rpm -ql shim
/boot/efi/EFI/BOOT/BOOTX64.EFI
/boot/efi/EFI/BOOT/fallback.efi
/boot/efi/EFI/fedora/BOOT.CSV
/boot/efi/EFI/fedora/MokManager.efi
/boot/efi/EFI/fedora/shim-fedora.efi
/boot/efi/EFI/fedora/shim.efi
Reply With Quote
  #20  
Old 12th April 2017, 09:40 PM
Vareg Offline
Registered User
 
Join Date: Aug 2013
Location: renaissance-dating.com
Posts: 136
linuxfedorafirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

Thanks a lot. Well, I have just had a chance to experiment a little and turns out no matter what boot order I set (and I have tried 3001 as first boot also), the system always ends up creating a 0002 entry and so on.

I could swear every time I boot I see something like Boot order not found, etc... It all happens in the blink of an eye but I'm sure it's what I get. I have reinstalled shim, no result...
__________________
http://renaissance-dating.com
http://rolandc.net
https://www.linkedin.com/in/rclemenceau
https://google.com/+RolandCLEMENCEAU
Reply With Quote
  #21  
Old 12th April 2017, 09:46 PM
Vareg Offline
Registered User
 
Join Date: Aug 2013
Location: renaissance-dating.com
Posts: 136
linuxfedorafirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

also, dunno how meaningfull that's gonna be but I just saw BOOTX64.EFI file is not in /boot/efi/EFI/fedora, rather it's in /boot/efi/EFI/BOOT
__________________
http://renaissance-dating.com
http://rolandc.net
https://www.linkedin.com/in/rclemenceau
https://google.com/+RolandCLEMENCEAU
Reply With Quote
  #22  
Old 13th April 2017, 12:01 AM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,467
linuxchrome
Re: Long, long Fedora boot (stopwatch Fedorathon)

Well, try this. Create the file:

/etc/rc.d/rc.local

You will probably need to create that file if you have not done so already for some other purpose. It should look like this:
Code:
#!/bin/bash
efibootmgr -q -n 3001
Be sure to make that file executable.
Code:
chmod +x /etc/rc.d/rc.local
This assumes that you still have a "0001*Boot Fedora" and a "Boot3001* Internal Hard Disk or Solid State Disk" entry in the efibootmgr output. But before just rebooting after setting up that file, enter that command:
Code:
efibootmgr -n 3001
Then confirm there is a NextBoot set with:
Code:
efibootmgr
Then reboot and see if it stops spawning new Fedora entries.
Reply With Quote
  #23  
Old 13th April 2017, 08:27 AM
Vareg Offline
Registered User
 
Join Date: Aug 2013
Location: renaissance-dating.com
Posts: 136
linuxfirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

Well I have followed every instruction to the letter but am still getting a boot order not found...

Anyway I have compared the output of efibtoomgr both before and after the last boot and here is how it goes:



I'm posting this as an image since it comes from LibreOffice and this forum won't preserve the original text formatting.

Anyway, underlined in blue is what was added at boot time, what's stricken through in orange however concerns what was before the boot, so we can clear see the difference.

Boot next is 3001 but the 0002 keeps being added every time though
__________________
http://renaissance-dating.com
http://rolandc.net
https://www.linkedin.com/in/rclemenceau
https://google.com/+RolandCLEMENCEAU
Reply With Quote
  #24  
Old 13th April 2017, 02:04 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,467
linuxchrome
Re: Long, long Fedora boot (stopwatch Fedorathon)

My instructions to boot from 3001 were based on your earlier posting showing that 0001 was a "Fedora" entry. What you are showing now is that 0001 is "EFI HDD Device (WDC WD7500BPVT-60HXZT3)", which is exactly what you DO NOT want to boot from, as that is what is creating a new Fedora entry every time it is called.

So the NextBoot seems to work as it should, but you now need to change the NextBoot to 3002 (0002), which is the newest and only "Fedora" entry shown above, assuming you haven't already deleted it. But I see there is no "3002" entry to correspond to the "0002" entry, and I'm not sure why that was not generated.

At this point, if "0002" stays as the first boot entry, I would just let it boot from that, by removing the rc.local file from /etc/rc.d/ and see what happens on the next boot.

Keep in mind that 3001 and 0001 point to the same thing, 3002 and 0002 point to the same thing, etc. So if 0002 is a newly created "Fedora" entry and there is no other "Fedora" entries present, then there was no "Fedora" entry to boot from in the first place. Unless there is a 0004 Fedora entry to pair with the shown 3004 entry, then 3004 entry should not be there.

In your cleaning up editing, if you delete, for instance, a 0004 Fedora entry, you would also want to delete its 3004 Internal Hard Disk or Solid State Disk counterpart.
Reply With Quote
  #25  
Old 13th April 2017, 02:43 PM
gordon64 Offline
Registered User
 
Join Date: Mar 2017
Location: Australia
Posts: 120
linuxfirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

Vareg

why are you using EFI (uefi) is it because one or more of those other disks contains windows,
in which case I shall sneak away.

I tend to have less hassle and decent boot times by having MBR (non-EFI) system with secure boot turned off
__________________
tower asus z97m plus
laptop Acer aspire ES1-420-55H6
Reply With Quote
  #26  
Old 13th April 2017, 02:45 PM
topiwala Offline
Registered User
 
Join Date: Aug 2011
Location: India
Age: 31
Posts: 320
linuxfedorafirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

The reason is that HP UEFI identifies the EFI file from particular location as the first boot file if it is not there it doesn't identifies it and creates a new one everytime.

Do you have microsoft folder in /boot/efi anywhere?

EDIT: Here is mine

Code:
bash-4.4$ efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 3000,3001,3002,3004,2001,2002,2003
Boot0000* Fedora
Boot0001* EFI HDD Device (Hitachi HTS547575A9E384)
Boot0002* Fedora
Boot0004* neon
Boot0010* USB Hard Drive (UEFI) - SanDisk Cruzer Blade
Boot00A9* rEFInd Boot Manager
Boot00B0* rEFInd Boot Manager
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk
Boot3001* Internal Hard Disk
Boot3002* Internal Hard Disk
Boot3004* Internal Hard Disk
And tree

Code:
oot@xyz efi]# tree
.
├── 754b00f129df4235a29d476d534d8716
│** ├── 4.11.0-0.rc2.git2.2.fc26.x86_64
│** ├── 4.11.0-0.rc3.git0.2.fc26.x86_64
│** ├── 4.11.0-0.rc4.git0.1.fc26.x86_64
│** ├── 4.11.0-0.rc5.git0.1.fc26.x86_64
│** └── 4.11.0-0.rc6.git0.1.fc26.x86_64
├── EFI
│** ├── BOOT
│** │** ├── BOOTX64.EFI
│** │** └── fallback.efi
│** ├── fedora
│** │** ├── BOOT.CSV
│** │** ├── MokManager.efi
│** │** ├── fonts
│** │** │** └── unicode.pf2
│** │** ├── fw
│** │** ├── fwupx64.efi
│** │** ├── gcdx64.efi
│** │** ├── grub.cfg
│** │** ├── grubenv
│** │** ├── grubx64.efi
│** │** ├── modelist.efi
│** │** ├── route80h.efi
│** │** ├── shim-fedora.efi
│** │** ├── shim.efi
│** │** └── themes
│** ├── neon
│** │** ├── MokManager.efi
│** │** ├── fbx64.efi
│** │** ├── grub.cfg
│** │** ├── grubx64.efi
│** │** ├── mmx64.efi
│** │** └── shimx64.efi
│** └── ubuntu
│**     ├── fw
│**     ├── fwupx64.efi
│**     └── grub.cfg
├── System
│** └── Library
│**     └── CoreServices
│**         └── SystemVersion.plist
└── mach_kernel

18 directories, 24 files
Reply With Quote
  #27  
Old 13th April 2017, 03:01 PM
Vareg Offline
Registered User
 
Join Date: Aug 2013
Location: renaissance-dating.com
Posts: 136
linuxfirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

Quote:
Originally Posted by PabloTwo View Post
My instructions to boot from 3001 were based on your earlier posting showing that 0001 was a "Fedora" entry. What you are showing now is that 0001 is "EFI HDD Device (WDC WD7500BPVT-60HXZT3)", which is exactly what you DO NOT want to boot from, as that is what is creating a new Fedora entry every time it is called.

So the NextBoot seems to work as it should, but you now need to change the NextBoot to 3002 (0002), which is the newest and only "Fedora" entry shown above, assuming you haven't already deleted it. But I see there is no "3002" entry to correspond to the "0002" entry, and I'm not sure why that was not generated.

At this point, if "0002" stays as the first boot entry, I would just let it boot from that, by removing the rc.local file from /etc/rc.d/ and see what happens on the next boot.

Keep in mind that 3001 and 0001 point to the same thing, 3002 and 0002 point to the same thing, etc. So if 0002 is a newly created "Fedora" entry and there is no other "Fedora" entries present, then there was no "Fedora" entry to boot from in the first place. Unless there is a 0004 Fedora entry to pair with the shown 3004 entry, then 3004 entry should not be there.

In your cleaning up editing, if you delete, for instance, a 0004 Fedora entry, you would also want to delete its 3004 Internal Hard Disk or Solid State Disk counterpart.
Yes I had understood 3001 and 0001 point to the same thing, like i also understand for the rest. Now I have deleted rc.local, let's see what it does next time I boot...

---------- Post added at 03:57 PM ---------- Previous post was at 03:55 PM ----------

Quote:
Originally Posted by gordon64 View Post
Vareg

why are you using EFI (uefi) is it because one or more of those other disks contains windows,
in which case I shall sneak away.

I tend to have less hassle and decent boot times by having MBR (non-EFI) system with secure boot turned off
actually....good point because I have nothing that looks even remotely like Windows on my comp. But then, how do I switch? (securely because this is my only prod machine)

---------- Post added at 04:01 PM ---------- Previous post was at 03:57 PM ----------

Quote:
Originally Posted by topiwala View Post
The reason is that HP UEFI identifies the EFI file from particular location as the first boot file if it is not there it doesn't identifies it and creates a new one everytime.

Do you have microsoft folder in /boot/efi anywhere?
...
Actually no, I have nothing that resembles Windows on my comp. Used to be a win 8 pro install like 3-4 years ago I think, would it be possible that it'd messed up something in the boot files that I'm still now struggling with?
__________________
http://renaissance-dating.com
http://rolandc.net
https://www.linkedin.com/in/rclemenceau
https://google.com/+RolandCLEMENCEAU
Reply With Quote
  #28  
Old 13th April 2017, 03:12 PM
topiwala Offline
Registered User
 
Join Date: Aug 2011
Location: India
Age: 31
Posts: 320
linuxfedorafirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

Can you look in your /etc/efi folder tree that is there something named Microsoft? If you have not formatted EFI partition at the time of linux install it could be there. I have experienced this same problem in past and now don't.
Reply With Quote
  #29  
Old 13th April 2017, 04:25 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,467
linuxchrome
Re: Long, long Fedora boot (stopwatch Fedorathon)

Quote:
Originally Posted by topiwala View Post
Can you look in your /etc/efi folder tree that is there something named Microsoft? If you have not formatted EFI partition at the time of linux install it could be there. I have experienced this same problem in past and now don't.
If Vareg still had Windows 8 installed (in UEFI mode) it would show up in both his F9 (OS Boot Menu) as "OS Boot Manager" and in his efibootmgr output. Also, if there was a "Microsoft" entry in an ESP partition, it wouldn't necessarily show up in his mounted /boot/efi/EFI tree if the Microsoft entry was on another unmounted ESP.
Code:
$ sudo ls /boot/efi/EFI
BOOT  fedora
No "Microsoft" there. But I dual boot with W8. The Microsoft UEFI files are on a different ESP partition on my system, which is not mounted when booting into Fedora.
Code:
$ sudo efibootmgr
BootNext: 3005
BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 3000,3001,3005,2001,2002,2003
Boot0000* Windows Boot Manager <== from ESP /dev/sda2
Boot0001* EFI HDD Device (TOSHIBA MQ01ABD075)
Boot0005* Fedora <== from ESP /dev/sda8
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk
Boot3005* Internal Hard Disk or Solid State Disk
I feel fairly confident Vareg no longer has W8 installed, at least not any of the UEFI boot files. Windows partitions are another matter, which the blkid command could confirm if they still exist or not.
Code:
$ sudo blkid | grep ntfs
/dev/sda1: LABEL="WINRE" UUID="8A2A196B2A195613" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b2c21e35-0b22-453b-a874-59c40daf3031"
/dev/sda4: LABEL="W8" UUID="02BA4919BA490B1D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="19fcfe16-90c1-48c5-b551-46a53d281187"
/dev/sda11: LABEL="RECOVERY" UUID="DE02174302172057" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="646b8675-6801-4de7-9e0e-d3829543fc7a"
Reply With Quote
  #30  
Old 13th April 2017, 04:49 PM
topiwala Offline
Registered User
 
Join Date: Aug 2011
Location: India
Age: 31
Posts: 320
linuxfedorafirefox
Re: Long, long Fedora boot (stopwatch Fedorathon)

Then i think other way is to name one of the fedora entries as Windows Boot Manager. and make it default.
Reply With Quote
Reply

Tags
boot, fedora, fedorathon, long, stopwatch

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Fedora 21 long boot time khoacao96 Using Fedora 7 31st January 2015 05:17 PM
Long boot times - Fedora 19 X64 cranil7 Using Fedora 9 3rd August 2013 08:02 PM
Long boot time in Fedora 15 chm270 Guides & Solutions (Not For Questions) 0 16th November 2011 05:04 AM
tar -czf taking long long time shariqnitt EOL (End Of Life) Versions 3 31st January 2011 12:17 PM
Fedora 12 taking too long to Boot Gaurav Prabhu Using Fedora 4 7th March 2010 08:12 AM


Current GMT-time: 10:35 (Tuesday, 25-04-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat