Fedora Linux Support Community & Resources Center
  #1  
Old 21st April 2014, 04:01 PM
HeyRicardo Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfirefox
how to fan-control (full speed after standby)?

I had to move my hdd from hp550 to hp615 laptop (never had this issue using hp550).

After googling about it, I only found some help for ubuntu linux.
So, I partially solved the issue, but need some help to make a script for fedora.
That is, from the link

http://kernelreloaded.blog385.com/in...after-suspend/

I was able to stop it using the following:

for i in {0..13}; do echo 0 > /sys/class/thermal/cooling_device$i/cur_state; done

(on my system there are up to 13 cooling_device numbered files)

However,
will the script suggested on that webpage work, as it is, on fedora 20 LXDE?

In particular, I don't understand what to do with that referred "leading space" and where the script starts and ends exactly. There is a cat command before, and a chmod after, which I probably have to execute separately..

Could you please have a look into that for me?
Feel free to let me know any other way you believe is better to manage this behavior.
Any hint will be useful to me, thank you in advance,
Ricardo
Reply With Quote
  #2  
Old 21st April 2014, 06:12 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,532
linuxfirefox
Re: how to fan-control (full speed after standby)?

The script itself starts with the line "#!/bin/sh" and ends with the line "esac".

You can change "#!/bin/sh" to "#!/bin/bash" since /bin/sh is just a symlink to /bin/bash, but either will work.

The "cat" command is just writing everything typed into the console (the script) after issuing that command to the file /etc/pm/sleep.d/fan_fix.sh until you type EOF on it's own line. He's saying the leading space before etc is just a typo and to not include it. In other words, it's "/etc..." and not "/ etc...".

It's much simpler to just use whatever text editor you want and type the script code into it. Save the file with the name "fan_fix.sh", then make the file executable using,
Code:
chmod +x fan_fix.sh
Then as root, copy (or move) the file to the /etc/pm/sleep.d/ folder,
Code:
# cp fan_fix.sh /etc/pm/sleep.d/
Since you've already shown that the basic function of the script (writing zero's into /sys/class/thermal/cooling_device$i/cur_state works) then whether the script is triggered or not when your laptop is brought out of suspend will determine if it "works".
Reply With Quote
  #3  
Old 22nd April 2014, 11:19 PM
HeyRicardo Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfedorachrome
Re: how to fan-control (full speed after standby)?

Thank you for your prompt and accurate post which addressed my request perfectly.
I've been trying since yesterday to make it work, no success yet.

When I asked whether it will work or not, I was concerned with script language and syntax (not knowing whether the way a script is written is universal, or distro-dependent).

Sadly, it is not triggered or just doesn't have the desired effect, and out of standby the fan speeds up at 100% (normally it runs at about 30-50%), so I have to manually issue the command to have it stop, and then it runs accordingly to temp control normally.

I hope to find a way, and in case I'll report it later on.
Reply With Quote
  #4  
Old 27th April 2014, 07:52 PM
HeyRicardo Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfirefox
Thumbs down Re: how to fan-control (full speed after standby)?

Today I installed lm_sensors package (as soon as I found it out..) and I got this result from sensors-detect:

Code:
Driver `to-be-written':
   Bus `SMBus PIIX4 adapter at 0b00'
    Busdriver `i2c_piix4', I2C address 0x4c
    Chip `SMSC EMC1402' (confidence: 6)

Driver `k10temp' (autoloaded):
  Chip `AMD Family 11h thermal sensors' (confidence: 9)

Driver `adm1021':
   Bus `SMBus PIIX4 adapter at 0b00'
    Busdriver `i2c_piix4', I2C address 0x4e
    Chip `Maxim MAX1617' (confidence: 3)

Note: there is no driver for SMSC EMC1402 yet.
Check http://www.lm-sensors.org/wiki/Devices for updates.
So, I assume I'll have to use adm1021, until emc1402 driver is made available.

In addition, to comply with the following:

Code:
To load everything that is needed, add this to one of the system
initialization scripts (e.g. /etc/rc.d/rc.local):

#----cut here----
# Chip drivers
modprobe adm1021
/usr/bin/sensors -s
#----cut here----
Actually, I don't find any config file for sensors (not even /etc/sensors.d folder), which probably make the second line useless.

But I went ahead and use /etc/rc.d/init.d which is already there (I don't think I have to create rc.local folder).
Here, from a readme file about the change of systemd-based OSs, I took another command,

$ systemctl list-unit-files

and I discovered that the fancontrol.service is disabled (is it normal?)
By the way, it didn't start when I tried using
# systemctl start fancontrol.service
(it still showed up as disabled).

Be it the missing driver, which is being replaced by a lesser confidence one, or this disabled service, are they involved in my suspend/wakeup issue?
Should I think the laptop is not appropriate for fc20, so far?
Reply With Quote
  #5  
Old 27th April 2014, 10:28 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,532
linuxfirefox
Re: how to fan-control (full speed after standby)?

Quote:
Originally Posted by HeyRicardo
Actually, I don't find any config file for sensors (not even /etc/sensors.d folder), which probably make the second line useless.
lm_sensors uses the file /etc/sensors3.config to define the functions of all the sensor devices it knows about. The entries there are very much configurable if you know and understand what you are doing.
See "man 5 sensors3.config"

Quote:
Originally Posted by HeyRicardo
But I went ahead and use /etc/rc.d/init.d which is already there (I don't think I have to create rc.local folder).
Yes, you do have to create that file. It is no longer a standard system file as in earlier times.
Reply With Quote
Reply

Tags
control, fan, fancontrol, speed, standby, standby or suspend

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
is there a way to disable cpu fan control (make fan run at max speed at all times) adav84 Hardware & Laptops 0 14th April 2014 10:01 AM
Toshiba Satellite Fan Speed Control ScottDillon Using Fedora 0 16th April 2012 11:44 AM
control cpu fan speed chandru1 Hardware & Laptops 1 10th July 2010 02:39 PM
[SOLVED] Radeon fan speed control in FC13 syngiun Hardware & Laptops 1 29th June 2010 07:45 AM
CPU Fan Speed Control Noosentaal Using Fedora 8 29th December 2009 01:36 AM


Current GMT-time: 05:39 (Friday, 26-05-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat